Overview

EMC Storage Integrator for Windows Suite

EMC Storage Integrator (ESI) for Windows Suite online help provides instructions to set up and use the following:

ESI for Windows

ESI system adapters

  • ESI Symmetrix VMAX Adapter

  • ESI VNX Adapter

  • ESI VNXe Adapter

  • ESI XtremIO Adapter

  • ESI VPLEX Adapter

  • ESI Linux Adapter

ESI application adapters

  • ESI SharePoint Adapter

  • ESI Exchange Adapter

  • ESI SQL Server Adapter

Replication adapters

  • ESI AppSync Adapter

  • ESI RecoverPoint Adapter

ESI Service

ESI SCOM Management Packs

ESI PowerShell Toolkits

  • ESI PowerShell cmdlet list

  • ESI Service PowerShell cmdlet list

Copyright © 2011—2015 EMC Corporation. All rights reserved.

Version 3.7, published April 2015

For the latest list of EMC product names, see EMC Corporation Trademarks on EMC.com.

All other trademarks used herein are the property of their respective owners.


ESI Overview

EMC Storage Integrator for Windows overview

EMC Storage Integrator for Windows Suite

EMC Storage Integrator (ESI) for Windows Suite is a set of tools for Microsoft Windows and Microsoft applications administrators. The suite includes: ESI for Windows and ESI PowerShell Toolkit, ESI hypervisor support and system adapters, application and replication adapters, ESI Service and ESI Service PowerShell Toolkit, and ESI SCOM Management Packs.

ESI for Windows and ESI PowerShell Toolkit

ESI for Windows has a GUI that is based on Microsoft Management Console (MMC). You can run ESI as a stand-alone tool or as part of an MMC snap-in on a Windows platform.

ESI also provides storage provisioning and discovery with the ESI PowerShell Toolkit. Getting started with the ESI PowerShell toolkits provides installation and setup information.

ESI for Windows enables you to view, provision, and manage block storage for Microsoft Windows, Exchange, SQL Server, and SharePoint sites. ESI supports the EMC VMAX3 and EMC VMAX series, EMC VNX series, EMC VNXe series, and EMC XtremIO storage systems. ESI also supports EMC AppSync and Linux hosts.

ESI requires that you install the corresponding adapters for specific system and application support. ESI prerequisites provides specific details about the prerequisites for storage systems and applicable adapters.

The ESI PowerShell Toolkit provides ESI storage provisioning and discovery capabilities with corresponding PowerShell cmdlets.

ESI hypervisor support

In addition to physical environments, ESI also supports storage provisioning and discovery for Windows virtual machines running on Microsoft Hyper-V, and VMware vSphere. The Hyper-V Adapter is installed with ESI core installation and the VMware vSphere Adapter is installed by default as part of the ESI installation. These adapters require no additional installation or setup.

The storage options in ESI vary depending on what is supported on the hypervisor:

  • For Hyper-V virtual machines, you can create virtual hard disks (VHD and VHDX files) and pass-through SCSI disks. You can also create host disks and cluster shared volumes.

  • For VMware vSphere virtual machines, you can create virtual hard disks (VMDK files) and raw device mapping (RDM) disks. You can also create SCSI disks and view datastores. SCSI disks require the use of existing SCSI controllers.

System adapters

When you install ESI, you can select which adapters to install. ESI provides adapters for most supported storage systems and hypervisors, including VMAX3, VMAX, VNX, VNXe, XtremIO, VMware vSphere, and Microsoft Hyper-V. Most of these adapters require no additional setup. However, the VMAX Adapter requires some additional setup as described in ESI VMAX Adapter overview.

ESI also has adapters for Linux hosts and for monitoring the health of VPLEX systems in SCOM. The Linux Adapter overview and VPLEX Adapter overview has more details.

Application and replication adapters

ESI also provides the following application and replication adapters:

SharePoint Adapter

The ESI SharePoint Adapter enables you to view and manage SharePoint storage, farms, sites, and content databases. The SharePoint Adapter overview has more details.

SQL Server Adapter

The ESI SQL Server Adapter enables you to view local and remote Microsoft SQL Server instances and databases and to map the databases to EMC storage. ESI supports the AlwaysOn feature in SQL Server 2012 and 2014, so you can view the primary SQL Server replica and up to four secondary replicas.

You can use SQL Scripts to create and configure SQL Server databases from an ESI host. The SQL Server Adapter overview has more details.

Exchange Adapter

Microsoft Exchange Server is a mail server, calendaring software, and contact manager program that runs on Windows Server. the ESI Exchange Adapter enables you to view Microsoft Exchange databases and map the databases to EMC storage. The Exchange Integration overview has more details.

AppSync Adapter (Replication)

The ESI AppSync Adapter provides simple, self-service application protection with tiered protection options and proven recoverability. This adapter supports multiple SQL Server instances on the same host. The ESI AppSync Adapter overview has more details.

RecoverPoint Adapter (Replication)

The ESI RecoverPoint Adapter provides local and remote data protection. If a disaster occurs, RecoverPoint can recover lost data from any point in time. You can use this adapter to connect to existing RecoverPoint/SE or RecoverPoint/EX systems and manage and view replication service clusters for replication. The ESI RecoverPoint Adapter overview has more details.

ESI Service and ESI Service PowerShell Toolkit

The ESI Service is the communications link between ESI and the ESI SCOM Management Packs. You can use the ESI Service with or without the ESI SCOM Management Packs. The ESI Service enables you to view and report on all registered EMC storage systems and storage-system components connected to the ESI host system.

The ESI Service PowerShell Toolkit is also installed as part of the ESI Service. You can use this toolkit, Installing ESI Service, and Setting up ESI Service to install and set up the ESI Service.

ESI SCOM Management Packs

The ESI SCOM Management Packs for Microsoft System Center Operations Manager (SCOM) enable you to manage EMC storage systems with SCOM by providing consolidated and simplified dashboard views of storage entities. The management packs support the same EMC XtremIO, EMC VMAX family, and VNX series storage systems that are supported in ESI. The ESI SCOM Management packs also support EMC VPLEX systems and Symmetrix DMX 4 storage system. The VPLEX Adapter overview and ESI Service and ESI SCOM Management Packs overview has more details.

Related links |
Adding storage systems | ESI home window
Adding hosts | ESI prerequisites
Adding host clusters | Installation overview


ESI home window

The main ESI GUI window provides a one-stop view of the storage systems, hosts, host clusters, and applications added to ESI.

The ESI interface has three panes:

  • The left pane is the navigation pane.

  • The center pane shows the details of the items selected in the navigation pane.

  • The right pane is the Actions pane, which lists the possible actions based on the items selected in the navigation pane or the center pane.

The following table lists some of the more commonly used actions available in the right Actions pane.

Action

Description

Add Storage System

Adds a storage system.

Add Windows System

Adds a Windows host system.

Add Linux System

Adds a SUSE Linux host system.

Publish Connection

Publishes or unpublishes connection information for one or more selected systems.

Add Cluster System

Adds a host cluster system.

Add Hypervisor

Adds a hypervisor for which you can select Microsoft Hyper-V, VMware vSphere, VMware vCenter.

Add SharePoint

Adds a Microsoft SharePoint farm.

Add Exchange

Adds a Microsoft Exchange forest.

Add SQL Server

Adds a Microsoft SQL Server.

Add Replication

Adds an EMC RecoverPoint or AppSync replication service.

Refresh

Refreshes the window. If you have ESI open for a long period of time, click Refresh to reset the display.

View

Contains options to customize the current view.

Options

Set the time-out for pinging a system to the number of milliseconds for a ping between ESI and a selected system.

Note: You can then click Ping to test the connection between ESI and a storage system, host, host cluster, application, or hypervisor.

Customize view settings

To show or hide items in the ESI home window, select View > Customize from the menu bar. The Customize view dialog box appears. Select or clear the following checkboxes to customize your view.

Note: Many of the checkboxes are selected by default.

Checkbox | View displayed if selected
Console tree | Left navigation pane.
Standard menus (Action and View) | Top menu bar: View and Help.
Standard toolbar | Icons in the second row of the menu bar: Back and Forward arrows, Up One Level in the Console Tree, Show/Hide Console Tree, Help, and Show/Hide Action Pane.
Status bar | Status bar at the bottom of the Home window.
Description bar | Description at the top of a pane. For example, if a VMAX storage system is selected, VMAX and the size and ID of the storage system are displayed.
Taskpad navigation tabs | ESI does not use MMC taskpad navigation tabs, so this selection does not provide any additional choices.
Action pane | Right Actions pane.
Menus | ESI does not have additional menu views.
Toolbar | ESI does not have additional toolbar views.

Notes:

  • To customize the center pane, such as to remove or add columns for a custom view, right-click a column and select actions from the menu. By default, not all of the information is displayed for some lists due to space limitations.

  • If a plus (+) or minus (-) symbol is displayed next to a list item, you can click the + symbol to expand the information displayed and click the - symbol to reduce the information displayed.

  • You can also adjust column width sizes with your mouse.

Related links |
Adding storage systems | ESI overview
Adding hosts | ESI prerequisites
Adding host clusters | Installation overview


Prerequisites

ESI prerequisites

System prerequisites

Storage system and hypervisor prerequisites

VNX Adapter overview

VNXe Adapter overview

VPLEX Adapter overview

XtremIO Adapter overview

Linux Adapter overview

Symmetrix VMAX Adapter overview

SharePoint Adapter overview

SQL Server Adapter overview

SharePoint Adapter overview

Exchange Adapter overview

AppSync Adapter overview

RecoverPoint Adapter overview

ESI Service and ESI SCOM Management Packs prerequisites

System prerequisites

Before you install ESI, complete the following:

  • Install .NET Framework 4.5 on the ESI host controller (the host on which ESI runs).

  • Ensure that a full installation of Windows Server 2012 R2 or 2012 is installed on the ESI controller (Windows Server Core installations are not supported)

    • Ensure that Microsoft Management Console (MMC) 3.0 is installed. Otherwise, the ESI installer prompts you to upgrade to MMC 3.0 before installing ESI.

  • Enable the following firewall exceptions on all ESI hosts:

    • Remote Volume Management - Virtual Disk Service (RPC) (vds.exe)

    • Remote Volume Management - Virtual Disk Service Loader (RPC) (vdsldr.exe)

    • Remote Volume Management (RPC-EPMAP) (svchost.exe)

    • Windows Management Instrumentation

  • Confirm that Microsoft PowerShell 4.0 is installed on all hosts. If it is not, download and install it from the Microsoft website.

  • Confirm that PSLanguageModel is set to FullLanguage in Windows PowerShell.

  • Enable the remote PowerShell on ESI controllee hosts by running the following command on the controllee host (the host on which ESI provisions storage):

Enable-PSRemoting -force

  • If iSCSI transport is used for SAN connectivity:

  • Use the iSCSI initiator to log in to the storage systems.

  • Configure zoning for the FC (Fibre-Channel) initiator and use the FC initiator to log in to the storage system.

  • Install the latest version of EMC PowerPath or Microsoft Multipath Input/Output (MPIO) with the Microsoft Device Specific Module (MSDSM) on the controllee host.

  • Ensure that ESI is installed and runs in a domain user login session with administrative privileges for the controller host. All ESI hosts must be members of the same Windows domain or in trusted domains.

  • To use Microsoft Directory Services with ESI, confirm that Windows Server 2012 R2 or 2012 Active Directory is installed. For using AD LDS, confirm an AD LDS instance is installed on the Windows Server.

Storage system and hypervisor prerequisites

ESI supports the following storage systems and hypervisors with the following, required software.

Storage system | Required software versions
EMC VMAX3 storage family | Enginuity release level 5977.498.472 and EMC Solutions Enabler 8.0.2 or later with EMC SMI-S Provider version 8.0.2 or later
EMC VMAX2 storage family | Enginuity release level 5876.159.102, 5876.159.102, 5876.229.145, 5876.251.161, 5876.268.174, or 5875.267.201e (depending on the VMAX model) and EMC Solutions Enabler 8.0.2 or later with EMC SMI-S Provider version 8.0.2 or later
EMC VMAXe | Enginuity release level 5875.267.201e and EMC Solutions Enabler 7.6.2 with EMC SMI-S Provider version 4.6.2
EMC VNX5100, VNX5200, VNX5300, VNX5400, VNX5500, VNX5600, VNX5700, VNX5800, VNX7500, VNX7600, and VNX8000 | Block 05.31, 05.32, or 05.33.000.5.072
EMC VNX-F5000 and EMC VNX-F7000 | Block 05.33.000.5.072
EMC VNXe3200 | VNXe 3.0.1 SP1 OE
EMC VNXe3100, VNXe3150, and VNXe3300* | VNXe 2.3.1.20364 OE
EMC XtremIO | 3.0.1, 3.0, or 2.4.1
Microsoft Hyper-V | Windows Server 2012 R2 or 2012
VMware vSphere ESXi Server | 5.0 Update 1 or later

* ESI SCOM Management Packs do not support these earlier VNXe models.

Related links |
Installation overview | ESI overview
Installing ESI | ESI home window
Reinstalling ESI |
Upgrading to the latest ESI version |
Uninstalling ESI |


Installation overview

Overview

The ESI Zip file includes:

  • The EMC Storage Integrator for Windows Suite Release Notes and Online Help.

  • The ESI installer for installing the core ESI setup and other options.

  • The ESI SCOM Management Packs installer—If you select to install the ESI Service, the installer also installs the ESI Service PowerShell Toolkit.

You can install ESI in one of the following ways:

  • Installing ESI: New installation of ESI with all available options. During the installation, you can select which adapters and other options are installed with ESI. During the installation you can select to use AD DS or AD LDS for persisting connection settings in a central store.

  • Reinstalling ESI: Reinstallation of the same adapters and options as selected during your last ESI installation.

  • Upgrading to the latest ESI version: Upgrade to the latest version from an earlier version of ESI.

Note: Uninstalling ESI provides information on uninstalling ESI.

ESI system adapters

Some of the ESI system adapters require no additional setup for use with ESI, such as the ESI VNX, VNXe, VPLEX, XtremIO, and Linux Adapters. However, the following ESI system adapters do require some additional setup:

  • VMAX Adapter

  • SharePoint Adapter

  • Exchange Adapter overview

  • SQL Server Adapter overview

  • AppSync Adapter overview

  • RecoverPoint Adapter overview

ESI Service and ESI SCOM Management Packs

  • You can use and install the ESI Service and ESI SCOM Management Packs separately or together with ESI. The following provide installation and setup instructions:

  • Installing ESI Service installation and Setting up ESI Service

  • Installing ESI SCOM Management Packs and Setting up ESI SCOM Management Packs

Related links |
Prerequisites | ESI overview
Installing a new, complete version of ESI | ESI home window
Reinstalling ESI |
Upgrading from an earlier version of ESI |
Uninstalling ESI |


Installing a new, complete version of ESI

To install a new, complete version of ESI:

  1. Locate and double-click the latest version of ESI.3.*.Setup.exe.

  2. In the ESI InstallShield Wizard, click Next.

  3. When the EMC Software License Agreement appears, accept the license agreement and click Next.

  4. In the Prerequisites window, confirm that your system meets the prerequisites and click Next.

Note: If the ESI installer detects that a later version of redistributables is already installed, it will not install the earlier version and will prompt you with an error message that it failed to install any required redistributables. If you get this message, click Yes.

  5. In the Setup window, confirm or change the options to be installed and click Next.

Note: Some options, such as the ESI Service, are not selected by default. You can click Change to change the installable path to a drive other than the default drive.

  6. In the Publish Connection Information window, select one of the following options and click Next.

Field | Description
Active Directory Lightweight Directory Service (AD LDS) | Persists or stores connection settings in a central location. For this option, type the Server Name and Service Port for connecting to the AD LDS instance.
Active Directory | Uses Active Directory Domain Services (AD DS) to persist connection settings.
Local Server | Persists connection settings locally (same as earlier versions of ESI). For example, MMC and PowerShell use the Windows user profile folder and the ESI Service uses SQLCE to persist settings locally.

  7. If you are not using Active Directory, skip to the next step.

    If you are using Active Directory, in the Configure Active Directory window, specify the username and password of the Active Directory user account for ESI. The ESI installer uses this account to configure Windows Active Directory for ESI. The ESI username must include (that is, be qualified with) the domain name: DOMAIN\Username

  8. In the Ready to Install the Program window, click Install.

Note: If the installer detects that a later version of a redistributable is already installed, it will not install the earlier version that is included with ESI and will prompt you with an error message that it failed. If you get this message, click Yes.

  9. Click Finish.

  10. If using Active Directory Services, configure AD DS or AD LDS for ESI supported applications.

Note: The ESI installer attempts to add a firewall exception rule to enable Remote Volume Management on the host where ESI is being installed. The installer also attempts to enable PS Remoting on the same host. If the installer encounters a problem during these steps, perform these steps manually after the installation is complete.

Related links |
Installation overview | ESI overview
Reinstalling ESI | Home window
Upgrading from an earlier version of ESI |
Uninstalling ESI |


Reinstalling ESI

To reinstall the same version of ESI to the same installation path and repair the installation or modify the options that are installed:

  1. If you plan to select Local Server for Publish Connection Information in step 8, then skip to step 2.

If you plan to select either of the new Active Directory options, you must remove all system connection settings before installing ESI as follows:

    1. Remove all systems from ESI.

    2. Delete the following ESI settings file:
      <system drive>:\Users\<user name>\AppData\Local\EMC\ESI\EMC Storage Integrator.settings

    2. Locate and double-click the latest version of ESI.3.*.Setup.exe.

    3. In the InstallShield Wizard, click Next.

The Setup window displays the Modify or Repair options.

    4. To add or remove adapters or other options, click Modify and Next.

Or to repair the installation, click Repair and Next.

    5. When the EMC Software License Agreement appears, accept the license agreement and click Next.

    6. In the Prerequisites window, confirm that your system meets the prerequisites and click Next.

    7. In the Setup window, confirm the list of adapters and other options to be installed and click Next.

    8. In the Publish Connection Information window, select one of the following options and click Next.

Field | Description
Active Directory Lightweight Directory Service (AD LDS) | Persists or stores connection settings in a central location. For this option, type the Server Name and Service Port for connecting to the AD LDS instance.
Active Directory | Uses Active Directory Domain Services (AD DS) to persist connection settings.
Local Server | Persists connection settings locally (same as earlier versions of ESI). For example, MMC and PowerShell use the Windows user profile folder and the ESI Service uses SQLCE to persist settings locally.

    9. If you are not using Active Directory, skip to the next step.

      If you are using Active Directory, in the Configure Active Directory window, specify the username and password of the Active Directory user account for ESI. The ESI installer uses this account to configure Windows Active Directory for ESI. The ESI username must include (that is, be qualified with) the domain name, as follows: DOMAIN\Username

  10. Depending on your selection, in the Ready to Modify the Program or the Ready to Repair the Program window, click Install.

Note: If the installer detects that a later version of a redistributable is already installed, it will not install the earlier version that is included with ESI and will prompt you with an error message that it failed. If you get this message, click Yes.

  11. Click Finish.

  12. If using Active Directory Services, configure AD DS or AD LDS for ESI supported applications.

Note: The ESI installer attempts to add a firewall exception rule to enable Remote Volume Management on the host where ESI is being installed. The installer also attempts to enable PS Remoting on the same host. If the installer encounters a problem during these steps, perform these steps manually after the installation is complete.

Related links |
Installation overview | ESI overview
Installing a new, complete version of ESI | Home window
Upgrading from an earlier version of ESI |
Uninstalling ESI |


Upgrading from an earlier version of ESI

From version 3.x or later

To upgrade ESI:

  1. If you plan to select Local Server for Publish Connection Information in step 7, then skip to step 2.

If you plan to select either of the new Active Directory options, you must remove all system connection settings before installing ESI, as follows:

  1. If using ESI Service, unpublish all systems from the ESI Service.

  2. Remove all systems from ESI.

  3. Delete the following settings file:
    <system drive>:\Users\<user name>\AppData\Local\EMC\ESI\EMC Storage Integrator.settings

  2. Locate and double-click the latest version of ESI.3.*.Setup.exe.

  3. In the InstallShield Wizard, click Next.

  4. When the EMC Software License Agreement appears, accept the license agreement and click Next.

  5. In the Prerequisites window, confirm that your system meets the prerequisites and click Next.

  6. In the Setup window, confirm or change the options to be installed and click Next.

Note: Some options, such as the ESI Service, are not selected by default. You can click Change to change the installable path to a drive other than the default drive.

    7. In the Publish Connection Information window, select one of the following options and click Next.

Field | Description
Active Directory Lightweight Directory Service (AD LDS) | Persists or stores connection settings in a central location. For this option, type the Server Name and Service Port for connecting to the AD LDS instance.
Active Directory | Uses Active Directory Domain Services (AD DS) to persist connection settings.
Local Server | Persists connection settings locally (same as earlier versions of ESI). For example, MMC and PowerShell use the Windows user profile folder and the ESI Service uses SQLCE to persist settings locally.

    8. If you are not using Active Directory, skip to the next step.

    If you are using Active Directory, in the Configure Active Directory window, specify the username and password of the Active Directory user account for ESI. The ESI installer uses this account to configure Windows Active Directory for ESI. The ESI username must include (that is, be qualified with) the domain name, as follows: DOMAIN\Username

      9. In the Ready to Install the Program window, click Install.

    Note: If the installer detects that a later version of a redistributable is already installed, it will not install the earlier version that is included with ESI and will prompt you with an error message that it failed. If you get this message, click Yes.

      10. Click Finish.

      11. If using Active Directory Services, configure AD DS or AD LDS for ESI supported applications.

Note: The ESI installer attempts to add a firewall exception rule to enable Remote Volume Management on the host where ESI is being installed. The installer also attempts to enable PS Remoting on the same host. If the installer encounters a problem during these steps, perform these steps manually after the installation is complete.

Upgrading your ESI SCOM Management Packs

From version 3.0 or later:

You can install and import the latest version of the ESI SCOM Management Packs. Installing the ESI SCOM Management Packs provides instructions. However, do not delete or reimport the two customization files or you will lose your customization settings.

Related links |
Installation overview | ESI overview
Installing ESI | Home window
Reinstalling ESI |
Uninstalling ESI |


Uninstalling ESI

To uninstall ESI:

  1. Close all ESI applications, including ESI and the ESI PowerShell toolkits. If you do not close all applicable ESI applications, you may receive a warning message to close them during the process.

  2. Navigate to and open the Windows Control Panel.

  3. Click Uninstall a program.

  4. Select the EMC Storage Integrator program and click Uninstall.

If you are upgrading from version 1.2, continue this process until you have removed all EMC Storage Integrator adapters or programs from the list.

    5. ESI is uninstalled.

    See Installing ESI to install a new, complete installation of ESI.

Related links |
Installation overview | ESI overview
Installing ESI | Home window
Reinstalling ESI |
Upgrading from an earlier version of ESI |


Setting up Directory Services integration

Setting up Directory Services integration for ESI applications

ESI can store connection settings locally or persist connection settings in a central location by integrating with Microsoft Active Directory Domain Services (AD DS) or Active Directory Lightweight Directory Services (AD LDS).

The Microsoft Active Directory Services use the Lightweight Directory Access Protocol (LDAP) for both AD DS and AD LDS.

You can use AD DS or AD LDS for all supported applications and systems, such as ESI, MMC, ESI Service, and SQL Server.

Prerequisites

To use AD DS or AD LDS with ESI, confirm that Windows Server (2012 R2, 2012, or 2008 R2) Active Directory is installed on the Domain Controller of the AD domain. And for AD LDS, confirm an AD LDS instance is installed on the Windows Server. Microsoft TechNet provides instructions on how to install and set up AD DS and AD LDS.

Setting up

To set up AD DS:

  1. Confirm you selected Active Directory in the Publish Connection Information window during the ESI installation.

  2. Login to the domain controller with domain administrator credentials.

  3. Perform the applicable steps in Configuring Directory Services for ESI applications.

To set up AD LDS:

  1. Login to the domain controller with domain administrator credentials.

  2. During the AD LDS installation, set up the following application directory partition for ESI: DC=EMC, DC=Storage, DC=Integrator, DC=COM.

  3. Confirm you selected AD LDS in the Publish Connection Information window during the ESI installation.

  4. Confirm the AD LDS instance schema has definitions for msDS-App-Configuration and msDS-Settings.

If not, extend the AD LDS schema to get them by generating an LDIF file with the ADSchemaAnalyzer.exe. Refer to Microsoft TechNet for instructions.

  5. Perform the applicable steps in Configuring Directory Services for ESI applications.

Configuring Directory Services for ESI applications

To configure AD DS and AD LDS for ESI, MMC, and PowerShell connections:

  1. Use ADSI Edit (adsiedit.msc) to connect to the domain controller active directory and create a Container for this ESI store: CN=ESI Object Connection Store.

For example, for mydomain.corp.com, create the CN=ESI Object Connection Store,DC=mydomain,DC=corp,DC=com Distinguished Name.

  2. Create a container in the ESI store container with the domain user name for each user.

For example, for User 1, create a CN=User1 Distinguished Name.

  3. Grant full control permissions for the users that own the ESI AD store.

To configure AD DS and AD LDS for ESI Service connections:

  1. Use ADSI Edit to create an ESI Service container in the ESI AD store. Use the name of the computer that is running ESI Service, such as CN=ESIService1. This new container enables ESI Service to store persistence settings in the ESI AD store.

  2. ESI Service runs as a network service. If ESI Service is running on a remote computer, grant full control permissions to the computer account.

If the directory service and ESI Service are running on the same computer, grant full control permissions to the network service account.

Related links |
Installation overview | Home window
Adding hosts | Prerequisites


ESI Symmetrix VMAX Adapter overview

ESI VMAX Adapter overview

The ESI VMAX Adapter enables storage administrators to create, provision, and manage VMAX storage with ESI. This VMAX Adapter is based on the Solutions Enabler Storage Management Initiative - Specification (SMI-S) provider. This adapter:

  • Supports all VMAX storage systems that are supported in ESI.

  • Supports the VMAX3 service level objectives (SLO) feature.

  • Replaces the EMC Symmetrix Adapter that was based on the Storage Pool Manager (SPM) from previous versions.

Limitations

The VMAX Adapter has the following limitations:

  • Using FAST VP lists the limitations associated with FAST VP.

  • Managing metas lists the limitations associated with managing metas or composite LUNs.

  • This adapter cannot provision storage on host systems that are provisioned with Virtualization Domains or with the Storage Pool Manager (SPM) from previous releases of the ESI VMAX Adapter.

  • You cannot create, view, or remove snapshot LUNs for VMAX systems with this release.

Prerequisites

To use the VMAX Adapter to provision storage, you must do the following:

  • Download and install the latest applicable version of SMI-S that is available for your VMAX model from the EMC SMI-S Provider Software Downloads page on EMC Online Support. VMAX systems with Enginuity release level 5876.* require EMC Solutions Enabler 8.0.2 with 8.0.2.

  • Install and run SMI-S on a management server that is separate from all ESI hosts and storage systems. The VMAX Adapter cannot provision storage on a server that is running SMI-S.

  • Install Oracle Java SE Runtime Environment (JRE) 7 or later, which is required for VMAX3

Installation

The EMC VMAX Adapter is installed by default with ESI. If you changed the defaults during your installation of ESI, then reinstall ESI and confirm that the EMC VMAX Adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installing ESI provide system prerequisites and installation instructions for the ESI host system.

Setting up SMI-S

After installing the latest version of EMC SMI-S Provider, use VMAX to create two or more gatekeeper devices and unmask the gatekeepers to the SMI-S server that is hosting the SMI-S provider. Gatekeepers are required for accessing and issuing management commands. EMC VMAX documentation has more details.

Related links |
Adding VMAX storage systems | ESI overview
Managing VMAX storage systems | ESI home window


Adding VMAX storage systems

To add a VMAX storage system to ESI:

  1. In the left pane of the ESI window, select EMC Storage Integrator or Storage Systems.

  2. In the Actions pane, click Add Storage System.

The Add Storage System dialog box appears.

  3. Set the following field values for the storage system.

Note: In the dialog box, the * indicates mandatory fields.

Field | Description
System Type | VMAX
Friendly Name | Short name for the storage system that is unique across different storage systems
Array serial number | Serial number for the array
SMI provider host | Host name or IP address of the SMI-S provider
SMI provider port | IP port of the SMI-S provider, or you can accept the default port 5988 for HTTP or 5989 for HTTPS
Use secured connection | Use a secure connection to the SMI-S provider
Use Windows Authentication | If selected, disregard the Username and Password fields
Username and Password | Not used if Windows Authentication is selected; otherwise, type a username and password for the SMI-S provider
Connection timeout (seconds) | Time limit for a connection to be made to the SMI-S provider
Operation timeout (seconds) | Time limit for an operation to be completed
Ignore server certificate chain validation | Bypass security certificate chain validation
Ignore server certificate name validation | Bypass security certificate name validation

  4. Click Test Connection to test the connection before adding the system.

  5. Click Add.

The VMAX storage system appears in the Available Systems list in the center pane.

Related links |
ESI Symmetrix VMAX Adapter overview | ESI overview
Managing VMAX storage systems | ESI home window


Working with VMAX storage systems

Managing VMAX storage systems

Creating thin pools

With the VMAX Adapter, ESI only supports provisioning disks from thin pools for VMAX systems. Before creating, provisioning, and managing disks in ESI, you must create the thin pools with other EMC tools, such as the EMC Solutions Enabler SYMCLI or Unisphere for VMAX.

Creating and connecting disks

The VMAX Adapter enables you to use ESI to create disks for a VMAX host or cluster. You can change the drive letter and the path after the disk is created. To provision a LUN for a VMAX host or cluster, the VMAX system must be either locally connected to the host or to the cluster member nodes.

Adding hosts provides instructions for creating and connecting VMAX host disks with ESI.

Related links |
ESI Symmetrix VMAX Adapter overview | ESI overview
Adding VMAX storage systems | ESI home window


Using FAST VP

The ESI VMAX Adapter supports EMC Fully Automated Storage Tiering for Virtual Pool (FAST VP) policies for the VMAX family. EMC FAST VP is a VMAX feature that combines virtual provisioning of thin pools with automated data movement between tiers, which is based on performance measurements and user-defined policies.

Each FAST VP policy can contain different tiers, including FC tiers, SATA tiers, and so on. A storage group represents a set of LUNs, storage volumes, or devices that you can apply to a FAST VP policy.

You can use the ESI PowerShell FAST VP cmdlets to do the following tasks:

  • Add and remove FAST VP policies to storage groups.

  • Manage and remove storage groups.

  • Add LUNs to and remove LUNs from storage groups.

ESI has the following limitations for FAST VP and VMAX systems:

  • You must create storage pools, FAST VP policies, and tiers with other EMC tools, such as the EMC Solutions Enabler SYMCLI or Unisphere for VMAX.

  • If LUNs in a storage group are not bound to at least one pool that is part of the policy tier, you cannot associate a FAST VP policy to the storage group.

  • You cannot rebind LUNs to different storage pools for FAST VP.

Related links |
ESI Symmetrix VMAX Adapter overview | ESI overview
Adding VMAX storage systems | ESI home window
Managing VMAX storage systems |


Managing metas

The VMAX Adapter enables you to use ESI to expand and extend existing LUNs into metas and create new metas or meta volumes for a VMAX host or cluster. Metas are combined storage devices that are grouped together to create a larger meta.

Metas represent meta volumes, composite LUNs, metadevices, meta LUNs, composite volumes, and metaheads. Meta members represent meta volume members, constituent LUNs, and composite LUN members.

To create and manage metas, use the ESI PowerShell Toolkit meta cmdlets.

ESI has the following limitations for expanding LUNs into metas and for creating and managing metas:

  • Expanding a bound stripe meta volume results in the creation of a Business Continuity Volume (BCV), which has the same meta configuration to preserve data. During the expansion, the system creates a mirror relationship between the meta and the BCV, which means the meta and the BCV contain the same data. After the expansion, the storage system detaches the BCV from the meta and by default, ESI does not delete the device. You can manually delete the devices with EMC tools, such as EMC Solutions Enabler SYMCLI or Unisphere for VMAX, to manage disk space.

  • The Expand-EmcLun cmdlet does not expand thin meta LUNs. The command expands meta volumes.

  • You cannot expand meta volumes that involve a clone, remote data facility (RDF), or snap session. However, you can expand existing bound LUNs by forming new metas with the New-EmcCompositeLun cmdlet.

  • You cannot compress or shrink meta volumes.

Related links |
ESI Symmetrix VMAX Adapter overview | ESI overview
Adding VMAX storage systems | ESI home window
Managing VMAX storage systems |


ESI VNX Adapter overview

The ESI VNX Adapter enables storage administrators to create, provision, and manage VNX storage arrays with ESI. This adapter supports all VNX storage systems that are supported in ESI.

You can view and manage advanced VNX snapshots in both the ESI GUI and ESI PowerShell Toolkit.

Prerequisite

For VNX block storage systems, you must enable Access Logix on the storage array before connecting a host disk on a Windows host.

Installing the adapter

The ESI VNX Adapter is installed by default with ESI. However, if you changed the default during your installation of ESI, then reinstall ESI and confirm that the EMC VNX Adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installing ESI provide system prerequisites and installation instructions for the ESI host system.

Related links |
Adding VNX storage systems | ESI overview
Adding hosts | ESI home window
Publishing connections |


Adding VNX storage systems

To add a VNX storage system to ESI:

  1. In the left pane of the ESI window, select EMC Storage Integrator or Storage Systems.

  2. In the Actions pane, click Add Storage System.

The Add Storage System dialog box appears.

  3. Set the following details for the VNX storage system.

Field | Description
System Type | VNX-F or VNX-Block
Friendly Name | Short name for the storage system that is unique across different storage systems

Note: The credentials required for each storage system are different. Fields marked with an * in the UI are required. The following table lists the VNX storage system parameters for the two types.

Field | Description
Username | Username for the storage system
Password | Password for the storage system
SPA's IP Address | IP address of SP A
SPB's IP Address | IP address of SP B
Port Number | The default port is automatically set. If the field is empty, you can leave it empty to use the default port. For VNX-Block, this is the control station port number.

  4. Click Test Connection to test the connection before adding it.

  5. Click Add. The storage system appears in the Available Systems list in the center pane.

Related links |
ESI VNX Adapter overview | ESI overview
Adding hosts | ESI home window
Publishing connections | Viewing LUN Groups


ESI VNXe Adapter overview

The ESI VNXe Adapter enables storage administrators to create, provision, and manage VNXe storage arrays with ESI. This adapter supports all VNXe storage systems that are supported in ESI.

Prerequisites

To use this adapter, you need to install the latest version of the EMC Unisphere VNXe CLI for your specific environment on the ESI controller host. The latest versions of the VNXe CLIs are available for download on EMC Online Support.

Installing the adapter

The EMC VNXe Adapter is not installed by default with ESI. You must select to install it during your installation of ESI. If you did not, then reinstall ESI and confirm that the EMC VNXe Adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installing ESI provide system prerequisites and installation instructions for the ESI host system.

VNXe3200 support

You can use the ESI GUI to view VNXe3200 LUN groups and unified snapshots.

You must use the ESI PowerShell Toolkit to do the following for block storage:

  • Create and delete LUN groups

  • Manage, add, and remove LUNs in LUN groups

  • Create and delete unified snapshots of LUNs in LUN groups

  • Restore snapshots to LUNs in LUN groups

Adding a VNXe system

After meeting the prerequisites and completing the ESI installation, your final setup step is to add the VNXe systems in ESI.

Related links |
Adding VNXe storage systems | ESI overview
Adding hosts | ESI home window
Publishing connections |


Adding VNXe storage systems

To add a VNXe storage system to ESI:

  1. In the left pane of the ESI window, select EMC Storage Integrator or Storage Systems.

  2. In the Actions pane, click Add Storage System.

The Add Storage System dialog box appears.

  3. Set the following values.

Field | Description
Management Server IP Address | IP address for the VNXe management server
Username | Username for the storage system
Password | Password for the storage system

  4. Click Test Connection to test the connection.

  5. Click Add.

The VNXe storage system appears in the Available Systems list in the center pane.

Related links |
ESI VNXe Adapter overview | ESI overview
Adding hosts | ESI home window
Publishing connections | Viewing LUN Groups


ESI VPLEX Adapter overview

The ESI VPLEX Adapter enables you to use the ESI SCOM Management Packs and ESI Service to monitor the operational status of EMC VPLEX system components in SCOM. You can use SCOM to monitor the health of both physical and logical VPLEX system components. You can view the health of individual LUNs and if failures occur, the failures roll up to the affected virtual volumes and corresponding VPLEX systems.

Prerequisites

This adapter requires the following:

  • GeoSynchrony version 5.3 installed on the VPLEX systems.

  • This adapter uses the standard SSH network connection to communicate with VPLEX. Confirm that the SSH port 443 is open on the VPLEX host system. If it is not, the connection fails.

Installing the adapter

This adapter is installed by default with ESI. If you changed the defaults during the installation, reinstall ESI and confirm that the adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installing ESI provide system prerequisites and installation instructions for the ESI host system.

Setting up VPLEX health monitoring in SCOM

After you install the adapter, do the following to set up health monitoring of VPLEX systems in SCOM:

  1. Set up the ESI Service.

  2. Install and set up the ESI SCOM Management Packs.

  3. Use Add-EMCSystem in the ESI Service PowerShell toolkit to add (register or publish) the VPLEX system with the ESI Service.

Related links |
Installing ESI Service | ESI overview
Setting up ESI Service | ESI home window
Installing ESI SCOM Management Packs | ESI Service PowerShell cmdlet list
Setting up ESI SCOM Management Packs | Troubleshooting ESI Service and ESI SCOM Management Packs


ESI XtremIO Adapter overview

The ESI XtremIO Adapter enables you as storage administrators to create, provision, and manage EMC XtremIO storage systems with ESI. XtremIO is an all-flash storage system that supports block storage operations.

The ESI PowerShell Toolkit includes cmdlets specifically for XtremIO systems: Get-EmcInitiatorGroup and Get-EmcXBrick. This adapter enables support of XtremIO snapshots.

Prerequisites

This adapter requires XtremIO version 3.0.1, 3.0, or 2.4.2.

Limitations

This adapter has the following limitations:

  • For XtremIO entities, ESI manages XtremIO volumes as LUNs and volume mappings as masking views in ESI.

  • You can view, but cannot modify, create, or delete XtremIO folders in ESI.

  • You cannot provision XtremIO storage for SQL Server, Exchange, or SharePoint applications in ESI.

  • Because XtremIO systems do not use storage pools, ESI lists the entire XtremIO system as a single storage pool in the Storage Pools tab.

  • Because XtremIO systems do not use service nodes, you cannot view service nodes for XtremIO systems in ESI.

  • Because XtremIO does not require the registration of hosts, you cannot use the ESI PowerShell cmdlets that are related to registering hosts for XtremIO systems in ESI.

  • This adapter does not support IPv6.

Installing the adapter

The ESI XtremIO Adapter is installed by default with ESI. If you changed the defaults during your installation of ESI, then reinstall ESI and confirm that the EMC XtremIO Adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installing ESI provide system prerequisites and installation instructions for the ESI host system.

Related links |
Adding XtremIO storage systems | ESI overview
Publishing connections | ESI home window
ESI PowerShell cmdlet list |


Adding XtremIO storage systems

To add an EMC XtremIO storage system to ESI:

  1. In the left pane of the ESI window, select EMC Storage Integrator or Storage Systems.

  2. In the Actions pane, click Add Storage System.

  3. In the Add Storage System dialog box, set the following details for the XtremIO storage system.

Field | Description
System Type | XtremIO
Friendly Name | Short name for the storage system that is unique across different storage systems
Username | Username for the storage system
Password | Password for the storage system
XMS IP Address | IP address of the XtremIO management server
Port Number | The default port number is automatically set. If the field is empty, you can leave it empty to use the default port.

  4. Click Test Connection to test the connection before adding it.

  5. Click Add.

The storage system appears in the Available Systems list in the center pane.

Related links |
Creating volumes | ESI overview
Viewing storage pools | ESI home window
Viewing masked volumes | Viewing initiator groups
Viewing storage groups |


ESI Linux Adapter overview

The ESI Linux Adapter enables storage administrators to use ESI to manage Linux hosts.

Prerequisites

This adapter has the following prerequisites:

  • Red Hat version 6.1 and SUSE Linux version 11 is installed on the Linux server. These versions were tested with ESI; however, later versions might also work.

  • ESI uses the standard SSH network connection to communicate with Linux. Confirm that the SSH port 22 is open on the Linux client system.

  • For SCSI operations with ESI, confirm the following is installed on the Linux server:

  • The SCSI sg3-utils tool set component

  • The optional, open SCSI component with the iSCSI protocol

Installation

The ESI Linux Adapter is installed by default with ESI. However, if you changed the default during your installation of ESI, then reinstall ESI and confirm that the Linux Adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installing ESI provide system prerequisites and installation instructions for the ESI host system.

Related links |
Adding hosts | ESI overview
Removing hosts | ESI home window
Creating disks |


Adding storage systems

To add a storage system to ESI:

  1. In the left pane of the ESI window, select EMC Storage Integrator > Storage Systems.

  2. In the Actions pane, click Add Storage System.

  3. In the Add Storage System dialog box, specify the following for the storage system.

Field | Description
System Type | Type of storage system to add
Friendly Name | Short name for the storage system that is unique across different storage systems

Note: The credentials required for each storage system are different. Fields marked with an * in the ESI UI are required. The following tables list the storage system parameters for supported storage systems.

For VNXe storage systems, specify the following.

Field | Description
Management Server IP Address | IP address for the VNXe management server
Username | Username for the storage system
Password | Password for the storage system

For VNX-F or VNX-Block storage systems, specify the following.

Field | Description
Username | Username for the storage system
Password | Password for the storage system
SPA's IP Address | IP address of SP A
SPB's IP Address | IP address of SP B
Port Number | The default port number is automatically set. If the field is empty, you can leave it empty to use the default port. For VNX-Block, this is the control station port number.

For VMAX storage systems, specify the following.

Note: In the System Type field, the VMAX selection represents the group of VMAX storage systems supported with this release of ESI. For supported VMAX systems, see Prerequisites for ESI.

Field | Description
Array serial number | Serial number of the array
SMI provider host | Hostname or IP address of the SMI-S provider
SMI provider port | IP port of the SMI-S provider. Or you can accept the default port 5988 for HTTP or 5989 for HTTPS.
Use secured connection | Use a secure connection to the SMI-S provider
Use Windows Authentication | Use Microsoft Windows authentication
Username and Password | Not used and can be skipped Or type the username and password for the SMI-S provider
Connection timeout (seconds) | Time limit for a connection to connect to the SMI-S provider
Operation timeout (seconds) | Time limit for an operation to be completed
Ignore server certificate name validation | Bypass security certificate name validation
Ignore server certificate name validation | Bypass security certificate name validation

For XtremIO storage systems, specify the following.

Field | Description
Username | Username for the storage system
Password | Password for the storage system
XMS IP Address | IP address of the XtremIO management server
Port Number | The default port number is automatically set If the field is empty, you can leave it empty to use the default port

  4. Click Test Connection to test the connection before adding it.

  5. Click Add. The storage system appears in the Available Systems list in the center pane.

Related links |
Adding hosts | ESI overview
Removing storage systems | Home window
Publishing connections | Installation overview


Removing storage systems

Removing systems

You can use the Remove System action to remove storage systems, applications, appliances, and other supported systems from ESI.

To remove a system from ESI:

  1. In the left pane of the ESI window, select EMC Storage Integrator or Storage Systems.

  2. In the center pane, select the storage system.

  3. In the Actions pane, click Remove System.

  4. Click Yes when prompted for confirmation.

Related links |
Adding storage systems | ESI overview
Creating LUNs | ESI home window
Publishing connections |


Publishing connections

You can use the Publish Connection option to reuse the creation information, or parameters, that you enter when you add storage systems. When you use this option, you do not have to re-enter the parameters again.

You can choose to publish storage system creation information to three different locations:

  • Another User: Give a specified storage administrator or ESI user access to a specific set of supported EMC storage systems and related EMC RecoverPoint or replication systems. Publish systems to a remote storage administrator.

  • ESI Service: Publish or register the storage systems to the ESI Service that you want the service to monitor.

Publishing systems to another user

To publish one or more systems to a specified ESI user or administrator:

  1. In the left pane of the ESI window, select EMC Storage Integrator.

  2. In the Actions pane, click Publish Connection.

  3. In the Publish Connection Information dialog box, set the following field values.

Field | Description
IP Address/Name | Type the IP address or name of the host system that is running the extension or service.
Publish To | Select Another User to receive the connection information for the published systems.
User | Type the username to get access to the published systems.
Password | Type a password for the specified user.

  4. Click Refresh to get a list of available systems.

  5. In the Local – Storage and Replication Systems pane, select the systems that you want to publish, and then click Add.

  6. Click OK to accept the list of systems to publish in the Service – Storage and Replication Systems pane.

  7. Click Close to close the dialog box.

Removing or unpublishing systems from another user

You cannot unpublish a system from another user after publishing it with the Publish Connection action or with the ESI PowerShell Toolkit. However, you can remove the systems by running ESI under the user’s session and removing the system with the ESI Remove Systems action or the ESI PowerShell Toolkit.

Related links |
Adding storage systems | ESI overview
Removing storage systems | Home window


Creating LUNs

You can create one or more LUNs after adding the storage system to ESI.

To create one or more LUNs:

  1. In the left pane of the ESI window, select the storage system.

  2. In the Actions pane, click Create LUN.

The Create LUN wizard appears.

  3. Select a storage pool, and then click Next.

  4. On the New LUN page, set details for the new LUN or LUNs, and then click Next.

Field | Description
LUN Count | Number of LUNs to be created
Sequence Number | First number to append to the name for the first LUN Note: For example, to create three LUNs with the appended numbers 15, 16, and 17, type 3 in the LUN Count field and type 15 in the Sequence Number field.
Name | Name of the LUN or LUNs
Description | Description of the LUN or LUNs
Size | Size and unit of measurement for each LUN
Service Node | Storage processor that hosts the LUN or LUNs
Provision Type | Select either Thick or Thin
Stop provisioning new LUNs when error occurs | To stop creating new LUNs if an error occurs during the process

  5. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  6. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are creating a LUN, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  7. On the Summary page, click Finish.

    8. The new LUN or LUNs appear in the LUNs list for the specific storage system.

Related links |
Expanding LUNs | ESI overview
Viewing LUNs | ESI home window
Deleting LUNs |
Viewing masked LUNs |
Viewing storage groups |


Creating volumes

After adding an XtremIO storage system in ESI, you can create one or more volumes for an XtremIO storage system. In ESI, volumes equal LUNs. When you click Create Volume, ESI opens the Create LUN wizard to create the new volumes as LUNs.

To create one or more volumes (LUNs):

  1. In the left pane of the ESI window, select the storage system.

  2. In the Actions pane, click Create Volume.

The Create LUN wizard appears.

  4. Select a storage pool, and then click Next.

  5. On the New LUN page, set details for the new volume or volumes, and then click Next.

Field | Description
LUN Count | Number of LUNs (volumes) to be created
Sequence Number | First number to append to the name for the first LUN (XtremIO volume) Note: For example, to create three LUNs with the appended numbers 15, 16, and 17, type 3 in the LUN Count field and type 15 in the Sequence Number field.
Name | Name of the volume or volumes
Folder | For XtremIO, select the storage folder path for the new volume or leave it blank to use the default root folder
Description | Description of the volume or volume group or select Not Applicable if no description is required
Size | Size and unit of measurement for each volume
Service Node (grayed out) | Not applicable for XtremIO volumes

  6. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  7. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are creating a LUN, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  8. On the Summary page, click Finish.

    9. The new volume or volumes appear in the Volumes tab for the selected XtremIO storage system.

Related links |
Deleting volumes | ESI overview
Viewing storage pools | ESI home window
Viewing masked LUNs |
Viewing storage groups |


Expanding LUNs

For VNX block systems, you can expand both thin and thick pool LUNs with the ESI GUI. ESI supports expanding LUNs connected to a RAID or to VMAX systems with the Managing metas cmdlets in the ESI PowerShell Toolkit.

Note: You cannot expand LUNs (volumes) for XtremIO storage systems in ESI.

To expand the storage capacity of a LUN for a block-based storage system:

  1. In the left pane of the ESI window, select the storage system.

  2. In the center pane, click LUNs.

  3. Select the LUN that you want to expand.

  4. From the menu bar, select Action > Expand LUN.

The Expand LUN wizard appears.

  6. On the New LUN Capacity page, type the new capacity for the LUN and select a unit of measurement.

Note: For example, change the LUN capacity from 3 GB to 4 GB.

  7. Click Next.

  8. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  9. On the Progress page, click Next. The new expanded LUN creation starts.

Note: Click More Information for more progress details. If a problem occurs while you are expanding a LUN, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  10. On the Summary page, click Finish.

    11. You can view the expanded storage capacity for the LUN in the LUNs tab.

Related links |
Creating LUNs | ESI overview
Viewing LUNs | ESI home window
Deleting LUNs |
Viewing storage pools |


Viewing LUNs

To view LUNs or the initiators to which each LUN is unmasked:

  1. In the left pane of the ESI window, select the storage system.

  2. Click LUNs in the center pane.

  3. Select the LUN from the list.

  4. Click the plus (+) symbol to expand the LUN and view the initiators to which the LUN is unmasked.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column and select actions from the menu.

Related links |
Creating LUNs | ESI overview
Expanding LUNs | ESI home window
Deleting LUNs |
Viewing storage pools |


Deleting LUNs

To delete a LUN in ESI:

  1. In the left pane of the ESI window, select the storage system.

  2. Click LUNs in the center pane, and then select one or more LUNs to delete from the list.

    3. Note: To select multiple LUNs, press and hold Ctrl and click the LUNs to delete. Each LUN is highlighted as it is selected.

  3. In the Actions pane, click Delete LUN.

    The Delete LUN wizard appears.

  4. Click Next, and then click Yes when prompted for confirmation.

  5. On the Review Input Parameters page, review the settings and then click Next to confirm them.

  6. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are deleting a LUN, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step. Click More Information to view more progress details.

  7. On the Summary page, click Finish.

Related |
Creating LUNs | ESI overview
Expanding LUNs | ESI home window
Viewing LUNs |
Viewing storage pools |


Viewing volumes

Viewing XtremIO volumes

You can use ESI to view volume storage information for XtremIO systems. The Volumes tab includes: volume name and ID, user (total) capacity, available capacity, parity type of XtremIO data protection (XDP), provision type, parent storage pool, Network Address Authority (NAA, required bits in the World Wide Name), and host name and IP address.

To view XtremIO volumes:

  1. In the left pane of the ESI window, select the XtremIO storage system.

  2. Click Volumes in the center pane.

  3. Select the volume from the list.

  4. Click the plus (+) symbol to expand the volume and view the initiators to which the volume is unmasked.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Viewing masked volumes | ESI overview
Viewing storage pools | ESI home window
Viewing masked LUNs |
Viewing storage groups |


Deleting volumes

To delete an XtremIO volume in ESI:

  1. In the left pane of the ESI window, select the XtremIO storage system.

  2. Click Volumes in the center pane, and then select one or more volumes to delete from the list.

    3. Note: To select multiple volumes, press and hold Ctrl and click the volumes to delete. Each volume is highlighted as it is selected.

  3. In the Actions pane, click Delete Volume.

    The Delete LUN wizard appears.

  4. Click Nextand then click Yes when prompted to confirm.

  5. On the Review Input Parameters page, review the settings and then click Next to confirm them.

  6. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are deleting a volume, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step. Click More Information to view more progress details.

  7. On the Summary page, click Finish.

Related links |
Creating volumes | ESI overview
Viewing storage pools | ESI home window
Viewing masked LUNs |
Viewing storage groups |


Viewing storage pools

You can use the Storage Pools tab to view the storage pools for a selected storage system, the LUNs (XtremIO volumes) in each storage pool, and the initiators to which each LUN is unmasked.

To view storage pools:

  1. In the left pane of the ESI window, select the storage system.

  2. Click Storage Pools in the center pane.

  3. Select a storage pool from the list.

  4. Click the plus (+) symbol to expand the storage pool and view the LUNs in that storage pool.

  5. Click the plus (+) symbol next to a LUN to view the initiators to which that LUN is unmasked.

Notes:

  • To customize the center pane, such as to remove or add columns for a custom view, right-click a column and select actions from the menu.

  • When you create snapshot LUNs for block storage systems, ESI adds a new storage pool for snapshot LUNs to the Storage Pools tab. This pool lists all snapshot LUNs created for that storage system. This pool is just a list and not an actual storage pool.

  • Because XtremIO does not use storage pools, the entire XtremIO system is listed as a single storage pool in the Storage Pools tab.

Related links |
Creating LUNs | ESI overview
Expanding LUNs | ESI home window
Viewing LUNs |
Viewing masked LUNs |
Viewing storage groups |


Viewing registered hosts

For supported block storage systems, ESI requires that you add or register hosts before viewing them in ESI.

To view registered hosts for block storage arrays:

  1. In the left pane of the ESI window, select the storage system.

  2. Click Registered Hosts in the center pane. The registered hosts are listed.

  3. Click the plus (+) symbol to expand the registered host information.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Expanding LUNs | ESI overview
Viewing LUNs | ESI home window
Viewing storage pools |
Viewing masked LUNs |


Viewing masked LUNs

You can view masked LUNs in the ESI GUI for supported EMC storage systems. Masked LUNs are provisioned and managed as logical storage system components in ESI.

You must use the ESI PowerShell Toolkit to mask and unmask LUNs with ESI. Set-EmcLunAccess provides details.

How you view masked LUNs depends on the type of storage system:

  • For VNX and VNXe3200 block storage systems, you can view masked LUNs in the Storage Groups tab. Viewing storage groups provides details.

  • For VMAX and some VNXe storage systems, use the LUN Masking Views tab to view masked LUNs.

  • For XtremIO storage systems, use the Masking Views tab to view masked volumes.

Note: You can also view masked LUNs with the ESI PowerShell Toolkit. Get-EmcLunMaskingView provides details.

To view masked LUNs for VNXe and VMAX storage systems:

  1. In the left pane of the ESI window, select the storage system.

  2. Click LUN Masking Views in the center pane.

The masked LUNs are displayed.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Creating LUNs | ESI overview
Creating volumes | ESI home window
Viewing storage pools | Viewing masked volumes
Viewing storage groups |


Viewing masked volumes

Viewing XtremIO masked volumes

You can view masked volumes in the ESI GUI for EMC XtremIO storage systems. Masked volumes are provisioned and managed as logical storage system components in ESI.

You must use the ESI PowerShell Toolkit to mask and unmask volumes with ESI. Set-EmcLunAccess provides details.

Note: You can also view masked volumes with the ESI PowerShell Toolkit. Get-EmcLunMaskingView provides details.

To view masked volumes:

  1. In the left pane of the ESI window, select the storage system.

  2. Click Masking Views in the center pane.

The masked volumes and related information are displayed.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Creating volumes | ESI overview
Deleting volumes | ESI home window
Viewing storage pools |
Viewing storage groups |


Viewing storage groups

For block storage systems, you can view masked LUNs in the Storage Groups tab.

To view the storage groups:

  1. In the left pane of the ESI window, select the storage system.

  2. Click Storage Groups in the center pane. The storage group details are listed.

Notes:

  • The storage groups listed here are the same storage groups that are available in Unisphere.

  • To customize the center pane, such as to remove or add columns for a custom view, right-click on a column in the center pane and select actions from the menu.

  • For VMAX and some VNXe storage systems, use the LUN Masking Views tab to view masked LUNs. Viewing masked LUNs provides details.

Related links |
Viewing LUNs | ESI overview
Viewing storage pools | ESI home window
Viewing registered hosts |
Viewing masked LUNs |


Viewing service nodes

Each LUN is assigned an active service node. Service nodes can have multiple ports that can be either Fibre Channel (FC) or iSCSI.

Note: Because XtremIO systems do not use service nodes, you cannot view service nodes for XtremIO systems in ESI.

To view the service nodes for a block storage system, such as VNX-Block and VNXe:

  1. In the left pane of the ESI window, select the storage system.

  2. Click Service Nodes in the center pane.

  3. Click the plus (+) symbol to expand the storage processor (SP) A or SP B list.

  4. Click Fibre Channel Target Ports to view the FC target ports for each SP.

  5. Click iSCSI Target Ports to view iSCSI target ports for each SP.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click the column and select actions from the menu.

Related links |
Creating LUNs | ESI overview
Expanding LUNs | ESI home window
Viewing LUNs |
Viewing masked LUNs |
Viewing storage pools |
Viewing registered hosts |


Viewing LUN groups

You can use the ESI GUI to view LUN groups for VNXe3200 systems only.

For each LUN group, you can view total capacity, total current allocation, thin provisioning setting, member LUNs, snapshots, hosts with LUN access, and hosts with snapshot access.

To view LUN groups:

  1. In the left pane of the ESI window, select a VNXe3200 system.

  2. Click LUN Groups in the center pane.

  3. Select a LUN group from the list.

  4. Click the plus (+) symbol to expand and view group details.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Creating LUNs | ESI overview
Expanding LUNs | ESI home window
Viewing LUNs | VNXe Adapter overview


Viewing storage controllers

Viewing XtremIO storage controllers

You can view details about storage controllers for XtremIO storage systems in ESI. The Storage Controllers tab provides details about the FC and iSCSI target ports, such as: iSCSI qualified name (IQN) or World Wide Name (WWN), IP address, availability, storage controller ID, and link status.

To view XtremIO storage controllers:

  1. In the left pane of the ESI window, select an XtremIO storage system.

  2. Click Storage Controllers in the center pane.

  3. Select a storage controller from the list.

  4. Click the plus (+) symbol to expand the controller data and view specifics for FC and iSCSI target ports.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column and select actions from the menu.

Related links |
Creating volumes | ESI overview
Viewing volumes | ESI home window
Viewing masked LUNs |
Viewing initiator groups |


Viewing initiator groups

Viewing XtremIO initiator groups

You can view details about initiator groups for XtremIO storage systems in ESI. The Initiator Groups tab includes the initiator group names and host bus adapter (HBA) IDs for each group.

To view XtremIO initiator groups:

  1. In the left pane of the ESI window, select an XtremIO storage system.

  2. Click Initiator Groups in the center pane.

  3. Select an initiator group from the list.

  4. Click the plus (+) symbol to expand for more details, such as the HBA ID.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column and select actions from the menu.

Related links |
Creating volumes | ESI overview
Viewing storage pools | ESI home window
Viewing masked LUNs |
Viewing volumes |


Adding hosts

ESI requires that you add all supported systems as hosts before you can view or manage these systems in ESI.

Adding Windows system hosts

To add a Windows system host in ESI:

  1. In the left pane of the ESI window, click Hosts.

  2. In the Actions pane, click Add Windows System or Add Host.

  3. In the Add Host dialog box, specify the following.

Field | Description
IP address/Name | IP address or name of the host
Username and Password | Username and password for the host

Note: Instead of entering a username and password, you can select Use current Windows credentials.

  4. Click Test Connection to test the connection.

  5. Click Add.

The host appears in the center pane.

Adding Linux system hosts

To add a Linux system host in ESI:

  1. In the left pane of the ESI window, click Hosts.

  2. In the Actions pane, click Add Linux System.

  3. In the Add Linux Host dialog box, specify the following.

Field

Description

IP address/Name

IP address or name of the host

Port

Confirm the default value of 22.

Note: If you change this, the connection will fail.

Authentication Type

Select Password to use your Linux password for authentication.

Or select Key-based to use your Linux encryption key.

Password:

Username and Password

Username and password for the host

Key based:

  • Username

  • Filepath

  • Passphrase

Username for your Linux encryption key.

Browse for or type the path for the key.

Type the passphrase for the key.

  4. Click Test Connection to test the connection.

  5. Click Add.

The host appears in the center pane.

Related links |
Removing hosts | ESI overview
Creating disks | Home window


Removing hosts

To remove hosts from ESI:

  1. In the left pane of the ESI window, select EMC Storage Integrator or Hosts.

  2. Select the host from the center pane.

  3. In the Actions pane, click Remove System.

  4. Click Yes to confirm that you want to remove the host.

Related links |
Adding hosts | ESI overview
Creating disks | Home window
Deleting disks |


Creating disks

Creating host disks

If the host is a virtual machine hosted on a hypervisor, review the notes in Creating disks for a virtual machine before creating virtual disks for virtual machines. The hypervisor must appear in the Hypervisors section of the ESI main window and a hypervisor host must be added after the hypervisor is connected and listed in the Hypervisors section or the disk creation will fail.

To create one or more disks or LUNs for a host:

  1. In the left pane of the ESI window, select the host.

  2. In the Actions pane, click Create Disk.

    The Create Disk wizard appears.

  3. Select the storage system, and then click Next.

  4. On the Storage Pool page, select a storage pool, and then click Next.

  5. On the New LUN page, set the following details for one or more new LUNs, and then click Next.

Field | Description
LUN Count | Number of disks to be created
Sequence Number | First number to append to the name for the first LUN Note: For example, to create three LUNs with the appended numbers 15, 16, and 17, type 3 in the LUN Count field and type 15 in the Sequence Number field.
Name | Name of disk or disks
Description | Description for the disk or disks
Size | Size and unit of measurement for each disk
Service Node | Storage processor that hosts the disk or disks
Provision Type | Select either Thick or Thin
Stop provisioning new LUNS when error occurs | To stop creating new folders if an error occurs during the process

  6. On the Disk Preparation Settings page, set the following details for the disk or disks, and then click Next.

Field

Description

Partition Type

Type of partition to be created, either MBR (Master Boot Record) or GPT (GUID Partition Table)

Volume Size

Disk volume size

File System

For MBR partitions:

  • NTFS (New Technology File System)

  • For Linux only, Ext2, Ext3, or Ext4

For GPT partitions: NTFS is the only available option

Allocation Unit Size

Size of the allocation unit measured in bytes

Volume Label

Label for the volume

Drive Letter or Mount Path

Drive letter or a mount path for the disk or disks

Note: For Linux, Mount Path is the only available option

  7. On the Review Input Parameters page, review the selected settings, and then click Next to confirm them.

  8. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are connecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  9. On the Summary page, click Finish.

    The disk or disks appear in the list of Host Disks for the specific host and in the LUNs list under Storage Systems.

Related links |
Creating disks for virtual machines | ESI overview
Creating SCSI Disks | ESI home window
Creating virtual disks |
Creating pass-through SCSI disks |
Viewing host disks |
Connecting disks |
Disconnecting disks |
Deleting disks |
Expanding disks |


Creating SCSI disks

Note: The SCSI disk option is not available for VMAX storage systems when provisioning storage to virtual machines.

To create one or more SCSI disks after adding a host:

  1. In the left pane of the ESI window, select the host.

  2. In the Actions pane, click Create Disk.

    3. The Create Disk wizard appears.

  3. Select SCSI Disk as the disk type, and then click Next.

  4. On the Storage System page, verify the information, and then click Next.

  5. On the Storage Pool page, select the storage pool, and then click Next.

  6. On the New LUN page appears, set the details for the new disk or disks, and then click Next.

Field | Description
Name | Name of the disk or disks
Description | Description for the disk or disks
Size | Size and unit of measurement for each disk
Service Node | Storage processor that hosts the disk or disks
Provision Type | Select either Thick or Thin

  7. On the Disk Preparation Settings page, set the details for the disk or disks, and then click Next.

Field

Description

Partition Type

Type of partition to be created, either MBR (Master Boot Record) or GPT (GUID Partition Table)

Volume Size

Disk volume size in MB

File System

  • Partition Type of MBR or GPT is NTFS as the only available choice

Allocation Unit Size

Size of the allocation unit measured in bytes

Volume Label

Label for the volume

Drive letter or mount path

Drive letter or a mount path for the disk or disks

  8. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  9. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are creating a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  10. On the Summary page, click Finish.

    11. The disk or disks appear in the list of Host Disks for the specific host and in the LUNs list under Storage Systems.

Related links |
Creating disks | ESI overview
Creating disks for virtual machines | ESI home window
Creating virtual disks |
Creating pass-through SCSI disks |
Viewing host disks |
Connecting disks |
Disconnecting disks |
Deleting disks |
Expanding disks |


Creating virtual disks

You must add the host before creating virtual disks. You can use ESI to create additional virtual disks for a virtual machine. However, before this option is available, the hypervisor that hosts the virtual machine must appear in the Hypervisors section on the main ESI windows and the virtual machine must be listed in the Hosts section. When you select the virtual machine in the Hosts section, the Hypervisor and Hypervisor Type must appear at the top of the center pane (gray information area). If these do not appear, the virtual machine might have been discovered before the hypervisor. If so, remove the virtual machine and add it again as a host.

To create a virtual disk after adding a host:

  1. In the left pane of the ESI window, select the host. The host has to be a virtual machine that correctly identifies the hypervisor

  2. Select the host disk from the center pane.

  3. In the Actions pane, click Create Disk.

    4. The Create Disk wizard appears.

  4. Select Virtual Hard Disk as the disk type, and then click Next.

  5. On the Create File-based Disk page, set the following details and then click Next.

Field | Description
File Name | Name of the file, including the file extension of VHD, VHDX, or VMDK.
Size | Size of the file in GB
File-based Disk Type | Select either Fixed or Dynamic

Note: The page that appears next depends on the type of host that you select:

    • The Hypervisor Settings page appears if you selected a hypervisor host.

    • The VMware Settings page appears if you selected a VMware vSphere host.

    6. On either the Hypervisor Settings or VMware Settings pages, set the following details, and then click Next.

    Field

    Description

    Controller

    Hypervisor or VMware controller

    Location

    SCSI controller location

    Persistence (VMware Settings page only)

    Types include:

    • Persistent: Changes are immediately and permanently written to the disks

    • Independent Persistent: Independent disks are not affected by snapshots

    • Independent Non Persistent: Changes to disks are discarded when you shut down your system or revert to the snapshot

    Disk Provisioning (VMware Settings page only)

    Select either Thick or Thin

    7. Depending on the hypervisor, the Disk Preparation Settings page may appear. If the page appears and the disk does not require these values, skip this step. If the disk requires one or more of the following, set the applicable details, and then click Next.

    Field

    Description

    Partition Type

    Type of partition to be created, select either MBR (Master Boot Record) or GPT (GUID Partition Table)

    File System

    • Partition Type of MBR or GPT is NTFS as the only available choice

    Allocation Unit Size

    Size of the allocation unit measured in bytes

    Volume Label

    Label for the volume

    Drive letter or mount path

    Drive letter or a mount path to the disk

    Note: If you enter a drive letter and folder path that does not exist, ESI will create the specified folder path, and then create the disk.

    8. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

    9. On the Progress page, click Next.

    Note: Click More Information for more progress details. If a problem occurs while you are connecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    10. On the Summary page, click Finish.

    Related links |
Creating disks | ESI overview
Creating disks for virtual machines | ESI home window
Creating SCSI disks |
Creating pass-through SCSI disks |
Viewing host disks |
Connecting disks |
Disconnecting disks |
Deleting disks |
Expanding disks |


Creating pass-through SCSI disks

If the selected hypervisor supports pass-through SCSI disks, then selecting Passthrough SCSI is an option when you are creating a disk for a virtual machine. See Creating raw device mapping disks if the hypervisor supports a raw device mapping disk instead.

To create one or more pass-through SCSI disks after adding a host:

  1. In the left pane of the ESI window, select the host.

  2. Select the host disk from the center pane.

  3. In the Actions pane, click Create Disk.

    4. The Create Disk wizard appears.

  4. Select Passthrough SCSI Disk as the disk type, and then click Next.

  5. On the Storage System page, select the storage system, and then click Next.

  6. On the Storage Pool page, select the storage pool, and then click Next.

  7. On the New LUN page, set the following details for the disk or disks, and then click Next.

Field | Description
LUN Count | Number of disks to be created
Sequence Number | First number to append to the name for the first LUN Note: For example, to create three LUNs with the appended numbers 15, 16, and 17, type 3 in the LUN Count field and type 15 in the Sequence Number field.
Name | Name of the disk or disks
Description | Description for the disk or disks
Size | Size and unit of measurement for each disk
Service Node | Storage processor that hosts the disk or disks
Provision Type | Select either Thick or Thin

  8. On the Hypervisor Settings page, select the SCSI controller and SCSI controller location settings, and then click Next.

Note: For hypervisors, ESI does not support creating SCSI controllers. However, ESI uses existing SCSI controllers to create disks for virtual machines.

  9. On the Disk Preparations Settings page, set the following values for the disk or disks, and then click Next.

Field | Description
Partition Type | Type of partition to be created, either MBR (Master Boot Record) or GPT (GUID Partition Table)
File System | Partition Type of MBR or GPT is NTFS as the only available choice
Allocation Unit Size | Size of the allocation unit measured in bytes
Volume Label | Label for the volume
Drive letter or mount path | Drive letter or a mount path for the disk or disks

  10. On the Review Parameters Input page, review the settings, and then click Next to confirm them.

  11. On the Progress page, click Next.

    Note: Click More Information for more progress details. If a problem occurs while you are creating a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  12. On the Summary page, click Finish.

    13. The disk or disks appear in the list of Host Disks for the specific host and in the LUNs list under Storage Systems.

Related links |
Creating disks | ESI overview
Creating disks for virtual machines | ESI home window
Creating SCSI disks |
Creating virtual disks |
Creating raw device mapping disks |
Viewing host disks |
Connecting disks |
Disconnecting disks |
Deleting disks |
Expanding disks |


Creating raw device mapping disks

If the hypervisor supports raw device mapping (RDM) disks, then RDM is an option when you are creating disks for a virtual machine. See Creating pass-through SCSI disks if the hypervisor uses a pass-through SCSI disk.

Note: With VMware systems, ESI does not support expanding RDM disks that are attached with virtual compatibility mode.

To create one or more RDM disks:

  1. In the left pane of the ESI window, select the host.

  2. In the Actions pane, click Create Disk.

    3. The Create Disk wizard appears.

  3. Select Raw Device Mapping as the disk type, and then click Next.

  4. On the Storage System page, select the storage system, and then click Next.

  5. On the Storage Pool page, select the storage pool, and then click Next.

  6. On the New LUN page, set the details for the new disk or disks, and then click Next.

Field | Description
LUN Count | Number of disks to be created
Sequence Number | First number to append to the name for the first LUN Note: For example, to create three LUNs with the appended numbers 15, 16, and 17, type 3 in the LUN Count field and type 15 in the Sequence Number field.
Name | Name of the disk or disks
Description | Description for the disk or disks
Size | Size and unit of measurement for each disk
Service Node | Storage processor that hosts the disk or disks
Provision Type | Select either Thick or Thin
Stop provisioning new LUNs when error occurs | To stop creating new LUNs if an error occurs during the process

  7. On the hypervisor settings page, set the following field values, and then click Next.

Note: For hypervisors, ESI does not support creating SCSI controllers. However, ESI uses existing SCSI controllers to create disks for virtual machines.

Field

Description

Controller

SCSI controller

Location

SCSI controller location

RDM Compatibility Mode

The type of compatibility (physical or virtual)

Note: If you select Physical in the RDM Compatibility field, the guest operating system can access the hardware directly.

Persistence

Types include:

  • Persistent: Changes are immediately and permanently written to the disks.

  • Independent Persistent: Independent disks are not affected by snapshots.

  • Independent Non Persistent: Changes to disks are discarded when you shut down your system or revert to the snapshot.

Note: With Physical mode, Persistent is the only available option.

Disk Provisioning

Options if you create a virtual disk:

  • Thick Provision Eager Zeroed: All disk space is allocated and any previous content is deleted when the disk is created; this option may take longer than the other two options.

  • Thick Provision Lazy Zeroed: All disk space is allocated but existing content is not deleted when the disk is created.

  • Thin Provision: Allocates only the disk space that is currently needed.

  8. On the Disk Preparations Settings page, set the following field values for the disk or disks, and then click Next.

Field | Description
Partition Type | Type of partition to be created, either MBR (Master Boot Record) or GPT (GUID Partition Table)
Volume Size | Disk volume size
File System | Partition Type of MBR or GPT is NTFS as the only available choice
Allocation Unit Size | Size of the allocation unit measured in bytes
Volume Label | Label for the volume
Drive letter or mount path | Drive letter or a mount path to the disk

  9. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  10. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are connecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  11. On the Summary page, click Finish.

    12. The disk appears in the list of Host Disks for the specific host and in the LUNs list under Storage Systems.

Related links |
Creating disks | ESI overview
Creating disks for virtual machines | ESI home window
Creating SCSI disks |
Creating virtual disks |
Creating pass-through SCSI disks |
Viewing host disks |
Connecting disks |
Disconnecting disks |
Deleting disks |
Expanding disks |


Viewing host disks

To view host disks in ESI:

  1. In the left pane of the ESI window, select Hosts. The list of available hosts appears in the center pane.

  2. Select a host from the list.

  3. Click Host Disks. The list of host disks is displayed.

  4. Click the plus (+) symbol to expand the host disk information.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Creating disks | ESI overview
Creating disks for virtual machines | ESI home window
Creating SCSI disks |
Creating virtual disks |
Creating pass-through SCSI disks |
Connecting disks |
Disconnecting disks |
Deleting disks |
Expanding disks |


Connecting disks

To connect a disk to a host:

  1. In the left pane of the ESI window, select the host.

  2. Select the host disk from the center pane.

  3. In the Actions pane, click Connect Disk.

    4. The Connect Disk wizard appears.

  4. On the Storage System page, select the storage system, and then click Next.

  5. On the Storage Pool page, select the storage pool, and then click Next.

  6. In the LUN page, select one or more LUNs, and then click Next.

  7. In the Review Input Parameters page, review the settings, and then click Next to confirm them.

  8. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are connecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  9. On the Summary page, click Finish.

Related links |
Creating disks | ESI overview
Connecting SCSI disks | Home window
Connecting virtual disks |
Connecting pass-through SCSI disks |
Connecting raw device mapping disks |
Disconnecting disks |


Connecting SCSI disks

To connect a SCSI disk to a host:

  1. In the left pane of the ESI window, select the host.

  2. Select the host disk from the center pane.

  3. In the Actions pane, click Connect Disk.

    4. The Connect Disk wizard appears.

  4. On the Select Disk Type page, select SCSI Disk, and then click Next.

  5. On the Storage System page, review the details, and then click Next.

  6. On the Storage Pool page, select a storage pool, and then click Next.

  7. On the LUN page, select a LUN, and then click Next.

  8. On the LUN Masking Settings page, review the settings, and then click Next.

  9. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  10. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are connecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  11. On the Summary page, click Finish.

Related links |
Creating SCSI disks | ESI overview
Connecting disks | Home window
Connecting virtual disks |
Connecting pass-through SCSI disks |
Connecting raw device mapping disks |
Disconnecting disks |


Connecting virtual disks

To connect a virtual disk to a host:

  1. In the left pane of the ESI window, select the host.

  2. Select the host disk from the center pane.

  3. In the Actions pane, click Connect Disk.

    4. The Connect Disk wizard appears.

  4. On the Select Disk Type page, select Virtual Disk, and then click Next.

  5. On the Virtual Hard Disk page, type the File Path, or browse to select it, and then click Next.

  6. On the Hypervisor Settings page, select the controller and location settings, and then click Next.

  7. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  8. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are connecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

      9. On the Summary page, click Finish.

Related links |
Creating virtual disks | ESI overview
Connecting disks | Home window
Connecting SCSI disks |
Connecting pass-through SCSI disks |
Connecting raw device mapping disks |
Disconnecting disks |


Connecting pass-through SCSI disks

To connect a pass-through SCSI disk to a host:

  1. In the left pane of the ESI window, select the host.

  2. Select the host disk from the center pane.

  3. In the Actions pane, click Connect Disk.

    4. The Connect Disk wizard appears.

  4. On the Select Disk Type page, select Passthrough SCSI Disk, and then click Next.

  5. On the Hypervisor Settings page, select the controller and location settings, and then click Next.

  6. On the Passthrough SCSI Disk page, select the candidate disk, and then click Next.

  7. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  8. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are connecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    9. On the Summary page, click Finish.

Related links |
Creating pass-through SCSI disks | ESI overview
Connecting disks | Home window
Connecting SCSI disks |
Connecting virtual disks |
Connecting raw device mapping disks |
Disconnecting disks |


Connecting raw device mapping disks

To connect a raw device mapping (RDM) disk to a host:

  1. In the left pane of the ESI window, select the host.

  2. Select the host disk from the center pane.

  3. In the Actions pane, click Connect Disk.

    4. The Connect Disk wizard appears.

  4. On the Select Disk Type page, select the disk type of Raw Device Mapping, and then click Next.

  5. On the VMware vSphere Settings page, set the following field values, and then click Next:

Note: For hypervisors, ESI does not support creating SCSI controllers. However, ESI uses existing SCSI controllers to create disks for virtual machines.

Field

Description

Controller

SCSI controller.

Location

SCSI controller location.

RDM Compatibility Mode

Type of compatibility (physical or virtual).

Note: With physical mode, the guest operating system can access the hardware directly.

Persistence

Types include:

  • Persistent: Changes are immediately and permanently written to the disks.

  • Independent Persistent: Independent disks are not affected by snapshots.

  • Independent Non Persistent: Changes to disks are discarded when you shut down your system or revert to the snapshot.

Note: With Physical mode, Persistent is the only available option.

Disk Provisioning

Select one of the following options if you are creating a virtual disk:

  • Thick Provision Eager Zeroed: All disk space is allocated and any previous content is deleted when the disk is created; this option may take longer than the other two options.

  • Thick Provision Lazy Zeroed: All disk space is allocated but existing content is not deleted when the disk is created.

  • Thin Provision: Allocates only the disk space that is currently needed.

  6. On the Passthrough SCSI Disk page, select the candidate disk, and then click Next.

  7. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  8. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are connecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    9. On the Summary page, click Finish.

Related links |
Creating raw device mapping disks | ESI overview
Connecting disks | Home window
Connecting SCSI disks |
Connecting virtual disks |
Connecting pass-through SCSI disks |
Disconnecting disks |


Disconnecting disks

To disconnect a disk from a host:

  1. In the left pane of the ESI window, select the host.

  2. Click Host Disks, and then select the host disk from the list.

  3. In the Actions pane, click Disconnect Disk.

    4. The Disconnect Host Disk wizard appears.

  4. Click Next.

  5. Click Yes when prompted for confirmation again.

  6. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  7. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are disconnecting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  8. On the Summary page, click Finish.

Related links |
Creating disks for a host | ESI overview
Connecting disks | ESI home window
Deleting disks |
Expanding disks |
Changing a host disk drive letter or path |


Deleting disks

Deleting host disks

To delete one or more host disks:

  1. In the left pane of the ESI window, select the host.

  2. In the center pane, click Host Disks, and then select the disk or disks to delete.

Note: To select multiple disks from the list, press and hold Ctrl and select each disk. Each disk is highlighted as it is selected.

  3. In the Actions pane, click Delete Disk.

    4. The Delete Disk wizard appears.

  4. Confirm the list of disks to delete, and then click Next.

  5. Click Yes when prompted for confirmation again.

  6. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  7. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are deleting a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    8. On the Summary page, click Finish.

Related links |
Creating disks | ESI overview
Connecting disks | ESI home window
Disconnecting disks |
Expanding disks |
Changing a host disk drive letter or path |


Expanding disks

Expanding host disks

With ESI, you can expand host disks that meet the following criteria:

  • The disk has only one volume. The volume can be expanded if the host is connected.

  • The disk has an associated LUN that can either be expanded or is a file-based disk which is supported by VMware.

Note: With VMware systems, ESI does not support expanding RDM disks that are attached with virtual compatibility mode.

To expand host disks in ESI:

  1. In the left pane of the ESI window, select the host.

  2. In the center pane, click Host Disk, and then select a disk from the list.

  3. From the menu bar, select Action > Expand Disk.

  4. On the New Disk Capacity page, type the new capacity for the disk, select a unit of measurement, and then click Next.

Note: For example, change the disk capacity from 3 GB to 4 GB.

  5. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  6. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are expanding a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  7. On the Summary page, click Finish.
    The expanded storage capacity for the disk will display in the Host Disks tab.

Related links |
Creating disks | ESI overview
Connecting disks | ESI home window
Disconnecting disks |
Deleting disks |
Changing a host disk drive letter or path |


Changing a host disk drive letter or path

To change a drive letter or path for a host disk:

  1. In the left pane of the ESI window, select the host.

  2. Click Host Disks.

  3. Select a disk from the list.

  4. In the Actions pane, click Change Drive Letter and Paths.

    5. The Change Drive Letter and Paths wizard appears.

  5. Select the drive letter or mount point, and then click Next.

  6. Click Yes when prompted for confirmation again.

  7. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

    8. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  9. On the Summary page, click Finish. The drive letter or mount path is changed.

Related links |
Creating disks for a host | ESI overview
Connecting disks | ESI home window
Disconnecting disks |
Deleting disks |
Expanding disks |


Viewing SAN initiators

To view the SAN initiators for a host:

  1. In the left pane of the ESI window, select Hosts.

  2. Select the host from the center pane.

  3. Click SAN Initiators.

The SAN initiator details are listed.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Viewing host disks | ESI overview
 | ESI home window


Adding host clusters

To add host clusters in ESI:

  1. In the left pane of the ESI window, select EMC Storage Integrator or a host cluster.

  • If you selected EMC Storage Integrator, click Add Host Cluster in the Actions pane.

  • If you selected Host Clusters, click Add Cluster System in the Actions pane.

  2. In the Add Cluster dialog box, specify the following for the cluster.

Field | Description
IP address/Name | IP address or name of the cluster
Username/Password | Username and password for the cluster Note: You can instead click Use current Windows credentials.

  3. Click Test Connection to test the connection before adding it.

  4. Click Add.

The cluster appears in the Available Systems list.

Related links |
Creating cluster disks | ESI overview
Viewing host clusters and nodes | Home window
Connecting cluster disks |
Connecting cluster nodes |
Disconnecting cluster disks |
Deleting cluster disks |
Removing clusters |
Changing a cluster disk drive letter or path |


Viewing host clusters and nodes

To view host cluster disks, cluster nodes, and SAN initiators of a host cluster:

  1. In the left pane of the ESI window, select Host Clusters.

  2. Select the host cluster.

  3. Click Cluster Disks from the center pane.

The cluster disks are listed.

  4. Click the following tabs in the center pane to view host cluster details:

  • Cluster Disks

  • Cluster Nodes

  • SAN Initiators

  5. Click the plus (+) symbols to expand the host cluster information.

Notes:

  • Click Connect to Host in the Actions pane or click the host node to connect to the host. This host must be added to ESI. If not, ESI prompts you to add the host.

  • To customize the center pane, such as to remove or add columns for a custom view, right-click on a column in the center pane and select actions from the menu.

Related links |
Adding host clusters | ESI overview
Creating cluster disks | Home window
Connecting cluster disks |
Connecting cluster nodes |
Disconnecting cluster disks |
Deleting cluster disks |
Removing clusters |
Changing a cluster disk drive letter or path |


Removing clusters

To remove one or more clusters from a host:

  1. In the left pane of the ESI window, select EMC Storage Integrator or Host Clusters.

  2. Select one or more clusters from the center pane.

Note: To select multiple clusters, press and hold Ctrl and select each cluster from the list. Each cluster is highlighted as it is selected.

  3. In the Actions pane, click Remove System.

  4. Click Yes to confirm your selection.

Related links |
Adding host clusters | ESI overview
Creating cluster disks | Home window
Viewing host clusters and nodes |
Disconnecting cluster disks |
Deleting cluster disks |


Creating cluster disks

To create one or more cluster disks after a host cluster is added:

  1. In the left pane of the ESI window, select the host cluster.

  2. In the Actions pane, click Create Cluster Disk.

    3. The Create Cluster Disk wizard appears.

  3. In the Storage System list box, select a storage system, and then click Next.

  4. On the Storage Pool page, select a storage pool, and then click Next.

  5. On the New LUN page, set the following values for the new disk or disks, and then click Next.

Field | Description
LUN Count | Number of disks to be created
Sequence Number | First number to append to the name for the first disk Note: For example, to create three LUNs with the appended numbers 15, 16, and 17, type 3 in the LUN Count field and type 15 in the Sequence Number field.
Name | Name of the disk or disks
Description | Description of the disk or disks
Size | Size and unit of measurement for each disk
Service Node | Storage processor that hosts the disk or disks
Provision Type | Select either Thick or Thin Note: The Thin option is not available if the selected pool does not support thin LUNs.
Application | The type of application, such as Generic Storage or some other type Note: This field appears only if a VNXe storage system is selected.

  6. On the Cluster Parameters page, select one of the following, and then click Next:

    • Cluster Group and the name of a cluster group

    • Cluster Shared Volumes for a shared disk

  7. On the Disk Preparation Settings page, set the following values, and then click Next.

Field

Description

Partition Type

Type of partition to be created, either MBR (Master Boot Record) or GPT (GUID Partition Table)

File System

  • Partition Type of MBR or GPT is NTFS as the only available choice

Allocation Unit Size

Size of the allocation unit in bytes

Volume Label

Label for the volume

Drive letter or mount path

Drive letter or mount path for the disk

  8. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  9. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are creating a cluster disk, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  10. In the Summary page, click Finish.

    11. The cluster disk or disks appear in the Cluster Disks list for the specified cluster.

Related links |
Adding host clusters | ESI overview
Viewing host clusters and nodes | Home window
Connecting cluster disks |
Connecting cluster nodes |
Disconnecting cluster disks |
Deleting cluster disks |
Removing clusters |
Changing a cluster disk drive letter or path |


Connecting cluster disks

To connect a cluster disk to a host cluster:

  1. In the left pane of the ESI window, select the host cluster.

  2. In the Actions pane, click Connect Cluster Disk.

    3. The Connect Cluster Disk wizard appears.

  3. In the Storage System list box, select a storage system, and then click Next.

  4. On the Storage Pool page, select a storage pool, and then click Next.

  5. On the LUN page, select a LUN from the storage pool, and then click Next.

  6. On the Cluster Parameters page, select one of the following, and then click Next:

  • Cluster Group and the name of a cluster group

  • Cluster Shared Volumes for a shared disk

  7. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  8. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are connecting the disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  9. On the Summary page, click Finish.

Related links |
Adding host clusters | ESI overview
Creating cluster disks | Home window
Viewing host clusters and nodes |
Connecting cluster nodes |
Disconnecting cluster disks |
Deleting cluster disks |
Removing clusters |
Changing a cluster disk drive letter or path |


Connecting cluster nodes

To connect a cluster node to a host:

  1. In the left pane of the ESI window, select the host cluster.

  2. Click Cluster Nodes from the center pane.

  3. Select a cluster node from the list.

  4. In the Actions pane, click Connect.

Related links |
Adding host clusters | ESI overview
Creating cluster disks | Home window
Viewing host clusters and nodes |
Connecting cluster disks |
Disconnecting cluster disks |
Deleting cluster disks |
Removing clusters |
Changing a cluster disk drive letter or path |


Disconnecting cluster disks

To disconnect a cluster disk from a host cluster:

  1. In the left pane of the ESI window, select the host cluster.

  2. Select the cluster disk from the list.

  3. In the Actions pane, click Disconnect Cluster Disk.

    4. The Disconnect Cluster Disk wizard appears.

  4. On the Disconnect Cluster Disk page, click Next.

  5. Click Yes to confirm your selection.

  6. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  7. On the Progress page, click Next.

    8. Note: Click More Information for more progress details. If a problem occurs while you are disconnecting a disk, an error message appears along with options to resume or roll back the process. After you resolve the error, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  8. On the Summary page, click Finish.

Related links |
Adding host clusters | ESI overview
Creating cluster disks | Home window
Viewing host clusters and nodes |
Connecting cluster disks |
Connecting cluster nodes |
Deleting cluster disks |
Removing clusters |
Changing a cluster disk drive letter or path |


Deleting cluster disks

To delete one or more cluster disks from a host cluster:

  1. In the left pane of the ESI window, select a host cluster.

  2. Select one or more cluster disks to be deleted.

Note: To select multiple disks from the list, press and hold Ctrl and select each disk. Each disk is highlighted as it is selected.

  3. In the Actions pane, click Delete Cluster Disk.

    4. The Remove Cluster Disk wizard appears.

  4. Verify the cluster disk details, and then click Next.

  5. Click Yes when prompted for confirmation again.

  6. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  7. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are deleting a disk, an error message appears along with options to resume or roll back the process. After you resolve the error, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  8. On the Summary page, click Finish.

Related links |
Adding host clusters | ESI overview
Creating cluster disks | Home window
Viewing host clusters and nodes |
Connecting cluster disks |
Connecting cluster nodes |
Disconnecting cluster disks |
Removing clusters |
Changing a cluster disk drive letter or path |


Changing a cluster disk drive letter or path

To change the drive letter or path for a cluster disk:

  1. In the left pane of the ESI window, select Host Clusters.

  2. Click Cluster Disks in the center pane.

  3. Select the cluster disk to change.

  4. In the Actions pane, click Change Drive Letter and Paths.

    5. The Change Drive Letter and Paths wizard appears.

    5. Set the following values to change, and then click Next.

      Field

      Description

      Drive Letter

      Select from the available drive letters.

      Mount Path

      Click Browse and locate the path.

    6. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  7. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are assigning the new drive letter or path, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  8. On the Summary page, click Finish.

    9. The cluster disk appears in the Cluster Disks list with the new disk drive or path.

Related links |
Adding host clusters | ESI overview
Creating cluster disks | Home window
Viewing host clusters and nodes |
Connecting cluster disks |


Creating disks for virtual machines

ESI supports Microsoft Hyper-V and VMware vSphere hypervisors. The disk options in ESI vary depending on what the hypervisor supports.

The following table shows the storage options that are supported by ESI for each hypervisor.

Disk Option | Microsoft Hyper-V | VMware vSphere
Pass-through disk | Yes (Pass-through SCSI) | Yes (Raw Device Mapping)
File-based or virtual disk | Yes (VHD or VHDX file) | Yes (VMDK file)
Datastore |  | Yes
SCSI disk |  | Yes
Host disk | Yes |
Storage repository |  |
Cluster shared volumes | Yes |

You can create the following disk types for virtual machines:

  • SCSI disk (VMware vSphere)

  • Virtual disk (Hyper-V and VMware vSphere)

  • Pass-through SCSI disk (Hyper-V) or raw device mapping (RDM) (VMware vSphere)

Notes:

  • For hypervisors, ESI does not support creating new SCSI controllers. However, ESI uses existing SCSI controllers to create disks for a virtual machine.

  • For hypervisors, if the Virtual disk option is not available, confirm that the applicable hypervisor appears as a connected hypervisor in the Hypervisors section in the main ESI window. When you select the virtual machine in the Hosts section, the Hypervisor and Hypervisor Type must appear at the top of the center pane (gray information area). If these do not appear, the virtual machine might have been discovered before the hypervisor. If so, remove the virtual machine and add it again as a host.

  • The order of the pages and steps vary slightly in the Create Disk wizard, depending on the disk type that you select.

Related links |
Managing virtual machines in ESI | ESI overview
Attaching virtual disks | ESI home window
Removing virtual disks |
Viewing snapshot LUNs |
Deleting snapshot LUNs |


Managing virtual machines in ESI

To connect a virtual machine so that it can be managed in ESI:

  1. In the left pane of the ESI window, select Hypervisors and one of the hypervisor servers.

    2. Click Virtual Machines in the center pane and select a virtual machine from the list.

  3. In the Actions pane, click Connect to Host.

    Note: If the virtual host is already in ESI, click Connect to Host to open the pane that displays the host information.

  4. Click Yes to confirm that you want to manage this virtual machine host in ESI.

    5. The Add Host dialog box appears.

  5. Review the details for the IP address or host name.

Note: Adding hosts provides more information about adding a host.

  6. Click Test Connection to test the connection before adding it.

  7. Click Add.

    8. The host name appears in the center pane.

Related links |
Creating disks for virtual machines | ESI overview
Attaching virtual disks | ESI home window
Removing virtual disks |
Viewing snapshot LUNs |
Deleting snapshot LUNs |


Attaching virtual disks

To attach a virtual disk:

  1. In the left pane of the ESI window, select Hypervisors and one of the hypervisor servers.

    2. Click Virtual Machines from the center pane and select a virtual machine from the list.

  3. In the Actions pane, click Attach Disk.

    4. The Attach Disk wizard appears.

  4. Identify the disk being attached by selecting one of the following four options:

  • Virtual hard disk

  • Virtual hard disk and create a virtual disk or LUN

  • Pass-through SCSI disk

  • Pass-through SCSI disk and create a virtual disk or LUN

Note: If you create a virtual disk or LUN during this process, select Create Virtual Disk or LUN. The pages for each disk option are different.

To attach a virtual hard disk:

  1. On the Select Disk Type page, select Virtual Hard Disk, and then click Next.

  2. On the Virtual Hard Disk page, type the File Path, or browse to select it, and then click Next.

    3. The Hypervisor Settings or VMware Settings page appears.

  3. Select the controller and location settings, and then click Next.

  4. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  5. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are attaching a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  6. On the Summary page, click Finish.

Note: Creating virtual disks provides more details on virtual hard disk settings.

To attach a virtual hard disk and create a virtual disk or LUN:

  1. On the Select Disk Type page, select Virtual Hard Disk.

  2. Select the Create Virtual Hard Disk or LUN checkbox, and then click Next.

  3. On the Virtual Hard Disk page, select a file name, location, size, and type (fixed or dynamic)and then click Next.

    4. The Hypervisor Settings or VMware Settings page appears.

  4. Select the controller and location settings, and then click Next.

  5. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  6. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are attaching a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

        7. On the Summary page, click Finish.

Note: Creating virtual disks provides more details on virtual hard disk and hypervisor settings.

To attach a pass-through SCSI disk:

  1. On the Select Disk Type page, select Passthrough SCSI Disk and then click Next.

  2. On the Passthrough SCSI Disk page, select the candidate disk from the list, and then click Next.

    3. The Hypervisor Settings or VMware Settings page appears.

  3. Select the controller and location settings, and then click Next.

  4. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  5. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are attaching a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  6. On the Summary page, click Finish.

Note: Creating pass-through SCSI disks provides more details.

To attach a pass-through SCSI disk and create a virtual disk or LUN:

  1. On the Select Disk Type page, select Passthrough SCSI Disk.

  2. Select the Create Virtual Hard Disk or LUN checkbox, and then click Next.

  3. On the Storage System page, review the details, and then click Next.

  4. On the Storage Pool page, select the storage pool for the disk, and then click Next.

  5. On the New LUN page, select the LUN count, sequence number, name, description, and other details for the new LUN, and then click Next.

    6. The Hypervisor Settings or VMware Settings page appears.

  6. Select the controller and location settings, and then click Next.

  7. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  8. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are attaching a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  9. On the Summary page, click Finish.

    10. Note: Creating pass-through SCSI disks provides more details.

Related links |
Creating disks for virtual machines | ESI overview
Managing virtual machines in ESI | ESI home window
Removing virtual disks |
Viewing snapshot LUNs |
Deleting snapshot LUNs |


Removing virtual disks

To remove virtual disks from a hypervisor in ESI:

  1. In the left pane of the ESI window, select Hypervisors and one of the hypervisor servers.

  2. Click Virtual Machines from the center pane and select a virtual machine.

  3. Click the plus (+) symbol to view the disks in the virtual machine.

  4. Select one or more disks to be removed and click Remove System in the Actions pane.

  5. Click Yes to confirm that you want to remove the virtual disks.

    6. The Remove Virtual Disk wizard appears.

  6. Select the Delete the corresponding virtual file or the passthrough SCSI disk checkbox if you want to delete the file or disk.

  7. Confirm the list of the disk or disks to be removed, and then click Next.

  8. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  9. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are removing a disk, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  10. On the Summary page, click Finish.

Related links |
Creating disks for virtual machines | ESI overview
Managing virtual machines in ESI | ESI home window
Attaching virtual disks |
Viewing snapshot LUNs |
Deleting snapshot LUNs |


Viewing snapshot LUNs

To view snapshot LUNs for a storage system:

  1. In the ESI window, select the storage system with the snapshot LUN.

  2. Click LUNs from the center pane to display a list of snapshot LUNs.

  3. Click the plus (+) symbol to view disk details.

Notes:

  • To create a snapshot LUN, use the ESI PowerShell Toolkit. ESI does not support creating snapshot LUNs from the ESI window, but you can create them using ESI PowerShell cmdlets. Getting started with the ESI PowerShell toolkits provides more details. You can then view and delete snapshot LUNs in the ESI window.

  • You cannot view or manage snapshot LUNs for VMAX systems in ESI. However, future ESI releases will support snapshot LUNs for VMAX.

  • For a block storage system, when you create snapshot LUNs, ESI adds a new snapshot LUNs storage pool to the Storage Pool tab. This pool groups and presents all the snapshot LUNs created for that storage system in that special storage pool. This pool is just a group and is not an actual storage pool. Viewing storage pools provides details about storage pools.

Related links |
Creating disks for virtual machines | ESI overview
Managing virtual machines in ESI | ESI home window
Attaching virtual disks |
Removing virtual disks |
Deleting snapshot LUNs |


Deleting snapshot LUNs

To delete one or more snapshot LUNs:

  1. In the ESI window, select the storage system with the snapshot LUN.

  2. Click LUNs from the center pane and select one or more snapshot LUNs from the list to delete.

Note: To select multiple snapshot LUNs from the list, press and hold Ctrl and select each snapshot LUN. Each snapshot LUN is highlighted as it is selected.

  3. In the Actions pane, click Delete LUN.

    4. The Delete LUN wizard appears.

  4. Click Yes when prompted for confirmation.

  5. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  6. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs while you are deleting a snapshot LUN, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  7. On the Summary page, click Finish.

Notes:

  • To create a snapshot LUN, use the ESI PowerShell Toolkit. ESI does not support creating snapshot LUNs from the ESI window, but you can create them using ESI PowerShell cmdlets. Getting started with the ESI PowerShell toolkits provides more details. You can then view and delete snapshot LUNs in the ESI window.

  • You cannot create or delete snapshot LUNs for VMAX systems in ESI. However, future ESI releases will support snapshot LUNs.

  • For a block storage system, when you can create snapshot LUNs, ESI adds a new snapshot LUNs storage pool to the Storage Pool tab. This pool groups and presents all the snapshot LUNs created for that storage system in that special storage pool. This pool is just a group and is not an actual storage pool. Viewing storage pools provides details about storage pools.

Related links |
Creating disks for virtual machines | ESI overview
Managing virtual machines in ESI | ESI home window
Attaching virtual disks |
Removing virtual disks |
Viewing snapshot LUNs |


Adding hypervisor servers

To add Microsoft Hyper-V or VMware vSphere hypervisor servers.

  1. In the left pane of the ESI window, select EMC Storage Integrator or Hypervisors.

  2. In the Actions pane, click Add Hypervisor.

  3. In the Add New Server dialog box, set the following values.

    Field

    Description

    Server

    Host name or IP address of the server that you are adding

    Type

    Select one of the following hypervisor types:

    • Microsoft Hyper-V

    • VMware vSphere

    Current Credentials

    or

    Specify Credentials

    Use existing server credentials

    or

    New username and password for that server

  4. Click Test Connection to test the connection before adding it.

  5. Click Add.

The server name appears in the center pane.

Related links |
Viewing hypervisor hosts | ESI overview
Viewing hypervisor datastores | ESI home window
Viewing hypervisor virtual machines |
Viewing hypervisor SAN initiators |
Viewing hypervisor SCSI LUNs |


Viewing hypervisor ESX hosts

Viewing hypervisor hosts

    To view hosts for Microsoft Hyper-V and VMware vSphere hypervisor servers:

  1. In the left pane of the ESI window, select Hypervisors, and then select one of the hypervisor servers.

  2. Click Hosts from the center pane.

Hosts details, such as host names, IP addresses, cluster and datacenter names, and the username, appears.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Adding hypervisor servers | ESI overview
Viewing hypervisor datastores | ESI home window
Viewing hypervisor virtual machines |
Viewing hypervisor SAN initiators |
Viewing hypervisor SCSI LUNs |


Viewing hypervisor datastores

You can view all datastores for a hypervisor or view datastores for a specific cluster.

To view all datastores for a hypervisor:

  1. In the left pane of the ESI window, select Hypervisors, and then select one of the hypervisor servers.

  2. Click Datastores from the center pane.

  3. Select a datastore from the list and then click the plus (+) symbol.

    4. Datastore information, such as LUNs, storage IDs, capacity, and provision types, appears.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

To view datastores for a specific cluster:

  1. In the left pane of the ESI window, select Hypervisors, and then select one of the hypervisor servers.

  2. From the left pane, click the plus (+) symbol for the hypervisor, and then click Datacenter - ESI.

  3. Click the plus (+) symbol for Datacenter - ESI and then click the plus (+) symbol for Cluster.

  4. Select a cluster from the list, and then click Datastores.

Datastore information appears for the cluster.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Adding hypervisor servers | ESI overview
Viewing hypervisor hosts | ESI home window
Viewing hypervisor virtual machines |
Viewing hypervisor SAN initiators |
Viewing hypervisor SCSI LUNs |


Viewing hypervisor virtual machines

You can view the virtual machines for the hypervisor or view virtual machines for a specific cluster.

To view the virtual machines for the hypervisor:

  1. In the left pane of the ESI window, select Hypervisors, and then select one of the hypervisor servers.

  2. Click Virtual Machines from the center pane, and then select a virtual machine from the list.

  3. Click the plus (+) symbol.

Disk information for the virtual machine appears.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

To view virtual machines for a specific cluster:

  1. In the left pane of the ESI window, select Hypervisors, and then select one of the hypervisor servers.

  2. From the left pane, click the plus (+) symbol for the hypervisor, and then click Datacenter - ESI.

  3. Click the plus (+) symbol for Cluster.

  4. Select a cluster from the list, and then click Virtual Machines.

Disk information is displayed for the virtual machines in the selected cluster.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Adding hypervisor servers | ESI overview
Viewing hypervisor hosts | ESI home window
Viewing hypervisor datastores |
Viewing hypervisor SAN initiators |
Viewing hypervisor SCSI LUNs |


Viewing hypervisor SAN initiators

To view SAN initiators for a hypervisor:

  1. In the left pane of the ESI window, select Hypervisors, and then select one of the hypervisor servers.

  2. From the left pane, click the plus (+) symbol for the hypervisor, and then click Datacenter - ESI.

  3. Click the plus (+) symbol for Datacenter - ESI and then click the + symbol for Cluster.

  4. Select a cluster from the list, and then click SAN Initiators.

The SAN initiator details appear.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Adding hypervisor servers | ESI overview
Viewing hypervisor hosts | ESI home window
Viewing hypervisor datastores |
Viewing hypervisor virtual machines |
Viewing hypervisor SCSI LUNs |


Viewing hypervisor SCSI LUNs

To view SCSI LUNs for a hypervisor:

  1. In the left pane of the ESI window, select Hypervisors, and then select one of the hypervisor servers.

  2. From the left pane, click the plus (+) symbol for the hypervisor, and then click Datacenter - ESI.

  3. Click the plus (+) symbol for Datacenter - ESI and then click the plus (+) symbol for Cluster.

  4. Select a cluster from the list, and then click SCSI LUNs.

The SCSI LUN details appear.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Adding hypervisor servers | ESI overview
Viewing hypervisor hosts | ESI home window
Viewing hypervisor datastores |
Viewing hypervisor virtual machines |
Viewing hypervisor SAN initiators |


Deleting hypervisor servers

To delete hypervisor servers in ESI:

  1. In the left pane of the ESI window, select Hypervisors, and then select a hypervisor.

  2. In the Actions pane, click Remove System.

  3. Click Yes to confirm your selection.

Related links |
Adding hypervisor servers | ESI overview
Viewing hypervisor hosts | ESI home window
Viewing hypervisor datastores |


ESI Microsoft SharePoint Adapter overview

ESI SharePoint Adapter overview

You can use the ESI SharePoint Adapter to perform the following functions with Microsoft SharePoint farms:

  • View SharePoint storage, farms, sites, and content databases.

  • Connect to existing SharePoint farms and enumerate farm information, including servers, Web Applications, Site Collections, and Content Databases.

  • Create content database and storage for the database, and map content databases to storage.

  • Provision storage on the SharePoint server by partitioning, formatting, and assigning it a drive letter, and provisioning the storage to the SharePoint site.

  • Support the File Stream Remote BLOB Store.

  • Create a web application and map it to the newly created content database.

  • Provision a web application and the associated content database

Note: For provisioning SharePoint storage, ESI requires that SQL Server and SharePoint be installed in the same Windows domain as the ESI host controller. If SQL Server is not running in the same Windows domain as ESI, SharePoint provisioning operations will fail.

Feature limitations

This adapter has the following feature limitations:

  • Does not support XtremIO storage systems.

  • SharePoint Foundation Client is not supported.

  • Domain-based SharePoint farm deployment is supported; however, clustered and stand-alone installations and web applications for remote farms are not supported.

Note: If you create a database without a web application on a remote farm, you cannot view the new database in ESI.

Prerequisites

The ESI Microsoft SharePoint Adapter has the following prerequisites:

  • Windows Server 2012 R2 or 2012 with SP2 is installed. (Windows Server Core installations are not supported.)

  • SQL Server 2012 R2, 2012, or 2008 R2 is installed.

  • Microsoft SharePoint Server 2013 or SharePoint Foundation 2013 is installed.

Installation

This adapter is installed by default with ESI. If you changed the defaults during your installation of ESI, then reinstall ESI and confirm that the adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installation overview provide system prerequisites and installation instructions for the ESI host system.

Related links |
Adding SharePoint farms | ESI overview
Creating SharePoint web applications | ESI home window
Removing SharePoint farms | SQL Server Adapter overview
Configuring remote SQL servers |


Adding SharePoint farms

To add a SharePoint farm:

  1. In the left pane of the ESI window, select EMC Storage Integrator or Applications > SharePoint.

  2. In the Actions pane, click Add Application.

  3. In the Applications dialog box, set the following values:

Field

Description

Farm Friendly Name

Type a name to identify the farm.

Local Farm

        • If ESI is running on the same server as the farm, select the Local Farm checkbox.

        • Clear the checkbox to connect to a remote farm.

        • Note: If Local Farm is not selected and the database server name matches the local server as the ESI host, ESI assumes that you are adding a local farm and ignores all of the field values except for the Friendly Name.

Database Server

Type the database server name.

Configuration Database

      • Type the farm name of the configuration database.

      • Get these details from the SQL Server or SharePoint administration.

Integrated Security

Select to use Microsoft Windows Authentication.

User Name and Password

Clear the Integrated Security checkbox to use SQL Server Authentication, and then type a username and password.

  4. To confirm that the values are correct, click Test Connection.

  5. Click Add.

The farm is added to the list in the Applications window. However, ESI is not yet connected to the farm.

Related links |
ESI Microsoft SharePoint Adapter overview | ESI overview
Viewing SharePoint farms | Home window
Creating SharePoint web applications |
Removing SharePoint farms |
Configuring remote SQL servers |


Viewing SharePoint farms

To view SharePoint farms:

  1. From the left pane of the ESI window, select Applications > SharePoint.

  2. Click the farm name to activate the connection.

  3. Click Web Applications to list the web applications in the farm.

  4. Click the plus (+) symbol to expand a web application and view Site Collections and Content Databases.

  5. Click Storage to view the content databases that are mapped to the storage systems used by the farms.

  6. Click the plus (+) symbol to view database storage details.

Related links |
ESI Microsoft SharePoint Adapter overview | ESI overview
Adding SharePoint farms | ESI home window
Creating SharePoint web applications |
Removing SharePoint farms |
Configuring remote SQL servers |


Creating SharePoint web applications

To create a SharePoint web application after a SharePoint farm is added:

  1. In the left pane of the ESI window, select Applications > SharePoint and the applicable SharePoint farm.

  2. In the Actions pane, click New SharePoint Web Application.

The ESI SharePoint Provisioning Wizard appears.

  3. On the SharePoint Information page, set the following values.

Field | Description
Selected Farm | The farm selected in step 1 appears in this field. Note: If the farm has more than one SQL Server, they will also be listed in the Database Server list box.
New IIS Web Site | For a local farm, select this checkbox, and then type a name to create a new web application. This field is not available if this is a remote farm. Note: If you do not want to create a new web application, clear the New IIS Web Site checkbox.
Database Server | Confirm or change the default corresponding database server.
SQL Server Instance | Confirm or change the default SQL Server instance.

Note: You cannot create SharePoint web applications for remote farms in ESI.

Application Pool Security Settings

To create a new web application, set the following values.

Field | Description
User Name | Confirm or change the default SharePoint username that has access to the configuration database.
Password | Password for the user who has access to the configuration database.
Confirm Password | Retype the password again to confirm it.

  4. Click Next.

If SQL Server is running on a virtual machine, the Select Disk Type page appears. If the Database Storage page appears, skip to step 7.

For the Virtual Hard Disk type, skip to step 7. Otherwise, the Database Storage page appears.

  5. In the Disk Type field, select the applicable disk type, and then click Next.

Note: Unless a Windows-based hypervisor is an option, the SCSI Disk type is the only choice.

For the Virtual Hard Disk type, skip to step 7. Otherwise, the Database Storage page appears.

  6. If the Database Storage page appears, set the following field values for new LUNs, and then click Next.

Field | Description
Database Name | Database name.
Data File Folder: Drive Letter or Mount Path | Drive letter or mount path for the data file folder.
Log File Folder: Drive Letter or Mount Path | Drive letter or mount path for the log file folder.

  7. On the Create File-based Disk page, set the following values for new LUNs, and then click Next.

Field | Description
File Name | Complete file name (including the VHD or VHDX extension) of the file to be used as a hard drive.
Folder | Folder on the hypervisor machine in which the file should be created.
Size | Size of the file in GB.
File-based Disk Type | Select either Fixed or Dynamic.

  8. On the Disk and Database Size Information page, set the following values, and then click Next.

Field | Description
Data File Initial Size | Initial size of the data file.
Log File Initial Size | Initial size of the log file.
Database Maximum Size | Maximum size of the database.
Database Growth Rate | Database growth rate.
Data Disk Size | Size of the data disk.
Log Disk Size | Size of the log disk. Note: The Log Disk Size field is unavailable when only one disk is being created for both folders. This occurs when the same drive letter or mount path is selected for both the data and log folders on the Database Storage page.

  9. On the Database Security page, confirm that the Server Name and SQL Instance Name are correct, and then set the following values.

    10. Field

    Description

    Integrated Security

    If SQL Server is configured for Windows Authentication, confirm that this checkbox is selected.

    Set the following values if Integrated Security is selected:

    • Database User Name

    SQL Server username

    • Password

    SQL Server password

    • Confirm Password

    Retype the password again to confirm it.

  10. Click Next.

The Remote Blob Storage (RBS) Information page appears.

  11. In the Storage System list box, select a storage system to host the SharePoint storage, and then click Next.

  12. On the Storage Pool Information page, select the required storage pool and service node, and then click Next.

  • Storage Pools: Select a storage pool or RAID group to host SharePoint storage.

  • Service Node: For a service node, select the applicable node.

  13. On the Review Parameters page, review the settings, and then click Next to confirm them.

  14. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs during this process, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  15. On the Summary page, click Finish.

Related links |
ESI Microsoft SharePoint Adapter overview | ESI overview
Adding SharePoint farms | ESI home window
Viewing SharePoint farms |
Removing SharePoint farms |
Configuring remote SQL servers |


Removing SharePoint farm

Removing SharePoint farms

To remove a SharePoint farm:

  1. From the left pane in ESI, select Applications > SharePoint.

  2. In the center pane, select the SharePoint farm.

  3. In the Actions pane, click Remove Application.

  4. In the Remove Farm dialog box, click Yes.

Related links |
ESI Microsoft SharePoint Adapter overview | ESI overview
Adding SharePoint farms | Home window
Viewing SharePoint farms |
Creating SharePoint web applications |
Configuring remote SQL servers |


Configuring remote SQL Servers

If you are using ESI to connect to a remote SharePoint farm, the SQL Server computer and other servers in the farm are distinct from the machine on which ESI is running.

For a remote SQL Server computer, complete the following steps to set up the remote connection with ESI:

Setting up login mode

  • SQL Authentication: If the remote SQL Server computer is configured for SQL Authentication, then confirm the data complies with the defined guidelines.

This should be simple, assuming that the machine running ESI is authenticated or trusted in the domain to which the farm belongs.

  • Windows Authentication: If the remote SQL Server is configured for Windows Authentication, then it is possible that the user who logged in to the ESI machine is in the same domain as the one used by SQL Server.

Note: ESI supports domain-based farm deployments, which requires that SQL Server and SharePoint be installed in the same Windows domain as the ESI host controller.

Setting up SQL Server

To set up SQL Server:

  1. On the SQL Server machine, navigate to Start > All Programs > SQL Server 2008 > Configuration Tools > SQL Server Configuration Manager.

  2. In the left side of the MMC console, expand SQL Server Network Configuration.

  3. Click Protocols for <Name>.

    4. The name may be MSSQLSERVER, but may be a different name, depending on your installation.

  4. In the main MMC view, double-click TCP/IP and confirm that it is enabled.

  5. In TCP/IP properties, click IP Address and confirm the following:

  1. The IP address is correct. For a virtual environment, you may need to correct the address.

  2. The port number is 1433. If the port number is different, make a note of the port number that SQL Server uses.

  6. Click Apply, and then click OK.

  7. In the left pane of MMC, confirm that TCP/IP is enabled under SQL Native Client appears.

Setting up the firewall

On the computer that is running SQL Server, which should be the same computer on which you applied the SQL settings, enable port 1433 in the firewall. If the selected port is not 1433, then enable the port that you noted. Then confirm that TCP/IP is enabled for the port.

Confirming the connection

If a machine other than the one configured earlier is running SQL Server, then open SQL Server Management Studio and confirm the connection:

  1. On the small toolbar above the left pane, click Connect Object Explorer.

  2. Complete the applicable details by using the correct server name.

    3. You can then connect to the remote server and browse the databases.

  3. Confirm the configuration by opening Visual Studio 2008.

  4. In Server Explorer, click Connect to Database.

  5. Type the remote SQL server name or IP address.

  6. Click Test Connection.

Related links |
ESI Microsoft SharePoint Adapter overview | ESI overview
Adding SharePoint farms | ESI home window
Viewing SharePoint farms |
Creating SharePoint web applications |
Removing SharePoint farms |


Exchange Integration overview

Exchange Adapter overview

Microsoft Exchange Server is a mail server, calendaring software, and contact manager program that runs on Windows Server. ESI Exchange Adapter enables you, the storage administrator, to integrate Exchange with supported EMC storage systems.

With this adapter, you can perform the following Exchange tasks in ESI:

  • Adding and viewing Exchange forests

  • Removing Exchange forests

You can also use the Exchange cmdlets in the ESI PowerShell Toolkit to add, view, and remove Exchange forests.

Limitations

  • This adapter does not support XtremIO storage systems.

  • You cannot use ESI to create DAGs or to create, add, or remove mailbox servers. Use the Exchange Management Tools for these tasks instead.

  • Prerequisites

  • For native Exchange DAGs, Microsoft Exchange 2013 installed on each Exchange server

  • Full installation of Windows Server 2012 R2 or 2102 SP2 on each Exchange server (Server Core installations are not supported)

  • For EMC RecoverPoint replication, ESI RecoverPoint Adapter is installed on the ESI controller and EMC RecoverPoint/SE or EX, version 4.2, and the applicable splitters are set up for each supported EMC storage system. EMC RecoverPoint Release Notes on EMC Online Support has more details about EMC RecoverPoint/SE and EMC RecoverPoint/EX.

Installation

When you install ESI for Windows, the ESI Exchange Adapter is an installable option in the InstallShield Wizard Setup window. After installation, the adapter requires no additional setup.

Related links |
Adding and viewing Exchange forests | ESI overview
 | ESI home window


Adding and viewing Exchange forests

Before you can view Exchange storage, add one or more Exchange on-premises forests or organizations in ESI. ESI does not support Exchange online forests. Exchange limits a single DAG to a maximum of 16 servers, so that is the maximum number supported in ESI.

After adding one or more Exchange forests in ESI, you can view all Exchange entities in that forest, including DAGs, mailbox servers, databases, and database copies. ESI discovers and associates database copies to corresponding host disks in ESI.

You can view the status of the database copies and associated disks in the ESI GUI or with the ESI PowerShell Toolkit. You can also use the Get-EmcMailboxServer and Get-EMCHostSystem ESI PowerShell cmdlets to associate Exchange mailbox servers with the corresponding host systems.

To add an Exchange on-premises forest:

  1. In the left pane of the ESI window, select Applications > Exchange.

  2. In the Actions pane, click Add Exchange.

The Add Exchange forest dialog box appears.

  3. Set the following field values for the forest.

Field | Description
Friendly Name | Short name for the forest that is unique across the different forests
FQDN or URL | Fully Qualified Domain Name (FQDN) or URL of an Exchange server name or URL that is in the forest
User login Username | Administrator user name for the forest
User login Password | Administrator password for the forest
Use current Windows Credential | Accept or change it to use the current credentials of the ESI host system

  4. Click Add to add the forest.

The forest and related servers appears in the Available Systems list in the center pane.

Note: Click Test Connection to test if the field settings are correct before adding the forest.

Related links |
Managing Exchange with ESI | ESI overview
Removing Exchange forests | ESI home window


Removing Exchange forests

To remove Exchange forests:

  1. In the left pane of the ESI window, select Applications > Exchange > Applicable Mailbox Server and the applicable mailbox forest.

  2. In the Actions pane, click Remove System.

  3. In the Remove System dialog box, click Yes to remove the forest and related servers.

Related links |
Managing Exchange with ESI | ESI overview
Adding and viewing Exchange forests | Home window


ESI SQL Server Adapter overview

ESI Microsoft SQL Server Adapter overview

The ESI SQL Server Adapter enables you to view local and remote Microsoft SQL Server instances and databases and to map the databases to EMC storage. ESI supports the SQL Server 2012 and 2014 Always On feature, so you can view the primary SQL Server replica and up to four secondary replicas.

You can use SQL Scripts to create and configure SQL Server databases from an ESI host.

This adapter supports all EMC storage systems that ESI supports with one exception. It does not support XtremIO storage systems.

Prerequisites

This adapter supports the following versions of Windows Server and SQL Server (full, 64-bit installations):

Supported versions | Windows 2012 | Windows 2012 R2
SQL Server 2008 R2 | Supported | Supported
SQL Server 2012 | Supported | Supported
SQL Server 2012 SP1 | Supported | Supported
SQL Server 2014 | Supported | Supported

Additionally, this adapter requires that ESI and SQL Server are connected to the same domain controller and you have Administrator login credentials for SQL Server.

Installation

This adapter is installed by default with ESI. If you changed the defaults during your installation of ESI, then reinstall ESI and confirm that the adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installation overview provide system prerequisites and installation instructions for the ESI host system.

Related links |
Adding SQL Servers | ESI overview
Viewing SQL Servers | ESI home window
Creating SQL Server databases |
Using T-SQL |


Adding SQL Servers

To add a SQL Server as an ESI host controllee:

  1. In the left pane of the ESI window, select Applications > SQL Server.

  2. In the Actions pane, click Add SQL Servers.

  3. In the SQL Servers dialog box, perform one of the following:

  • Select I have a range of Servers and type one or more IP addresses to define the range.

  • Select I will provide a list of IPs and type a list of one or more IP addresses or names (one IP or name per line). Click Browse to locate the server name.

  4. Click Start Scanning to locate and list the properties for the specified range of one or more servers.

  5. All accessible SQL Servers are by default set to be added. To not add a specific SQL Server, clear the Checked checkbox for that specific server in the list.

  6. Click Add.

The server appears in All groups.

Note: If the "Failed to connect to one or more SQL Server" message appears, one or more SQL Server instances rejected the attempt to open a connection with Windows Authentication. Confirm that firewall and remote settings for the SQL Server instances are set up per Microsoft documentation and that the instances support Windows Authentication. Servers that cannot be accessed are identified as Unknown in the Virtual Machine column.

Related links |
SQL Server Adapter overview | ESI overview
Viewing SQL Servers | ESI home window
Adding SQL Server replicas | Adding SQL Server databases to availability groups
Creating SQL Server databases | Using T-SQL script


Viewing SQL Servers

To view SQL Servers and server instances in ESI:

  1. From the left pane of the ESI window, select Applications > SQL Server Groups.

  2. The center pane displays the following:

  • All groups displays data for the selected SQL Server group, including all connected SQL Servers, related instances, databases, and connected storage. Click the group to display the group details in the center pane.

  • Servers and Storage lists the data for the selected group. For example, for servers, you can view server IDs, instance IDs, database IDs, total visible memory, total storage, and other details.

  • AlwaysOn lists the servers, server instances, databases in availability groups, and other details about groups that support the SQL Server AlwaysOn feature. For example, you can view the databases, candidate databases (primary groups), and replicas for a specific availability group, and their roles, failover mode, connection states, and other related details.

  • Script Execution provides the following tasks:

            • For AlwaysOn groups, add and remove replicas.

            • For databases, create and delete databases and add or remove databases to or from database availability groups.

Notes:

  • Click the plus (+) symbol to view more details.

  • To customize the center pane, such as columns, right-click a column in the center pane and select the action from the menu.

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Adding SQL Server replicas | Adding SQL Server databases to availability groups
Creating SQL Server databases | Using T-SQL script


Creating SQL Server databases

You can use ESI to create and configure new SQL Server databases.

To create one or more SQL Server databases:

  1. In the left pane of the ESI window, select Applications > SQL Server Groups.

  2. In All Groups, select the SQL Server and instance for the database.

  3. Click Script Execution and then click Create Database.

  4. On the Create Database page, specify the following.

Field | Description
Use Selected Instance Storage | Select to use the selected instance for the database, which you select in All groups.
Data Storage | Select Create New Storage and click Go to create a new disk, which opens the Create Disk wizard for to specify the disk details. Or if using a selected instance, select the disk folder for the data storage and click Go.
Log Storage | Select Create New Storage and click Go to create a new disk, which opens the Create Disk wizard for to specify the disk details. Or you can select an existing disk and click Go.
Use Selected Server or Instance | Select to use the selected server or instance for storage.
Server | Select the server for the new database or databases.
Instance | Select the instance for the new database or databases.
Database Name | Type a unique database name.
File Name | Type a unique file name for the database or databases.
Folder(s) | Type a folder path for the database or databases.
Bulk Create | Select Create Multiple Databases to create multiple databases. Or leave the default of 1 to create one database.

  5. Confirm or change the following default settings for the new database or databases.

Field | Description
Bulk Create Create a folder for each database | Default is False.
Number of Databases to Create | Defaults to the Bulk Create number value set in step 4.
Database Data File Growth Rate | Default is 1.
Data Growth Rate Type | Default is MB.
Default Log File Size | Default is 1.
Log File Growth Rate | Default is 10.
Log Growth Rate Type | Default is Percentage.
Maximum Data File Size | Default is -1.
Maximum Log File Size | Default is based on the Log Storage setting in the previous step.
Use Separate Data and Log Disks | Default is False.
Misc Remember My Settings | Default is True.
Server and Instance Create Database on Default Instance | Default is True.
T-SQL Show Script Before Creating Database | Default is True, which displays the T-SQL script after you click Create database.

  6. Click Create database to create the database.

  7. When the Created Database message appears, click OK.

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Adding SQL Server replicas | Adding SQL Server databases to availability groups
Deleting SQL Server databases | Using T-SQL script


Adding SQL Server replicas

Adding replicas to SQL Server availability groups

To add a database replica:

  1. In the left pane of the ESI window, select Applications > SQL Server Groups.

  2. In All Groups, select the SQL Server and instance for the replica.

  3. Click Script Execution and then click Add Replica.

  4. On the Add Replica page, specify the following.

Field

Description

  1. Server

SQL Server in the availability group

Instance

SQL Server instance in the availability group

Availability Group

Availability group for the database replica

Candidate Replica Server

Candidate server for the replica

Candidate Replica Instance

Candidate instance for the replica

Show Script

Select to show the T-SQL script, which appears after adding the replica.

  5. Click Add Replica.

  6. When the added replica message appears, click OK.

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Viewing SQL Servers | Adding SQL Server databases to availability groups
Creating SQL Server databases | Using T-SQL script


Creating SQL Server AGs

Creating SQL Server availability groups

You can use ESI to create and configure new SQL Server availability groups.

To create a SQL Server availability group:

  1. In the left pane of the ESI window, select Applications > SQL Server Groups.

  2. In All Groups, select the SQL Server for the group.

  3. Click Script Execution and then click Create Availability Group.

  4. On the Create Availability Group page, specify the following.

Field | Description
Availability Group Name | Type a unique name for the availability group
Primary Server | Select the server to be the primary replica in the DAG. Only instances with AlwaysOn enabled are available.
Primary Instance | Select the instance to be the primary replica instance in the group.
Database | Select one or more databases to add to the availability group. Only databases with full backups are available.
Replica Server | Select the server to be the secondary replica server in the availability group.
Replica Instance | Select the instance to be the secondary replica instance in the availability group. Only instances with AlwaysOn enabled are available.
Shared Network Location | Browse to or type a shared network path in UNC format that is accesible by the primary and secondary servers in the DAG. Local paths are not supported.
Show script | Select to show the T-SQL script, which appears after adding the availability group.

  5. Click Create Availability Group.

  6. If an added availability group message appears, click OK.

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Adding SQL Server replicas | Adding SQL Server databases to availability groups
Deleting SQL Server databases | Using T-SQL script


Adding SQL Server databases to AGs

Adding a SQL Server database to an availability group

To add a SQL Server database to a specified availability group:

  1. In the left pane of the ESI window, select Applications > SQL Servers Group.

  2. In All groups, select the SQL Server that contains the database.

  3. Click Script Execution and then click Add Database to Availability Group.

  4. Confirm or specify the following.

Field | Description
Server | SQL Server in the availability group
Instance | SQL Server instance in the availability group
Availability Group | Availability group for which to add the database
Candidate Database | Candidate database to add to the group.
Show script | Select to show the T-SQL script, which appears after adding the database.

  5. Click Add Database.

  6. If the added database to availability group message appears, click OK.

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Adding SQL Server replicas | Removing SQL Server databases from availability groups
Creating SQL Server databases | Using T-SQL script


Deleting SQL Server databases

To delete a SQL Server database:

  1. In the left pane of the ESI window, select Applications > SQL Server Groups.

  2. In All groups, select the group from which to delete the database.

  3. Click Script Execution and then click Delete Database.

  3. On the Delete Database page, confirm the correct server and instance is selected.

  4. Select the database name, select Show script to show T-SQL script, and then click Delete.

  5. When the database deleted message appears, click OK.

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Adding SQL Server replicas | Adding SQL Server databases to availability groups
Creating SQL Server databases | Using T-SQL script


Removing SQL Server replicas

To remove a SQL Server replica:

  1. In the left pane of the ESI window, select Applications > SQL Server Groups.

  2. In All Groups, select the SQL Server and instance for the replica.

  3. Click Script Execution and then click Remove Replica.

  4. On the Remove replica page, confirm or specify the following:

Field | Description
Server | SQL Server that contains the replica
Instance | SQL Server instance that contains the replica
Availability Group | Availability group from which to remove the replica
Availability Replica | Replica to remove from the group.
Show script | Select to show the T-SQL script, which appears after removing the replica.

  5. Click Remove replica.

  6. When the removed replica message appears, click OK.

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Adding SQL Server replicas | Adding SQL Server databases to availability groups
Creating SQL Server databases | Using T-SQL script


Removing SQL Server databases from availability groups

To remove a SQL Server database from an availability group:

  1. In the left pane of the ESI window, select Applications > SQL Server Groups.

  2. In All groups, select the group from which to delete the database.

  3. Click Script Execution and then click Remove Database from Availability Group.

  4. On the Remove Database from Availability Group page, confirm or select the following.

Field | Description
Server | SQL Server in the availability group
Instance | SQL Server instance in the availability group
Availability Group | Availability group from which to remove the database
Availability Database | Database to remove from the group.
Show script | Select to show the T-SQL script, which appears after removing the database.

    5. Click Remove Database.

    6. When the database removed message appears, click OK.

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Adding SQL Server replicas | Adding SQL Server databases to availability groups
Creating SQL Server databases | Using T-SQL script


Using T-SQL

Using T-SQL script

In the Script Execution tab, you can use the Show Script field to view, edit, and run script changes with T-SQL.

When you select to show the script, the T-SQL script appears on the page after the task is completed. You can then edit and execute any script changes for the following tasks:

  • Add or remove SQL Server replicas

  • Create or delete SQL Server databases

  • Create or delete SQL Server availability groups

  • Add or remove SQL Server databases to or from availability groups

Related links |
SQL Server Adapter overview | ESI overview
Adding SQL Servers | ESI home window
Adding SQL Server replicas | Adding SQL Server databases to availability groups
Creating SQL Server databases | Viewing SQL Servers


ESI RecoverPoint Adapter overview

You can use the ESI RecoverPoint Adapter for local and remote data protection. If a disaster occurs, EMC RecoverPoint can recover lost data from any point-in-time that you select. You can use the EMC RecoverPoint to do the following:

  • Connect to existing EMC RecoverPoint/SE or RecoverPoint/EX systems.

  • Manage and view replication service clusters, which are groups of RecoverPoint sites and appliances working together to perform replication for storage and applications that are managed in ESI.

  • Add consistency groups, which are groups of one or more replica sets.

  • Add replica copies, which can be either local or remote copies of a LUN.

  • Add replica sets, which are a source LUN and the local and remote copies for that LUN.

  • Seamlessly provision journal and replica LUNs when creating replica copies and sets.

  • View underlying storage details for volumes used by RecoverPoint.

Prerequisites

The ESI RecoverPoint Adapter prerequisites are as follows:

  • A full version of Windows Server 2012 R2 or 2012 is installed. (Windows Server Core installations are not supported.)

  • SQL Server 2012, 2010 SP1, 2008 R2, or 2008, 64-bit is installed.

  • EMC RecoverPoint/SE or RecoverPoint/EX version 4.2 is installed.

  • System.net.http.formatting DLL is installed on the ESI host controller. When you select to install the RecoverPoint Adapter as part of the ESI installation, this DLL is installed for you.

EMC RecoverPoint Release Notes on EMC Online Support provides installation and setup details for EMC RecoverPoint/SE and EMC RecoverPoint/EX.

Installation

EMC RecoverPoint Adapter is installed by default with ESI. If you changed the defaults during the ESI installation, then reinstall ESI and confirm that the adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installation overview provide system prerequisites and installation instructions for the ESI host system.

Related links |
Adding replication services | ESI overview
Adding consistency groups | Home window
Adding replica copies |
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


AppSync Adapter overview

ESI AppSync Adapter overview

The ESI AppSync Adapter enables simple, self-service application protection with tiered protection options and proven recoverability. This adapter supports multiple SQL Server instances on the same host.

With this adapter, you can do the following tasks in ESI for supported SQL Server and Exchange databases:

  • View AppSync Application Server instances and databases, including their database files, copies, subscribed service plans, service plan events, registered storage, registered hosts, and registered RecoverPoint systems.

  • Subscribe and unsubscribe databases to AppSync service plans.

  • Protect databases with AppSync service plans or protection policies.

  • Mount and unmount database copies on VNX or RecoverPoint target hosts.

  • Expire and restore database copies.

Limitations

This adapter has the following limitations:

  • SQL Server system databases are not supported.

  • SQL Server database snapshots are not discovered.

Prerequisites

This adapter has the following system prerequisites:

  • EMC AppSync version 2.0 or 1.6 is installed on the Windows Server.

  • When installing the adapter as part of the ESI installation, confirm that you use the same service name and port information that was used when installing Windows Server.

SQL Server prerequisites

Your system must meet the following to use this adapter with SQL Server databases:

  • Meets the SQL Server Adapter prerequisites.

  • SQL Server databases and transaction logs must be stored on disks in the same storage system.

  • SQL Server databases must be online during replication.

  • EMC recommends you use the same version of SQL Server on the production and mount hosts.

  • Mount hosts must have SQL Server installed to recover databases from mounted copies.

Exchange prerequisites

Your system must meet the following to use this adapter with Exchange databases:

  • Meets the Exchange Adapter prerequisites.

  • Mount hosts and production hosts must have same version of Windows installed.

Installation

The ESI AppSync Adapter is installed by default with ESI. However, if you changed the defaults during your installation of ESI, reinstall ESI and confirm that this adapter is selected in the InstallShield Wizard Setup window. Prerequisites and Installing ESI provide system prerequisites and installation instructions for the ESI host system.

Setting up AppSync

After installing ESI, the following steps are required to set up AppSync:

  1. Install the AppSync Server and connect it to ESI.

  2. Add the AppSync system as a replication service.

  3. In the AppSync console, add all ESI supported applications to the AppSync Server, including Exchange DAGs, SQL Servers, EMC storage systems, and EMC RecoverPoint appliances.

Related links |
Adding replication services | ESI overview
RecoverPoint Adapter overview | Home window
Exchange Integration overview | SQL Server Adapter overview


Adding replication services

You can add replication services, such as the EMC RecoverPoint Appliance (RPA) or EMC AppSync Application Servers. You can configure a replication service to enable continuous backup and recovery from any point-in-time for LUNs from a storage system.

With the AppSync service, you can also set up protection and service plan (policies) levels for database recovery and failovers.

Before adding a replication service, you must identify the connection information for that service.

To add a replication service:

  1. In the left pane of the ESI window, select Replication.

  2. From the Actions pane, click Add Replication.

    The Add Replication Service dialog box appears.

  3. For System Type, select either RecoverPoint or AppSync.

  4. For RecoverPoint, specify the following.

    RecoverPoint field

    Description

    Friendly Name

    Short and unique name for the replication service

    RPA Management IP

    IP address for the replication service

    Username and Password

    Username and password for connecting to the service

    Ignore SSL Errors

    To ignore certificate errors

    Test Connection

    To test the connection before adding it

For AppSync, specify the following.

AppSync field | Description
Username and Password | Username and password for connecting to the service
Server's name or IP address | IP address for the replication service
Port number | Default is 8445
Test Connection | To test the connection before adding it

  5. Click Test Connection to test the connection before adding the service.

  6. Click Add.

The replication service appears in the Available Services list in the center pane.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
AppSync Adapter overview | ESI home windows
Adding consistency groups |
Adding replica copies |
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


Adding consistency groups

A consistency group is a group of one or more replica sets that can be backed up together and recovered together as a unit or a set. Consistency groups can include both local and remote replica copies, and usually include as many replication sets as there are volumes in the production storage to replicate.

To add a consistency group:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups.

  3. From the Actions pane, click Add Consistency Group.

The Add Consistency Group wizard appears.

    4. On the Consistency Group page, type a name for the new consistency group.

    5. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

    6. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  7. On the Summary page, click Finish.

    You can click Consistency Groups in the center pane to view details for the new consistency group.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding replica copies |
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


Adding replica copies

You can add local and remote replica copies. The first copy is the production copy. You can then add a local copy or a remote copy, or add both local and remote copies.

To add a production copy and one or more replica copies:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups.

  3. From the Actions pane, click Add Replica Copy.

    The Add Replica Copy wizard appears.

  4. On the Replica Copy page, specify the following and click Next.

    Field

    Description

    Name

    Name for the replica copy.

    Replication Site

    Replication site that you want to use.

    Journal Size

    Size in GB for the journal LUN.

    Link Mode

    If this is not the production copy, select Asynchronous or Synchronous.

    • Select Asynchronous for write transactions to be acknowledged locally at the source side and then sent to the target side. Asynchronous replicas can be the fastest option, and similar to synchronous, without degrading the performance of host applications. This mode is typically used for remote copies.

    • Select Synchronous for host applications to wait for an acknowledgement from a replica before continuing. Synchronous can be slower than asynchronous, but offers less risk of data loss. This mode is typically used for local copies.

  5. On the Journal Storage System page, select a storage system from which the journal LUN will be created, and then click Next.

  6. On the Journal Storage Pool page, select a storage pool from which the journal LUN will be provisioned, and then click Next.

  7. On the Review Input Parameters, review the parameters, and then click Next to confirm them.

  8. On the Progress page, click Next.

  11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  9. On the Summary page, click Finish.

    You can click Consistency Groups > Replica Copies in the center pane to view details for the new replica copy or copies.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding consistency groups |
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


Adding replica sets

You can add a replica set, which is a source LUN and the local and remote copies that are managed by a replication cluster, and perform continuous backup for the source LUN.

You can use the Add Replica Set wizard to create replica sets that contain production, local, and remote copies. The order of the pages and steps vary in the wizard, based on which type or types of copies that you created.

Note: You must have at least one replica link before you can create a replica set.

To add a replica set:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups.

  3. From the Actions pane, click Add Replica Set. The Add Replica Set wizard appears.

  4. On the Replica Set page, type a name for the replica set and then click Next.

  5. For the production copy, do the following:

  1. On the Production Copy Storage System page, select a storage system, review the connection information, and then click Next.

  2. On the Production Copy Storage Pool page, select a storage pool from the list, and then click Next.

  3. On the Production Copy LUN page, select a LUN, and then click Next.

  6. If the consistency group contains a local copy, do the following:

  1. On the Local Copy Storage System page, select a storage system, review the connection information, and then click Next.

  2. On the Local Copy Storage Pool page, select a storage pool from the list, and then click Next.

  3. On the Local Copy LUN page, select a LUN, and then click Next.

  7. If the consistency group contains a remote copy, do the following:

  1. On the Remote Copy Storage System page, select a storage system, review the connection information, and then click Next.

  2. On the Remote Copy Storage Pool page, select a storage pool from the list, and then click Next.

  3. On the Remote Copy LUN page, select a LUN, and then click Next.

  8. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  9. On the Progress page, click Next.

    10. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  10. On the Summary page, click Finish.

    11. You can click Consistency Groups > Replica Sets in the center pane to view details for the new replica set.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding consistency groups |
Adding replica copies |
Viewing consistency groups |
Viewing replication clusters |


Viewing consistency groups

To view consistency groups:

  1. In the left pane of the ESI window, select a replication service.

  2. In the Actions pane, click Connect.

  3. Click Consistency Groups in the center pane.

  4. Select a consistency group from the list.

  5. Click the following to view replica details for the consistency group:

  • Replica Sets

  • Replica Copies

  • Replica Links

  6. Click the plus (+) symbols to expand the replica details.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding consistency groups |
Adding replica copies |
Adding replica sets |
Viewing replication clusters |


Viewing replication clusters

A replication cluster is a group of RecoverPoint replication services grouped together so that they are aware of each other and can back up linked storage systems.

To view replication clusters:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Replication Clusters in the center pane.

  3. Click Systems or Connected Storage Systems to view details.

  4. Click the plus (+) symbols to expand the replication cluster details.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding consistency groups |
Adding replica copies |
Adding replica sets |
Viewing consistency groups |


Applying bookmarks

Applying bookmarks to consistency groups

A RecoverPoint bookmark is a text label that you can apply to a snapshot to uniquely identify it at any point-in-time. You can create bookmarks manually or automatically at regular intervals. Bookmarks are useful to mark specific points in time, such as for an application update or for a failover. All bookmarks are listed in the copy journal.

You can only bookmark a snapshot for a consistency group that is enabled and actively transferring.

In ESI, use the Apply Bookmark action to bookmark a single consistency group. To apply a bookmark to multiple consistency groups, use the Apply Parallel Bookmark action.

Over time, the journal and space required for multiple snapshots can become very large. With ESI, you can specify how often to consolidate snapshots in the journal. You can set the consolidation policy so the snapshot survives either daily, weekly, or monthly replica copies.

To apply a bookmark to a consistency group:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups and select a consistency group.

  3. In the Actions pane, click Apply Bookmark.

  4. In the Apply Bookmark wizard, specify the following, and then click Next.

    Field

    Description

    Bookmark

    Unique name for the bookmark

    Mark as

    Select Crash-Consistent for immediate recovery to the time of a crash with no data loss.

    Or select Application Consistent for recovery consistent with application settings for failovers.

    Define a Consolidation Policy for this Snapshot

    Select to define the consolidation policy.

    Never consolidate this snapshot

    Select to prevent ESI from consolidating the snapshot with this bookmark.

    This snapshot must survive Daily (Weekly or Monthly) consolidations

    Select to keep the bookmark snapshot from consolidation until after Daily, Weekly, or Monthly EMC RecoverPoint snapshot consolidations.

  5. On the Review Input Parameters, review the parameters, and click Next.

  6. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    7. On the Summary page, click Finish.

Related links |
Adding replication services | ESI overview
Adding consistency groups | ESI home window
Adding replica copies | Applying parallel bookmarks
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


Removing replication services

To remove replication services:

  1. In the left pane of the ESI window, select the replication service.

  2. In the Actions pane, select Remove System.

  3. Click Yes when prompted for confirmation.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | Home window
Adding consistency groups |
Adding replica copies |
Adding replica sets |
Deleting consistency groups |
Deleting replica copies |
Deleting replica sets |


Deleting consistency groups

To delete a consistency group:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups in the center pane, and then select a consistency group from the list.

  3. In the Actions pane, select Delete consistency group.

    4. The Delete consistency group wizard appears.

  4. Click Next, and then click Yes when prompted for confirmation.

  5. In the Review Input Parameters page, review the settings, and then click Next to confirm them.

  6. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  7. On the Summary page, click Finish.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding consistency groups |
Adding replica copies |
Adding replica sets |
Removing replication services |
Deleting replica copies |
Deleting replica sets |


Deleting replica copies

To delete a replica copy:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups in the center pane and select a consistency group from the list.

  3. Click Replica Copies and select a replica copy.

  4. In the Actions pane, select Delete Replica Copy.

    5. The Delete Replica Copy wizard appears.

  5. Click Next, and then click Yes when prompted for confirmation.

  6. On the Review Input Parameters page, review the settings and click Next to confirm them.

  7. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  8. On the Summary page, click Finish.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding consistency groups |
Adding replica copies |
Adding replica sets |
Removing replication services |
Deleting consistency groups |
Deleting replica sets |


Deleting replica sets

To delete a replica set:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups in the center pane and select a consistency group from the list.

  3. Click Replica Sets and select a replica set.

  4. In the Actions pane, select Delete Replica Set.

    5. The Delete Replica Set wizard appears.

  5. Click Next, and then click Yes when prompted for confirmation.

  6. On the Review Input Parameters page, review the settings, and then click Next to confirm them.

  7. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs, an error message appears along with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  8. On the Summary page, click Finish.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding consistency groups |
Adding replica copies |
Adding replica sets |
Removing replication services |
Deleting consistency groups |
Deleting a replica copies |


Enabling image access for replica snapshots

You can search for a particular snapshot and apply that snapshot for RecoverProduction or Failover. You can use the Enable Image Access action to enable access to a replica copy image or snapshot so that it is available for a failover. Replication changes are not propagated to the copy while image access is enabled.

Notice: When image access for replica snapshots is enabled, ESI automatically uses the RecoverPoint Image Access mode of Logged Access. This mode ensures the snapshot resides on the replica LUN and not the journal. This is the only supported mode in ESI and cannot be changed.

To enable image access for a replica snapshot:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups and select a consistency group from the list.

  3. Click Replica Copies and select the target copy with the snapshot.

  4. In the Actions pane, click Enable Image Access.

  5. On the Select an Image page in the Enable Image Access for Snapshot wizard, specify the following, and then click Next:

  6. If you select A specific point-in-time or bookmark, specify the following.

    Field

    Description

    Copy Name

    Select the snapshot to enable access

    Image Access Scenario

    Select the applicable scenario: Failover to ReplicaCopy or RecoverProduction from ReplicaCopy

    Image to access

    Select the applicable image:

    • The latest image

    • An image from the image list

    • A specific point in time or bookmark

    • Previous Image

    • Current Image

    • Next Image

    If you selected A specific point-in-time or bookmark image to access, specify the following search criteria.

    Field

    Description

    Point-in-time

    Select the specific date and time, including microseconds

    Bookmark

    Select Exact and specify the unique name of the bookmark

    Image type

    Select the applicable type:

    • All images

    • All images with bookmarks

    • All images with system bookmarks

    • All images with user bookmarks

    Max. range

    Select the maximum range number of hours or minutes

  7. On the Replica Snapshots page, select a snapshot from the list, and then click Next.

  8. On the Review Input Parameters, review the parameters, and then click Next to confirm them.

  9. On the Progress page, click Next.

Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    10. On the Summary page, click Finish.

Related links |
Adding replication services | ESI overview
Adding consistency groups | ESI home window
Adding replica copies |
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


Failing over to replica copy

In ESI, you can use the Failover to Replica Copy action to failover to a specific replica copy in a single consistency group only.

To failover to a replica copy in a consistency group:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups and select a consistency group.

  3. In the Actions pane, click Failover to Replica Copy.

  4. On the Replica Copy page, confirm the correct copy is listed, and then click Next.

  5. When prompted for confirmation, click OK.

  6. On the Review Input Parameters, review the parameters, and then click Next.

  7. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    8. On the Summary page, click Finish.

Related links |
Adding replication services | ESI overview
Adding consistency groups | ESI home window
Adding replica copies | Applying parallel bookmarks
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


Recovering production for replicas

You use the RecoverProduction for Replica Copy action in ESI to restore a specific copy as a production copy. This restoration action starts from the selected snapshot (point of time) and restores the production source from this copy. The production source, data that is newer than the selected point in time is rolled back and rewritten with version in the copy. The copy’s journal is preserved and remains valid.

To recover the production source with a replica copy:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups and select a consistency group.

  3. In the Actions pane, click RecoverProduction for Replica Copy.

  4. On the Replica Copy page, specify the following, and then click Next.

    Field

    Description

    Bookmark

    Unique name for the bookmark

    Mark as

    Select Crash-Consistent for immediate recovery to the time of a crash with no data loss.

    Or select Application Consistent for recovery consistent with application settings for failovers.

    Define a Consolidation Policy for this Snapshot

    Select to define the consolidation policy.

    Never consolidate this snapshot

    Select to prevent ESI from consolidating the snapshot with this bookmark.

    This snapshot must survive Daily (Weekly or Monthly) consolidations

    Select to keep the bookmark snapshot from consolidation until after Daily, Weekly, or Monthly RecoverPoint snapshot consolidations.

  5. On the Review Input Parameters, review the parameters, and then click Next.

  6. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    7. On the Summary page, click Finish.

Related links |
Adding replication services | ESI overview
Adding consistency groups | ESI home window
Adding replica copies | Applying parallel bookmarks
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


Applying parallel bookmarks

Applying parallel bookmarks to consistency groups

For a single consistency group, you can apply an EMC RecoverPoint bookmark. However, for multiple consistency groups, you must apply a parallel bookmark. A parallel bookmark is a text label that you can apply to multiple consistency group snapshots to uniquely identify a specific point-in-time. You can create a parallel bookmark manually or automatically at regular intervals. Parallel bookmarks are useful to mark specific events, such as for an application update or a failover. All bookmarks are listed in the copy journal.

In ESI, you can only bookmark a snapshot for a consistency group that is enabled and actively transferring.

You can set a consolidation policy for the bookmark, which specifies the time the bookmark must survive either daily, weekly, or monthly consolidations. This setting helps to manage the journal and space required for consolidations.

To apply a parallel bookmark to two or more consistency groups:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups.

  3. Select two or more consistency groups and then click Apply Parallel Bookmark.

  4. In the Apply Bookmark wizard, specify the following and click Next.

    Field

    Description

    Bookmark

    Unique name for the bookmark

    Mark as

    Select Crash-Consistent for immediate recovery to the time of a crash with no data loss.

    Or select Application Consistent for recovery consistent with application settings for failovers.

    Define a Consolidation Policy for this Snapshot

    Select to define the consolidation policy.

    Never consolidate this snapshot

    Select to prevent ESI from consolidating the snapshot with this bookmark.

    This snapshot must survive Daily (Weekly or Monthly) consolidations

    Select to keep the bookmark snapshot from consolidation until after Daily, Weekly, or Monthly EMC RecoverPoint snapshot consolidations.

  5. On the Review Input Parameters, review the parameters and click Next.

  6. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    7. On the Summary page, click Finish.

Related links |
Adding replication services | ESI overview
Adding consistency groups | ESI home window
Adding replica copies | Applying bookmarks
Adding replica sets |
Viewing consistency groups |
Viewing replication clusters |


Disabling image access for replica snapshots

After you enable a snapshot for image access, you can disable the access for system updates, such as Replication changes, which are not propagated to the copy while image access is enabled. After changes are propagated, you can then enable image access again.

To disable image access to a specific snapshot for a replica:

  1. In the left pane of the ESI window, select a replication service.

  2. Click Consistency Groups and select a consistency group from the list.

  3. Click Replica Copies and select the target copy with the snapshot.

  4. In the Actions pane, select Disable Image Access.

ESI displays a progress message while disabling image access to the selected target copy.

Related links |
ESI RecoverPoint Adapter overview | ESI overview
Adding replication services | ESI home window
Adding consistency groups | Enabling image access for replica snapshots
Adding replica copies |
Adding replica sets |
Removing replication services |
Deleting consistency groups |
Deleting a replica copies |


Viewing AppSync databases

In ESI, you can view AppSync Application Server instances and databases, including SQL Server databases and Exchange databases, registered storage, registered hosts, and registered EMC RecoverPoint systems.

To view AppSync databases and database instances:

    1. In the left pane of the ESI window, select the AppSync replication service.

    2. In the Actions pane, click Connect.

    3. When the Protection Switch View is selected, you can click the following to view AppSync system details:

    • SQL Server Databases: View database names, host IP addresses, instance names, database files, database copies, and service plans, mount hosts, copy mount status, copy storage type, and copy backup type

    • Exchange Databases: View database names, host IP addresses, instance names, database files, database copies, and service plans, mount hosts, copy mount status, copy storage type, and copy backup type

    • Storage: View storage system names, display (friendly) names, usernames, IP addresses, and models

    • Registered Hosts: View host system names, display (friendly) names, usernames, and OS versions

    • RecoverPoint Systems: View AppSync RecoverPoint site IP addresses, site names, and site versions

    4. When the Service Plan Switch View is selected, click the Service Plan type and the following tabs and AppSync service plan details display for the selected service plan:

      • SQL Server Databases: Database subscriptions, database copies, settings, and events tabs with related details, such as server names, instance names, database names, service plan settings, and log events

      • Exchange Databases: Database subscriptions, database copies, settings, and events tabs with related details, such as server names, instance names, database names, service plan settings, and log events

    5. Click the plus (+) symbols to expand details.

Note: To customize the center pane, such as to remove or add columns for a custom view, right-click a column in the center pane and select actions from the menu.

Related links |
Protecting databases with service plans | ESI overview
Mounting database copies | ESI home window
Expiring database copies | AppSync Adapter overview


Expiring database copies

In ESI, you can expire (remove) a database copy from an AppSync database. You can only expire database copies that are unmounted.

To expire or remove an unmounted database copy from an AppSync database:

  1. In the left pane of the ESI window, select the AppSync replication service.

  2. In the Actions pane, click Connect.

  3. When the Protection Switch View is selected, select a database and expand it to view the AppSync database copies.

  4. Select a database copy and select Expire in the Actions pane.

  5. In the Expire Database Copy wizard, confirm the selected copy to expire, and then click Next.

  6. On the Review Input Parameters, review the parameters, and then click Next.

  7. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    8. On the Summary page, click Finish.

Related links |
Protecting databases with service plans | ESI overview
Mounting database copies | ESI home window
Restoring database copies | AppSync Adapter overview


Mounting database copies

Mounting database copies from AppSync databases

In ESI, you can mount AppSync database copies on VNX or RecoverPoint target hosts.

Note: Some of the field options in the wizard are only available for SQL Server database copies.

To mount a database copy that is using AppSync:

  1. In the left pane of the ESI window, select the AppSync replication service.

  2. In the Actions pane, click Connect.

  3. When the Protection Switch View is selected, select a database and expand it to view the AppSync database copies.

  4. Select a database copy and select Mount in the Actions pane.

  5. In the Mount Database Copy wizard, specify the following, and then click Next.

    Field

    Description

    Mount

    Select to mount without recovering the database copy.

    Mount and Recover (SQL Server only)

    Select to mount the database copy to recover the specified instance.

    Mount on Server

    Select the server on which to mount the copy.

    Mount with access

    Select Read-only or Read-write for the mounted copy.

    Mount Path

    Select Default path (displayed on screen) or a new path.

    Recovery Instance (SQL Server only)

    Select the database instance to recover with the selected copy to mount.

    Recovery Type (SQL Server only)

    Select the applicable type: Recovery, NoRecovery, or Standby.

    Database Name Suffix

    Type a suffix name for the recovered database.

  6. On the Review Input Parameters, review the parameters, and then click Next.

  7. On the Progress page, click Next.

      11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

  8. On the Summary page, click Finish.

Related links |
Protecting databases with service plans | ESI overview
Mounting database copies | ESI home window
Expiring database copies | AppSync Adapter overview


Protecting databases with service plans

In ESI, you can select an AppSync database to protect. The Protect Now action creates a database copy of the selected application database, which then prompts you to select the type of service plan to use to protect the database.

To protect a database with a database copy and specified AppSync service plan:

  1. In the left pane of the ESI window, select the AppSync replication service.

  2. In the Actions pane, click Connect.

  3. When the Protection Switch View is selected, select a database.

  4. In the Actions pane, select Protect Now.

  5. In the Protect Database wizard, select the AppSync service plan to use, and then click Next.

  6. On the Review Input Parameters page, review the parameters, and then click Next.

  7. On the Progress page, click Next.

      11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After you resolve the error, click Resume to resume the process. Click Rollback to revert to the previous step.

  8. On the Summary page, click Finish.

Related links |
Protecting databases with service plans | ESI overview
Mounting database copies | ESI home window
Expiring database copies | AppSync Adapter overview


Restoring database copies

In ESI, you can restore the selected database by using the specified database copy. You can only restore database copies that are unmounted.

To restore an unmounted database copy for an AppSync database:

  1. In the left pane of the ESI window, select the AppSync replication service.

  2. In the Actions pane, click Connect.

  3. When the Protection Switch View is selected, select a database and expand to view the available AppSync database copies.

  4. Select a database copy and select Restore in the Actions pane.

  5. In the Restore Database Copy wizard, confirm the selected copy to restore and click Next.

  6. On the Review Input Parameters, review the parameters, and then click Next.

  7. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    8. On the Summary page, click Finish.

Related links |
Protecting databases with service plans | ESI overview
Mounting database copies | ESI home window
Expiring database copies | AppSync Adapter overview


Subscribing database service plans

Subscribing databases to AppSync service plans

In ESI, you can subscribe Exchange and SQL Server databases to AppSync Service plans.

AppSync provides the following built-in service plans:

  • The Bronze plan creates and manages local copies.

  • The Silver plan creates and manages remote copies.

  • The Gold plan creates and manages local and remote copies.

To subscribe a database to an AppSync service plan:

  1. In the left pane of the ESI window, select the AppSync replication service.

  2. In the Actions pane, click Connect.

  3. In the Protection Switch View, select and expand the AppSync Database.

  4. Click AppSync Service Plans and then select the service plan to subscribe.

  5. In the Actions pane, click Subscribe Service Plan.

  6. In the Subscribe AppSync Service Plan wizard, specify the service plan to which to subscribe and click Next.

  7. On the Review Input Parameters page, review the parameters, and then click Next.

  8. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After you resolve the error, click Resume to resume the process. Click Rollback to revert to the previous step.

    9. On the Summary page, click Finish.

Related links |
Protecting databases with service plans | ESI overview
Mounting database copies | ESI home window
Expiring database copies | AppSync Adapter overview


Unmounting database copies

In ESI, you can unmount AppSync database copies from VNX or RecoverPoint target hosts. You can only unmount copies that are currently mounted.

To unmount an AppSync database copy:

  1. In the left pane of the ESI window, select the AppSync replication service.

  2. In the Actions pane, click Connect.

  3. When the Protection Switch View is selected, select a database and expand to view the AppSync database copies.

  4. Select a database copy and select Unmount in the Actions pane.

  5. In the Unmount Database Copy wizard, confirm the selected database copy to unmount and click Next.

  6. On the Review Input Parameters, review the parameters, and then click Next.

  7. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    8. On the Summary page, click Finish.

Related links |
Protecting databases with service plans | ESI overview
Mounting database copies | ESI home window
Expiring database copies | AppSync Adapter overview


Unsubscribing database service plans

Unsubscribing databases from AppSync service plans

In ESI, you can unsubscribe Exchange and SQL Server databases to AppSync Service plans.

To unsubscribe a database from an AppSync service plan:

  1. In the left pane of the ESI window, select the AppSync replication service.

  2. In the Actions pane, click Connect.

  3. In the Protection Switch View, select and expand the AppSync Database.

  4. Click AppSync Service Plans and then select the service plan to unsubscribe.

  5. In the Actions pane, click Unsubscribe Service Plan.

  6. In the Unsubscribe AppSync Service Plan wizard, confirm the selected service plan and click Next.

  7. On the Review Input Parameters, review the parameters, and then click Next.

  8. On the Progress page, click Next.

    11. Note: Click More Information for more progress details. If a problem occurs, an error message appears with options to resume or roll back the process. After the error is resolved, click Resume to resume the process. Click Rollback to revert to the previously executed step.

    9. On the Summary page, click Finish.

Related links |
Subscribing databases to AppSync service plans | ESI overview
Mounting database copies | ESI home window
Expiring database copies | AppSync Adapter overview


ESI Service and SCOM Management Packs

ESI Service and ESI SCOM Management Packs overview

ESI Service

ESI SCOM Management Packs

The ESI Service and the ESI SCOM Management Packs work in conjunction with Microsoft System Center Operations Manager for centralized discovery and monitoring of all supported EMC storage systems and storage-system components.

The ESI Service and ESI SCOM Management Packs support the same EMC VMAX family, VNX series, and VNXe3200 storage systems that are supported in ESI.

The ESI SCOM Management Packs also support EMC VPLEX systems and Symmetrix DMX-4 storage systems.

However, ESI SCOM Management Packs do not currently support EMC XtremIO, VNXe3100, VNXe3150, and VNXe3300 systems.

ESI Service

The ESI Service is the communications link between ESI and the ESI SCOM Management Packs. You can use the ESI Service to view and report on all registered systems and system components connected to the ESI host system. ESI Service then pushes this data to SCOM. You can also use the ESI Service as a stand-alone tool without SCOM to collect, view, and report this same system data.

The ESI Service PowerShell Toolkit is also installed as part of the ESI Service. Use this toolkit to set up the ESI Service to communicate with the ESI SCOM Management Packs. Getting started with the ESI PowerShell toolkits provides details.

The ESI Service provides the following functionality:

  • A common repository for all registered storage systems and related storage system connection information

  • Configures and securely stores the settings and access control policies for all of the registered storage systems

  • Authorization of storage system access with the Windows Authentication access control settings

  • An entity graph, a meta-model, and a query engine for discovering systems and related components

  • An HTTP API for remotely accessing the entity graph and remotely viewing policy and configuration information and operations

ESI SCOM Management Packs

    The ESI SCOM Management Packs enable you to manage EMC storage systems with SCOM by providing consolidated and simplified dashboard views of storage entities. These views enable you to:

  • Discover and monitor the health status and events of your EMC storage systems and system components in SCOM

  • Receive alerts for any possible problems with disk drives, power supplies, storage pools, and other types of physical and logical components in SCOM

    • The ESI SCOM Management packs include the following files:

  • EMC.SI.Library.mp: Defines properties for supported storage systems and system components and their relationships.

  • EMC.SI.Discovery.mp: Contains all of the discoveries for all of the ESI storage systems and system components. At a set interval, the ESI Service creates and updates the collection of classes and relationships that are defined in the library. It discovers all registered storage systems and all of their physical and logical components. Collected data is stored in the System Center Operations Manager database.

  • EMC.SI.Monitoring.mp: Contains the monitors, rules, and diagnostics for the storage systems and the physical and logical system components. These include disk drives, power supplies, and logical components, such as storage pools and storage volumes. It also monitors the available capacity of some components. Alerts generate when abnormal conditions are detected or the available capacity limit has been reached for a component. Data is stored in the System Center Operations Manager database and data warehouse.

  • EMC.SI.Presentation.mp: Presents all registered storage systems, systems components, and view definitions that appear in the SCOM console.

  • EMC.SI.Reporting.mp: Reports on the health and capacity of the storage systems and system components. For example, you can view a report for available storage capacity, storage pool capacity, and snapshot pool capacity in a storage environment. You can also view a report on the most common alerts that were generated during the previous week.

  • EMC.SI.Customization.xml: Contains all of the overrides and customizations for your specific storage environment. Import this management pack only during an initial installation. If you import it again, you will lose all of your overrides and customizations. The version number of this management pack is 1.0.0.0, which is different from the other management packs. You can increment the version number when you make changes.

Related links |
Considering capacity and topology | ESI overview
Installing ESI Service | Home window
Setting up ESI Service |
Installing ESI SCOM Management Packs |
Setting up ESI SCOM Management Packs |


Capacity and topology considerations

Considering capacity and topology

For performance and scalability, install ESI on a controller host machine that is dedicated to ESI and separate from the SCOM Management Group machines. For load balancing, you can use multiple SCOM agents to monitor a large number of storage systems. You can also set up multiple SCOM agents to communicate with one or more ESI hosts running the ESI Service.

To achieve the best scalability, assign storage systems with a large number of components to different SCOM agents running on your most resourceful computers.

The Number of Entities column in SCOM displays information about the number of entities that the ESI Service uses. To view this column:

Replace the <ESI Service IP> and <HTTPS port> with the applicable value and open this link in a web browser: https://<ESI Service IP>:<HTTPS port>/esi/console/RegisteredSystems

To get information about the number of entities that SCOM monitors:

Open the SCOM Operations Console, connect to the SCOM Management Group, and then open Operations Manager > Agent Performance > Module Count.

The following figure represents how one SCOM Management Group that is running the ESI SCOM Management Packs connects to multiple SCOM agents, which connect through HTTPS to one or more ESI Services.

ESI for Windows Suite setup with SCOM Management Group and monitoring agents

Related links |
ESI Service and SCOM Management Packs | ESI overview
Installing ESI Service | Home window
Setting up ESI Service |
Installing ESI SCOM Management Packs |
Setting up ESI SCOM Management Packs |


ESI Service and SCOM Management Packs prerequisites

ESI Service and ESI SCOM Management Packs prerequisites

Following are the requirements for the ESI Service and ESI SCOM Management Packs:

  • ESI Service must be installed and set up on the ESI host system. The ESI Service has the same prerequisites as the ESI host controller.

  • The SCOM Management Servers must have Microsoft SCOM 2012 R2, 2012 SP1, 2007 R2, or 2007 SP1 installed.

  • In addition to the ESI storage system prerequisites:

  • Symmetrix DMX 4 storage systems must have Enginuity release level 5773.183 (or higher) and EMC Solutions Enabler version 7.6.2 or later with EMC SMI-S Provider version 4.6.2 or later installed.

  • VPLEX systems must have GeoSynchrony version 5.3 installed.

For details on how to install and set up the ESI Service and Management Packs for SCOM, see the following:

  • ESI Service installation

  • ESI Service setup

  • ESI SCOM Management Packs installation

  • ESI SCOM Management Packs setup

Related links |
ESI Service and SCOM Management Packs | ESI overview
Considering capacity and topology | Home window


Installing ESI Service

Installing the ESI Service

During the ESI installation, you can choose to install the ESI Service on the same ESI host system. When you install the ESI Service, the ESI Service PowerShell Toolkit is also installed on the ESI host system. Installation overview provides instructions for installing ESI.

You can use the ESI Service PowerShell Toolkit to set up or update the ESI Service entity graph, service configuration, and system registration information. Getting started with the ESI PowerShell toolkits and ESI Service PowerShell cmdlet list provides details.

Related links |
Setting up ESI SCOM Management Packs | ESI overview
Setting up ESI Service | ESI home window
Installing ESI Management Packs |
Capacity and topology considerations |


Setting up ESI Service

The ESI installer automatically enables a Windows firewall rule for the ESI Service, sets up the SSL certificate, and sets the service to listen to two IP ports on the ESI host system.

To set up the ESI Service for SCOM:

  1. If using Microsoft Active Directory services, confirm that you created an ESI Service user account within the Active Directory domain as described in Configuring Directory Services for ESI Applications.

  2. If necessary, change the HTTP connection defaults as described in Changing HTTP connection defaults.

    If you do not need to change the defaults, then skip to the next step.

  3. Confirm that the correct HTTP connections are set up as described in Confirm HTTP connections.

  4. Register or publish all applicable systems with the ESI Service as described in Publishing and unpublishing systems to the ESI Service.

  5. View and set up the security policy for the ESI Service as described in Viewing and setting up the security policy.

  6. If necessary, change the System Refresh Interval setting, which by default is set to every 30 minutes. This is how often the ESI Service checks for registered systems and collects data about the registered systems and system components.

Related links |
Installing ESI Service | ESI overview
Publishing and unpublishing systems to the ESI Service | ESI home window
Changing the system refresh interval |
Viewing and setting up the security policy |


Changing HTTP connection defaults

By default, the installer sets up the HTTP port 54500 and HTTPS port 54501 connections. You can change the defaults for the ESI Service by using the following procedures:

    Setting up new IP ports with the default certificate

    Setting up default IP ports with a new domain certificate

    Setting up new IP ports with a new domain certificate

    Confirming the HTTP connections

    Note: All of these procedures require a Windows command prompt and not a PowerShell command prompt.

    Setting up new IP ports with the default certificate

To set up new IP ports with the default certificate:

    1. On the ESI host machine, open a command prompt and type the following to delete the reserved URLs:

    netsh http delete urlacl "http://+:54500/esi/"

    netsh http delete urlacl "https://+:54501/esi/"

    2. Choose new IP port numbers. The industry standard is to choose an available port that is between port numbers 49152 and 65535. To get a list of used IP ports for your ESI Service, type the following command at a Windows command prompt on the ESI Service machine:

    netstat –an

    3. To reserve the new URLs, type the following, replacing <HttpPort> and <HttpsPort> with the new port numbers:

    netsh http add urlacl url="http://+:<HttpPort>/esi/" user="NT AUTHORITY\NETWORK SERVICE"

    netsh http add urlacl url="https://+:<HttpsPort>/esi/" user="NT AUTHORITY\NETWORK SERVICE"

    For example:

    netsh http add urlacl url="http://+:56560/esi/" user="NT AUTHORITY\NETWORK SERVICE"

    netsh http add urlacl url="https://+:57570/esi/" user="NT AUTHORITY\NETWORK SERVICE"

    4. Delete the existing firewall rule for default ports:

    netsh advfirewall firewall delete rule name="ESI Service"

    5. To add the new firewall rule for the new ports, type the following replacing <HttpPort> and <HttpsPort> with the new port numbers:

    netsh advfirewall firewall add rule name="ESI Service" dir=in action="allow" protocol="TCP" localport=<HttpPort>, <HttpsPort>

    For example:

    netsh advfirewall firewall add rule name="ESI Service" dir=in action="allow" protocol="TCP" localport=<56560>,<57570>

    6. Type the following to unbind the existing IP ports from the SSL certificate:

    netsh http delete sslcert ipport=0.0.0.0:54501

    7. To bind the ports with the new certificate:

      • For Windows Server 2012, search and open Manage computer certificates.

      • For Windows Server 2008, at a command prompt, type mmc.exe.

      8. Select File > Add/Remove Snap-in, select Certificates, and click Add.

      9. In the Certificates snap-in dialog box, select Computer account, click Next, select Local computer, and click Finish.

      10. In Certificates (Local Computer) > Personal > Certificates>, double-click the new certificate to open it.

      11. Select Details, select Thumbprint, and then highlight and copy the thumbprint.

      12. At a command prompt, type the following command line, but in place of <Thumbprint>, paste your new certificate thumbprint and remove all spaces between the thumbprint numbers and letters. Also replace <HttpsPort> with the applicable port number and keep appid the same:

    netsh http add sslcert ipport=0.0.0.0:<HttpsPort> certhash=<Thumbprint> appid="{4024FDC3-B30D-43CA-8707-A50940B4BD14}"

    For example:

    netsh http add sslcert ipport=0.0.0.0:57570 certhash=0794721c36f00902c6b9b6cb687f7a6b2997925d appid="{4024FDC3-B30D-43CA-8707-A50940B4BD14}"

    13. To set the registry keys and change the ports, navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\EMC\WSI\Service folder and change the value of the Port key to the new HTTP port number and the SSLPort value to the new HTTPS port number. For example:

    Port: 12345 SSLPort: 23456

    14. To restart the ESI Service, go to Services and restart the ESI Service. Or you can run these commands:

    net stop esiservice

    net start esiservice

    15. Confirming the HTTP connections provides details to confirm the port setup.

    Setting up default IP ports with a new domain certificate

To set up default IP ports with a new domain default certificate:

    1. On the ESI host machine, create a new domain certificate.

      2. Refer to your Windows documentation for more information.

    2. Open a Windows command prompt and type the following to stop the ESI Service:

    net stop esiservice

    3. Type the following to unbind the existing IP ports from the ESI Service SSL certificate:

    netsh http delete sslcert ipport=0.0.0.0:54501

    4. To bind the ports with the new certificate:

      • For Windows Server 2012, search and open Manage computer certificates.

      • For Windows Server 2008, at a command prompt, type mmc.exe.

      5. Select File > Add/Remove Snap-in, select Certificates, and click Add.

      6. In the Certificates snap-in dialog box, select Computer account, click Next, select Local computer, and click Finish.

      7. In Certificates (Local Computer) > Personal > Certificates>, double-click the new certificate.

      8. Select Details, select Thumbprint, and then highlight and copy the thumbprint.

      9. At a command prompt, type the following command line and in place of <Thumbprint>, paste your new certificate thumbprint and remove all spaces between the thumbprint numbers and letters and keep appid the same:

    netsh http add sslcert ipport=0.0.0.0:54501 certhash=<Thumbprint> appid="{4024FDC3-B30D-43CA-8707-A50940B4BD14}"

    For example:

    netsh http add sslcert ipport=0.0.0.0:54501 certhash=0794721c36f00902c6b9b6cb687f7a6b2997925d appid="{4024FDC3-B30D-43CA-8707-A50940B4BD14}"

    10. At the Windows command prompt, type the following to restart the ESI Service:

    net start esiservice

    11. Confirming the HTTP connections provides details to confirm the port setup.

    Setting up new IP ports with a new domain certificate

To set up new IP ports with a new domain certificate:

    1. On the ESI host machine, open a Windows command prompt type the following to delete the reserved URLs:

    netsh http delete urlacl "http://+:54500/esi/"

    netsh http delete urlacl "https://+:54501/esi/"

    2. Choose new IP port numbers.

      3. The industry standard is to choose an available port that is between port numbers 49152 and 65535. To get a list of used IP ports for your ESI Service, type the following command at a Windows command prompt on the ESI Service machine:

    netstat –an

    3. To reserve the new URLs, type the following replacing <HttpPort> and <HttpsPort> with the new port numbers:

    netsh http add urlacl url="http://+:<HttpPort>/esi/" user="NT AUTHORITY\NETWORK SERVICE"

    netsh http add urlacl url="https://+:<HttpsPort>/esi/" user="NT AUTHORITY\NETWORK SERVICE"

    For example:

    netsh http add urlacl url="http://+:12345/esi/" user="NT AUTHORITY\NETWORK SERVICE"

    4. Type the following to delete the existing firewall rule for default ports:

    netsh advfirewall firewall delete rule name="ESI Service"

    5. To add the new firewall rule for the new ports, type the following, replacing <HttpPort> and <HttpsPort> with the new port numbers:

    netsh advfirewall firewall add rule name="ESI Service" dir=in action="allow" protocol="TCP" localport=<HttpPort>, <HttpsPort>

    For example:

    netsh advfirewall firewall add rule name="ESI Service" dir=in action="allow" protocol="TCP" localport=<56560>,<57570>

    6. Type the following to unbind the existing default IP ports from the SSL certificate:

    netsh http delete sslcert ipport=0.0.0.0:54501

    7. Create a new domain certificate. Refer to Windows documentation for more information.

    8. To bind the ports with the new certificate:

    • For Windows Server 2012, search and open Manage computer certificates.

    • For Windows Server 2008, at a command prompt, type mmc.exe.

    7. Select File > Add/Remove Snap-in, select Certificates, and click Add.

    8. In the Certificates snap-in dialog box, select Computer account, click Next, select Local computer, and click Finish.

    9. In Certificates (Local Computer) > Personal > Certificates>, double-click the new certificate.

    10. Select Details, select Thumbprint, and then highlight and copy the thumbprint.

    11. At a command prompt, type the following command line, but in place of <Thumbprint>, paste your new certificate thumbprint and remove all spaces between the thumbprint numbers and letters. Also replace <HttpsPort> with the applicable port number and keep appid the same:

    netsh http add sslcert ipport=0.0.0.0:<HttpsPort> certhash=<Thumbprint> appid="{4024FDC3-B30D-43CA-8707-A50940B4BD14}"

    For example:

    netsh http add sslcert ipport=0.0.0.0:57570 certhash=0794721c36f00902c6b9b6cb687f7a6b2997925d appid="{4024FDC3-B30D-43CA-8707-A50940B4BD14}"

    12. To set the registry keys and change the ports, navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\EMC\WSI\Service folder and change the value of the Port key to the new HTTP port number and the SSLPort value to the new HTTPS port number. For example:

    Port: 56560 SSLPort: 57570

    13. To restart the ESI Service, go to Services and restart the ESI Service. Or you can use this command:

    net stop esiservice

    net start esiservice

    14. Confirming the HTTP connections provides details to confirm the port setup.

    Confirming the HTTP connections

    To confirm that the HTTP connections are set up correctly:

    1. Open a web browser that supports Windows Authentication and browse to the ESI Service console with the applicable IP port numbers:

      • For an HTTP connection with the default IP port numbers, go to http://<ESI Service IP>:54500/esi/console, replacing <ESI Service IP>.

      • For an HTTP connection with new port numbers, replace <ESI Service IP> and <new HTTP port>, and go to http://<ESI Service IP>:<new HTTP port>/esi/console, replacing <ESI Service IP>.

      • For a secured HTTPS connection with the default IP port numbers, go to https://<ESI Service IP>:54501/esi/console, replacing <ESI Service IP>.

      • For a secured HTTPS connection with new port numbers, go to https://<ESI Service IP>:<new HTTPS port>/esi/console, replacing <ESI Service IP> and <new HTTPS port>.

    2. In the Services applet on the ESI host system, confirm that the ESI Service is installed and started as a network service.

    3. On the ESI host system, confirm that the ESIService-SSL or your new domain certificate is listed in the \Personal\Certificates folder on the local computer. How to: View Certificates with the MMC Snap-in at http://msdn.microsoft.com/en-us/library/ms788967.aspx describes how to view certificates.

    4. On the host, open the Start menu and search for firewall to locate the Windows firewall.

    5. In the search results, select Windows Firewall with Advanced Security.

    6. Select Inbound rules, and confirm that ESI Service is listed and enabled as the new ESI Service firewall rule for the default 54500 and 54501 ports or your new port numbers.

Next step

After confirming HTTP connections, you must publish systems to the ESI Service.

Related links |
Setting up ESI Service | ESI overview
Publishing and unpublishing systems to the ESI Service | ESI home window
Changing the system refresh interval |
Viewing and setting up the security policy |


Publishing and unpublishing systems to the ESI Service

Publishing and unpublishing systems to and from the ESI Service

Publishing storage systems to the ESI Service

After installing the ESI Service, to publish or register supported systems so that the ESI Service and the ESI SCOM Management Packs can discover and monitor them:

  1. In the left pane of the ESI window on the ESI host controller system, select EMC Storage Integrator.

  2. In the Actions pane, click Publish Connection.

  3. In the Publish Connection Information dialog box, set the following field values.

Field | Description
IP Address/Name | Select the ESI Service to receive the connection information for the systems.
Publish To | Select ESI Service to receive the connection information for the systems.
Default Port | Accept the default port or clear the checkbox to specify a different port number.
Port | If you clear the Default Port checkbox, type the new port number.

  4. Click Refresh to get a list of available systems.

  5. In the Local – Storage and Replication Systems pane, select the systems that you want to publish, and then click Add.

  6. Click OK to accept the list of systems to publish in the Service – Storage and Replication Systems pane.

Note: This pane also lists systems that were previously published or registered with the ESI Service by using the ESI Service PowerShell Toolkit, the ESI PowerShell Toolkit, or this procedure.

  7. Click Close to close the dialog box.

Notes:

      • You can also use the Add-EmcSystem cmdlet in the ESI Service PowerShell Toolkit to add or publish supported storage systems.

      • The ESI Service does not monitor replication systems, so replication systems cannot be published to the ESI Service.

Next step

After publishing systems to the service, your next step in setting up the ESI Service is to set up the security policy.

Removing or unpublishing systems from the ESI Service

You can unpublish or remove the connection information for selected systems from the ESI Service.

You can also use the Get-EmcSystem and Remove-EmcSystem cmdlets that are part of the ESI Service PowerShell Toolkit to remove or unpublish systems from the ESI Service.

To unpublish systems:

  1. In the left pane of the ESI window, on the ESI host controller system, select EMC Storage Integrator.

  2. In the Actions pane, click Publish Connection.

  3. In the Publish Connection Information dialog box, set the following fields.

Field

Description

IP Address/Name

Type the IP address or name of the host system that is running the service.

Publish To

Select ESI Service as the service with the published systems.

    Default Port

Accept the default port or clear the checkbox to specify a different port number for the service.

    Port

If you clear the Default Port checkbox, type the port number for the service.

  4. Click Refresh to get the list of published systems.

  5. In the Target – Storage and Replication Systems pane, select the systems that you want to unpublish, and then click Remove.

  6. Click Publish in the Service – Storage and Replication Systems pane to accept the list of systems to unpublish.

    7. Note: This panel lists systems that were previously published or registered by using the ESI Service PowerShell Toolkit or this procedure.

  7. Click Close to close the dialog box.

Related links |
Setting up ESI Service | ESI overview
Changing HTTP connection defaults | ESI home window
Changing the system refresh interval |
Viewing and setting up the security policy |


Viewing and setting up the security policy

The ESI Service authorizes every API call based on the Windows identity of the caller. Authorization is granted based on the caller’s role membership. The following Service roles are defined by the ESI Service. If these roles are changed, the ESI Service will not work.

  • Administrator role group members can invoke configuration commands on the ESI Service and query the Entity Graph for discovered systems and system components.

  • Monitor role group members can only query the Entity Graph to view discovered systems and system components and set the system refresh interval policy.

The ESI Service Administrator can add principal names (security groups or users) to one of these ESI Service roles. Adding a security principal to a Service role enables the administrator to delegate access control to one or more users who can add or modify members of the group. After you add the group to the Monitor role, any user who belongs to this group can make an ESI Service call.

Note: As an exception to the role assignments, the ESI Service automatically grants the Administrator role to the local administrator group on the host that is running the ESI Service. This allows any local administrator to manage the ESI Service without being explicitly added; however, the user must be running elevated credentials if UAC is enabled.

View the security policy

To view the security policy in one of the following ways:

  • Open a web browser that supports Windows Authentication and browse to the ESI Service console. If you have changed the default port numbers, replace the following default numbers with your assigned ports:

  • For an HTTP connection, go to http://localhost:54500/esi/console

  • For a secured HTTPS connection, go to https://localhost:54501/esi/console

  • Or at a PowerShell command prompt, type the following, and press Enter:

Get-EmcServicePolicy

Set the security policy for a user

To set the security policy:

At a PowerShell command prompt, type the following where you replace <domain name>/<principal name> with the applicable domain name and principal name that you want to add to the Monitor role, and then press Enter:

Add-EmcUser "<domain name>\<principal name>" Monitor

Note: The cmdlet fails if the principal name is invalid. Also, if you want to add the principal name to the Administrator role, replace Monitor in the command above with Administrator.

Next step

After setting up the security policy, you can change the system refresh interval.

Related links |
Setting up ESI Service | ESI overview
Changing HTTP connection defaults | ESI home window
Publishing and unpublishing systems to the ESI Service |
Changing the system refresh interval |


Changing the system refresh interval

The ESI Service has a System Refresh Interval setting for how often it polls all registered storage systems and populates the entity graph with all discovered storage systems and system components. The ESI Management Packs use this information to confirm and update to the most current data about discovered components.

By default, this interval is set to poll the storage systems every 30 minutes for new information. This setting, combined with the ESI Monitoring management pack interval number, is the set frequency for receiving monitor updates in SCOM. For example, with this interval set to 30 minutes and the ESI Monitoring interval override set to 10 minutes, an updated health state can take up to 40 minutes. The time intervals can affect the data performance. Changing discovery interval overrides provides details on the Monitor interval override.

To change the system refresh interval for the ESI Service:

  1. If necessary, open a PowerShell command prompt and type the following, and then press Enter to import the ESI Service PowerShell module:

Import-Module ESIServicePSToolkit

  2. Type the following and press Enter to get the current setting in minutes:

Get-EmcServicePolicy

  3. Type the following replacing 30 with the preferred number of minutes, and press Enter:

Set-EmcServicePolicy –RefreshIntervalInMinutes 30

Related links |
Setting up ESI Service | ESI overview
Changing HTTP connection defaults | ESI home window
Publishing and unpublishing systems to the ESI Service |
Viewing and setting up the security policy |


Installing ESI SCOM Management Packs

Installing the ESI SCOM Management Packs

The ESI Zip file, which is available on EMC Online Support, contains the ESI SCOM Management Packs installer. The management packs must be installed on the SCOM Management Group that is connected to the ESI SCOM monitoring agents. The ESI SCOM agents are connected to the same Windows domain as the ESI host system that has the ESI Service installed.

Upgrading to the latest version of the ESI SCOM Management Packs

To upgrade from version 3.0 or later version of the ESI SCOM Management Packs, skip to the next section and perform the steps to install and import the latest ESI SCOM management pack files. However, do not delete or reimport the two customization files or you will lose your customization settings.

To upgrade from version 2.1 to the latest version of the ESI SCOM Management Packs, you must remove version 2.1 management packs (except for the customization files) and then import the latest version of the files in SCOM:

  1. On the Administration tab of the SCOM console, select all the EMC Storage Integrator management packs, except for the EMC Storage Integrator Customization and EMC Storage Integrator Exchange High Availability Extension Monitoring Customization XML files, right-click and select Delete.

Notice: Do not delete the two customization files or you will lose your customization settings.

  2. If prompted, select to also delete any other dependencies.

  3. After deleting the ESI version 2.1 SCOM Management Packs, locate and import the latest version of the management packs with the following procedure.

Installing and importing the ESI SCOM Management Packs

To install and import the management packs:

  1. On the SCOM Management Group server that is connected to the ESI SCOM agents, download the ESI Zip file.

  2. In the ESI Zip file, locate and double-click the ESI SCOM ManagementPacks.*.Setup file.

  3. The management pack files are installed by default to the C:\Program Files\EMC\Management Packs folder.

  4. If upgrading from ESI version 2.1, delete the existing files, except for the customization files, from SCOM before importing the new management pack files.

  5. Import each ESI management pack file in SCOM; however, if you have previously imported the management packs and are performing an update, do not import the EMC.SI.Customization.xml files.

    6. Notice: The customization file contains your overrides and customizations. You will lose your override settings if you reimport this file. This file is installed with version number 1.0.0.0. You can increment the version number when you make changes.

    Note: How to Import a Management Pack in Operations Manager 2007 and How to Import a Management Pack in Operations Manager 2012 on Microsoft TechNet provide more details on importing the management packs.

If you are using SCOM to monitor Exchange, refer to Installing and importing ESI Exchange SCOM Management Packs to install and import the ESI Exchange SCOM Management Packs.

Related links |
Setting up ESI SCOM Management Packs | ESI overview
Using the ESI Monitoring Management Pack | Home window
Setting up optional management pack overrides |


Setting up ESI SCOM Management Packs

After you install and import the ESI SCOM management packs, complete the following setup:

  1. See Confirming connection between SCOM agents and ESI Service to confirm the connection.

  2. See Setting up EMC SI Run As profiles to access the ESI Service.

  3. If necessary, set up the following optional overrides:

  1. If you have more than one SCOM agent connecting to one or more ESI Services, see Setting up the system filter file to set up the system filter file.

  2. If you want to skip the client certificate error message for your specific setup, see Setting the ignore client certificate error override to set the client certificate error override.

  3. If the ESI Service must connect to the ESI Service with a web proxy server, see Setting up the HTTP proxy to set up the HTTP proxy.

  4. Set up the required ESI Service Host override and discovery to set up the host and enable discovery of the ESI Service.

  5. For additional monitoring of the ESI Service, see Setting up the ESI Service Monitoring Account to set up the monitoring account.

  6. See Using the ESI Monitoring Management Pack to set up the management packs.

After you complete these setup steps, refer to Setting up optional management pack overrides for information about optional overrides.

Related links |
Confirming connection between SCOM agents and ESI Service | ESI overview
Setting up the EMC SI Run As profiles | Home window
Setting up the SCOM agent registry |
Setting up ESI Service discovery overrides |


Confirming connection between SCOM agents and ESI Service

Confirming the connection between SCOM agents and ESI Service

Before setting up the agents, confirm the connection between the SCOM agents and ESI Service:

  1. On the SCOM Agent computer, open this link: https://<ESI Service IP>:<https port>/esi/console/graph/Entities?class=StorageSystem. Replace <ESI Service IP> and <https port> with the applicable values.

  2. Confirm that the load time displayed at the bottom of the page is less than one second. Repeat this step a few times for consistent results.

Related links |
Setting up optional management pack overrides | ESI overview
Setting up the EMC SI Run As profiles | Home window
Setting up the SCOM agent registry |
Setting up ESI Service discovery overrides |


Setting up the EMC SI Run As profiles

Setting up the EMC SI Run As profiles in SCOM

Setting up the EMC SI Monitoring account

For the EMC SI Monitoring Account Run As profile, create and set up the Run As profile for each SCOM agent that needs to connect to ESI Service. Refer to Microsoft TechNet for detailed instructions.

To set up an EMC SI Monitoring Account Run As profile for a SCOM agent to connect to each ESI Service:

  1. Create a Windows Run As account from the Windows account that is used in the Monitoring Role for the ESI Service.

  2. In the EMC SI Monitoring account, assign the Windows Run As account to the related SCOM agent that will connect to the ESI Service.

Setting up the EMC SI Service Monitoring account

You can set up an EMC SI Service (ESI Service) Monitoring account Run As profile to monitor the ESI Windows Service. If you install a SCOM agent on the ESI controller host, this agent can discover and monitor the health state of the ESI Service.

The SCOM agent periodically checks if the ESI Service is running and checks the application event log for any events written by the ESI Service. This agent also raises alerts if the ESI Service is not running, if any events that indicate problems with the ESI Service occur, or if any expected events are not received.

Some errors are only detected and reported with a SCOM agent installed on the ESI host controller.

If your SCOM environment uses a Default Action account that is a local administrator, then the action account has the necessary settings.

However, if your SCOM environment uses a low privilege account as the Default Action account, you might need to use a special account to monitor the ESI Service. If you do, then you must work with a SCOM administrator to create the Run As account. You might also need to create a Windows account to monitor the service.

The SCOM account that monitors the ESI Service must have the Allow log on locally enabled, which enables the account to read the Application Event log and use WMI (Windows Management Instrumentation) to query the status of the service.

Refer to SCOM documentation on Microsoft TechNet for details on agent installation considerations and instructions.

Related links |
Setting up optional management pack overrides | ESI overview
Confirming connection between SCOM agents and ESI Service | Home window
Setting up the SCOM agent registry |
Setting up ESI Service discovery overrides |


Setting up the SCOM agent registry

Before enabling the discovery of ESI Service, you must change the Value to Decimal 5120 in the following registry key for each SCOM agent that will monitor EMC systems:

Subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HealthService\Parameters

Type: REG_DWORD

Name: Persistence Version Store Maximum

Value: Number of 16-kilobyte pages (change to Decimal 5120)

Related links |
Setting up optional management pack overrides | ESI overview
Confirming connection between SCOM agents and ESI Service | Home window
Setting up EMC SI Run As profiles |
Setting up ESI Service discovery overrides |


Setting up ESI Service discovery overrides

Setting up optional ESI Service discovery overrides

Based on your specific environment, you can set up the following optional discovery overrides for the ESI Service:

Setting up a system filter file

Setting up the HTTP proxy

Changing the HTTPS to HTTP override

Setting the Ignore client certificate error override

Setting basic authentication overrides

After setting up these optional overrides, you must then set up the required ESI Service Host override.

Setting up a system filter file

If you are using more than one SCOM agent to connect to one or more ESI Services, set up a system filter file for each SCOM agent. The filter file tells the SCOM agent which system to monitor. This text file must be set up on each SCOM agent with the ESI Service Registered Systems Friendly Name for all the supported systems. Confirm that each system appears in a single list.

To set up the system filter file on a SCOM agent for an ESI Service:

  1. On the SCOM agent, open Notepad.

  2. Type the ESI Service Registered Systems Friendly Name of each supported system being monitored by this agent. Use one name per line in the text file.

  3. Save the file to a location on the SCOM agent machine. Confirm that the Windows domain account set up in the Run As Account has at least read access to this file.

  4. Enter the full path to this file in the Filter File Path override field for the ESI Service Discovery management pack.

Setting up the HTTP proxy

If the SCOM agent must connect to the ESI Service through a web proxy server, provide the following information for the Proxy Server and Bypass List overrides in the EMC SI Service Discovery for each related SCOM agent:

  • Proxy server: proxy server string. For example:

proxy_server:80

  • Bypass List: domain bypass list string. For example, the following represents that the discovery can bypass the proxy server when the host name ends with .emc.com:

. *.emc.com

  • If the overrides above are not set, then the proxy settings are obtained from the registry. This assumes the proxy configuration tool, Proxycfg.exe has been run. If Proxycfg.exe has not been run, then the ESI Service can be accessed directly.

Changing the HTTPS to HTTP override

The SCOM agent will always try to connect to the ESI Service by using an HTTPS connection. By default, if the HTTPS connection fails, the SCOM agent cannot communicate with the ESI Service.

If you want the ESI Service to connect with an HTTP connection instead of an HTTPS connection, you can set the HTTPS to HTTP Override to True for the ESI Service connection.

Note: If you set up the override, secure the SCOM agents. With this override, SCOM sends the username and password as text, which can be hijacked. This option is a data security risk.

To change the HTTPS to HTTP override:

  1. Open the SCOM Operations Console and connect to the SCOM Management Group.

  2. From the menu bar, select Go > Authoring.

  3. In the left pane, select Object Discoveries.

  4. Locate and double-click the EMC SI Service Discovery.

  5. Open the Overrides properties and select to Override > For a specific object of class: Windows Computer.

  6. In the Select Object dialog box, select the SCOM proxy agent that you want to connect to the ESI Service, and then click OK.

The Override Properties page appears .

  7. Click the Override checkbox for the HTTPS to HTTP Fallback override to enable it.

  8. Change the value of the Override Value field to True and click OK.

  9. Click Close to save the change.

HTTPS to HTTP Override

Setting the ignore client certificate error override

You can set up an override to ignore the client certificate when the SCOM agent connects to the ESI Service. You can set up this override by following the same steps in Set up HTTPS to HTTP override and selecting the Ignore Certificate Error override and setting it to True.

Setting basic authentication overrides

If one or more SCOM agents are not on the same domain or trusted domain as the ESI Service, you can use basic authentication. To use basic authentication, set up the User Name and Password overrides for the EMC SI Service Discovery.

Note: This override is a data security risk, because SCOM stores the username and password as text, so any user with SCOM console access or access to the file system on the agent can view and hijack the account credentials. If you set up the basic authentication overrides, you must secure the SCOM agents to avoid this risk.

Related links |
Setting up optional management pack overrides | ESI overview
Confirming connection between SCOM agents and ESI Service | Home window
Setting up EMC SI Run As profiles |
Setting up the SCOM agent registry |


Setting up the ESI Service Host override

Setting up the required ESI Service Host override and discovery

After changing the registry key value for each SCOM agent and setting up any optional overrides, you must set up the ESI Service Host override and enable the discovery of the ESI Service for each SCOM agent:

  1. Open the SCOM Operations Console and connect to the SCOM Management Group.

  2. From the menu bar, select Go > Authoring.

  3. In the left pane, select Object Discoveries.

  4. Locate and double-click EMC SI Service Discovery and the EMC SI Service Discovery Properties page appears.

  5. Open the Overrides properties and select Override > For a specific object of class: Windows Computer.

EMC SI Service Discovery overrides

  6. In the Select Object dialog box, select the SCOM proxy agent that you want to connect to the ESI Service from the list and click OK.

The Override Properties page appears.

  7. Confirm the Enabled parameter name override is selected and that the override value is set to True.

  8. Change the override value for the ESI Service Host parameter to the IP address of the computer hosting the ESI Service.

  9. If the default port number of 54500 or 54501 for the ESI Service has been changed, change the port parameter default value to the correct port number.

  10. In the Select destination management pack list box, select the EMC Storage Integrator Customizations management pack.

  11. Click Apply and confirm the changed values.

  12. Click OK.

Note: If you change the Interval or Discovery Timeout (sec) values, discovery performance may be affected.

  13. After completing this setup, export and save a copy of the EMC.SI.Customization.xml file as a backup of your customization values. If you lose a needed customization, you can import this backup copy to recover your set customizations. This file is installed with version number 1.0.0.0. You can increment the version number when you make changes.

Note: How to Monitor Using Overrides on Microsoft TechNet provides more information on creating overrides.

Related links |
Setting up optional management pack overrides | ESI overview
Confirming connection between SCOM agents and ESI Service | Home window
Setting up the SCOM agent registry |
Setting up ESI Service discovery overrides |


Using the ESI Monitoring Management Pack

The ESI Monitoring Management Pack can discover many different system components. The discovery and monitoring of these components is through SCOM agents. The monitoring agent retrieves data from the ESI Service by using a RESTful HTTPS connection, which in turn retrieves the data from the supported (registered) systems. The monitoring data is inserted into the SCOM database.

The ESI Monitoring Management Pack views the components of EMC systems as a topology map. The health of each level depends on the health of the components that roll up to the component.

At the lowest level, the SCOM Management Group monitors the physical and logical components, such as disk drives, power supplies, storage volumes, and virtual volumes. The ESI management packs monitor the operational state of the components. For example, when one or more storage or virtual volumes are in an unhealthy state, then the unhealthy state is rolled up to the storage groups containing the volumes.

The ESI Monitoring Management Pack provides the following monitors:

Monitor | Action at the set interval
Physical Health Monitors check the health of the system physical components, such as the disk drives and power supplies. | Check the operational status of all of the physical components of a specific class and raise alerts when abnormal conditions are detected.
Logical Health Monitors check the health of the logical components, such as the storage pools, storage volumes, and virtual volumes. | Check the operational status of all of the logical components of a specific class and raise alerts when abnormal conditions are detected.
Capacity Monitors check the available capacity of a number of physical and logical system components. | Check the available and subscribed capacity of the components and issue alerts if limits are met or exceeded. These monitors also collects data for SCOM displays and reports.
Diagnostic monitors and rule. | Check the execution of the management pack components and generate alerts when errors occur.

The EMC Storage Integrator Monitoring Management Pack monitors all systems that are registered to the ESI Service and all of the physical and logical system components. The following figure shows which system components are monitored and the health rollup component relationships.

If you are supporting mission-critical applications on VMAX and VNX storage systems, you can also set up fault monitoring, fault reporting, call home, and remote diagnostics features to ensure redundancy for VNX and VMAX arrays.

EMC System Components Monitored by the ESI Monitoring Management Pack

Related links |
Monitoring physical component health | ESI overview
Monitoring logical component health | Home window
Monitoring capacity |
Viewing monitors |
Setting up monitoring maintenance mode |


Monitoring physical component health

When a warning or critical error occurs in a physical component, the health state of the affected component changes and generates an alert. You can use the alert description and product knowledge to troubleshoot the issue.

If a physical component fails and disappears from the data collected by ESI Service, an alert is generated to investigate the failure. You can use this alert to determine root cause of a failure. You can also use the physical component count values that are stored in the database to detect long term trends.

The following rules are available for each component:

  • Two collection rules save the count values to the database (DB) and data warehouse (DW) for the specified physical components of a specified class per parent instance.

  • One warning alert is generated and updated in the active alerts folder in SCOM if a physical-component count changes. If the alert rule for the specified physical component is enabled, the rule collects data every 90 minutes and calculates the total component count. Multiple alert generations are suppressed to reduce the number of alerts generated for the same failure.

Table 1 lists the collection and alert rules that are enabled by default and Table 2 lists the rules that are disabled by default. The total counts for enclosures and LUN storage service nodes includes all of the components in the class hierarchy. The disabled rules are optional for investigating problem alerts. You can enable one or more of the disabled rules when a physical component or hardware problem requires investigation.

Table 1. Enabled component collection and alert rules

Physical component | Enabled collection and alert rules
Enclosure | EMC SI Enclosure Physical Components Total Count Collection Rule (DB) EMC SI Enclosure Physical Components Total Count Collection Rule (DW) EMC SI Enclosure Physical Components Total Count Alert Rule
LUN storage service node | EMC SI LUN Storage Service Node Physical Components Total Count Collection Rule (DB) EMC SI LUN Storage Service Node Physical Components Total Count Collection Rule (DW) EMC SI LUN Storage Service Node Physical Components Total Count Alert Rule

Table 2. Disabled component collection and alert rules

Physical component | Disabled collection and alert rules
Cluster (VPLEX) | EMC SI VPLEXCluster Count Collection (DB) EMC SI VPLEXCluster Collection (DW) EMC SI VPLEXCluster Alert Rule
Cooling component | EMC SI Cooling Component Count Collection (DB) EMC SI Cooling Component Count Collection (DW) EMC SI Cooling Component Count Alert Rule
CPU module | EMC SI CPU Module Count Collection (DB) EMC SI CPU Module Count Collection (DW) EMC SI CPU Module Count Alert Rule
Device | EMC SI Storage Device Count Collection (DB) EMC SI Storage Device Count Collection (DW) EMC SI Storage Device Count Alert Rule
Disk drive | EMC SI Disk Drive Count Collection(DB) EMC SI Disk Drive Count Collection(DW) EMC SI Disk Drive Count Alert Rule
Engine (VPLEX) | EMC SI Engine Count Collection (DB) EMC SI Engine Count Collection (DW) EMC SI Engine Count Alert Rule
Extent (VPLEX) | EMC SI Extent Count Collection (DB) EMC SI Extent Count Collection (DW) EMC SI Extent Count Alert Rule
FC storage port | EMC SI Fc Storage Port Count Collection (DB) EMC SI Fc Storage Port Count Collection (DW) EMC SI Fc Storage Port Count Alert Rule
I/O module | EMC SI IO Module Count Collection (DB) EMC SI IO Module Count Collection (DW) EMC SI IO Module Count Alert Rule
iSCSI storage port | EMC SI ISCSI Storage Port Count Collection (DB) EMC SI ISCSI Storage Port Count Collection (DW) EMC SI ISCSI Storage Port Count Alert Rule
Link control card | EMC SI Link Control Card Collection (DB) EMC SI Link Control Card Collection (DW) EMC SI Link Control Card Count Alert Rule
Storage array (VPLEX back-end storage system) | EMC SI Storage Array Collection (DB) EMC SI Storage Array Collection (DW) EMC SI Storage Array Alert Rule
Storage service node | EMC SI Storage Service Node Count Collection (DB) EMC SI Storage Service Node Count Collection (DW) EMC SI Storage Service Node Count Alert Rule
Storage volume | EMC SI Storage Volume Count Collection (DB) EMC SI Storage Volume Count Collection (DW) EMC SI Storage Volume Count Alert Rule
Memory module | EMC SI Memory Module Count Collection (DB) EMC SI Memory Module Count Collection (DW) EMC SI Memory Module Count Alert Rule
Network switch | EMC SI Network Switch Count Collection(DB) EMC SI Network Switch Count Collection(DW) EMC SI Network Switch Count Alert Rule
Power supply | EMC SI Power Supply Count Collection (DB) EMC SI Power Supply Count Collection (DW) EMC SI Power Supply Count Alert Rule
Unclassified port | EMC SI Unclassified Port Count Collection (DB) EMC SI Unclassified Port Count Collection (DW) EMC SI Unclassified Port Count Alert Rule
Virtual volume (VPLEX) | EMC SI Virtual Volume Count Collection (DB) EMC SI Virtual Volume Count Collection (DW) EMC SI Virtual Volume Count Alert Rule

Related links |
Using the ESI Monitoring Management Pack | ESI overview
Monitoring logical component health | Home window
Monitoring capacity |
Viewing monitors |
Setting up monitoring maintenance mode |


Monitoring logical component health

When a warning or critical error occurs in a logical component (such as a storage or virtual volume), the health state of the affected component changes and generates an alert. You can use the alert description and product knowledge to decide what action is necessary.

If a logical component fails and disappears from the data collected by ESI Service, an alert is generated to investigate the failure. You can use this alert to determine root cause of a failure. You can also use the logical component count values that are stored in the database to detect long term trends.

The collection and alert rules that are enabled and disabled by default for system components are described in Monitoring physical component health.

Related links |
Using the ESI Monitoring Management Pack | ESI overview
Monitoring physical component health | Home window
Monitoring capacity |
Viewing monitors |
Setting up monitoring maintenance mode |


Monitoring capacity

The available capacity of storage and snapshot pools and groups are monitored. Alerts are generated when certain thresholds are exceeded. These monitors allow a storage administrator to ensure that adequate capacity is available on a system.

The following table shows the default thresholds for the capacity monitors. If the thresholds are not appropriate for your environment, you can override them, either for all instances of the monitors or for specific snapshot, storage pools, or virtual volume.

Capacity monitoring threshold values:

Capacity monitors | Warning Thresholds | Error Thresholds
Snapshot Pool available capacity | 20% | 10%
Storage Pool available capacity | 20% | 10%
Storage Pool subscribed capacity | 70% | 90%

Related links |
Using the ESI Monitoring Management Pack | ESI overview
Monitoring physical component health | Home window
Monitoring logical component health |
Viewing monitors |
Setting up monitoring maintenance mode |


Viewing monitors

In the Monitoring tab of the Operations Console, the EMC Storage Integrator folder contains views for monitoring the supported systems and the ESI Service:

  • The top Active Alerts view lists the open alerts for all of the systems.

  • The Overall Topology view displays a hierarchical diagram of all the monitored systems.

  • The ESI Service Overall Health and the ESI Windows Service Overall Health views list the health state and active alerts for the ESI Service and ESI Windows Service.

  • Each physical and logical component has an Overall Health view showing health state and active alerts.

  • The Diagnostics folder contains views that are related to the health of the management pack monitoring facilities. The Monitoring Delays, Errors and Timeouts view displays events and alerts for monitoring failures, which include: ESI Service authorization problems, communication timeouts, and problems with resource availability on the monitoring agents. The other views display performance data for the ESI Service. Some of the rules collecting this data are disabled by default, so some data might be unavailable. If you have monitoring problems, EMC Support might ask that you enable one or more of these rules for diagnostic tests.

Related links |
Using the ESI Monitoring Management Pack | ESI overview
Monitoring logical component health | Home window
Monitoring capacity |
Monitoring physical component health |
Setting up monitoring maintenance mode |


Setting up monitoring maintenance mode

When a monitored object, such as a disk drive or power supply, goes offline for maintenance, the ESI Service detects the condition and might generate numerous alerts and notifications.

To prevent ESI Service and the ESI SCOM Management Packs from creating alerts and notifications, you can set the monitored object to maintenance mode.

When an object is in maintenance mode, alerts, notifications, rules, monitors, automatic responses, state changes, and new alerts are suppressed by SCOM.

For more information on setting a monitored object to maintenance mode in SCOM, refer to How to Put a Monitored Object into Maintenance Mode in Operations Manager 2007 or Operations Manager Maintenance Mode (for 2012) on Microsoft TechNet.

Related links |
Using the ESI Monitoring Management Pack | ESI overview
Monitoring physical component health | Home window
Monitoring logical component health |
Monitoring capacity |
Viewing monitors |


Setting up optional management pack overrides

You can use the procedures in this section to temporarily change intervals during a customization or when making significant storage environment changes. You can also use the following procedures to reduce network traffic and increase network performance for your specific storage environment:

Disabling performance data collection

Changing discovery interval overrides

Changing monitoring interval overrides

After changing intervals and each time you make changes to your overrides and customizations, export and save a copy of the EMC.SI.Customization.xml file as a backup of your customization values. If you lose a needed customization, you can import this backup copy to recover your specific customizations.

How to Monitor Using Overrides on Microsoft TechNet provides more information on creating overrides.

Related links |
Disabling performance data collection | ESI overview
Changing discovery interval overrides | Home window
Changing monitoring interval overrides |


Disabling performance data collection

To reduce network traffic or to improve performance on servers with slow WAN links, you can disable the rules that collect performance data. Each performance counter has two rules: One for the operational database and one for the data warehouse. If you disable an operational database rule or data warehouse rule, performance data cannot be viewed in the Operations console or in reports.

Note: When you disable the rules that collect performance data, the views and reports that rely on this data do not work. You must enable them again before you use the views or run any performance data reports.

To disable the rules that collect performance data:

  1. Open the SCOM Operations Console and connect to the SCOM Management Group.

  2. Select Go > Authoring.

  3. In the left pane, select Rules.

  4. Change the scope to EMC SI Snapshot Pool and EMC SI Storage Pool.

  5. Select and double-click the rule that you want to disable.

Note: The collection rules for the operational database include (DB) in the name. Collection rules for the data warehouse include (DW) in the name.

  6. Open the Override properties and select to edit the overrides for all objects of class.

  7. Select the EMC Storage Integrator Customizations management pack.

  8. Change the Enabled property to False.

  9. Click Apply and verify the changed values.

  10. Click OK, and then click Close.

  11. Repeat this procedure for each rule that you want to disable.

Related links |
Setting up optional management pack overrides | ESI overview
Changing discovery interval overrides | Home window
Changing monitoring interval overrides |


Changing discovery interval overrides

When you install a new system or make changes to an existing system, the ESI Service takes a set amount of time to send these changes to the ESI management packs on the SCOM agents.

To trigger the discovery of new changes, you can toggle the Enabled override setting for the EMC SI Service Discovery:

  1. Open the Override Properties window for the EMC SI Service Discovery.

  2. Clear the Enabled override checkbox and click Apply.

  3. Then, before closing the window, select the Enabled override checkbox to reset the override. This triggers the discovery of all changes to components regardless of the interval values.

The default intervals for the discovery of new components vary depending on the component. If you want SCOM to discover newly added components more quickly than the set interval, you can temporarily change the interval setting. Then you can see the changes more quickly in SCOM. And after the changes are discovered, you can change it back to the preferred setting for your storage environment.

To change the discovery interval:

  1. Open the SCOM Operations Console and connect to the SCOM Management Group.

  2. Select Go > Authoring.

  3. In the left pane, select Object Discoveries.

  4. Locate and double-click the EMC Discovery for the desired object class.

  5. Open the Override properties and select to edit the overrides for all objects of class.

  6. Change the Interval (sec) property to the preferred value. The default values vary depending on the specific object or component.

Notes:

  • You can temporarily reduce the interval to 600 or more seconds (10 minutes) to enable quick discovery of new components.

  • The Discovery Timeout (sec) must remain unchanged. If you reduce it, discoveries can fail before retrieving all of the data. And if you increase it, performance problems can occur.

  7. Select the EMC Storage Integrator Customizations management pack.

  8. Click Apply and verify the changed values.

  9. Click OK, and then click Close.

Related links |
Setting up optional management pack overrides | ESI overview
Disabling performance data collection | Home window
Changing monitoring interval overrides |


Changing monitoring interval overrides

By default, the monitors communicate with the ESI Service approximately every six minutes to check the status of the systems. In a large storage environment, the ESI controller host, the SCOM agent, or the SCOM Management Group machines may experience a resource (CPU or memory capacity) shortage. Increasing the monitoring interval can help alleviate this type of shortage.

The ESI Service interval setting combined with the ESI Service system refresh interval number is the maximum frequency for receiving monitor updates in SCOM. For example, with this interval set to 600 seconds (about 10 minutes) and the ESI Service system refresh interval set to 30 minutes, an updated health state can take up to 40 minutes. The time intervals can affect the data performance. Changing the system refresh interval provides details on the ESI Service interval.

How to Monitor Using Overrides on Microsoft TechNet more details.

To change the SCOM overrides for the ESI Monitoring management packs:

  1. Open the SCOM Operations Console and connect to the SCOM Management Group.

  2. From the menu bar, select Go > Authoring or select Authoring from the lower left pane.

  3. From the left pane, select Monitors.

  4. Locate and double-click the EMC component and monitor that you want to change.

  5. Open the Overrides properties and select one of the following choices:

  • For all objects of class: to override the rule for all objects

  • For a specific object of class: to override for a specific object.

  6. Select the EMC Storage Integrator Customizations management pack.

  7. Change the Interval (sec) property to your preferred time. The default value is 600 seconds (about 10 minutes).

  8. Click Apply and verify the changed values.

  9. Click OK.

  10. Click Close.

Note: The Timeout Value (sec) value needs to remain unchanged. If you reduce it, monitors can fail before retrieving all of the data. And if you increase it, performance problems may occur.

Related links |
Setting up optional management pack overrides | ESI overview
Disabling performance data collection | Home window
Disabling performance data collection |


Getting Started

Getting started with the ESI PowerShell toolkits

ESI PowerShell toolkits

ESI for Windows includes:

  • ESI PowerShell Toolkit

  • ESI Service PowerShell Toolkit

The toolkits are written for the PowerShell 4.0 platform, which is developed by Microsoft specifically for Windows System Management automation.

ESI PowerShell Toolkit

The ESI PowerShell Toolkit enables you to provision and manage storage to Microsoft Windows hosts that use EMC storage. This toolkit includes a set of PowerShell cmdlets to manage EMC storage systems from the PowerShell command line. The ESI PowerShell Toolkit provides access to most of the provisioning functionality offered by the ESI Microsoft Management Console (MMC) application and shares a common configuration set with the MMC application.

The ESI PowerShell Toolkit provides cmdlets to manage:

  • Connections to host and storage systems and to provision block storage.

  • Disk devices in hypervisor environments, such as VMware vSphere and Microsoft Hyper-V.

  • Block device snapshots for EMC VNX, and VNXe storage systems.

ESI PowerShell cmdlet list provides a complete list of the cmdlets.

ESI Service PowerShell Toolkit

The ESI Service PowerShell Toolkit provides cmdlets for setting up the ESI Service for use with the ESI System Center Operations Manager (SCOM) Management Packs.

The toolkit provides cmdlets for setting up the ESI Service to:

  • Get the storage system entity data and entity relationships for the entity graph.

  • Configure service security.

  • Register EMC storage systems.

ESI Service PowerShell cmdlet list provides a complete list of the cmdlets.

System prerequisites

The ESI PowerShell Toolkit is installed as part of the ESI product. The ESI Service PowerShell Toolkit is installed when you install the ESI Service. The toolkits have the same system prerequisites as ESI, including that Microsoft Windows PowerShell 4.0 be installed and enabled as a Windows feature on each system that is running the toolkit.


Getting help at the command line

The same detailed cmdlet information is also available at the command line. To view cmdlet details at the command line, type the following from the Windows PowerShell command line where you replace <cmdlet name> with a specific cmdlet name:

get-help <cmdlet name> -full

For example, type the following at the PowerShell command line to get help on the Get-EmcLun cmdlet:

get-help Get-EmcLun -full


Importing the modules

To use the ESI PowerShell toolkits, with Windows Server 2008 R2, you must run the toolkit launcher and then import the corresponding toolkit module. With Windows Server 2012, modules are imported automatically and you can omit this step.

Run the launcher and import the ESI PowerShell Toolkit

During the core ESI installation, the ESI PowerShell Toolkit is installed on the same system in a default EMC folder.

To run the launcher and import the ESI PowerShell Toolkit module:

  1. Open a Windows PowerShell command prompt in either the interactive or scripting environment.

  2. At the PS C:\> command prompt, type the following and press Enter to run each command separately:

cd "C:\Program Files\EMC\EMC Storage Integrator\ESIPSToolKit"

.\ESIPSToolKitLauncher.ps1

import-module ESIPSToolkit

Import the ESI Service PowerShell Toolkit

During the ESI installation, when you select to install the ESI Service, the ESI Service PowerShell Toolkit is installed on the same system in a default EMC folder.

To import the ESI Service PowerShell Toolkit module:

  1. Open a Windows PowerShell command prompt in either the interactive or scripting environment.

  2. At the PS C:\> command prompt, type the following and press Enter to run each command separately:

cd "C:\Program Files\EMC\EMC Storage Integrator\ESIServicePSToolKit"

import-module ESIServicePSToolkit


Using PowerShell objects

The ESI PowerShell toolkits accept objects as inputs. The inputs can be standard objects, such as strings and integers. In many instances, these inputs have useful properties that can be accessed using dot notation. A full list of these objects and their properties is beyond the scope of this help file.

Defining and accessing variables

PowerShell enables you to create objects and store them in variables. For example, an ESI LUN object can be created and stored in a variable by using the Get-EmcLun command:

$lun = Get-EmcLun “My LUN”

This LUN object is used with the Set-EmcLunAccess cmdlet to present the LUN to a host:

Set-EmcLunAccess –LUN $lun –HostSystem $myhost -Available

Retrieving object information

Use the Get-Member cmdlet to access information about the properties and methods supported by an object. The Get-Member cmdlet accepts pipeline inputs. You can pipe an object returned by a cmdlet to Get-Member to determine the properties and methods of the object.

Standard object descriptions

The following table lists common PowerShell objects.

Object | Description
Boolean | Represents a true or false value. For true, type 1 or $true. For false, type 1 or $false.
Int32 | Represents a 32-bit signed integer. Signed integers are either positive or negative.
Int64 | Represents a 64-bit signed integer. Signed integers are either positive or negative.
SecureString | Represents an encrypted string for private data.
String | Represents a set of alphanumeric characters. A string that contains the space character must be enclosed by quotation marks. For example: Get-EmcLun “My Basic LUN”
UInt32 | Represents a 32-bit unsigned integer. Unsigned integers cannot be negative.
UInt64 | Represents a 64-bit unsigned integer. Unsigned integers cannot be negative.


ESI PowerShell cmdlet list

This is a complete list of available ESI PowerShell cmdlets, grouped by operation type. Within each group, the cmdlets are listed alphabetically. The syntax, parameters, and examples are provided for each cmdlet.

To get the same information for a specific cmdlet, type the following at the PowerShell command prompt:

get-help <cmdlet name> -full

Connection-related operations

Storage system operations

FAST VP operations

Managing metas

Host operations

Hypervisor virtualization operations

Application operations

Exchange

SQL Server

Replication

AppSync

RecoverPoint

Connection-related operations

  • Connect-EmcSystem: Connects or adds host, cluster, and storage systems to ESI.

  • Disable-EmcPublisherCertificateValidation: Disables server SSL certificate validation when using SSL to communicate with the specified ESI Service.

  • Enable-EmcPublisherCertificateValidation: Enables server SSL certificate validation when using SSL to communicate with the specified ESI Service.

  • Disconnect-EmcClusterSystem: Disconnects cluster systems.

  • Disconnect-EmcHostSystem: Disconnects host systems.

  • Disconnect-EmcStorageSystem: Disconnects storage systems.

  • Disconnect-EmcSystem: Disconnects clusters, hosts, and storage systems.

  • Get-EmcClusterSystemCredential: Gets the encrypted connection string or BLOB, based on the specified parameters.

  • Get-EmcHostSystemCredential: Gets the encrypted connection or system object creation parameters BLOB, which you can use with the Connect-EmcSystem cmdlet to connect host systems to ESI.

  • Get-EmcLinuxHostSystemCredential: Gets the encrypted connection string or BLOB, based on the specified connection (system object creation) parameters for a Linux system. You can use the BLOB with the Connect-EmcSystem cmdlet to connect or add Linux host systems to ESI.

  • Get-EmcPublisherConnectionInfo: Gets the list of systems currently registered with the specified ESI Service.

  • Get-EmcPublisherEndpointOptions: Gets the current options used to connect to the specified ESI Service.

  • Get-EmcPublisherSupportedSystem: Gets all of the system types that are available for registration with the specified ESI Service.

  • Get-EmcStorageIntegratorVersion: Gets the specific software version of ESI that is installed.

  • Get-EmcStorageSystemCredential: Gets the encrypted connection or system object creation parameters BLOB, which you can use with the Connect-EmcSystem cmdlet to connect storage systems to ESI.

  • Get-EmcSupportedSystemsCreationRequirement: Gets the list of creational parameters required to add or connect to a system in ESI.

  • Publish-EmcPublisherConnectionInfo: Publishes the connection information of the specified system to the specified ESI Service.

  • Publish-EmcPublisherUserConnectionInfo: Publishes the connection information for the specified system to the specified user.

  • Set-EmcPublisherEndpointUrl: Sets the URL to the specified ESI Service on the current session.

  • Test-EmcSystemConnectedToBlockStorageSystem: Verifies the connectivity of a host system or replication system to a block storage system. This cmdlet only works with VNX and VMAX block storage systems.

  • Unpublish-EmcPublisherConnectionInfo: Unpublishes the connection information for the specified system to the specified ESI Service.

  • Update-EmcSystem: Updates the specified host, storage, or cluster systems.

Storage system operations

  • Add-EmcVnxeLunGroupMember: Adds one or more members to a VNXe3200 LUN group.

  • Copy-EmcVnxAdvancedSnapshot: Copies Vnx advanced snapshot to new Vnx advanced snapshot.

  • Dismount-EmcVnxAdvancedSnapshot: Dismounts/Detaches the VNX advanced snapshot with associated snapshot mount point LUN.

  • Dismount-EmcVnxeSnapshot: Dismounts a VNXe3200 LUN or LUN group snapshot to prevent host access.

  • Expand-EmcLun: Expands the capacity of a LUN.

  • Expand-EmcCompositeLun: Expands the capacity of the composite LUN.

  • Expand-EmcFileBasedDisk: Expands the size of a file-based disk.

  • Get-EmcCompositeLunMember: Gets the composite LUN members of the specified composite LUN head.

  • Get-EmcInitiatorGroup: Gets a list of initiator groups for the specified XtremIO storage system.

  • Get-EmcLun: Gets the list of LUNs for the specified storage system or systems.

  • Get-EmcLunMaskingView: Gets a list of LUN masking views.

  • Get-EmcScsiLun: Gets the list of VMware SCSI LUNs.

  • Get-EmcSnapshotLun: Gets the list of Snapshot LUNs.

  • Get-EmcSnapshotPool: Gets the list of Snapshot Pools.

  • Get-EmcStoragePool: Gets the list of storage pools.

  • Get-EmcStorageRegisteredHost: Gets a list of registered hosts for a specified storage system.

  • Get-EmcStorageRegisteredInitiator: Gets the list of host initiators that are registered on the storage systems.

  • Get-EmcStorageServiceNode: Gets the list of storage service nodes.

  • Get-EmcStorageSystem: Gets the list of storage systems.

  • Get-EmcSupportedSystem: Gets the list of supported systems.

  • Get-EmcTargetPort: Gets the list of target ports.

  • Get-EmcVnxAdvancedSnapshot: Gets the list of VNX advanced snapshots.

  • Get-EmcVnxAdvancedSnapshotMountPoint: Gets the list of VNX advanced snapshot mount points.

  • Get-EmcVnxeLunGroup: Gets VNXe3200 LUN groups.

  • Get-EmcVnxeLunGroupMember: Gets VNXe3200 LUN group members.

  • Get-EmcVnxeSnapshot: Gets VNXe3200 snapshots.

  • Get-EmcXBrick: Get a list of X-Brick information from the XtremIO storage system.

  • Mount-EmcVnxAdvancedSnapshot: Mounts/Attaches the VNX advanced snapshot with specified snapshot mount point LUN.

  • Mount-EmcVnxeSnapshot: Mounts a VNXe LUN or LUN group snapshot so that it is visible to hosts that have been added to the snapshot access list for the LUN or LUN group.

  • New-EmcLun: Creates a new ESI LUN object.

  • New-EmcSnapshotLun: Creates a new snapshot LUN.

  • New-EmcStorageRegisteredHost: Registers a host for a specified storage system.

  • New-EmcStorageRegisteredInitiator: Registers a host initiator on a specified storage system.

  • New-EmcVnxAdvancedSnapshot: Creates new Vnx advanced snapshot from Lun and snapshot mount point (SMP).

  • New-EmcVnxAdvancedSnapshotMountPoint: Creates new Vnx advanced snapshot mount LUN from source LUN.

  • New-EmcVnxeLunGroup: Creates a new LUN group on a VNXe3200 system.

  • New-EmcVnxeSnapshot: Creates a new snapshot on a VNXe system.

  • Remove-EmcFileBasedDisk: Deletes a file-based disk from a hypervisor.

  • Remove-EmcLun: Removes or destroys the LUN from the storage system.

  • Remove-EmcSnapshotLun: Removes the snapshot LUN.

  • Remove-EmcStorageRegisteredHost: Removes the registered host from the storage system where it is registered.

  • Remove-EmcStorageRegisteredInitiator: Removes the specified host initiator from the storage system where the initiator host is registered.

  • Remove-EmcVnxAdvancedSnapshot: Removes or deletes the specified VNX advanced snapshot.

  • Remove-EmcVnxeLunGroup: Deletes a LUN group from a VNXe3200 system.

  • Remove-EmcVnxeLunGroupMember: Removes one or more members from a LUN group.

  • Remove-EmcVnxeSnapshot: Deletes a snapshot from a VNXe3200 system.

  • Restore-EmcSnapshotLun: Restores the source content from the Snapshot LUN.

  • Restore-EmcVnxAdvancedSnapshot: Restores the VNX advanced snapshot to the source LUN.

  • Restore-EmcVnxeSnapshot: Restores a VNXe snapshot back to its source.

  • Set-EmcLun: Sets the storage service node for the specified LUN. For VNX storage systems only, sets the storage tiering policy and LUN compression and compression rate for the specified LUN.

  • Set-EmcLunAccess: Masks or unmasks a LUN to a host, a cluster, or an FC or iSCSI initiator.

  • Set-EmcVnxLunAllocationPolicy: Modifies the Allocation Policy of a LUN.

  • Update-EmcVnxAdvancedSnapshot: Updates the VNX advanced snapshot.

FAST VP operations

    • Add-EmcFastVpPolicy: Adds or associates the specified storage group to the specified FAST VP policy.

    • Add-EmcLunsToVmaxStorageGroup: Adds one or more LUNs to the specified VMAX storage group. Clears the host disk signatures and assigns new ones.

    • Get-EmcFastVpPolicy: Gets the FAST VP policies that are associated with the specified storage system or VMAX storage group.

    • Get-EmcStorageTier: Gets the storage tiers in the specified storage system with the specified FAST VP policy.

    • Get-EmcVmaxStorageGroup: Gets all storage groups for the specified VMAX storage system.

    • New-EmcVmaxStorageGroup: Create a new storage group for the specified VMAX system.

    • Remove-EmcFastVpPolicy: Removes the specified FAST VP policy from the specified storage groups.

    • Remove-EmcLunsFromVmaxStorageGroup: Removes LUNs from a VMAX storage group.

    • Remove-EmcVmaxStorageGroup: Deletes the specified storage group that is associated with the specified FAST VP Policy.

Managing metas

    • Get-EmcAvailableCandidatesForLunComposition: Gets all the LUNs which are qualified to be a member LUN of the specified meta, meta volume, or composite LUN.

    • Get-EmcCompositeLun: Gets all composite LUNs from the specified storage system.

    • Get-EmcCompositeLunMember: Gets one or more meta or composite LUN members of the specified composite LUN head.

    • New-EmcCompositeLun: Creates a new meta or composite LUN from the specified LUNs. To compose or form a meta or composite LUN, requires at least two LUNs and the first LUN becomes the metahead.

    • Remove-EmcCompositeLun: Removes (destroys) the composite LUN from the storage system.

Host operations

  • Add-EmcHostDiskToCluster: Adds a disk to a cluster.

  • Clear-EmcHostDiskSignature: Clears the host disk signatures and assigns new ones.

  • Expand-EmcHostVolume: Expands the volume of a host.

  • Find-EmcHostDisk: Finds the ESI Host Disk associated with an ESI LUN, host LUN identifier, or virtual machine disk configuration on a host or cluster system.

  • Get-EmcAvailableDriveLetter: Gets the available drive letters on a host system or cluster system.

  • Get-EmcClusterDisk: Gets the list of cluster disks.

  • Get-EmcClusterGroup: Gets the list of cluster groups.

  • Get-EmcClusterNode: Gets the list of cluster nodes.

  • Get-EmcClusterSystem: Gets connected cluster systems.

  • Get-EmcHostBusAdapter: Gets the list of host bus adapters for the specified hosts.

  • Get-EmcHostDisk: Gets the list of host disk objects.

  • Get-EmcHostLunIdentifier: Gets the host LUN identifier.

  • Get-EmcHostSystem: Gets connected host systems.

  • Get-EmcHostVolume: Gets the list of host volumes.

  • Initialize-EmcHostDisk: Initializes a host disk by bringing the disk online and setting a specified partition style in a host or cluster system.

  • New-EmcVolume: Creates a volume.

  • Remove-EmcHostDiskFromCluster: Removes a disk from a cluster.

  • Remove-EmcVolumeMountPoint: Removes or unmounts the specified volume.

  • Set-EmcHostDiskOnlineState: Changes the online state of the specified disk.

  • Set-EmcHostDiskReadonlyState: Changes the read-only state for the specified disk.

  • Set-EmcVolumeMountPoint: Sets the drive letter or mount path for the volume.

Hypervisor virtualization operations

  • Add-EmcFilebasedDiskToVirtualMachine: Adds or attaches a file-based disk to a virtual machine.

  • Add-EmcPassthroughDiskToVirtualMachine: Adds or attaches a pass-through disk to a virtual machine.

  • Get-EmcAvailablePassthroughDiskCandidate: Gets the list of available pass-through disk candidates to attach or add to a virtual machine for a specified hypervisor.

  • Get-EmcAvailableScsiControllerLocation: Gets the list of available SCSI controllers for a virtual machine that you can use to attach file-based or pass-through disks.

  • Get-EmcDatastore: Gets the list of VMware datastores.

  • Get-EmcESXCluster: Gets the list of VMware ESX Clusters.

  • Get-EmcESXHost: Gets the list of VMware ESX hosts.

  • Get-EmcHyperVSystem: Gets the list of connected Hyper-V systems.

  • Get-EmcHyperVSystemCredential: Gets the credentials for Microsoft Hyper-V to connect ESI.

  • Get-EmcVcenterSystem: Gets the list of vCenter systems.

  • Get-EmcVirtualDiskConfiguration: Gets the virtual disk configuration for the specified host disk of a virtual machine, which can be either a file-based or pass-through disk.

  • Get-EmcVirtualMachineConfiguration: Gets the virtual machine configuration.

  • Get-EmcVirtualMachineHypervisor: Gets the virtual machine hypervisor.

  • Get-EmcVirtualMachineScsiController: Gets the SCSI controllers from the virtual machine configurations.

  • Get-EmcVMwareSystemCredential: Gets the encrypted connection parameters BLOB or the system object creation parameters for VMware systems.

  • New-EmcDatastore: Creates a new datastore.

  • New-EmcFileBasedDisk: Creates a file-based disk for a specified hypervisor.

  • Remove-EmcDatastore: Deletes the specified datastore.

  • Remove-EmcVirtualDiskFromVm: Removes a file-based or pass-through disk from the virtual machine.

Application operations

Exchange

    • Get-EmcDatabaseAvailabilityGroup: Gets the configuration settings, status, and other information about a database availability group (DAG).

    • Get-EmcExchangeCmdletOutput: Gets results of some standard Microsoft PowerShell cmdlets for Exchange. This is not an ESI cmdlet.

    • Get-EmcExchangeSystem: Gets the information about the Exchange system.

    • Get-EmcExchangeSystemCredential: Gets the encrypted connection string or BLOB. You can use this cmdlet with the Connect-EmcSystem cmdlet to connect or add host systems to ESI.

    • Get-EmcMailboxDatabase: Gets one or more mailbox database objects from a server, forest, or organization.

    • Get-EmcMailboxDatabaseCopy: Gets one or more mailbox database copy objects from a server or organization.

    • Get-EmcMailboxDatabaseCopyStatus: Gets the health and status information for one or more mailbox database copies.

    • Get-EmcMailboxServer: Gets the list of mailbox database servers. If no parameters are specified, it gets a complete list of the mailbox servers in the entire organization.

SQL Server operations

    • Add-EmcDatabaseToAvailabilityGroup: Adds one or more databases to a specified AlwaysOn Availability Group.

    • Add-EmcReplicaToAvailabilityGroup: Adds a secondary replica to a specified AlwaysOn Availability Group.

    • Get-EmcSqlServer: Gets databases that are present in a specified SQL Server.

    • Get-EmcSqlServerAvailabilityGroup: Lists Availability Groups that are present in a specified SQL Server.

    • Get-EmcSqlServerCredential: Gets connection information

    • Get-EmcSqlServerDatabase: Gets SQL Server database information.

    • New-EmcSqlServerAvailabilityGroup: Creates a new AlwaysOn Availability Group.

    • New-EmcSqlServerDatabase: Creates a new database in a specified SQL Server.

    • Remove-EmcDatabaseFromAvailabilityGroup: Removes one or more databases from a specified AlwaysOn Availability Group.

    • Remove-EmcReplicaFromAvailabilityGroup: Removes a secondary replica from a specified AlwaysOn Availability Group.

    • Remove-EmcSqlServerAvailabilityGroup: Removes a specified SQL Server Availability Group.

    • Remove-EmcSqlServerDatabase: Removes one or more databases from a specified SQL Server.

Replication—AppSync

  • Dismount-EmcAppSyncCopy: Dismounts a specified copy of a SQL Server database or an Exchange database.

  • Get-EmcAppSyncCopy: Gets the copies of SQL Server databases or Exchange databases for the specified system.

  • Get-EmcAppSyncExchangeDatabase: Gets the Exchange databases for the specified system.

  • Get-EmcAppSyncExchangeServer: Gets the Exchange servers for the specified system.

  • Get-EmcAppSyncManifest: Gets the manifest information for the specified AppSync system.

  • Get-EmcAppSyncRegisteredHost: Gets the hosts that are registered with the specified AppSync system.

  • Get-EmcAppSyncRegisteredRecoverPointSystem: Gets the RecoverPoint systems that are registered with the specified AppSync system.

  • Get-EmcAppSyncRegisteredStorageSystem: Gets the storage systems that are registered with the specified AppSync system.

  • Get-EmcAppSyncServicePlan: Gets the service plans for the specified AppSync system.

  • Get-EmcAppSyncServicePlanSubscription: Gets the subscriptions for the specified service plan.

  • Get-EmcAppSyncSqlServerDatabase: Gets the SQL Server databases on the specified AppSync system.

  • Get-EmcAppSyncSqlServerInstance: Gets the SQL Server instances on the specified AppSync system.

  • Get-EmcAppSyncSystemAlert: Gets the alerts for the specified AppSync system.

  • Mount-EmcAppSyncExchangeDatabaseCopy: Mounts the specified Exchange database copy.

  • Mount-EmcAppSyncSqlServerDatabaseCopy: Mounts the specified SQL Server database copy.

  • New-EmcAppSyncExchangeDatabaseCopy: Protects the specified Exchange database by making a copy according to the criteria set by the specified service plan.

  • New-EmcAppSyncServicePlanCopies: Runs the specified service plan and creates copies of applications that subscribe to that service plan.

  • New-EmcAppSyncServicePlanSubscription: Subscribes the specified SQL Server database or Exchange database to the specified service plan.

  • New-EmcAppSyncSqlServerDatabaseCopy: Protects the specified SQL Server database by making a copy according to the criteria set by the specified service plan.

  • Remove-EmcAppSyncCopy: Expires the specified SQL Server database copy or Exchange database copy.

  • Remove-EmcAppSyncServicePlanSubscription: Removes the specified subscription.

  • Restore-EmcAppSyncExchangeDatabaseCopy: Restores the source Exchange database by using the specified copy.

  • Restore-EmcAppSyncSqlServerDatabaseCopy: Restores the source SQL Server database by using the specified copy.

  • Update-EmcAppSyncSystem: Updates the AppSync system by discovering applications.

Replication—RecoverPoint

  • Disable-EmcReplicaCopy: Disables a replica copy to stop the replication of that copy.

  • Disable-EmcReplicaCopyImageAccess: Disables a replica copy image access so that it is not available for mounting, and replication changes are again propagated to the copy.

  • Disconnect-EmcReplicationService: Disconnects replication services.

  • Enable-EmcReplicaCopy: Enables a replica copy to start replication on that copy.

  • Enable-EmcReplicaCopyImageAccess: Enables a replica copy image access so that it can be available for mounting. Replication changes are not propagated to the copy while image access is enabled.

  • Get-EmcConsistencyGroup: Retrieves consistency groups that are used to protect LUNs.

  • Get-EmcReplicaCopy: Gets the list of replica copies that specify the copies within a consistency group.

  • Get-EmcReplicaCopySnapshots: Gets the list of snapshots for the specified replica copy.

  • Get-EmcReplicaLink: Gets the list of replica links that specify the replication connection and direction between two replica copies within a consistency group.

  • Get-EmcReplicaLun: Gets the replica LUNs for replication.

  • Get-EmcReplicaSet: Gets replica sets that contain the LUNs for the replication of source LUNs.

  • Get-EmcReplicationService: Gets the list of replication services. The replication service is the primary object for managing replication clusters, sites, and systems.

  • Get-EmcReplicationServiceCluster: Gets the list of replication clusters, which contains all of the replication sites and systems in a replication service.

  • Get-EmcReplicationServiceCredential: Gets the encrypted connection string or BLOB. You can use this cmdlet along with the Connect-EmcSystem cmdlet to connect or add replication services to ESI.

  • Get-EmcReplicationServiceSite: Gets the list of replication sites, which contains all of the replication systems in the site.

  • Get-EmcReplicationSystem: Gets the list of replication systems. A replication system is an individual replication appliance that performs and facilitates replication.

  • Move-EmcProductionReplicaCopy: Performs a permanent failover to the specified replica copy, and then the copy becomes the new production copy.

  • New-EmcBookmark: Creates a bookmark for a specified consistency group.

  • New-EmcConsistencyGroup: Creates a new consistency group, which is a group of one or more replica sets.

  • New-EmcParallelBookmark: Creates a bookmark for more than one consistency group.

  • New-EmcReplicaCopy: Creates a new replica copy for a consistency group.

  • New-EmcReplicaLink: Creates a new replica link between two replica copies.

  • New-EmcReplicaSet: Creates a new replica set for a consistency group.

  • Remove-EmcConsistencyGroup: Deletes a consistency group and removes all associated resources for that consistency group.

  • Remove-EmcReplicaCopy: Deletes a replica copy from a consistency group and removes and masks LUNs for that replica copy.

  • Remove-EmcReplicaSet: Deletes a replica set from a consistency group and removes and masks LUNs for that replica set.

  • Set-EmcRecoverProductionCopy: Recovers a production copy by using the specified replica copy.


Provisioning a new storage volume

The following script is an example of how to:

  • Create a new 100 GB thin LUN on a VNX storage pool.

  • Present the LUN to a Windows 2008 R2 host and initialize the disk.

  • Create an NTFS volume and mount it on an available drive letter. The following example requires that the storage system and host are connected and available.

Example script

PS C:\Users\administrator.BROOKSDOM> import-module esipstoolkit

PS C:\Users\administrator.BROOKSDOM> $pool = Get-EmcStoragePool "VM Pool"

Block storage system: [Name = APM00111102550. UserFriendlyName = VNX5100]. Lun Pools are not initialized. Refreshing Lun

Pools.

PS C:\Users\administrator.BROOKSDOM> $system = Get-EmcHostSystem NEC-BLADE6

PS C:\Users\administrator.BROOKSDOM> $lun = New-EmcLun -Pool $pool -CapacityInMB 102400 -Thin

TaskStatus: Started

10% : Creating the LUN...

100% : The specified LUN has been created...

TaskStatus: Completed

PS C:\Users\administrator.BROOKSDOM> Set-EmcLunAccess -Lun $lun -HostSystem $system -Available

TaskStatus: Started

10% : Unmasking the LUN to the specified host(s)...

100% : The specified LUN has been unmasked to the specified initiators...

TaskStatus: Completed

PS C:\Users\administrator.BROOKSDOM> $hdisk=Get-EmcHostDisk -

Host: NEC-BLADE6. Refreshing MultiPath software information.

Host: NEC-BLADE6. Retrieving disk information from Virtual Disk Service.

WARNING: Unable to find host disk(s) with the given parameters

PS C:\Users\administrator.BROOKSDOM> $hdisk=Get-EmcHostDisk -HostSystem $system -Lun $lun

PS C:\Users\administrator.BROOKSDOM> Initialize-EmcHostDisk -HostSystem $system -HostDisk $hdisk -PartitionStyle GPT

TaskStatus: Started

10% : Initializing the disk...

100% : The specified disk has been initialized...

TaskStatus: Completed

PS C:\Users\administrator.BROOKSDOM> $vol =New-EmcVolume -HostSystem $system -HostDisk $hdisk -FileSystemType NTFS -Labe

l TestVolume

TaskStatus: Started

10% : Provisioning the volume...

100% : The specified volume has been provisioned...

TaskStatus: Completed

PS C:\Users\administrator.BROOKSDOM> Get-EmcAvailableDriveLetter -HostSystem $system

A, B, D, E, F, … (up to Z, except for default C)

PS C:\Users\administrator.BROOKSDOM> Set-EmcVolumeMountPoint -HostSystem $system -Volume $vol -DriveLetter Z

TaskStatus: Started

10% : Mounting the volume...

100% : The specified volume has been mounted...

TaskStatus: Completed

PS C:\Users\administrator.BROOKSDOM>


Removing a storage volume

The following script is an example of how to:

  • Remove a volume from a host,

  • Delete the LUN where it resides, and

  • Because the LUN identity may be unknown, map the Windows volume to the storage LUN.

Example script

PS C:\Users\administrator.BROOKSDOM> import-module esipstoolkit

PS C:\Users\administrator.BROOKSDOM> $system = Get-EmcHostSystem NEC-BLADE6

PS C:\Users\administrator.BROOKSDOM> $vol = Get-EmcHostVolume -HostSystem $system -ID TestVolume

Host: NEC-BLADE6. Refreshing MultiPath software information.

Host: NEC-BLADE6. Retrieving disk information from Virtual Disk Service.

PS C:\Users\administrator.BROOKSDOM> $hdisk = Get-EmcHostDisk -Volume $vol

PS C:\Users\administrator.BROOKSDOM> $lun = Get-EmcLUN -HostDisk $hdisk

Associating the specified host disk with its corresponding storage system...

PS C:\Users\administrator.BROOKSDOM> Remove-EmcVolumeMountPoint -HostSystem $system -Volume $vol

TaskStatus: Started

10% : Unmounting the volume...

100% : The specified volume has been unmounted...

TaskStatus: Completed

PS C:\Users\administrator.BROOKSDOM> Set-EmcHostDiskOnlineState -HostDisk $hdisk -Offline

TaskStatus: Started

10% : Bringing the disk offline...

100% : The specified disk has been brought offline...

TaskStatus: Completed

PS C:\Users\administrator.BROOKSDOM> Set-EmcLunAccess -HostSystem $system -Lun $lun -Unavailable

TaskStatus: Started

10% : Masking the LUN from the initiators...

100% : The specified LUN has been masked from the specified initiators...

TaskStatus: Completed

PS C:\Users\administrator.BROOKSDOM> Update-EmcSystem -HostSystem $system

Refreshing disks of host system '[Name: NEC-BLADE6, IP address: 172.20.1.106.]'

Host: NEC-BLADE6. Refreshing MultiPath software information.

Host: NEC-BLADE6. Retrieving disk information from Virtual Disk Service.

PS C:\Users\administrator.BROOKSDOM> Remove-EmcLun -Lun $lun

Confirm

Are you sure you want to perform this action?

Performing operation "Remove-EmcLun" on Target "LUN 44".

[Y] Yes [A] Yes to All [N] No [L] No to All [S] Suspend [?] Help (default is "Y"): y

TaskStatus: Started

10% : Destroying the LUN...

100% : The specified LUN has been destroyed...PS C:\Users\administrator.BROOKSDOM>

TaskStatus: Completed


Connect-EmcSystem

Connects or adds the host, cluster, and storage systems to ESI.

Syntax

  • Connect-EmcSystem [-CreationBlob] <String> [-Refresh] [-Silent] [<CommonParameters>]

  • Connect-EmcSystem [-Refresh] [-Silent] -CreationParameters <Hashtable> -SystemType <String> [<CommonParameters>]

Description

The Connect-EmcSystem cmdlet is used to connect the host, cluster, and storage systems to ESI from the specified creation BLOB. You can use this cmdlet along with the Get-EmcHostSystemCredential, Get-EmcClusterSystemCredential, and Get-EmcStorageSystemCredential cmdlets to get the creation BLOB.

Parameters

-CreationBlob <String>

Attributes: Required, Position: 1

Specifies the creation BLOB, which is an encrypted connection or creation parameter BLOB. You can get the BLOB by using the Get-EmcHostSystemCredential, Get-EmcClusterSystemCredential, and Get-EmcStorageSystemCredential cmdlets.

-Refresh <SwitchParameter>

Attributes: Optional, Position: named

Specifies whether to refresh the system after connecting to it.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-CreationParameters <Hashtable>

Attributes: Required, Position: named

Specifies the key value pair of the creation parameters for the system to be connected.

-SystemType <String>

Attributes: Required, Position: named

Specifies the storage system type. Valid values are VMAX, VNX-Block, VNXe.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$h = Connect-EmcSystem -CreationBlob $hBlob

This example uses the Get-EmcHostSystemCredential cmdlet to get the creation BLOB, which is used to connect or add a host system to ESI.

-------------- Example 2 --------------

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>$c = Connect-EmcSystem -CreationBlob $cBlob

This example uses the Get-EmcClusterSystemCredential cmdlet to get the creation BLOB, which is used to connect or add a cluster system to ESI.

-------------- Example 3 --------------

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>$s = Connect-EmcSystem -CreationBlob $sBlob

This example uses the Get-EmcStorageSystemCredential cmdlet to get the creation BLOB, which is used to connect or add a storage system to ESI.

-------------- Example 4 --------------

C:\PS>$p = @{"Username"="admin";"Password"="xxx";"SpaIpAddress"="x.x.x.x";"SpbIpAddress"="x.x.x.x"; "UserFriendlyName"="VNX-x"};

C:\PS> connect-emcsystem -SystemType "vnx-block" -CreationParameters $p

This example connects a VNX-Block storage system with specified parameters to ESI.

-------------- Example 5 --------------

C:\PS>$p = @{"SerialNumber"="xxx";"Host"="x.x.x.x"};

connect-emcsystem -SystemType "vmax" -CreationParameters $p

This example connects a VMAX storage system with specified parameters to ESI.

-------------- Example 6 --------------

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem -Refresh

This example disables server certificate validation when using SSL to communicate with the specified ESI service.


Disable-EmcPublisherCertificateValidation

Disables server SSL certificate validation when using SSL to communicate with the specified ESI service.

Syntax

Disable-EmcPublisherCertificateValidation -ServiceName <String> [-Silent] [<CommonParameters>]

Description

The publish commands use a secure channel (SSL) when connecting to the specified ESI service by specifying an HTTPS URL in the Set-EmcPublisherEndpointUrl cmdlet or via the -ServiceURL parameter. This command disables the validation of the server certificate while establishing the SSL connection. This is necessary if the specified ESI service is configured to use a self-signed certificate.

Parameters

-ServiceName <String>

Attributes: Required, Position: named

Specifies which service to use to publish the systems. The value can be esiservice (for ESI Service).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Disable-EmcPublisherCertificateValidation -ServiceName esiservice

In this example, the server SSL certificate validation has been disabled.


Enable-EmcPublisherCertificateValidation

Enables server SSL certificate validation when using SSL to communicate with the specified ESI service.

Syntax

Enable-EmcPublisherCertificateValidation -ServiceName <String> [-Silent] [<CommonParameters>]

Description

The publish commands use a secured channel (SSL) when connecting to the specified ESI service by specifying an HTTPS URL in the Set-EmcPublisherEndpointUrl cmdlet or via the -ServiceURL parameter. This command disables the validation of the server certificate while establishing the SSL connection. This is necessary if the specified ESI service is configured to use a self-signed certificate.

Parameters

-ServiceName <String>

Attributes: Required, Position: named

Specifies which service to use to publish the systems. The value can be esiservice (for ESI Service).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Enable-EmcPublisherCertificateValidation -ServiceName esiservice

In this example, the server SSL certificate validation has been enabled.


Disconnect-EmcClusterSystem

Disconnects cluster systems.

Syntax

  • Disconnect-EmcClusterSystem [[-Id] <String>] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Disconnect-EmcClusterSystem [-Force] [-Silent] [-WhatIf] [-Confirm] [-System <IClusterSystem>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the cluster name, IP address, or global ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

-System <IClusterSystem>

Attributes: Optional, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcClusterSystem

This example disconnects connected cluster systems with user confirmation.

---------- Example 2 ----------

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcClusterSystem -System $c -Confirm

This example disconnects a specified cluster system.

---------- Example 3 ----------

C:\PS>Disconnect-EmcClusterSystem -Id mycluster*

C:\PS>Disconnect-EmcClusterSystem -Id 10.x.y.*

C:\PS>Disconnect-EmcClusterSystem 2cc75087-8ddf*

This example disconnects a cluster system based on the specified cluster name or IP address or global ID (accepts wild card). Because the ID parameter is positional, you can omit the name.

---------- Example 4 ----------

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcClusterSystem -System $c -Force

This example disconnects a selected cluster system without asking for user confirmation.

---------- Example 5 ----------

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcClusterSystem -System $c

This example disconnects a specified cluster system.


Disconnect-EmcHostSystem

Disconnects host systems.

Syntax

  • Disconnect-EmcHostSystem [[-Id] <String>] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Disconnect-EmcHostSystem [-Force] [-Silent] [-WhatIf] [-Confirm] [-System <IHostSystem>] [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the host name, IP address, or global ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

-System <IHostSystem>

Attributes: Optional, Position: named

Specifies the ESI host system object, which can be added by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can obtain a host system object by using the Get-EmcHostSystem cmdlet. It can be a stand-alone host system or virtual machine or hypervisor.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcHostSystem

C:\PS>Get-EmcHostSystem | Disconnect-EmcHostSystem

This example disconnects connected host systems with user confirmation.

---------- Example 2 ----------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcHostSystem -System $h -Confirm

C:\PS>Disconnect-EmcHostSystem -System $h

C:\PS>Disconnect-EmcHostSystem -System $h -Force

C:\PS>$h | Disconnect-EmcHostSystem

This example disconnects a specified host system.

---------- Example 3 ----------

C:\PS>Disconnect-EmcHostSystem -Id myhost*

C:\PS>Disconnect-EmcHostSystem -Id 10.x.y.*

C:\PS>Disconnect-EmcHostSystem 2cc75087-8ddf*

This example disconnects a host system based on the specified host name or IP address or global ID (accepts wild card). Because the ID parameter is positional, you can omit the name.


Disconnect-EmcStorageSystem

Disconnects clusters, hosts, and storage systems.

Syntax

  • Disconnect-EmcStorageSystem [[-Id] <String>] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Disconnect-EmcStorageSystem [-Force] [-Silent] [-WhatIf] [-Confirm] [-System <IStorageSystem>] [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the storage system name, user-friendly name, or global ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Force <SwitchParameter>

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

-System <IStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI storage system object. You can add a storage system object to ESI by using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object by using the Get-EmcStorageSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcStorageSystem

C:\PS>get-emcstoragesystem | Disconnect-EmcStorageSystem

This example disconnects the connected storage systems.

---------- Example 2 ----------

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcStorageSystem -System $s -Confirm

C:\PS>Disconnect-EmcStorageSystem -System $s

C:\PS>Disconnect-EmcStorageSystem -System $s -Force

C:\PS>$s | Disconnect-EmcStorageSystem

C:\PS>$s | Disconnect-EmcStorageSystem -Force

This example disconnects the specified storage system.

---------- Example 3 ----------

C:\PS>Disconnect-EmcStorageSystem  *

C:\PS>Disconnect-EmcStorageSystem  * -Force

C:\PS>Disconnect-EmcStorageSystem  id *

C:\PS>Disconnect-EmcStorageSystem -id mystorage*

C:\PS>Disconnect-EmcStorageSystem -id d456* -Confirm

This example disconnects the storage systems as specified by the storage system name, user-friendly name, or global ID (accepts wild cards) with user confirmation. Because the ID parameter is positional, you can omit the name.


Disconnect-EmcSystem

Disconnects clusters, hosts, and storage systems.

Syntax

  • Disconnect-EmcSystem [[-Id] <String>] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Disconnect-EmcSystem [-Force] [-Silent] [-WhatIf] [-Confirm] [-System <SystemObjectBase>] [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the system user-friendly name or global ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

-System <SystemObjectBase>

Attributes: Optional, Position: named

Specifies the cluster, host, or storage system.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>Disconnect-EmcSystem

This example disconnects the connected host, cluster, and storage systems.

---------- Example 2 ----------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>$h | Disconnect-EmcSystem

C:\PS>$c | Disconnect-EmcSystem

C:\PS>$s | Disconnect-EmcSystem

This example disconnects the specified host, cluster, or storage systems.

---------- Example 3 ----------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>$h | Disconnect-EmcSystem -Confirm

C:\PS>$c | Disconnect-EmcSystem -Confirm

C:\PS>$s | Disconnect-EmcSystem -Confirm

This example disconnects the specified host, cluster, and storage systems with user confirmation.

---------- Example 4 ----------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>$h | Disconnect-EmcSystem -Force

C:\PS>$c | Disconnect-EmcSystem -Force

C:\PS>$s | Disconnect-EmcSystem -Force

This example disconnects the specified host, cluster, and storage systems without user confirmation.

---------- Example 5 ----------

C:\PS>Disconnect-EmcSystem *

C:\PS>Disconnect-EmcSystem id *

C:\PS>Disconnect-EmcSystem -id mystorage*

C:\PS>Disconnect-EmcSystem -id myhost*

C:\PS>Disconnect-EmcSystem -id mycluster*

C:\PS>Disconnect-EmcSystem -id d456*

This example disconnects the storage systems as specified by the system user-friendly name or global ID (accepts wild card). Because the ID parameter is positional, you can omit the name.


Get-EmcClusterSystemCredential

Gets the encrypted connection string or BLOB, based on the specified parameters. You can use this cmdlet with the Connect-EmcSystem cmdlet to connect cluster systems to ESI.

Syntax

Get-EmcClusterSystemCredential [-Silent] [<CommonParameters>]

Description

The Get-EmcClusterSystemCredential cmdlet creates a BLOB or encrypted string based on the specified parameters. The cmdlet prompts you to specify the cluster name, IP address, and credentials. The cmdlet then creates a BLOB with these credentials. You can use the BLOB to connect cluster systems to ESI by using the Connect-EmcSystem cmdlet. You can also click Test Connection in ESI to test the connection with the specified parameters. Current Credential is selected by default for authentication. If you are using another credential, click Specify Credential and type the username and password.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>$c = Connect-EmcSystem -CreationBlob $cBlob

This example uses the Get-EmcClusterSystemCredential cmdlet to return the BLOB, which is used to connect or add the cluster system to ESI.


Get-EmcLinuxHostSystemCredential

Gets the encrypted connection string or BLOB, based on the specified connection (system object creation) parameters for a Linux system. You can use the BLOB with the Connect-EmcSystem cmdlet to connect or add Linux host systems to ESI. You can use the BLOB with the Connect-EmcSystem cmdlet to connect or add Linux host systems to ESI.

Syntax

Get-EmcLinuxHostSystemCredential [-Silent] [<CommonParameters>]

Description

Creates a BLOB (encrypted string) from the specified connection (system object creation) parameters. It prompts the user for host name, IP address, and connection. Use the BLOB to connect or add a Linux host system to ESI with the Connect-EmcSystem cmdlet. Password authentication is a default selection. If you are using key-based authentication, then use the key-based username, file path, and pass phrase.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$lhBlob = Get-EmcLinuxHostSystemCredential

C:\PS>$lh = $lhBlob | Connect-EmcSystem

C:\PS>$lh = Connect-EmcSystem -CreationBlob $lhBlob

Returns the creation BLOB to then connect or add a Linux host system to ESI.


Get-EmcPublisherConnectionInfo

Gets the list of systems currently registered with the specified ESI service.

Syntax

Get-EmcPublisherConnectionInfo [-ServiceUrl <String>] -ServiceName <String> [-Silent] [<CommonParameters>]

Parameters

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-ServiceName <String>

Attributes: Required, Position: named

Specifies which service for which to publish the systems. The value can be esiservice (for ESI Service).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Get-EmcPublisherConnectionInfo -ServiceName esiservice

FriendlyName : My VMAX

SystemType : VMAX

EntityId : f66a10a9c404f98432310499e21218891741dd69

LastSyncTimeUTC : 1/30/2015 9:30:13 PM

ElapsedMilliSeconds : 126062

NumEntities : 758

Properties : {SerialNumber=000194900376, Host=10.5.222.240, Port=5988, UseSSL=False...}

FriendlyName : My VNX

SystemType : VNX-Block

EntityId : ad43421b21f152714874aad685677c7ef9b3e470

LastSyncTimeUTC : 1/30/2015 9:28:43 PM

ElapsedMilliSeconds : 35637

NumEntities : 164

Properties : {Username=nasadmin, Password=*****, ControlStationIPAddress=10.5.223.240, ControlStationPort=443...}

This example lists all the storage systems that are registered or published to the ESI Service.


Get-EmcPublisherEndpointOptions

Gets the current options used to connect to the specified ESI service.

Syntax

Get-EmcPublisherEndpointOptions -ServiceName <String> [-Silent] [<CommonParameters>]

Parameters

-ServiceName <String>

Attributes: Required, Position: named

Specifies which service to use to publish the systems. The value can be esiservice (for ESI Service).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. It still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Get-EmcPublisherEndpointOptions -ServiceName esiservice

ServiceURL ValidateServerCertificate

---------- -------------------------

https://localhost:54501 False

This example gets the web connection options for the ESI Service.


Get-EmcPublisherSupportedSystem

Gets all the system types that are available for registration with the specified ESI service.

Syntax

Get-EmcPublisherSupportedSystem [-ServiceUrl <String>] -ServiceName <String> [-Silent] [<CommonParameters>]

Parameters

ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the service instance on which to issue the request. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-ServiceName <String>

Attributes: Required, Position: named

Specifies the service to use to publish the systems. The values can be esiservice (for ESI Service).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Get-EmcPublisherSupportedSystem -ServiceName esiservice

VMAX

VNX-Block

This example gets the list of registered systems supported by the ESI service.


Get-EmcHostSystemCredential

Gets the encrypted connection or system object creation parameters BLOB, which you can use along with the Connect-EmcSystem cmdlet to connect host systems to ESI.

Syntax

Get-EmcHostSystemCredential [-Silent] [<CommonParameters>]

Description

Creates a BLOB or encrypted string from the specified connection or system object creation parameters. It prompts you for the host name, IP address, and credentials. The cmdlet then creates a BLOB with these specified parameters. You can use the BLOB to connect or add host systems to ESI by using the Connect-EmcSystem cmdlet. You can click Test Connection in ESI to test the connection with the specified parameters. Current Credential is selected by default for authentication. If you are using another credential, then click Specify Credential and type the username and password.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$h = Connect-EmcSystem -CreationBlob $hBlob

In this example, the Get-EmcHostSystemCredential cmdlet returns the creation BLOB, which is used to connect or add the host system to ESI.


Get-EmcStorageIntegratorVersion

Gets the specific software version of ESI that is installed.

Syntax

Get-EmcStorageIntegratorVersion [-Silent] [<CommonParameters>]

Description

Gets EMC Storage Integrator version details including: product name, product version, and company name.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcStorageIntegratorVersion

Product Name : EMC Storage Integrator(x64)

Product Version : 3.5.315

Product Company : EMC

This example displays the specific software version of ESI that is installed.


Get-EmcStorageSystemCredential

Gets the encrypted connection or system object creation parameters BLOB, which is used along with the Connect-EmcSystem cmdlet to connect storage systems to ESI.

Syntax

Get-EmcStorageSystemCredential [-Silent] [<CommonParameters>]

Description

Prompts the user for the storage system connection or creation parameters, which include the storage system type, user-friendly name, and credentials required for connection. You can click Test Connection in the dialog to test the connection with the specified parameters. The cmdlet uses these specified parameters to create the BLOB. You can use the BLOB to add storage systems to ESI by using the Connect-EmcSystem cmdlet.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$sBlob = Get-EmcStorageSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>$s = Connect-EmcSystem -CreationBlob $sBlob

This example uses the cmdlet to return the creation BLOB, which is used to add the storage system to ESI.


Get-EmcSupportedSystemsCreationRequirement

Gets the list of creational parameters required to add or connect to a system in ESI.

Syntax

Get-EmcSupportedSystemsCreationRequirement -SystemType <String> [-Silent] [<CommonParameters>]

Parameters

-SystemType <String>

Attributes: Required, Position: named

Specifies the storage system type. Valid values are VMAX, VNX-Block, VNXe.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$s = Get-EmcSupportedSystem

PS C:\> $p = Get-EmcSupportedSystemsCreationRequirement -SystemType $s[2]

PS C:\> $p.Values

Name : Username

Type : System.String

DefaultValue :

CandidateValues : {}

DisplayText : Username

Description : Username to be used to manage the VMware Server

IsOptional : False

IsSensitiveData : False

Name : Password

Type : System.String

DefaultValue :

CandidateValues : {}

DisplayText : Password

Description : Password to be used together with username to manage the VMware Server

IsOptional : False

IsSensitiveData : True

Name : ConnectionName

Type : System.String

DefaultValue :

CandidateValues : {}

DisplayText : VMware vSphere Host IP address or name

Description : VMware vSphere Host IP address or name to manage ESX or vCenter Server

IsOptional : False

IsSensitiveData : False

Gets the required parameters to add a system to ESI.


Publish-EmcPublisherConnectionInfo

Publishes the connection information of the specified system to the specified ESI service.

Syntax

  • Publish-EmcPublisherConnectionInfo [-ServiceUrl <String>] -UserFriendlyName <String> -ServiceName <String> [-Silent] [<CommonParameters>]

  • Publish-EmcPublisherConnectionInfo [-ServiceUrl <String>] -ServiceName <String> [-Silent] -StorageSystem <IStorageSystem> [<CommonParameters>]

  • Publish-EmcPublisherConnectionInfo [-ServiceUrl <String>] -ServiceName <String> [-Silent] -ReplicationService <IReplicationService> [<CommonParameters>]

Parameters

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-UserFriendlyName <String>

Attributes: Required, Position: named

Specifies the user-friendly name for the system registered with ESI whose connection information will be published to the service.

-ServiceName <String>

Attributes: Required, Position: named

Specifies which service to use to publish the systems. The value can be esiservice (for ESI Service).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-StorageSystem <IStorageSystem>

Attributes: Required, Position: named

Specifies the storage system object you want to publish. A storage system object can be obtained by using the Get-EmcStorageSystem cmdlet.

-ReplicationService <IReplicationService>

Attributes: Required, Position: named

Specifies the replication service object you want to publish. A replication service object can be obtained by using the Get-EmcReplicationService cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Publish-EmcPublisherConnectionInfo -ServiceName esiservice -UserFriendlyName MyVMAX

This example publishes the connection information of the MyVMAX system to the ESI Service.

---------- Example 2 ----------

C:\PS>Get-EmcStorageSystem | Publish-EmcPublisherConnectionInfo -ServiceName esiservice

This example publishes the connection information of all of the storage systems to the ESI Service.


Publish-EmcPublisherUserConnectionInfo

Publishes the connection information for the specified system to the specified user.

Syntax

  • Publish-EmcPublisherUserConnectionInfo [-DomainName <String>] -UserName <String> -UserPassword <String> -SystemFriendlyName <String> [-Silent] [<CommonParameters>]

  • Publish-EmcPublisherUserConnectionInfo [-DomainName <String>] -UserName <String> -UserPassword <String> [-Silent] -StorageSystem <IStorageSystem> [<CommonParameters>]

  • Publish-EmcPublisherUserConnectionInfo [-DomainName <String>] -UserName <String> -UserPassword <String> [-Silent] -ReplicationService <IReplicationService> [<CommonParameters>]

  • Publish-EmcPublisherUserConnectionInfo -SystemFriendlyName <String> [-Silent] -Credential <PSCredential> [<CommonParameters>]

  • Publish-EmcPublisherUserConnectionInfo [-Silent] -StorageSystem <IStorageSystem> -Credential <PSCredential> [<CommonParameters>]

  • Publish-EmcPublisherUserConnectionInfo [-Silent] -ReplicationService <IReplicationService> -Credential <PSCredential> [<CommonParameters>]

Description

This cmdlet passes the connection information for the specified system and registers it in the context of the specified user. When the specified user logs into the ESI controller host, the system is available without having to enter the connection information.

Parameters

-DomainName <String>

Attributes: Optional, Position: named

Specifies the domain that the user belongs to.

-UserName <String>

Attributes: Required, Position: named

Specifies the username for the user to get the published systems.

-UserPassword <String>

Attributes: Required, Position: named

Specifies the login password for the user.

-SystemFriendlyName <String>

Attributes: Required, Position: named

Specifies the user-friendly name for the system registered with ESI whose connection information needs to be published to the user.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-StorageSystem <IStorageSystem>

Attributes: Required, Position: named

Specifies the storage system object you want to publish. A storage system object can be obtained by using the Get-EmcStorageSystem cmdlet.

-ReplicationService <IReplicationService>

Attributes: Required, Position: named

Specifies the replication service object you want to publish. A replication service object can be obtained by using the Get-EmcReplicationService cmdlet.

-Credential <PSCredential>

Attributes: Required, Position: named

Specifies the credential object used for impersonating a user. A credential object can be created by using the Get-Credential cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Publish-EmcPublisherUserConnectionInfo -DomainName contoso -UserName fabrikam -UserPassword Password! -SystemFriendlyName MyVMAX

This example publishes the connection information of the system with a user friendly name of "MyVMAX" to the user contoso\fabrikam.

---------- Example 2 ----------

C:\PS>Get-EmcStorageSystem | Publish-EmcPublisherUserConnectionInfo -DomainName contoso -UserName fabrikam -UserPassword Password!

AdapterType : StorageSystem

UserFriendlyName : vnx_200

OperationalStatus : {}

StatusMessages : {}

SerialNumber : APM00123102886

Name : APM00123102886

Model : VNX5100

SoftwareRevision : 05.31.000.5.720

ServiceNodes : {}

Enclosures : {}

Disks : {}

ManagementServiceEndpointList : {[IpAddress: 10.5.223.200, Port: 443.], [IpAddress: 10.5.223.201, Port: 443.]}

LunPools : {}

Luns : {}

BlockStorageCache :

LunMaskingViews : {}

SupportedHostBusAdapterTypes : {Iscsi, FibreChannel}

RegisteredRemoteHosts : {}

LoggedInInitiators : {}

SnapshotLuns : {}

SnapshotPools : {}

EntityClassMapping : {[LunStorageServiceNode, Storage Processor], [PowerSupply, Power Supply], [StandbyPow

erSupply, SPS], [CPUModule, CPU Module]...}

OtherProperties : {}

DefaultStringForOtherProperties : ()

GlobalId : 0815b526-6a6e-4f32-8389-8c5f5c3d3217

SystemObjectType : VNX-Block

TestMode : False

OperationalStatus : {OK, Online}

AdapterType : StorageSystem

UserFriendlyName : vmax_37

SerialNumber : 000195700895

Name : Symmetrix VMAX40K

Model : VMAX40K

SoftwareRevision : 5876.191.124

Enclosures : {}

ManagementServiceEndpointList : {}

ServiceNodes : {}

Disks : {}

DiskServiceNodes : {}

LunPools : {}

Luns : {}

ThinLuns : {}

UnclassifiedLunPool : [Name: UnclassifiedLunPool. PoolId: {37AD6876-B757-4C92-A6B8-482FCA65E21C}]

UnclassifiedLuns : {}

BlockStorageCache :

LoggedInInitiators : {}

LunMaskingViews : {}

SupportedHostBusAdapterTypes : {FibreChannel}

SnapshotLuns : {}

SnapshotPools : {}

StatusMessages : {}

EntityClassMapping : {[LunStorageServiceNode, Director], [ServiceNodeContainer, Director Slot], [PowerSupp

ly, Power Supply], [StandbyPowerSupply, SPS]...}

OtherProperties : {}

DefaultStringForOtherProperties : ()

GlobalId : db754b56-5166-4732-bd8b-6ef2ee2c7ca3

SystemObjectType : VMAX

TestMode : False

OperationalStatus : {OK, Degraded, Online}

This example publishes the connection information of all of the storage systems to the user contoso\fabrikam.


Set-EmcPublisherEndpointUrl

Sets the URL to the specified ESI service on the current session.

Syntax

  • Set-EmcPublisherEndpointUrl [-ServiceUrl] <String> -ServiceName <String> [-Silent] [<CommonParameters>]

  • Set-EmcPublisherEndpointUrl -ServiceName <String> [-Silent] -IpAddress <String> -Port <String> [-SSL] [<CommonParameters>]

  • Set-EmcPublisherEndpointUrl -ServiceName <String> [-Silent] -Clear [<CommonParameters>]

Description

By default the commands in the PowerShell Toolkit connect to an instance of the specified ESI service running on localhost. This command allows a URL to another ESI service instance to be specified.

Parameters

-ServiceUrl <String>

Attributes: Required, Position: 1

Specifies the service URL.

-ServiceName <String>

Attributes: Required, Position: named

Specifies which service to use to publish the systems. The value can be esiservice (for ESI Service).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-IpAddress <String>

Attributes: Required, Position: named

Specifies the IP address of the service URL.

-Port <String>

Attributes: Required, Position: named

Specifies the port of the service URL.

-SSL <SwitchParameter>

Attributes: Optional, Position: named

Specifies whether the service URL uses the SSL protocol.

-Clear <SwitchParameter>

Attributes: Required, Position: named

Clears the service URL for this session, which causes ESI to use the default of localhost or the ServiceURL parameter to be used if the parameter is not specified on a command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Set-EmcPublisherServiceUrl http://10.0.0.50:54500 -ServiceName esiservice

ESI Service URL successfully set to value: http://10.0.0.50:54500

This example sets the connection URL for the ESI Service.

---------- Example 2 ----------

C:\PS>Set-EmcPublisherEndpointUrl -ServiceName esiservice -IpAddress 10.0.0.50 -Port 54500 -SSL

ESI Service URL successfully set to value: https://10.0.0.50:54500

This example sets the connection URL for the ESI Service.

---------- Example 3 ----------

C:\PS>Set-EmcPublisherEndpointUrl -ServiceName esiservice -Clear

ESI Service URL on session cleared, will use default: https://localhost:54501

This example clears the current URL connection for the ESI Service and sets the connection to the default URL.


Test-EmcSystemConnectedToBlockStorageSystem

Verifies the connectivity of a host system or replication system to a block storage system. This cmdlet only works with VNX and VMAX block storage systems. The cmdlet does not work with VNXe storage systems.

Syntax

  • Test-EmcSystemConnectedToBlockStorageSystem [-BlockStorageSystem] <IBlockStorageSystem> -HostSystem <IHostSystem> [-Silent] [<CommonParameters>]

  • Test-EmcSystemConnectedToBlockStorageSystem [-BlockStorageSystem] <IBlockStorageSystem> [-Silent] -ReplicationSystem <ReplicationSystem> [-Refresh] [<CommonParameters>]

Parameters

-BlockStorageSystem <IBlockStorageSystem>

Attributes: Required, Position: 1

Specifies the ESI block storage system object, which you can add to ESI by using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object by using the Get-EmcStorageSystem cmdlet.

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ReplicationSystem <ReplicationSystem>

Attributes: Required, Position: named

Specifies the ESI replication system object, which you can get by using the Get-EmcReplicationSystem cmdlet.

-Refresh <SwitchParameter>

Attributes: Optional, Position: named

Specifies whether to refresh the system after connecting to it.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>PS C:\> $s | select serialnumber, model

SerialNumber Model

------------ -----

APM00130706440 VNX5300

PS C:\> $h | select HostSystemType, BuildNumber, OsString

HostSystemType BuildNumber OsString

-------------- ----------- --------

HyperV_VirtualMachine 7601 Microsoft Windows Server 2008 R2 Enterprise Service Pack 1 64-bit

PS C:\> Test-EmcSystemConnectedToBlockStorageSystem -HostSystem $h -BlockStorageSystem $s -Silent

True

This example verifies the connectivity of a host system to a VNX block storage system.

---------- Example 2 ----------

C:\PS>PS C:\> $rpas = Get-EmcReplicationSystem

PS C:\> $rpa = $rpas[0]

PS C:\> $s | select serialnumber, model

SerialNumber Model

------------ -----

APM00130706440 VNX5300

PS C:\> Test-EmcSystemConnectedToBlockStorageSystem -ReplicationSystem $rpa -BlockStorageSystem $s -Silent

True

This example verifies the connectivity of a replication system to a VNX block storage system.

---------- Example 3 ----------

C:\PS>PS C:\> Test-EmcSystemConnectedToBlockStorageSystem -HostSystem $h -BlockStorageSystem $s -Silent

True

PS C:\> $s | select serialnumber, model

SerialNumber Model

------------ -----

000192605412 VMAX20K

PS C:\> $h | select HostSystemType, BuildNumber, OsString

HostSystemType BuildNumber OsString

-------------- ----------- --------

HyperV 7601 Microsoft Windows Server 2008 R2 Enterprise Service Pack 1 64-bit

PS C:\> Test-EmcSystemConnectedToBlockStorageSystem -HostSystem $h -BlockStorageSystem $s -Silent

True

This example verifies the connectivity of a host system to a VMAX block storage system.


Unpublish-EmcPublisherConnectionInfo

Unpublishes the connection information for the specified system to the specified ESI Service.

Syntax

  • Unpublish-EmcPublisherConnectionInfo [-ServiceUrl <String>] -UserFriendlyName <String> [-Force] -ServiceName <String> [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Unpublish-EmcPublisherConnectionInfo [-ServiceUrl <String>] [-Force] -ServiceName <String> [-Silent] [-WhatIf] [-Confirm] -System <RegisteredSystem> [<CommonParameters>]

Description

Unregisters the specified system from the specified ESI service.

Parameters

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI service on which to issue the request. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-UserFriendlyName <String>

Attributes: Required, Position: named

Specifies the user-friendly name for the system registered with the service whose connection information needs to be removed.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-ServiceName <String>

Attributes: Required, Position: named

Specifies the service to use to publish the systems. The value can be esiservice (for ESI Service).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

-System <RegisteredSystem>

Attributes: Required, Position: named

Specifies the system object that you want to unpublish or remove from the published systems list.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

---------- Example 1 ----------

C:\PS>Unpublish-EmcPublisherConnectionInfo -ServiceName esiservice -UserFriendlyName MyVNX

This example unregisters the MyVNX system from the ESI Service.

---------- Example 2 ----------

C:\PS>C:\PS> $s = Get-EmcPublisherConnectionInfo -ServiceName esiservice

C:\PS> Unpublish-EmcPublisherConnectionInfo -ServiceName esiservice -UserFriendlyName $s[0].UserFriendlyName

This example gets all of the registered systems with the ESI Service and unregisters the first system object.


Update-EmcSystem

Updates the specified host, storage, or cluster systems.

Syntax

  • Update-EmcSystem [-EmcSystem] <SystemServiceObjectBase> [-Silent] [<CommonParameters>]

  • Update-EmcSystem [-Silent] -ExchangeSystem <IExchangeApplicationSystem> [-QuickRefresh] [<CommonParameters>]

Description

The Update-EMCSystem cmdlet updates the specified host, cluster, or storage systems. For the host system, the cmdlet updates the host disks. For the cluster system, it updates the cluster disks. For the block storage system, it updates the LUNs.

Parameters

-EmcSystem <SystemServiceObjectBase>

Attributes: Required, Position: 1

Specifies the system to be updated, which can be a host, cluster or storage system. The required value can be obtained by using the Get-EmcHostSystem, Get-EmcClusterSystem, or Get-EmcStorageSystem cmdlets.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ExchangeSystem <IExchangeApplicationSystem>

Attributes: Required, Position: named

Specifies the Exchange system to be updated. This value can be obtained by using the Get-EmcExchangeSystem cmdlet.

-QuickRefresh <SwitchParameter>

Attributes: Optional, Position: named

Turns on quick refresh during the system update.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcHostSystem | Update-EmcSystem –Silent

This example updates the specified host system.

-------------- Example 2 --------------

C:\PS>Get-EmcClusterSystem | Update-EmcSystem –Silent

This example updates the specified cluster system.

-------------- Example 3 --------------

C:\PS>Get-EmcStorageSystem | Update-EmcSystem –Silent

This example updates the specified storage system.

-------------- Example 4 --------------

C:\PS>Get-EmcHostSystem -HostSystemtype vmwareesxhost | Update-EmcSystem -Silent

This example updates the specified VMware system.

-------------- Example 5 --------------

C:\PS>$exchange=Get-EmcExchangeSystem *exchange

C:\PS>Update-EmcSystem -ExchangeSystem $exchange –QuickRefresh

This example updates the Exchange system by using the QuickRefresh mode.


Get-EmcExchangeSystem

Gets the information about the Exchange system.

Syntax

  • Get-EmcExchangeSystem [[-ID] <String>] [-DatabaseAvailabilityGroup <DatabaseAvailabilityGroup>] [-Silent] [<CommonParameters>]

  • Get-EmcExchangeSystem [[-ID] <String>] [-Silent] [-MailboxServer <MailboxServer>] [<CommonParameters>]

  • Get-EmcExchangeSystem [[-ID] <String>] [-Silent] [-MailboxDatabase <MailboxDatabase>] [<CommonParameters>]

  • Get-EmcExchangeSystem [[-ID] <String>] [-Silent] [-MailboxDatabaseCopy <MailboxDatabaseCopy>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the mailbox database name or ID. Wildcards are permitted.

-DatabaseAvailabilityGroup <DatabaseAvailabilityGroup>

Attributes: Optional, Position: named

Specifies the mailbox DAG.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-MailboxServer <MailboxServer>

Attributes: Optional, Position: named

Specifies the mailbox server.

-MailboxDatabase <MailboxDatabase>

Attributes: Optional, Position: named

Specifies the mailbox database.

-MailboxDatabaseCopy <MailboxDatabaseCopy>

Attributes: Optional, Position: named

Specifies the mailbox database copy.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$mailserver = Get-EmcMailboxServer MS1

C:\PS>Get-EmcExchangeSystem -MailboxServer $mailserver

This example gets the exchange system for the MS1 mailbox server.

-------------- Example 2 --------------

C:\PS>$dag = Get-EmcDatabaseAvailabilityGroup TestDAG

C:\PS>Get-EmcExchangeSystem -DatabaseAvailabilityGroup $dag

This example gets the exchange system for the TestDAG DAG.

-------------- Example 3 --------------

C:\PS>$database = Get-EmcMailboxDatabase db1

C:\PS>Get-EmcExchangeSystem -MailboxDatabase $database

This example gets the exchange system for the db1 mailbox database.

-------------- Example 4 --------------

C:\PS>$databasecopy = Get-EmcMailboxDatabasecopy db1\MS2

C:\PS>Get-EmcExchangeSystem -ID exchange1 -MailboxDatabaseCopy $databasecopy

This example gets the exchange1 Exchange system for the db1 mailbox database copy on the MS2 mailbox server.


Get-EmcExchangeSystemCredential

Gets the encrypted connection string or BLOB. You can use this cmdlet with the Connect-EmcSystem cmdlet to connect or add host systems to ESI.

Syntax

Get-EmcExchangeSystemCredential [-Silent] [<CommonParameters>]

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$exBlob = Get-EmcExchangeSystemCredential

C:\PS>$s = $exBlob | Connect-EmcSystem

C:\PS>$s = Connect-EmcSystem -CreationBlob $exBlob

In this example, the Get-EmcExchangeSystemCredential cmdlet returns the creation BLOB, which is used to connect or add the Microsoft Exchange system or forest to ESI.


Get-EmcExchangeCmdletOutput

Gets results of some standard Microsoft PowerShell cmdlets for Exchange. This is not an ESI cmdlet.

Syntax

Get-EmcExchangeCmdletOutput -Cmdlet <String> [-ExchangeSystem <IExchangeApplicationSystem>] [-Silent] [<CommonParameters>]

Parameters

-Cmdlet <String>

Attributes: Required, Position: named

Specifies the name of a standard Exchange cmdlet.

-ExchangeSystem <IExchangeApplicationSystem>

Attributes: Optional, Position: named

Specifies the Exchange system object.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$exchange = Get-EmcExchangeSystem

C:\PS>$mailboxservers = $exchange | Get-EmcExchangeCmdletOutput -Cmdlet "Get-MailboxServer"

Gets the mailbox servers for the specified Exchange system.

-------------- Example 2 --------------

C:\PS>$exchange = Get-EmcExchangeSystem

C:\PS>$mailboxservers = Get-EmcExchangeCmdletOutput -ExchangeSystem $exchange[0] -Cmdlet "Get-MailboxServer"

Gets the mailbox servers for the specified Exchange system.


Get-EmcMailboxDatabase

Gets one or more mailbox database objects from a server, forest, or organization.

Syntax

  • Get-EmcMailboxDatabase [[-ID] <String>] [-ExchangeSystem <IExchangeApplicationSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcMailboxDatabase [[-ID] <String>] [-ExchangeSystem <IExchangeApplicationSystem>] [-Silent] [-HostDisk <Disk>] [<CommonParameters>]

  • Get-EmcMailboxDatabase [[-ID] <String>] [-ExchangeSystem <IExchangeApplicationSystem>] [-Silent] [-Lun <Lun>] [<CommonParameters>]

  • Get-EmcMailboxDatabase [[-ID] <String>] [-Silent] [-DatabaseAvailabilityGroup <DatabaseAvailabilityGroup>] [<CommonParameters>]

  • Get-EmcMailboxDatabase [[-ID] <String>] [-Silent] [-MailboxServer <MailboxServer>] [<CommonParameters>]

  • Get-EmcMailboxDatabase [[-ID] <String>] [-Silent] [-MailboxDatabaseCopy <MailboxDatabaseCopy>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the mailbox database name or ID. Wildcards are permitted.

-ExchangeSystem <IExchangeApplicationSystem>

Attributes: Optional, Position: named

Specifies the Exchange system object from which to retrieve mailbox database information.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-HostDisk <Disk>

Attributes: Optional, Position: named

Specifies the host disk associated with the mailbox database.

-Lun <Lun>

Attributes: Optional, Position: named

Specifies the ESI LUN object, which can be obtained by using the ESI Storage System object or by using the Get-EmcLun cmdlet. It specifies the LUN on which the mailbox database is created.

-DatabaseAvailabilityGroup <DatabaseAvailabilityGroup>

Attributes: Optional, Position: named

Specifies the DAG object from which to retrieve mailbox database information.

-MailboxServer <MailboxServer>

Attributes: Optional, Position: named

Specifies the name of the mailbox server from which to retrieve mailbox database information.

-MailboxDatabaseCopy <MailboxDatabaseCopy>

Attributes: Optional, Position: named

Specifies the mailbox database copy object to retrieve mailbox database information.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$ms = Get-EmcMailboxServer MS1

C:\PS>Get-EmcMailboxDatabase -Id MailboxDatabase01 -Server $ms

This example gets information about MailboxDatabase01 on the MS1 mailbox database server.

-------------- Example 2 --------------

C:\PS>$dag = Get-EmcDatabaseAvailabilityGroup TestDAG

C:\PS>Get-EmcMailboxDatabase -DatabaseAvailabilityGroup $dag

This example gets information about all mailbox databases in TestDAG.

-------------- Example 3 --------------

C:\PS>$exchange = Get-EmcExchangeSystem

C:\PS>Get-EmcMailboxDatabase -ExchangeSystem $exchange

This example gets information about all mailbox databases in the Exchange system.

-------------- Example 4 --------------

C:\PS>$databasecopy = Get-EmcMailboxDatabasecopy db1\MS2

C:\PS>Get-EmcMailboxDatabase -MailboxDatabaseCopy $databasecopy

This example gets information about all mailbox databases associated with the mailbox database copy.

-------------- Example 5 --------------

C:\PS>$lun = Get-EmcLun testlun

C:\PS>$ms = Get-EmcMailboxServer MS1

C:\PS>$h = Get-EmcHostSystem -MailboxServer $ms

C:\PS>Set-EmcLunAccess -Lun $lun -HostSystem $h -Available

C:\PS>$disk = Get-EmcHostDisk -Lun $lun -HostSystem $h

C:\PS>Initialize-EmcHostDisk -HostSystem $h -HostDisk $disk

C:\PS>$vol = New-EmcVolume -HostSystem $h -HostDisk $disk -Label “New Volume”

C:\PS>Set-EmcVolumeMountPoint -HostSystem $h -DriveLetter V -Volume $vol

C:\PS>New-EmcMailboxDatabase -Name MailboxDatabase01 -MailboxServer $ms -EdbFilePath “V:\DatabaseFiles\MailboxDatabase01.edb” -LogFolderPath “V:\LogFiles”

C:\PS>Get-EmcMailboxDatabase -Lun $lun

C:\PS>Get-EmcMailboxDatabase -HostDisk $disk

This example gets information about mailbox databases that reside on the LUN or host disk.


Get-EmcMailboxDatabaseCopy

Gets one or more mailbox database copy objects from a server or organization.

Syntax

  • Get-EmcMailboxDatabaseCopy [[-ID] <String>] [-ExchangeSystem <IExchangeApplicationSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcMailboxDatabaseCopy [[-ID] <String>] [-ExchangeSystem <IExchangeApplicationSystem>] [-Silent] [-Lun <Lun>] [<CommonParameters>]

  • Get-EmcMailboxDatabaseCopy [[-ID] <String>] [-ExchangeSystem <IExchangeApplicationSystem>] [-Silent] [-HostDisk <Disk>] [<CommonParameters>]

  • Get-EmcMailboxDatabaseCopy [[-ID] <String>] [-Silent] [-DatabaseAvailabilityGroup <DatabaseAvailabilityGroup>] [<CommonParameters>]

  • Get-EmcMailboxDatabaseCopy [[-ID] <String>] [-Silent] [-MailboxServer <MailboxServer>] [<CommonParameters>]

  • Get-EmcMailboxDatabaseCopy [[-ID] <String>] [-Silent] [-MailboxDatabase <MailboxDatabase>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the mailbox database name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-ExchangeSystem <IExchangeApplicationSystem>

Attributes: Optional, Position: named

Specifies the Exchange system object from which to retrieve mailbox database copy information.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-Lun <Lun>

Attributes: Optional, Position: named

Specifies the ESI LUN object, which can be obtained by using the ESI Storage System object or by using the Get-EmcLun cmdlet.

-HostDisk <Disk>

Attributes: Optional, Position: named

Specifies the host disk associated with the mailbox database.

-DatabaseAvailabilityGroup <DatabaseAvailabilityGroup>

Attributes: Optional, Position: named

Specifies the DAG object from which to retrieve mailbox database copy information.

-MailboxServer <MailboxServer>

Attributes: Optional, Position: named

Specifies the name of the mailbox server object from which to retrieve mailbox database copy information.

-MailboxDatabase <MailboxDatabase>

Attributes: Optional, Position: named

Specifies the name of the mailbox database from which to retrieve mailbox database copy information.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

:\PS>$ms = Get-EmcMailboxServer MS1

C:\PS>Get-EmcMailboxDatabaseCopy -MailboxServer $ms

This example gets all the mailbox database copies on the MS1 mailbox database server.

-------------- Example 2 --------------

C:\PS>$exchange = Get-EmcExchangeSystem exchange1

C:\PS>Get-EmcMailboxDatabaseCopy -ExchangeSystem $exchange

This example gets all the mailbox database copies on the exchange1 exchange system.

-------------- Example 3 --------------

C:\PS>$dag = Get-EmcDatabaseAvailabilityGroup DAG1

C:\PS>Get-EmcMailboxDatabaseCopy -DatabaseAvailabilityGroup $dag

This example gets all the mailbox database copies on the DAG1 database available group.

-------------- Example 4 --------------

C:\PS>$db = Get-EmcMailboxDatabase MBDB1

C:\PS>Get-EmcMailboxDatabaseCopy -MailboxDatabase $db

This example gets all the mailbox database copies of the MBDB1 mailbox database.

-------------- Example 5 --------------

C:\PS>$lun = Get-EmcLun testlun

C:\PS>$ms = Get-EmcMailboxServer MS1

C:\PS>$h = Get-EmcHostSystem -MailboxServer $ms

C:\PS>Set-EmcLunAccess -Lun $lun -HostSystem $h -Available

C:\PS>$disk = Get-EmcHostDisk -Lun $lun -HostSystem $h

C:\PS>Initialize-EmcHostDisk -HostSystem $h -HostDisk $disk

C:\PS>$vol = New-EmcVolume -HostSystem $h -HostDisk $disk -Label “New Volume”

C:\PS>Set-EmcVolumeMountPoint -HostSystem $h -DriveLetter V -Volume $vol

C:\PS>New-EmcMailboxDatabase -Name MailboxDatabase01 -MailboxServer $ms -EdbFilePath “V:\DatabaseFiles\MailboxDatabase01.edb” -LogFolderPath “V:\LogFiles”

C:\PS>Get-EmcMailboxDatabaseCopy -Lun $lun

C:\PS>Get-EmcMailboxDatabaseCopy -HostDisk $disk

This example gets all the mailbox database copies for a specified LUN or host disk.


Get-EmcMailboxDatabaseCopyStatus

Gets the health and status information for one or more mailbox database copies.

Syntax

  • Get-EmcMailboxDatabaseCopyStatus [-MailboxDatabaseCopy] <MailboxDatabaseCopy> [-Refresh] [-Silent] [<CommonParameters>]

  • Get-EmcMailboxDatabaseCopyStatus [-MailboxServer] <MailboxServer> [-Refresh] [-Silent] [<CommonParameters>]

Parameters

-MailboxDatabaseCopy <MailboxDatabaseCopy>

Attributes: Required, Position: 1

Specifies the mailbox database copy object from which to retrieve mailbox database information.

-MailboxServer <MailboxServer>

Attributes: Required, Position: 1

Specifies the name of the mailbox server from which to retrieve mailbox database information.

-Refresh <SwitchParameter>

Attributes: Optional, Position: named

If specified, performs a full refresh of the components related to the mailbox database copy before retrieving the status. This will take longer to complete, but ensures that the data is up to date.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$copies = Get-EmcMailboxDatabaseCopy MBDB1

C:\PS>Get-EmcMailboxDatabaseCopyStatus -MailboxDatabaseCopy $copies[0]

This example gets the status of all database copies on the MBDB1 mailbox server.

-------------- Example 2 --------------

C:\PS>$ms = Get-EmcMailboxServer MS1

C:\PS>Get-EmcMailboxDatabaseCopyStatus -MailboxServer $ms

This example gets the status of all database copies on the MS1 mailbox server.


Get-EmcMailboxServer

Gets the list of mailbox database servers. If no parameters are specified, it gets a complete list of the mailbox servers in the entire organization.

Syntax

  • Get-EmcMailboxServer [[-ID] <String>] [-ExchangeSystem <IExchangeApplicationSystem>] [-HostSystem <IWindowsHostSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcMailboxServer [[-ID] <String>] [-Silent] [-DatabaseAvailabilityGroup <DatabaseAvailabilityGroup>] [<CommonParameters>]

  • Get-EmcMailboxServer [[-ID] <String>] [-Silent] [-MailboxDatabase <MailboxDatabase>] [<CommonParameters>]

  • Get-EmcMailboxServer [[-ID] <String>] [-Silent] [-MailboxDatabaseCopy <MailboxDatabaseCopy>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the mailbox server name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-ExchangeSystem <IExchangeApplicationSystem>

Attributes: Optional, Position: named

Specifies the Exchange system object from which to retrieve mailbox server information.

-HostSystem <IWindowsHostSystem>

Attributes: Optional, Position: named

Specifies the host system associated with the specified mailbox server.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-DatabaseAvailabilityGroup <DatabaseAvailabilityGroup>

Attributes: Optional, Position: named

Specifies the DAG object from which to retrieve mailbox server information.

-MailboxDatabase <MailboxDatabase>

Attributes: Optional, Position: named

Specifies the mailbox database object from which to retrieve mailbox server information.

-MailboxDatabaseCopy <MailboxDatabaseCopy>

Attributes: Optional, Position: named

Specifies the mailbox database copy object from which to retrieve mailbox server information.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$db = Get-EmcMailboxDatabase MBDB1

C:\PS>Get-EmcMailboxServer -MailboxDatabase $db

This example gets the mailbox server for the MBDB1 mailbox database.

-------------- Example 2 --------------

C:\PS>Get-EmcMailboxServer

This example gets the list of all mailbox database servers in the organization.

-------------- Example 3 --------------

C:\PS>$dag = Get-EmcDatabaseAvailabilityGroup TestDAG

C:\PS>Get-EmcMailboxServer -DatabaseAvailabilityGroup $dag

This example gets information about all mailbox servers in TestDAG.

-------------- Example 4 --------------

C:\PS>$exchange = Get-EmcExchangeSystem Exchange1

C:\PS>Get-EmcMailboxServer -ExchangeSystem $exchange

This example gets information about all mailbox servers in the Exchange1 exchange system.

-------------- Example 5 --------------

C:\PS>$databasecopy = Get-EmcMailboxDatabasecopy db1\MS2

C:\PS>Get-EmcMailboxServer -MailboxDatabaseCopy $databasecopy

This example gets information about the mailbox server associated with the mailbox database copy.


Add-EmcDatabaseToAvailabilityGroup

Syntax

Add-EmcDatabaseToAvailabilityGroup -AvailabilityGroupName <String> -PrimaryReplicaServerName <String> -PrimaryReplicaInstanceName <String> -Databases <Object[]> -SharedLocationPath <String> [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

AvailabilityGroupName <String>

Attributes: Required, Position: 1

-PrimaryReplicaServerName <String>

Attributes: Required, Position: 2

-PrimaryReplicaInstanceName <String>

Attributes: Required, Position: 3

-Databases <Object[]>

Attributes: Required, Position: 4

-SharedLocationPath <String>

Attributes: Required, Position: 5

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

-------------- Example 1 --------------

C:\PS>Add-EmcDatabaseToAvailabilityGroup -AvailabilityGroupName TestGroup -PrimaryReplicaServerName SQLServer01 -PrimaryReplicaInstanceName MSSQLSERVER -Databases Database1 -SharedLocationPath \\server01\folder01

Example to add database to AvailabilityGroup.


Add-EmcReplicaToAvailabilityGroup

Syntax

Add-EmcReplicaToAvailabilityGroup -AvailabilityGroupName <String> -PrimaryReplicaServerName <String> -PrimaryReplicaInstanceName <String> -SecondaryReplicaServerName <String> -SecondaryReplicaInstanceName <String> -SharedLocationPath <String> [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-AvailabilityGroupName <String>

Attributes: Required, Position: 1

-PrimaryReplicaServerName <String>

Attributes: Required, Position: 2

-PrimaryReplicaInstanceName <String>

Attributes: Required, Position: 3

-SecondaryReplicaServerName <String>

Attributes: Required, Position: 5

-SecondaryReplicaInstanceName <String>

Attributes: Required, Position: 6

-SharedLocationPath <String>

Attributes: Required, Position: 7

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Add-EmcReplicaToAvailabilityGroup -AvailabilityGroupName TestGroup -PrimaryReplicaServerName SQLServer01 -PrimaryReplicaInstanceName MSSQLSERVER -SecondaryReplicaServerName SQLServer02 -SecondaryReplicaInstanceName MSSQLSERVER -SharedLocationPath \\server01\folder01

Example to add secondary replica server to an AvailabilityGroup.


Get-EmcDatabaseAvailabilityGroup

Gets the configuration settings, status, and other information about a database availability group (DAG).

Syntax

  • Get-EmcDatabaseAvailabilityGroup [[-ID] <String>] [-ExchangeSystem <IExchangeApplicationSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcDatabaseAvailabilityGroup [[-ID] <String>] [-Silent] [-MailboxServer <MailboxServer>] [<CommonParameters>]

  • Get-EmcDatabaseAvailabilityGroup [[-ID] <String>] [-Silent] [-MailboxDatabase <MailboxDatabase>] [<CommonParameters>]

  • Get-EmcDatabaseAvailabilityGroup [[-ID] <String>] [-Silent] [-MailboxDatabaseCopy <MailboxDatabaseCopy>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the mailbox database name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-ExchangeSystem <IExchangeApplicationSystem>

Attributes: Optional, Position: named

Specifies the exchange system of the DAG to query.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-MailboxServer <MailboxServer>

Attributes: Optional, Position: named

Specifies the mailbox database of the database availability group (DAG) to query.

-MailboxDatabase <MailboxDatabase>

Attributes: Optional, Position: named

Specifies the name of the mailbox database of the DAG to query.

-MailboxDatabaseCopy <MailboxDatabaseCopy>

Attributes: Optional, Position: named, Accepts pipeline input (by value)

Specifies the mailbox database copy of the DAG to query.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$ms = Get-EmcMailboxServer MS1

C:\PS>Get-EmcDatabaseAvailabilityGroup -MailboxServer $ms

This example displays the basic properties for the DAG of the MS1 mailbox database server.

-------------- Example 2 --------------

C:\PS>Get-EmcDatabaseAvailabilityGroup DAG1

This example displays the basic properties for DAG1.

-------------- Example 3 --------------

C:\PS>$db = Get-EmcMailboxDatabase MBDB1

C:\PS>Get-EmcDatabaseAvailabilityGroup -MailboxDatabase $db

This example displays the basic properties for the DAG of the MBDB1 mailbox database.

-------------- Example 4 --------------

C:\PS>$exchange = Get-EmcExchangeSystem Exchange1

C:\PS>Get-EmcDatabaseAvailabilityGroup -ExchangeSystem $exchange

This example displays the basic properties for the DAG of Exchange system Exchange1.

-------------- Example 5 --------------

C:\PS>$databasecopy = Get-EmcMailboxDatabasecopy db1\MS2

C:\PS>Get-EmcDatabaseAvailabilityGroup -MailboxDatabaseCopy $databasecopy

This example displays the basic properties for the DAG of mailbox database copy db1 on mailbox server MS2.


Get-EmcSqlServerAvailabilityGroup

Syntax

Get-EmcSqlServerAvailabilityGroup [-ID <String>] -ServerName <String> -InstanceName <String> [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

-ServerName <String>

Attributes: Required, Position: named

-InstanceName <String>

Attributes: Required, Position: named

-Silent <SwitchParameter>

Attributes: Optional, Position: named

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

-------------- EXAMPLE 1 --------------

C:\PS>Get-EmcSqlServerAvailabilityGroup -ServerName SQLServer01 -InstanceName MSSQLSERVER -Silent

Example for fetching Availability Groups present in SQL Server with hostname SQLServer01 and instance name MSSQLSERVER

---------- EXAMPLE 2 ----------

C:\PS>Get-EmcSqlServerAvailabilityGroup -ID test* -ServerName SQLServer01 -InstanceName MSSQLSERVER -Silent

Example for fetching Availability Groups with Name starting with 'test' in SQL Server with hostname SQLServer01 and instance name MSSQLSERVER


Get-EmcSqlServerDatabase

Syntax

Get-EmcSqlServerDatabase [-ID <String>] -ServerName <String> -InstanceName <String> [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

-ServerName <String>

Attributes: Required, Position: named

-InstanceName <String>

Attributes: Required, Position: named

-Silent <SwitchParameter>

Attributes: Optional, Position: named

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

-------------- EXAMPLE 1 --------------

C:\PS>Get-EmcSqlServerDatabase -ServerName SQLServer01 -InstanceName MSSQLSERVER -Silent

Example for fetching databases in SQL Server with host name SQLServer01 and instance name MSSQLSERVER.

---------- EXAMPLE 2 ----------

C:\PS>Get-EmcSqlServerDatabase -ID test* -ServerName SQLServer01 -InstanceName MSSQLSERVER -Silent

Example for fetching databases with name starts with 'test' in SQL Server with host name SQLServer01 and instance name MSSQLSERVER.


Get-EmcSqlServer

Syntax

Get-EmcSqlServer -HostNamesOrIPAddresses <String> [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-HostNamesOrIPAddresses <String>

Attributes: Required, Position: 1

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Get-EmcSqlServer -HostNamesOrIPAddresses SQLServer01

Example for fetching SQL Server using a hostname SQLServer01


Get-EmcSqlServerCredential

Syntax

Get-EmcSqlServerCredential [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Get-EmcSqlServerAvailabilityGroup -ServerName SQLServer01 -InstanceName MSSQLSERVER

Example for fetching Availability Groups present in SQL Server


New-EmcSqlServerAvailabilityGroup

Syntax

New-EmcSqlServerAvailabilityGroup -AvailabilityGroupName <String> -PrimaryReplicaServerName <String> -PrimaryReplicaInstanceName <String> -Databases <Object[]> -SecondaryReplicaServerName <String> -SecondaryReplicaInstanceName <String> -SharedLocationPath <String> [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-AvailabilityGroupName <String>

Attributes: Required, Position: 1

-PrimaryReplicaServerName <String>

Attributes: Required, Position: 2

-PrimaryReplicaInstanceName <String>

Attributes: Required, Position: 3

-Databases <Object[]>

Attributes: Required, Position: 4

-SecondaryReplicaServerName <String>

Attributes: Required, Position: 5

-SecondaryReplicaInstanceName <String>

Attributes: Required, Position: 6

-SharedLocationPath <String>

Attributes: Required, Position: 7

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$dbs = Get-EmcSqlServerDatabase -ServerName SQLServer01 -InstanceName MSSQLSERVER New-EmcSqlServerAvailabilityGroup -AvailabilityGroupName TestGroup -PrimaryReplicaServerName SQLServer01 -PrimaryReplicaInstanceName MSSQLSERVER -Databases $dbs[2], $dbs[3] -SecondaryReplicaServerName SQLServer02 -SecondaryReplicaInstanceName MSSQLSERVER -SharedLocationPath \\server01\folder01

Example for creating an Availability Group TestGroup using primary replica server SQLServer01 and Secondary Replica server SQLServer02. All databases are fetched using Get-EmcSqlServerDatabase and selected databases are passed using Databases parameter. Sharedlocation path accessible by both primary and secondary replica server is specified as \\server01\folder01.


New-EmcSqlServerDatabase

Syntax

New-EmcSqlServerDatabase -ServerName <String> -InstanceName <String> -DatabaseName <String> -DataFilePath <String> -LogFilePath <String> [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-ServerName <String>

Attributes: Required, Position: 1

-InstanceName <String>

Attributes: Required, Position: 2

-DatabaseName <String>

Attributes: Required, Position: 3

-DataFilePath <String>

Attributes: Required, Position: 4

-LogFilePath <String>

Attributes: Required, Position: 5

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>New-EmcSqlServerDatabase -ServerName SQLServer01 -InstanceName MSSQLSERVER -DatabaseName Database1 -DataFilePath C:\SQL\Database1.mdf -LogFilePath C:\SQL\Database1_log.ldf

Example for creating a new database named Database1 on SQL Server SQLServer01 under instnace MSSQLSERVER. The file path for data file and log file are also illustrated.


Remove-EmcDatabaseFromAvailabilityGroup

Syntax

Remove-EmcDatabaseFromAvailabilityGroup -Name <String> -PrimaryReplicaServerName <String> -PrimaryReplicaInstanceName <String> -Databases <Object[]> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Name <String>

Attributes: Required, Position: 1

-PrimaryReplicaServerName <String>

Attributes: Required, Position: 2

-PrimaryReplicaInstanceName <String>

Attributes: Required, Position: 3

-Databases <Object[]>

Attributes: Required, Position: 4

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet runs. The cmdlet is not run.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Get-EmcSqlServerAvailabilityGroup -ServerName SQLServer01 -InstanceName MSSQLSERVER $dbs = Get-EmcSqlServerDatabase -ServerName SQLServer01 -InstanceName MSSQLSERVER Remove-EmcDatabaseFromAvailabilityGroup -Name TestGroup -PrimaryReplicaServerName SQLServer01 -PrimaryReplicaInstanceName MSSQLSERVER -Databases $dbs[0], $dbs[1]

Get-EmcSqlServerAvailabilityGroup -ServerName SQLServer01 -InstanceName MSSQLSERVER


Remove-EmcReplicaFromAvailabilityGroup

Syntax

Remove-EmcReplicaFromAvailabilityGroup -AvailabilityGroupName <String> -PrimaryReplicaServerName <String> -PrimaryReplicaInstanceName <String> -SecondaryReplicaServerName <String> -SecondaryReplicaInstanceName <String> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-AvailabilityGroupName <String>

Attributes: Required, Position: 1

-PrimaryReplicaServerName <String>

Attributes: Required, Position: 2

-PrimaryReplicaInstanceName <String>

Attributes: Required, Position: 3

-SecondaryReplicaServerName <String>

Attributes: Required, Position: 5

-SecondaryReplicaInstanceName <String>

Attributes: Required, Position: 6

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet runs. The cmdlet is not run.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Remove-EmcReplicaFromAvailabilityGroup -AvailabilityGroupName TestGroup -PrimaryReplicaServerName SQLServer01 -PrimaryReplicaInstanceName MSSQLSERVER -SecondaryReplicaServerName SQLServer02 -SecondaryReplicaInstanceName MSSQLSERVER

Example for removing a secondary replica from Availability Group.


Remove-EmcSqlServerAvailabilityGroup

Syntax

Remove-EmcSqlServerAvailabilityGroup -AvailabilityGroupName <String> -PrimaryReplicaServerName <String> -PrimaryReplicaInstanceName <String> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-AvailabilityGroupName <String>

Attributes: Required, Position: 1

-PrimaryReplicaServerName <String>

Attributes: Required, Position: 2

-PrimaryReplicaInstanceName <String>

Attributes: Required, Position: 3

-Force <SwitchParameter>

Attributes: Optional, Position: named

-Silent <SwitchParameter>

Attributes: Optional, Position: named

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Remove-EmcSqlServerAvailabilityGroup -AvailabilityGroupName TestGroup -PrimaryReplicaServerName SQLServer01 -PrimaryReplicaInstanceName MSSQLSERVER -Silent

Example for removing Availability Group TestGroup from Primary Replica Server SQLServer01.


Remove-EmcSqlServerDatabase

Syntax

Remove-EmcSqlServerDatabase -ServerName <String> -InstanceName <String> -DatabaseNames <Object[]> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-ServerName <String>

Attributes: Required, Position: 1

-InstanceName <String>

Attributes: Required, Position: 2

-DatabaseNames <Object[]>

Attributes: Required, Position: 3

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. Errors will still be displayed.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet runs. The cmdlet is not run.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Remove-EmcSqlServerDatabase -ServerName SQLServer01 -InstanceName MSSQLSERVER -DatabaseNames testdb-1,testdb-2

Example for removing databases from specified SQL server instance.


Copy-EmcVnxAdvancedSnapshot

Copies VNX advanced snapshot to new VNX advanced snapshot.

Syntax

Copy-EmcVnxAdvancedSnapshot -AdvancedSnapshot <VnxAdvancedSnapshot> [-CopySnapshotName <String>] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-AdvancedSnapshot <VnxAdvancedSnapshot>

Attributes: Required, Position: 1

Specifies the ESI VnxAdvancedSnapshot object. You can get a VnxAdvancedSnapshot object using Get-EmcVnxAdvancedSnapshot commandlet.

-CopySnapshotName <String>

Attributes: Optional, Position: named

Specifies the name of the new(copy) Vnx advanced snapshot.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

PipelineVariable stores the value of the current pipeline element as a variable, for any named command as it flows through the pipeline. Valid values are strings, the same as for any variable names.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

C:\PS>$snapshot = Get-EmcVnxAdvancedSnapshot -ID "firstsnap" -BlockStorageSystem $storage

C:\PS>Copy-EmcVnxAdvancedSnapshot -AdvancedSnapshot $snapshot -CopySnapshotName "newsnapshotname"

These examples copy the specified advanced snapshot to the new VNX advanced snapshot.


Add-EmcFastVpPolicy

Adds or associates the specified storage group to the specified FAST VP policy.

Syntax

Add-EmcFastVpPolicy -VmaxStorageGroups <VmaxStorageGroup[]> -VmaxFastVpPolicy <VmaxFastVpPolicy> [-Silent] [<CommonParameters>]

Parameters

-VmaxStorageGroups <VmaxStorageGroup>

Attributes: Required, Position: named

Specifies the ESI VMAX storage group object. You can get a VMAX storage group object with the ESI storage system object or Get-EmcVmaxStorageGroup cmdlet.

-VmaxFastVpPolicy <VmaxFastVpPolicy>

Attributes: Required, Position: named

Specifies the ESI FAST VP policy system object. You can get the FAST VP policy system object with the Get-EmcFastVpPolicy cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$storage = Get-EmcStorageSystem vmax348

C:\PS>$storagegroup = Get-EmcVmaxStorageGroup *test_SG* -StorageSystem $storage

C:\PS>$fvp = Get-EmcFastVpPolicy -StorageSystem $storage

C:\PS>Add-EmcFastVpPolicy -VmaxStorageGroups $storagegroup -VmaxFastVpPolicy $fvp

This example gets the specified storage group from the specified storage system and the FAST VP policy for that storage system, and then adds that FAST VP Policy to that storage group.


Add-EmcLunsToVmaxStorageGroup

Adds one or more LUNs to the specified VMAX storage group. Clears the host disk signatures and assigns new ones.

Syntax

Add-EmcLunsToVmaxStorageGroup -VmaxStorageGroup <VmaxStorageGroup> -Luns <Lun[]> [-Silent] [<CommonParameters>]

Parameters

-VmaxStorageGroup <VmaxStorageGroup>

Attributes: Required, Position: named

Specifies the ESI VMAX storage group object. You can get the object with the ESI storage system object or Get-EmcVmaxStorageGroup cmdlet.

-Luns <Lun[]>

Attributes: Required, Position: named

Specifies the list of ESI LUN objects. You can get a LUN object with the ESI storage system object or Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

C:\PS>$storagegroup=Get-EmcVmaxStorageGroup -VmaxStorageSystem $storage

C:\PS>$luns =Get-EmcLun -ID 0d*

C:\PS>Add-EmcLunsToVmaxStorageGroup -VmaxStorageGroup $storagegroup -Luns $luns

This example gets the specified VMAX storage group and the LUNs, and then adds the LUNs to that VMAX storage group for the specified VMAX system.


Get-EmcFastVpPolicy

Gets the FAST VP policies that are associated with the specified storage system or VMAX storage group.

Syntax

  • Get-EmcFastVpPolicy [-ID <String>] [-StorageSystem <IStorageSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcFastVpPolicy [-ID <String>] [-Silent] [-VmaxStorageGroup <VmaxStorageGroup>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the FAST VP policy ID. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <IStorageSystem>

Attributes: Optional, Position: named

Specifies the storage system object. You can add the storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get the storage system object with the Get-EmcStorageSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-VmaxStorageGroup <VmaxStorageGroup>

Attributes: Optional, Position: named

Specifies the ESI VMAX storage group object. You can get a VMAX storage group object with the ESI storage system object or Get-EmcVmaxStorageGroup cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

C:\PS>Get-EmcFastVpPolicy -StorageSystem $storage

This example gets the FAST VP policies from the specified storage system.

-------------- Example 2 --------------

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

C:\PS>$storagegroup = Get-EmcVmaxStorageGroup *test_SG* -VmaxStorageSystem $storage

C:\PS>Get-EmcFastVpPolicy –VmaxStorageGroup $storagegroup

This example gets the FAST VP policies associated with the specified storage system and storage group.


Get-EmcStorageTier

Gets the storage tiers for the specified storage system or the specified FAST VP policy.

Syntax

  • Get-EmcStorageTier [-ID <String>] [-StorageSystem <IStorageSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcStorageTier [-ID <String>] [-Silent] [-VmaxFastVpPolicy <VmaxFastVpPolicy>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the storage tier ID. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <IStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI storage system object. You can add the storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get the storage system object with the Get-EmcStorageSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-VmaxFastVpPolicy <VmaxFastVpPolicy>

Attributes: Optional, Position: named

Specifies the ESI VMAX FAST VP policy system object. You can get the FAST VP policy system object with the Get-EmcFastVpPolicy cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

C:\PS>Get-EmcStoragetier -VmaxStorageSystem $storage

This example gets the storage tiers from the specified VMAX storage system.

---------- Example 2 ----------

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

$policy=Get-EmcFastVpPolicy -ID p1 -StorageSystem $storage

C:\PS>Get-EmcStorageTier -VmaxFastVpPolicy $policy

This example gets the storage tiers for the specified storage system and FAST VP policy.

---------- Example 3 ----------

C:\PS>Get-EmcStorageTier

This example gets the storage tiers from all connected storage systems.


Get-EmcVmaxStorageGroup

Gets all storage groups for the specified VMAX storage system.

Syntax

  • Get-EmcVmaxStorageGroup [-ID <String>] -StorageSystem <IStorageSystem> [-Silent] [<CommonParameters>]

  • Get-EmcVmaxStorageGroup [-ID <String>] [-Silent] -VmaxFastVpPolicy <VmaxFastVpPolicy> [<CommonParameters>]

  • Get-EmcVmaxStorageGroup [-ID <String>] [-Silent] -Lun <Lun> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the VMAX storage group ID. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <IStorageSystem>

Attributes: Required, Position: named

Specifies the storage system object. You can add the storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get the storage system object with the Get-EmcStorageSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-VmaxFastVpPolicy <VmaxFastVpPolicy>

Attributes: Required, Position: named

Specifies the ESI FAST VP policy system object. You can get the FAST VP policy system object with the Get-EmcFastVpPolicy cmdlet.

-Lun <Lun[]>

Attributes: Required, Position: named

Specifies the list of ESI LUN objects. You can get a LUN object with the ESI storage system object or Get-EmcLun cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$storage = Get-EmcStorageSystem vmax348

C:\PS>Get-EmcVmaxStorageGroup -VmaxStorageSystem $storage

This example gets the storage groups for the specified VMAX storage system.

---------- Example 2 ----------

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

C:\PS>$policy=Get-EmcFastVpPolicy -StorageSystem $storage

C:\PS>Get-EmcVmaxStorageGroup -VmaxFastVpPolicy $policy

This example gets the FAST VP policies for the specified storage system and gets the storage groups associated to the specified FAST VP policy.


New-EmcVmaxStorageGroup

Adds LUNs to the specified VMAX storage group.

Syntax

New-EmcVmaxStorageGroup -Name <String> -VmaxStorageSystem <IVmaxStorageGroupManager> [-Luns <Lun[]>] [-DeleteWhenRemovedFromMaskingView] [-Silent] [<CommonParameters>]

Parameters

-Name <String>

Attributes: Required, Position: named

Specifies the name of the VMAX storage group.

-ID <String>

Attributes: Optional, Position: 1

Specifies the VMAX storage group ID. Wildcards are permitted. It is a positional parameter (position = 1).

-VmaxStorageSystem <IVmaxStorageGroupManager>

Attributes: Required, Position: named

Specifies the ESI storage system system object. You can add a storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object with the Get-EmcStorageSystem cmdlet.

-Luns <Lun[]>

Attributes: Optional, Position: named

Specifies the list of ESI LUN objects. You can get a LUN object with the ESI storage system object or Get-EmcLun cmdlet.

-DeleteWhenRemovedFromMaskingView <SwitchParameter>

Attributes: Optional, Position: named

VMAX storage groups have options to facilitate automatic clean-up when a group is no longer in use. When this property is set to True, the array automatically deletes the VMAX storage group if no longer associated with any masking view.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Getting Storage System

$storage = Get-EmcStorageSystem –ID *VMAX348

C:\PS>$luns=Get-EmcLun -ID *test*

C:\PS>$newstoragegroup =New-EmcVmaxStorageGroup -Name dummy_sg -VmaxStroageSystem $storage -Luns $luns

This example gets the specified VMAX storage group for the specified storage system and then adds the specified LUNs to the specified VMAX storage group.


Remove-EmcFastVpPolicy

Removes the specified FAST VP policy from the specified storage groups.

Syntax

Remove-EmcFastVpPolicy -VmaxStorageGroups <VmaxStorageGroup[]> -VmaxFastVpPolicy <VmaxFastVpPolicy> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-VmaxStorageGroups <VmaxStorageGroup>

Attributes: Optional, Position: named

Specifies the list of ESI VMAX storage group objects. You can get a VMAX storage group object with the ESI storage system object or Get-EmcVmaxStorageGroup cmdlet.

-VmaxFastVpPolicy <VmaxFastVpPolicy>

Attributes: Required, Position: named

Specifies the ESI FAST VP policy system object. You can get the FAST VP policy system object with the Get-EmcFastVpPolicy cmdlet.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

C:\PS>$storagegroup = Get-EmcVmaxStorageGroup *test_SG* -VmaxStorageSystem $storage

C:\PS>$policy=Get-EmcFastVpPolicy *test_p* -StorageSystem $storage

C:\PS>Remove-EmcFastVpPolicy -VmaxStorageGroups $storagegroup -VmaxFastVpPolicy $policy

This example gets and removes the specified FAST VP policy from the specified storage groups in the specified storage system.


Remove-EmcLunsFromVmaxStorageGroup

Removes LUNs from a VMAX storage group.

Syntax

Remove-EmcLunsFromVmaxStorageGroup [-Force] -VmaxStorageGroup <VmaxStorageGroup> -Luns <Lun[]> [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-VmaxStorageGroup <VmaxStorageGroup>

Attributes: Optional, Position: named

Specifies the ESI VMAX storage group object. You can get a VMAX storage group object with the ESI storage system object or with the Get-EmcVmaxStorageGroup cmdlet.

-Luns <Lun[]>

Attributes: Optional, Position: named

Specifies the list of ESI LUN objects. You can get a LUN object with the ESI storage system object or Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

C:\PS>$storagegroup = Get-EmcVmaxStorageGroup -VmaxStorageSystem $storage

C:\PS>$luns =Get-EmcLun -ID 0d*

C:\PS>Remove-EmcLunsFromVmaxStorageGroup -VmaxStorageGroup $storagegroup -Luns $luns

This example gets and removes the specified LUNs from the specified storage group on the specified storage system.


Remove-EmcVmaxStorageGroup

Deletes the specified storage group that is not associated to any FAST VP policies.

Syntax

Remove-EmcVmaxStorageGroup -VmaxStorageGroup <VmaxStorageGroup> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-VmaxStorageGroup <VmaxStorageGroup>

Attributes: Optional, Position: named

Specifies the ESI VMAX storage group object. You can get a VMAX storage group object with the ESI storage system object or Get-EmcVmaxStorageGroup cmdlet.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Getting storage system

$storage = Get-EmcStorageSystem vmax348

C:\PS>$storagegroup = Get-EmcVmaxStorageGroup *test_SG* -VmaxStorageSystem $storage

C:\PS>Remove-EmcVmaxStorageGroup -VmaxStorageGroup $storagegroup

This example gets and removes the storage groups from the specified storage system.


Get-EmcCompositeLun

Gets all composite LUNs from the specified storage system.

Syntax

Get-EmcCompositeLun [-ID <String>] -StorageSystem <IStorageSystem> [-CompositionConfiguration <CompositionConfiguration>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the LUN name or LUN ID. Wildcards are permitted.

-StorageSystem <IStorageSystem>

Attributes: Required, Position: named

Specifies the Storage System object. You can add the storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get the storage system object with the Get-EmcStorageSystem cmdlet.

-CompositionConfiguration <CompositionConfiguration>

Attributes: Optional, Position: named

Specifies the Composite Configuration object, which can be either striped, concatenated, or both.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Getting storage system.

$storage= Get-EmcStorageSystem *480

C:\PS>$compositeluns= Get-EmcCompositeLun -StorageSystem $storage

This example gets all composite LUNs from the specified storage system.

---------- Example 2 ----------

C:\PS>Getting storage system.

$storage= Get-EmcStorageSystem *480

C:\PS>$compositeluns= Get-EmcCompositeLun -StorageSystem $storage -CompositeConfiguration ConcatenateOnly

This example gets all composite LUNs from the specified storage system for which you can apply a filter, such as: ConcatenateOnly, StripeOnly, or ConcatenateAndStripe.


New-EmcCompositeLun

Creates a new meta or composite LUN from the specified LUNs. To compose or form a meta or composite LUN, at least two LUNs are required and the first LUN becomes the metahead.

Syntax

New-EmcCompositeLun [-Name <String>] -LunsThatParticipateInComposition <Lun[]> -CompositionConfiguration <CompositionConfiguration> [-Silent] [<CommonParameters>]

Parameters

-Name <String>

Attributes: Optional, Position: named

Specifies the name of the new composite LUN.

-LunsThatParticipateInComposition <Lun[]>

Attributes: Required, Position: named

Specifies the list of ESI LUN objects. You can get a LUN object with the ESI storage system object or with the Get-EmcLun cmdlet.

-CompositionConfiguration <CompositionConfiguration>

Attributes: Required, Position: named

Specifies the composite configuration object, which can be either striped or concatenated.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.


Remove-EmcCompositeLun


Expand-EmcCompositeLun


Add-EmcVnxeLunGroupMember

Adds one or more members to a LUN group. A LUN group has three types of members: LUNs, hosts that have access to LUNs in the group, and hosts that have access to snapshots of LUNs in the group. This command is used to add any of these to the LUN group.

Note: This command is applicable only for VNXe3200 systems.

Syntax

  • Add-EmcVnxeLunGroupMember -LunGroup <Vnx2eLunGroup> -Luns <Lun[]> [-Silent] [<CommonParameters>]

  • Add-EmcVnxeLunGroupMember -LunGroup <Vnx2eLunGroup> [-Silent] -LunHosts <RemoteHost[]> [<CommonParameters>]

  • Add-EmcVnxeLunGroupMember -LunGroup <Vnx2eLunGroup> [-Silent] -SnapshotHosts <RemoteHost[]> [<CommonParameters>]

Parameters

-LunGroup <Vnx2eLunGroup>

Attributes: Required, Position: named

Specifies the LUN group object to which to add the members. You can get this with the Get-EmcVnxeLunGroup cmdlet.

-Luns <Lun[]>

Attributes: Required, Position: named

Specifies one or more LUNs to add to the LUN group. You can get LUN objects with the Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-LunHosts <RemoteHost[]>

Attributes: Required, Position: named

Specifies one or more hosts to add to the LUN group with LUN access. You can get the host objects with the Get-EmcStorageRegisteredHost command.

-SnapshotHosts <RemoteHost[]>

Attributes: Required, Position: named

Specifies one or more hosts to add to the LUN group with snapshot access. You can get host objects with the Get-EmcStorageRegisteredHost command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$ss = Get-EmcStorageSystem TestVNXeSystem

$group = Get-EmcVnxeLunGroup -StorageSystem $ss TestLG

$lun = Get-EmcLun -BlockStorageSystem $ss TestLUN

Add-EmcVnxeLunGroupMember -LunGroup $group -Luns $lun

This example adds a LUN to a LUN group.

-------------- Example 2 --------------

C:\PS>$ss = Get-EmcStorageSystem TestVNXeSystem

$group = Get-EmcVnxeLunGroup -StorageSystem $ss TestLG

$h = Get-EmcStorageRegisteredHost -StorageSystem $ss TestHost

Add-EmcVnxeLunGroupMember -LunGroup $group -LunHosts $h

This example adds a LUN to a LUN group with hosts with access to the LUNs.

-------------- Example 3 --------------

C:\PS>$ss = Get-EmcStorageSystem TestVNXeSystem

$group = Get-EmcVnxeLunGroup -StorageSystem $ss TestLG

$h = Get-EmcStorageRegisteredHost -StorageSystem $ss TestHost

Add-EmcVnxeLunGroupMember -LunGroup $group -SnapshotHosts $h

This example adds a host to a LUN group with access to snapshots.


Dismount-EmcVnxeSnapshot

Dismounts a VNXe LUN or LUN group snapshot to prevent host access.

Syntax

Dismount-EmcVnxeSnapshot -Snapshot <Vnx2eSnapshot> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Snapshot <Vnx2eSnapshot>

Attributes: Required, Position: 1

LUN or LUN group snapshot to dismount.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$ss = Get-EmcStorageSystem TestVNXeSystem

$snap = Get-EmcVnxeSnapshot -StorageSystem $ss TestSnap

Dismount-EmcVnxeSnapshot -Snapshot $snap

Gets a LUN snapshot and dismounts it.


Expand-EmcLun

Expands the capacity of a LUN.

Note: You cannot expand LUNs (volumes) for XtremIO storage systems in ESI.

Syntax

Expand-EmcLun -Lun <Lun> -NewCapacity <UInt64> [-Silent] [<CommonParameters>]

Parameters

-Lun <Lun>

Attributes: Required, Position: named

Specifies the ESI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcLun cmdlet.

-NewCapacity <UInt64>

Attributes: Optional, Position: named

Specifies the new capacity for the LUN.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$sys = Get-EmcStorageSystem -ID *166*

C:\PS>$pool = Get-EmcStoragePool -StorageSystem $sys -id ESI_TEST*

C:\PS>$lun = New-EmcLUN -Pool $pool -Name myTestLun -Capacity 1GB

C:\PS>Expand-EmcLun -Lun $lun -NewCapacity 2GB

In this example, the capacity of the specified LUN is expanded from 1 GB to 2 GB.

-------------- Example 2 --------------

C:\PS>$clun = Get-EmcCompositeLun -ID 14 -StorageSystem $s

C:\PS>Expand-emclun -Lun $clun -NewCapacity 2GB

In this example, the capacity of the specified meta or composite LUN gets expanded.


Get-EmcInitiatorGroup

Gets a list of initiator groups for the specified XtremIO storage system.

Syntax

  • Get-EmcInitiatorGroup [-ID <String>] [-Silent] [<CommonParameters>]

  • Get-EmcInitiatorGroup [-ID <String>] [-Silent] [-XioStorageSystem <IXioStorageSystem>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the LUN name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-XioStorageSystem <IXioStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI XtremIO storage system object. You can add a storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object with the Get-EmcStorageSystem cmdlet and then choose the XtremIO object from that list.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcInitiatorGroup -ID < String >

This example gets the initiator group or groups with the specified ID.

-------------- Example 2 --------------

C:\PS>Get-EmcInitiatorGroup -ID < String > -XioStorageSystem < IXioStorageSystem > -Silent -PipelineVariable < String >

This example gets the initiator group or groups with the specified ID and EMC XtremIO storage system.


Get-EmcLun

Gets the list of LUNs for the specified storage system or systems.

Syntax

  • Get-EmcLun [-ID] <String>] [-BlockStorageSystem <IBlockStorageSystem>] [-Concrete] [-Silent] [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] [-Pool <StoragePool>] [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] -HostDisk <Disk> [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] -Volume <Volume> [-ClusterSystem <IClusterSystem>] [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] -ClusterDisk <WindowsBasicClusterDisk> [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-BlockStorageSystem <IBlockStorageSystem>] [-Silent] -InitiatorId <String> -HostLunId <String> [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] -HostLunIdentifier <HostLunIdentifier> [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] -Datastore <Datastore> [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] -ScsiLun <ScsiLun> [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] -MailboxDatabase <MailboxDatabase> [-MailboxDatabaseFileType <MailBoxDatabaseFileType>] [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] [-MailboxDatabaseFileType <MailBoxDatabaseFileType>]-MailboxDatabaseCopy <MailboxDatabaseCopy> [<CommonParameters>]

  • Get-EmcLun [-ID] <String>] [-Silent] -VmaxStorageGroup <VmaxStorageGroup> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the LUN name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

BlockStorageSystem <IBlockStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI block storage system object, which you can add to ESI by using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object by using the Get-EmcStorageSystem cmdlet.

-Concrete <SwitchParameter>

Attributes: Optional, Position: named

Specifies the Concrete LUN type as an optional parameter, through which only Concrete LUNs can be filtered out. Do not use this parameter with the ID parameter. You can only use this with BlockStorageSystem.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-Pool <StoragePool>

Attributes: Optional, Position: named

Specifies the ESI storage pool object, which you can get from the ESI block storage system or by using the Get-EmcStoragePool cmdlet.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-Volume <Volume>

Attributes: Required, Position: named

Specifies the ESI volume object, which you can get by using the Get-EmcHostVolume cmdlet.

-ClusterSystem <IClusterSystem>

Attributes: Optional, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-ClusterDisk <WindowsBasicClusterDisk>

Attributes: Required, Position: named

Specifies the ESI cluster disk object, which you can get from the ESI cluster system object or by using the Get-EmcClusterDisk cmdlet.

-InitiatorId <String>

Attributes: Required, Position: named

Specifies the iSCSI or FC Initiator ID.

-HostLunId <String>

Attributes: Required, Position: named

Specifies the host LUN ID.

-HostLunIdentifier <HostLunIdentifier>

Attributes: Required, Position: named, Accepts pipeline input (by value)

Specifies the ESI host LUN identifier object, which you can get by using the Get-EmcHostLunIdentifier cmdlet.

-DataStore <Datastore>

Attributes: Required, Position: named

Specifies the VMware datastore object, which you can get by using the Get-EmcDatastore cmdlet.

-ScsiLun <ScsiLun>

Attributes: Required, Position: named

Specifies the ESI SCSI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcScsiLun cmdlet.

-MailboxDatabase <MailboxDatabase>

Attributes: Required, Position: named

Specifies the mailbox database associated with the specified LUN.

-MailboxDatabaseFileType <MailBoxDatabaseFileType>

Attributes: Optional, Position: named

Specifies the mailbox database file type associated with the host volume. It can be passed as an edbfile, logs, or All. By default it is set to All.

-MailboxDatabaseCopy <MailboxDatabaseCopy>

Attributes: Required, Position: named

Specifies the mailbox database copy.

-VmaxStorageGroup <VmaxStorageGroup>

Attributes: Required, Position: named

Specifies the ESI VMAX storage group object. You can get a VmaxStorageGroup object by using the Get-EmcVmaxStorageGroup cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcLun

C:\PS>Get-EmcStorageSystem | Get-EmcLun

C:\PS>Get-EmcStoragePool | Get-EmcLun

C:\PS>Get-EmcHostDisk | Get-EmcLun

C:\PS>Get-EmcHostVolume | Get-EmcLun

C:\PS>Get-EmcClusterDisk | Get-EmcLun

This example gets the list of disks as specified for all the connected storage systems, a specified storage system, host disks, host volumes, and cluster disks.

-------------- Example 2 --------------

C:\PS>Get-EmcLUN 12*

C:\PS>Get-EmcStorageSystem | Get-EmcLun -id my_*

C:\PS>Get-EmcHostDisk | Get-EmcLun my*

C:\PS>Get-EmcHostVolume | Get-EmcLun -id 224

This example gets the LUNs based on the LUN ID or name. Wildcards are permitted. Because the ID parameter is positional, you can omit the name.

-------------- Example 3 --------------

C:\PS>$ds = Get-EmcDatastore *myDatastore*

C:\PS>Get-EmcLun -Datastore $ds

This example gets the LUNs associated with the specified datastore object.

-------------- Example 4 --------------

C:\PS>$sl = Get-EmcScsiLun -ID *myScsiLun*

C:\PS> Get-EmcLUN -ScsiLun $sl

This example gets the LUN or LUNs associated with the specified SCSI LUN object.

-------------- Example 5 --------------

C:\PS>$cluster = Get-EmcClusterSystem myCluster

C:\PS>$cd = Get-EmcClusterDisk "Cluster Disk 1" -ClusterSystem $cluster

C:\PS>$vol = Get-EmcHostVolume "J:" -ClusterDisk $cd

C:\PS>Get-EmcLun -Volume $vol -ClusterSystem $cluster

This example gets the LUNs associated with the volume on the specified cluster.

---------- Example 6 ----------

C:\PS>$ss = Get-EmcStorageSystem myVNX

C:\PS>$h = Get-EmcHostSystem myHost

C:\PS>$initiator = Get-EmcHostBusAdapter -HostSystem $h

C:\PS>$initiatorId = $initiator.GlobalId

iqn.1991-05.com.microsoft:myHost.sr5dom.eng.emc.com

C:\PS>$view = Get-EmcLunMaskingView -StorageSystem $ss | where { $_.HostBusAdapterIds -match $initiatorId}

C:\PS>$view.LunHluPairs[0].Hlu

1

C:\PS>Get-EmcLun -BlockStorageSystem $ss -InitiatorId $initiatorId -HostLunId 1

This example gets the LUNs associated with the specified block storage system, initiator ID, and host LUN identifier.

---------- Example 7 ----------

C:\PS>$h = Get-EmcHostSystem myHost

C:\PS>$lunIdentifier = Get-EmcHostLunIdentifier - HostSystem $h

C:\PS>Get-EmcLun -HostLunIdentifier $lunIdentifier[0]

This example gets the LUNs that are associated with the specified host LUN identifier.

---------- Example 8 ----------

C:\PS>$db = Get-EmcMailboxDatabase MBDB1

C:\PS>Get-EmcLun -MailboxDatabase $db

This example gets the LUNs that are associated with the specified mailbox database.

---------- Example 9 ----------

C:\PS>$db= Get-EmcMailboxDatabase rvdb20

C:\PS>Get-EmcLun -MailboxDatabase $db -MailboxDatabaseFileType Logs

This example gets the LUNs for the log folder that is associated with the specified mailbox database.

---------- Example 10 ----------

C:\PS>$dbCopy= Get-EmcMailboxDatabaseCopy rvdb*

C:\PS>Get-EmcLun -MailboxDatabaseCopy $dbCopy -MailboxDatabaseFileType Logs

This example gets the LUNs for the log folder that is associated with the specified mailbox database copy.

---------- Example 11 ----------

C:\PS>$Storage= Get-EmcStorageSystem *myvmax*

C:\PS>$ConLun = Get-EmcLun -BlockStorageSystem $Storage -Concrete

This example applies a filter on the output of the Get-EmcLun cmdlet , specifying the LunType as ConcreteLun.

---------- Example 12 ----------

C:\PS>$storage = Get-EmcStorageSystem vmax348

C:\PS>$storagegroup=Get-EmcVmaxStorageGroup -StorageSystem $storage

C:\PS>Get-EmcLun -VmaxStorageGroup $storagegroup[0]

This example gets the list of LUNs based on the specified VMAX storage group.


Get-EmcLunMaskingView

Gets a list of LUN masking views.

Syntax

Get-EmcLunMaskingView [[-ID] <String>] [-StorageSystem <ISupportLunMasking>] [-InitiatorId <String[]>] [-Silent] [<CommonParameters>]

Description

Gets a list of LUN masking views. A LUN masking view object contains the information that a set of LUNs are unmasked to a set of initiators and the corresponding HLU (host logical unit) information of the unmasked LUNs with respect to those initiators.

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the LUN masking view name. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <ISupportLunMasking>

Attributes: Optional, Position: named

Specifies the ESI block storage system object, which you can add to ESI using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object by using the Get-EmcStorageSystem cmdlet.

-InitiatorId <String[]>

Attributes: Optional, Position: named

Specifies the iSCSI or FC initiator IDs.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$storage = Get-EmcStorageSystem clariion-1

C:\PS>Get-EmcLunMaskingView -StorageSystem $storage

This example gets LUN masking views from a specified storage system.

-------------- Example 2 --------------

C:\PS>Get-EmcLunMaskingView

This example gets LUN masking views from all storage systems.


Get-EmcScsiLun

Gets the list of VMware SCSI LUNs.

Syntax

  • Get-EmcScsiLun [[-ID] <String>] [-VcenterSystem <IVcenterSystem>] [-Lun <Lun>] [-Silent] [<CommonParameters>]

  • Get-EmcScsiLun [[-ID] <String>] [-Lun <Lun>] [-Silent] [-ESXHostSystem <IEsxHostSystem>] [<CommonParameters>]

  • Get-EmcScsiLun [[-ID] <String>] [-Silent] -Datastore <Datastore> [<CommonParameters>]

  • Get-EmcScsiLun [[-ID] <String>] [-Lun <Lun>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the device name, canonical name, or ID for the VMware SCSI LUN. Wildcards are permitted. It is a positional parameter (position = 1).

-VcenterSystem <IVcenterSystem>

Attributes: Optional, Position: named

Specifies the vCenter server.

-Lun <Lun>

Attributes: Optional, Position: named

Specifies the ESI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ESXHostSystem <IEsxHostSystem>

Attributes: Optional, Position: named

Specifies the ESI ESX host system object, which you can get by using the Get-EmcESXHost cmdlet.

-Datastore <Datastore>

Attributes: Required, Position: named

Specifies the ESI VMware datastore object, which you can get by using the Get-EmcDatastore cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$vc = Get-EmcVcenterSystem *myVcenter*

C:\PS>Get-EmcScsiLun -VcenterSystem $vc

This example gets all SCSI LUNs of a specified Vcenter server.

-------------- Example 2 --------------

C:\PS>$vc = Get-EmcVcenterSystem *myVcenter*

C:\PS>$esxhost = Get-EmcESXHost -VcenterSystem $vc

C:\PS>Get-EmcScsiLun -ESXHostSystem $esxhost

This example gets all SCSI LUNs for a specified ESX host.

-------------- Example 3 --------------

C:\PS>$lun = Get-EmcLUN -ID 298

C:\PS> Get-EmcScsiLun -Lun $lun

This example gets the SCSI LUN associated with a specified LUN object.

-------------- Example 4 --------------

C:\PS>$ds = Get-EmcDatastore *myDatastore*

C:\PS>Get-EmcScsiLun -Datastore $ds

This example gets the SCSI LUN associated with the specified database object.


Get-EmcSnapshotLun

Gets the list of snapshot LUNs.

Syntax

Get-EmcSnapshotLun [-ID <String>] [-SourceLun <Lun>] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Get-EmcSnapshotLun [-ID <String>] [-Silent] [-PipelineVariable <String>] [-BlockStorageSystem <IBlockStorageSystem>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the snapshot LUN name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-SourceLun <Lun>

Attributes: Optional, Position: named

Specifies the ESI (EMC Storage Integrator) Lun object. A Lun object can be obtained by using ESI Storage System object or by using Get-EmcLun Cmdlet. This parameter is not mandatory for some storage systems.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

PipelineVariable stores the value of the current pipeline element as a variable, for any named command as it flows through the pipeline.Valid values are strings, the same as for any variable names.

-BlockStorageSystem <IBlockStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI (EMC Storage Integrator) Block Storage System object. A storage system object can be added to ESI using Get-EmcStorageSystemCredential and Connect-EmcSystem Cmdlets. A storage system object can be obtained using Get-EmcStorageSystem Cmdlet.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Get-EmcSnapshotLun

Gets all the snapshot luns of the connected storage systems.

---------- EXAMPLE 2 ----------

C:\PS>Get-EmcSnapshotLun -id my*

C:\PS>Get-EmcSnapshotLun my*

C:\PS>Get-EmcSnapshotLun -ID 12

C:\PS>Get-EmcSnapshotLun 12

Gets the snapshot luns based on lun id or name (accepts wildcard).

Because id parameter is positional, you can omit the name.

---------- EXAMPLE 3 ----------

C:\PS>$vnxblock1 = Get-EmcStorageSystem myVNX

C:\PS>Get-EmcSnapshotLun -BlockStorageSystem $vnxblock1

SourceLunId : 98

SnapshotPoolId :

IsActivated : False

PointInTime : 1/1/0001 12:00:00 AM

StorageSystemGlobalId : 94627bc5-cfb4-4482-8347-4324b8780261

ArrayPoolId : ~SnapshotLunGroup

ArrayLunId : lun98snapshot1

Wwn : 60:06:01:60:97:41:2E:00:6E:E6:44:E8:1F:A3:E1:11

Name : lun98snapshot1

Capacity : 1.000 GB

Description :

IsPrivate : False

CanDestroy : True

CanExtend : False

ServiceNodeIds : {}

OperationalStatus : {OK}

StatusMessages : {INACTIVE}

OtherProperties : {}

Tag :

DefaultStringForOtherProperties : ()

This example shows how to get SnapshotLuns on a particular storage system.

---------- EXAMPLE 4 ----------

C:\PS>$source = Get-EmcLun 98

C:\PS>Get-EmcSnapshotLun -SourceLun $source

SourceLunId : 98

SnapshotPoolId :

IsActivated : False

PointInTime : 1/1/0001 12:00:00 AM

StorageSystemGlobalId : 94627bc5-cfb4-4482-8347-4324b8780261

ArrayPoolId : ~SnapshotLunGroup

ArrayLunId : lun98snapshot1

Wwn : 60:06:01:60:97:41:2E:00:6E:E6:44:E8:1F:A3:E1:11

Name : lun98snapshot1

Capacity : 1.000 GB

Description :

IsPrivate : False

CanDestroy : True

CanExtend : False

ServiceNodeIds : {}

OperationalStatus : {OK}

StatusMessages : {INACTIVE}

OtherProperties : {}

Tag :

DefaultStringForOtherProperties : ()

This example shows how to get the SnapshotLuns for a given source Lun.

---------- EXAMPLE 5 ----------

C:\PS>$xtremIO = Get-EmcStorageSystem myXIO

C:\PS>Get-EmcSnapshotLun -BlockStorageSystem $xtremIO

SourceLunId : 2

SnapshotPoolId :

IsActivated : False

PointInTime : 12/10/2014 9:38:25 AM

StorageSystemGlobalId : 51eece59-1599-481d-b79f-4cb7a23fbe98

ArrayPoolIds : {xio42220}

ArrayLunId : 51

Wwn :

Name : Min_ESA_XIO_add1 changenameMin_ESA_vROps6GA.snap.12102014-23:33

Capacity : 7.000 GB

Description :

IsPrivate : False

CompositionInfo : <Not a composite LUN>

CanDestroy : True

CanExtend : True

ServiceNodeIds : {}

OperationalStatus : {Information}

StatusMessages :

DisplayName :

OtherProperties : {[naa, ], [folder, /]}

Tag :

DefaultStringForOtherProperties : (naa, folder=/)]

This example shows how to get SnapshotLuns on a particular storage system.


Get-EmcSnapshotPool

Gets the list of snapshot Pools.

Syntax

Get-EmcSnapshotPool [-ID <String>] [-BlockStorageSystem <IBlockStorageSystem>]  [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the snapshot pool ID. Wildcards are permitted. It is a positional parameter (position = 1).

-BlockStorageSystem <IBlockStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI (EMC Storage Integrator) Block Storage System object. A storage system object can be added to ESI using Get-EmcStorageSystemCredential and Connect-EmcSystem Cmdlets. A storage system object can be obtained using Get-EmcStorageSystem Cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Get-EmcSnapshotPool

Gets all the snapshot pools from all the connected storage systems.

---------- EXAMPLE 2 ----------

C:\PS>Get-EmcSnapshotPool -id 12

C:\PS>Get-EmcSnapshotPool 12

Gets the snapshot pool(s) based on pool id (accepts wildcard). Because id parameter is positional, you can omit the name.

---------- EXAMPLE 3 ----------

C:\PS>Get-EmcSnapshotPool -BlockStorageSystem $vnxblock1

StorageSystemGlobalId : 94627bc5-cfb4-4482-8347-4324b8780261

PoolId : Reserved LUN Pool

UserCapacity : 19.993 GB

AvailableCapacity : 16.000 GB

OtherProperties : {}

Tag :

DefaultStringForOtherProperties : ()

This example shows how to get the SnapshotPools on a particular storage system.


Get-EmcStoragePool

Gets the list of storage pools.

Syntax

  • Get-EmcStoragePool [[-ID] <String>] [-Lun <ConcreteLun>] [-Silent] [<CommonParameters>]

  • Get-EmcStoragePool [[-ID] <String>] [-Silent] [-StorageSystem <IStorageSystem>] [-PoolType <GetEmcStoragePoolCmdlet+PoolTypeValues>] [<CommonParameters>]

  • Get-EmcStoragePool [-ID <String>] [-Silent] [-VmaxFastVpPolicy <VmaxFastVpPolicy>] [<CommonParameters>]

  • Get-EmcStoragePool [-ID <String>] [-Silent] [-VmaxStorageTier <VmaxFastStorageTier>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the storage pool name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Lun <ConcreteLun>

Attributes: Optional, Position: named

Specifies the ESI LUN object. You can get a LUN object by using the ESI storage system object or by using the Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-StorageSystem <IStorageSystem>

Attributes: Required, Position: named

Specifies the ESI storage system object. You can add a storage system object to ESI by using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object by using the Get-EmcStorageSystem cmdlet.

-PoolType <GetEmcStoragePoolCmdlet+PoolTypeValues>

Attributes: Optional, Position: named

Specifies the storage pool type to retrieve. The Block value retrieves storage pools for block storage.

-VmaxFastVpPolicy <VmaxFastVpPolicy>

Attributes: Optional, Position: named

Specifies the ESI FAST VP policy system object. You can get a FAST VP policy object with the Get-EmcFastVpPolicy cmdlet.

-VmaxStorageTier <VmaxFastStorageTier>

Attributes: Optional, Position: named

Specifies the ESI FAST storage tier object. You can get a FAST storage tier with the Get-EmcStorageTier cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcStoragePool

C:\PS>Get-EmcStorageSystem | Get-EmcStoragePool

C:\PS>$l = Get-EmcLUN

C:\PS>$l[0] | Get-EmcStoragePool |select ArrayPoolId

This example gets the list of storage pools from all the connected storage systems, specified storage systems, or specified LUNs.

-------------- Example 2 --------------

C:\PS>Get-EmcStoragePool -id my*

C:\PS>Get-EmcStorageSystem | Get-EmcStoragePool my*

C:\PS>Get-EmcStoragePool -id 12

C:\PS>Get-EmcStorageSystem | Get-EmcStoragePool 12

This example gets the storage pools based on the pool ID or name. Wildcards are accepted. Because the ID parameter is positional, you can omit the name.

-------------- Example 3 --------------

C:\PS>Get-EmcStorageSystem | Get-EmcStoragePool my* -PoolType Block

This example gets the storage pools based on pool ID or name. Wildcards are permitted. Because the ID parameter is positional, you can omit the name. The PoolType is specified by its parameter, as shown in the example.

-------------- Example 4 --------------

C:\PS>$policy=Get-EmcFastVpPolicy -StorageSystem $storage

C:\PS>Get-EmcStoragePool -FastVpPolicy $policy[0]

This example gets the storage pools based on the FAST VP policy.

---------- Example 5 ----------

C:\PS>$storagetier=Get-EmcStorageTier -StorageSystem $storage

C:\PS>Get-EmcStoragePool -StorageTier $storagetier[0]

This example gets the storage pool based on the storage tier.


Get-EmcStorageRegisteredHost

Gets a list of registered hosts for a specified storage system. This cmdlet is not supported for VMAX storage systems.

Syntax

Get-EmcStorageRegisteredHost [[-ID] <String>] [-StorageSystem <IRequireRemoteHostRegistration>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the host name or IP address. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <IRequireRemoteHostRegistration>

Attributes: Optional, Position: named

Specifies the ESI storage system object, which you can be add to ESI using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object by using the Get-EmcStorageSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcStorageRegisteredHost 10.2.5.252

C:\PS>Get-EmcStorageRegisteredHost TestHost.localdomain

This example gets the registered host for a storage system based on the specified host name or IP address.

-------------- Example 2 --------------

C:\PS>$ss = Get-EmcStorageSystem storage01

C:\PS>Get-EmcStorageRegisteredHost -StorageSystem $ss

This example gets the registered host for a specified storage system.


Get-EmcStorageRegisteredInitiator

Gets the list of host initiators that are registered on the storage systems. This cmdlet is not supported for VMAX storage systems.

Syntax

Get-EmcStorageRegisteredInitiatorId [[-ID] <String>] [-StorageSystem <IRequireRemoteHostRegistration>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the host name or IP address. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <IRequireRemoteHostRegistration>

Attributes: Optional, Position: named

Specifies the storage system.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$ss = Get-EmcStorageSystem storage01

C:\PS>Get-EmcStorageRegisteredInitiator -StorageSystem $ss

This example gets the registered initiators for a specified storage system.

-------------- Example 2 --------------

C:\PS>Get-EmcStorageRegisteredInitiator

This example gets the registered initiators for all storage systems.


Get-EmcStorageServiceNode

Gets the list of storage service nodes.

Syntax

  • Get-EmcStorageServiceNode [[-ID] <String>] [-StorageSystem <IStorageSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcStorageServiceNode [[-ID] <String>] [-Silent] [-Pool <StoragePool>] [<CommonParameters>]

  • Get-EmcStorageServiceNode [[-ID] <String>] [-Silent] [-Lun <Lun>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the storage pool name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <IStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI storage system object. You can add this object to ESI by using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get this object by using the Get-EmcStorageSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-Pool <StoragePool>

Attributes: Optional, Position: named

Specifies the ESI storage pool object, which you can get with the ESI block storage system or by using the Get-EmcStoragePool cmdlet.

-Lun <Lun>

Attributes: Optional, Position: named

Specifies the ESI LUN object, which you can get with the ESI storage system object or by using the Get-EmcLun cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcStorageServiceNode | select DisplayText

DisplayText

------------

iscsi_node_0(iqn.1992-05.com.emc:apm001120033400000-1-vnxe)

file_server_0(10.5.223.114)

This example gets the displayed text for the storage service nodes on all registered storage systems.

-------------- Example 2 --------------

C:\PS>$lun = Get-EmcLun myLun

C:\PS>Get-EmcStorageServiceNode -Lun $lun

StorageSystemGlobalId : 2cb81f21-f91d-41e6-b874-cef1f3401f99

ServiceNodeId : iscsi_node_2

DisplayText : iscsi_node_2(iqn.1992-05.com.emc:apm001203015100000-3-vnxe)

StoragePorts : {iqn.1992-05.com.emc:apm001203015100000-3-vnxe}

Modules : {}

OperationalStatus :

StatusMessages :

DisplayName :

OtherProperties : {}

Tag :

DefaultStringForOtherProperties : ()

This example gets the storage service nodes that serve the data service for the specified LUN.

---------- Example 3 ----------

C:\PS>$pool = Get-EmcStoragePool

C:\PS>Get-EmcStorageServiceNode -Pool $pool[0]

This example gets the storage service nodes that serve the data service for the specified pool.


Get-EmcStorageSystem

Gets the list of storage systems.

Syntax

  • Get-EmcStorageSystem [[-Id] <String>] [-SystemType <String>] [-Silent] [<CommonParameters>]

  • Get-EmcStorageSystem [[-Id] <String>] [-SystemType <String>] [-Silent] -BlockStorageSystem [<CommonParameters>]

  • Get-EmcStorageSystem [-Silent] -Lun <Lun> [<CommonParameters>]

  • Get-EmcStorageSystem [-Silent] -Pool <StoragePool> [<CommonParameters>]

  • Get-EmcStorageSystem [-Silent] -LunMaskingView <LunMaskingView> [<CommonParameters>]

  • Get-EmcStorageSystem [-Silent] -ReplicationServiceSite <ReplicationServiceSite> [<CommonParameters>]

  • Get-EmcStorageSystem [-Silent] -FastVpPolicy <FastVpPolicy> [<CommonParameters>]

  • Get-EmcStorageSystem [-Silent] -VmaxStorageGroup <VmaxStorageGroup> [<CommonParameters>]

  • Get-EmcStorageSystem [-Silent] -StorageTier <FastStorageTier> [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the storage system name, user-friendly name, or global ID. Wildcards are permitted. It is a positional parameter (position = 1).

-SystemType <String>

Attributes: Optional, Position: named

Specifies the storage system type. Valid values are VMAX, VNX-Block, VNXe.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-BlockStorageSystem <SwitchParameter>

Attributes: Required, Position: named

Enumerates block storage systems.

-Lun <Lun>

Attributes: Required, Position: named

Specifies the ESI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcLun cmdlet.

-Pool <StoragePool>

Attributes: Required, Position: named

Specifies the ESI pool object, which you can get by using the ESI storage system object or by using the Get-EmcStoragePool cmdlet.

-LunMaskingView <LunMaskingView>

Attributes: Required, Position: named

Specifies the ESI LunMaskingView system object, which can be obtained by using the Get-EmcLunMaskingView cmdlet.

-ReplicationServiceSite <ReplicationServiceSite>

Attributes: Required, Position: named

Specifies the replication site in which the replication system resides.

-FastVpPolicy <FastVpPolicy>

Attributes: Required, Position: named

Specifies the ESI FAST VP policy system object. You can get the FAST VP policy system object with the Get-EmcFastVpPolicy cmdlet.

-VmaxStorageGroup <VmaxStorageGroup>

Attributes: Optional, Position: named

Specifies the ESI VMAX storage group object. You can get a VMAX storage group object with the ESI Storage System object or Get-EmcVmaxStorageGroup cmdlet.

-StorageTier <FastStorageTier>

Attributes: Required, Position: named

Specifies the ESI Storage Tier object. You can get the storage tier object with the Get-EmcStorageTier cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcStorageSystem

C:\PS>Get-EmcStoragePool gold* | Get-EmcStorageSystem | select name

C:\PS>$l = Get-EmcLUN

C:\PS>$l[0] | Get-EmcStorageSystem

This example gets the storage systems.

-------------- Example 2 --------------

C:\PS>Get-EmcStorageSystem -BlockStorageSystem

This example gets the connected block storage systems.

-------------- Example 3 --------------

C:\PS>Get-EmcStorageSystem -SystemType VNX-Block

This example gets the VNX block storage systems.

-------------- Example 4 --------------

C:\PS>$lmv = Get-EmcLunMaskingView testMachine*

C:\PS>Get-EmcStorageSystem -LunMaskingView $lmv

This example gets the storage system based on the LUN masking view.

-------------- Example 5 --------------

C:\PS>$site = Get-EmcReplicationServiceSite

C:\PS>Get-EmcStorageSystem --ReplicationServiceSite $site[0]

This example gets the storage system based on the replication service site.

-------------- Example 6 --------------

C:\PS>$policy = Get-EmcFastVpPolicy

C:\PS>Get-EmcStorageSystem -FastVpPolicy $policy[0]

This example gets the storage system based on the FAST VP policy.

-------------- Example 7 --------------

C:\PS>$storagegroup = Get-EmcVMaxStorageGroup

C:\PS>Get-EmcStorageSystem -VmaxStorageGroup $storagegroup [0]

This example gets the storage system based on the storage group.

-------------- Example 8 --------------

C:\PS>$storagetier = Get-EmcStorageTier

C:\PS>Get-EmcStorageSystem -StorageTier $storagetier[0]

This example gets the storage system based on the storage tier.


Get-EmcVnxAdvancedSnapshot

Gets the list of Vnx advanced snapshots.

Syntax

  • Get-EmcVnxAdvancedSnapshot [-ID <String>] [-SourceLun <Lun>] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

  • Get-EmcVnxAdvancedSnapshot [-ID <String>] [-PipelineVariable <String>] [-BlockStorageSystem <IBlockStorageSystem>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name of the Vnx advanced snapshot (VnxAdvancedSnapshot ID). Wildcards are permitted. It is a positional parameter (position = 1).

-SourceLun <Lun>

Attributes: Optional, Position: named

Specifies the ESI LUN object. You can get a LUN object with the ESI storage system object or the Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-BlockStorageSystem <IBlockStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI storage system object. You can add a storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get the storage system object with the Get-EmcStorageSystem cmdlet

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

---------- EXAMPLE 1 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

$lun= Get-EmcLun -ID 25 -BlockStorageSystem $storage

C:\PS>Get-EmcVnxAdvancedSnapshot -SourceLun $lun

This example gets all the advanced snapshots of the specified LUN.

---------- EXAMPLE 2 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

C:\PS>Get-EmcVnxAdvancedSnapshot -BlockStorageSystem $storage

This example will get all the advanced snapshots that belong to specified storage system.


Get-EmcVnxAdvancedSnapshotMountPoint

Gets the list of Vnx advanced snapshot mount points.

Syntax

Get-EmcVnxAdvancedSnapshotMountPoint [-ID <String>] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Get-EmcVnxAdvancedSnapshotMountPoint [-ID <String>] [-Silent] [-PipelineVariable <String>] [-BlockStorageSystem <IBlockStorageSystem>] [<CommonParameters>]

Description
Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name of the Vnx advanced snapshot mount point (VnxAdvancedSnapshotMountPoint ID). Wildcards are permitted. It is a positional parameter (position = 1).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-BlockStorageSystem <IBlockStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI storage system object. You can add a storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get the storage system object with the Get-EmcStorageSystem cmdlet

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Example

---------- EXAMPLE 1 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

C:\PS>Get-EmcVnxAdvancedSnapshotMountPoint -ID "smp1" -BlockStorageSystem $storage

This example will get all the advanced snapshot mount points belong to specified storage system.


Get-EmcSupportedSystem

Gets the list of supported systems.

Syntax

Get-EmcSupportedSystem [-Silent] [<CommonParameters>]

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcSupportedSystem

vSphere/vCenter Server

VNXe

VNX-Block

VMAX

XtremIO

RecoverPoint

Exchange

Windows Server 2008 R2

Windows Server 2012

Microsoft Hyper-V

This example gets the list of supported systems.


Get-EmcTargetPort

Gets the list of target ports.

Syntax

  • Get-EmcTargetPort [[-ID] <String>] [-BlockStorageSystem <IBlockStorageSystem>] [-PortType <String>] [-Silent] [<CommonParameters>]

  • Get-EmcTargetPort [[-ID] <String>] [-PortType <String>] [-Silent] [-Pool <LunStoragePool>] [<CommonParameters>]

  • Get-EmcTargetPort [[-ID] <String>] [-PortType <String>] [-Silent] [-Lun <Lun>] [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the target port ID. Wildcards are permitted. It is a positional parameter (position = 1).

-BlockStorageSystem <IBlockStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI block storage system object, which can be added to ESI by using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object by using the Get-EmcStorageSystem cmdlet.

-PortType <String>

Attributes: Optional, Position: named

Specifies the port type. The value can be All, FC, or iSCSI.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-Pool <LunStoragePool>

Attributes: Optional, Position: named

Specifies the ESI storage pool object, which you can get from the ESI block storage system or by using the Get-EmcStoragePool cmdlet.

-Lun <Lun>

Attributes: Optional, Position: named

Specifies the ESI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcLun cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcTargetPort | select Iqn, IP address

Iqn IP address

--- ---------

iqn.1992-05.com.emc:apm001120033400000-1-vnxe 10.5.223.115

iqn.1992-05.com.emc:apm001120033400000-1-vnxe 10.5.223.116

This example gets the IQN and IP address information of the target ports on all registered storage systems.

-------------- Example 2 --------------

C:\PS>$lun = Get-EmcLun testlun

C:\PS>Get-EmcTargetPort -Lun $lun

Iqn : iqn.1992-05.com.emc:apm001120033400000-1-vnxe

IP address : 10.5.223.115

Port : 3260

InitiatorAuthentication : False

StorageSystemGlobalId : ae5107a4-0e17-4a3b-86c7-5cf84eed4e0e

ServiceNodeId : iscsi_node_0

TargetPortId : if_0

LinkState : Up

Status : OK

OtherProperties : {}

Tag :

DefaultStringForOtherProperties : ()

Iqn : iqn.1992-05.com.emc:apm001120033400000-1-vnxe

IP address : 10.5.223.116

Port : 3260

InitiatorAuthentication : False

StorageSystemGlobalId : ae5107a4-0e17-4a3b-86c7-5cf84eed4e0e

ServiceNodeId : iscsi_node_0

TargetPortId : if_1

LinkState : Up

Status : OK

OtherProperties : {}

Tag :

DefaultStringForOtherProperties : () ]

This example gets the target ports that serve the data service for the specified LUN.

-------------- Example 3 --------------

C:\PS>$pool = Get-EmcStoragePool myPool

C:\PS> Get-EmcTargetPort -Pool $pool -PortType FC

This example gets the FC target ports that serve the data service for the specified pool.


Get-EmcVnxeLunGroup

Gets LUN groups on the connected VNXe systems. LUN groups enable consistent snapshots of multiple LUNs and are used to grant hosts access to LUNs and to snapshots of LUNs in the group.

Note: This command is for VNXe3200 systems only.

Syntax

Get-EmcVnxeLunGroup [-ID <String>] [-StorageSystem <IStorageSystem>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the VNXe LUN group name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <IStorageSystem>

Attributes: Optional, Position: named

Optional parameter, if omitted, the cmdlet returns results from all connected VNXe systems.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$ss = Get-EmcStorageSystem TestVNXe

Get-EmcVnxeLunGroup -StorageSystem $ss

Gets the LUN groups for the specified storage system.


Get-EmcVnxeLunGroupMember

Gets the members of a LUN group. A LUN group has three types of members: LUNs, hosts that have access to LUNs in the group, and hosts that have access to snapshots of LUNs in the group. The -IncludeLuns, -IncludeLunHosts, and -IncludeSnapshotHosts parameters return only those specific types of members. If omitted, the cmdlet returns all member types.

Note: This command is for VNXe3200 systems only.

Syntax

Get-EmcVnxeLunGroupMember -LunGroup <Vnx2eLunGroup> [-IncludeLuns] [-IncludeLunHosts] [-IncludeSnapshotHosts] [-Silent] [<CommonParameters>]

Parameters

-LunGroup <Vnx2eLunGroup>

Attributes: Required, Position: named

Specifies the LUN group, which you can get with the Get-EmcVnxeLunGroup cmdlet.

-IncludeLuns <SwitchParameter>

Attributes: Optional, Position: named

If specified, includes the LUNs in the group.

-IncludeLunHosts <SwitchParameter>

Attributes: Optional, Position: named

If specified, includes the hosts that have access to LUNs in the group.

-IncludeSnapshotHosts <SwitchParameter>

Attributes: Optional, Position: named

If specified, includes the hosts that have access to snapshots of LUNs in the group.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$group = Get-EmcVnxeLunGroup TestLG

Get-EmcVnxeLunGroupMember -LunGroup $group -IncludeLuns

Gets all LUNs in the specified LUN group.


Get-EmcVnxeSnapshot

Gets the snapshots on connected VNXe systems. You can retrieve snapshots of a particular source LUN or LUN group with the Source parameter.

Note: This command is for VNXe3200 systems only.

Syntax

  • Get-EmcVnxeSnapshot [-ID <String>] [-StorageSystem <IStorageSystem>] [-IncludeLunSnapshots] [-IncludeLunGroupSnapshots] [-Silent] [<CommonParameters>]

  • Get-EmcVnxeSnapshot [-ID <String>] [-Silent] -Source <Object> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the VNXe LUN group name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-StorageSystem <IStorageSystem>

Attributes: Optional, Position: named

Optional parameter, if omitted, the cmdlet returns results from all connected VNXe systems.

-IncludeLunSnapshots <SwitchParameter>

Attributes: Optional, Position: named

If specified, includes the LUN snapshots.

-IncludeLunGroupSnapshots <SwitchParameter>

Attributes: Optional, Position: named

If specified, includes LUN group snapshots.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-Source <Object>

Attributes: Required, Position: named

If specified, includes the snapshots of the specified source LUN, LUN group, or file system.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$ss = Get-EmcStorageSystem TestVNXe

Get-EmcVnxeSnapshot -StorageSystem $ss

Gets all snapshots from the specified storage system.

-------------- Example 2 --------------

C:\PS>$ss = Get-EmcStorageSystem TestVNXe

Get-EmcVnxeSnapshot -StorageSystem $ss -IncludeLunGroupSnapshots

Gets all LUN group snapshots from the specified storage system.

-------------- Example 3 --------------

C:\PS>$group = Get-EmcVnxeLunGroup TestLG

Get-EmcVnxeSnapshot -Source $group

Gets all snapshots of the specified LUN group.


Get-EmcXBrick

Get a list of X-Brick information from XtremIO storage system.

Syntax

  • Get-EmcXBrick [-ID <String>] [-Silent] [<CommonParameters>]

  • Get-EmcXBrick [-ID <String>] [-Silent] [-XioStorageSystem <IXioStorageSystem>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the LUN name or ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-XioStorageSystem <IXioStorageSystem>

Attributes: Optional, Position: named

Specifies the ESI XtremIO storage system object. You can add a storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object with the Get-EmcStorageSystem cmdlet and then choose the XtremIO object from that list.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcXBrick -ID < String >

This example gets the X-Brick with the specified ID.

-------------- Example 2 --------------

C:\PS>Get-EmcXBrick -ID < String > -XioStorageSystem < IXioStorageSystem >

This example gets the X-Brick or X-Bricks with the specified ID and the EMC XtremIO storage system.


Dismount-EmcVnxAdvancedSnapshot

Dismounts/Detaches the Vnx advanced snapshot with associated snapshot mount point LUN.

Syntax

Dismount-EmcVnxAdvancedSnapshot -AdvancedSnapshot <VnxAdvancedSnapshot> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-AdvancedSnapshot <VnxAdvancedSnapshot>

Attributes: Required, Position: named

Specifies the ESI VnxAdvancedSnapshot object. You can get a VnxAdvancedSnapshot object using Get-EmcVnxAdvancedSnapshot commandlet.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user's confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

---------- EXAMPLE 1 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

C:\PS>$snapshot = Get-EmcVnxAdvancedSnapshot -ID "firstsnap" -BlockStorageSystem $storage

C:\PS>Dismount-EmcVnxAdvancedSnapshot -AdvancedSnapshot $snapshot

This examples detaches specified advanced snapshot with associated snapshotmountpoint.


Expand-EmcFileBasedDisk

Expands the size of a file-based disk.

Syntax

Expand-EmcFileBasedDisk -Size <UInt64> -VirtualMachineConfiguration <VirtualMachineConfiguration> -Location <UInt32> [-ScsiControllerId <String>] [-ScsiControllerIndex <Int32>] [-Silent] [<CommonParameters>]

Parameters

-Size <UInt64>

Attributes: Required, Position: named

Specifies the size of the file-based disk.

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: named

Specifies the ESI Virtual Machine Configuration object, which you can get from the ESI hypervisor host system object VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet. The cmdlets encapsulate VM configuration information, including status, MAC addresses, GUID, attached file-based disks, pass-through disks, and other disks.

-Location <UInt32>

Attributes: Required, Position: named

Specifies the available location or LUN number of the specified SCSI controller for adding the file-based disk. You can get the available SCSI controller location from the VM hypervisor object or by using the Get-EmcAvailableScsiControllerLocation cmdlet.

-ScsiControllerId <String>

Attributes: Optional, Position: named

Specifies the SCSI controller ID for adding to the specified file-based disk. You can get the ID from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-ScsiControllerIndex <Int32>

Attributes: Optional, Position: named

Specifies the SCSI controller zero-based index to add or attach to a specified file-based disk. You can get SCSI controller information for a virtual machine from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$h = Get-EmcVcenterSystem

C:\PS>$h | update-emcsystem

C:\PS>$h.VirtualMachinesConfigurations | select name

C:\PS>$vmconfig = $h.VirtualMachinesConfigurations[0]

C:\PS>$scsicontroller = Get-EmcVirtualMachineScsiController –VirtualMachineConfiguration $vmconfig

C:\PS>$locations = Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration $vmconfig -ScsiControllerId $scsicontroller.ScsiControllerId

C:\PS>$Expand-EmcFileBasedDisk -Size 2GB -VirtualMachineConfiguration $vmconfig -Location $location[0] -ScsiControllerIndex $scsicontroller.ScsiControllerIndex

This example expands the size of a file-based disk.


Get-EmcAvailableCandidatesForLunComposition

Gets all the LUNs which are qualified to be a member LUN of the specified meta, meta volume, or composite LUN.

Syntax

Get-EmcAvailableCandidatesForLunComposition [-ID <String>] -Lun <Lun> [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the LUN name or LUN ID. Wildcards are permitted.

-Lun <Lun[]>

Attributes: Required, Position: named

Specifies the ESI LUN object. You can get a LUN object with the ESI Storage System object or Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$lun = Get-EmcLun -ID 14

C:\PS>$candidates= Get-EmcAvailableCandidatesForLunComposition $lun

This example gets the available candidates for the meta or LUN composition on the storage system based on the specified LUN.


Get-EmcCompositeLunMember

Gets one or more meta or composite LUN members of the specified composite LUN head.

Syntax

Get-EmcCompositeLunMember [-ID <String>] -CompositeLunHead <Lun> [-ExcludeCompositeHead] [-CompositionConfiguration <CompositionConfiguration>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the LUN name or LUN ID. Wildcards are permitted.

-StorageSystem <IStorageSystem>

Attributes: Required, Position: named

Specifies the Storage System object. You can add the storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get the storage system object with the Get-EmcStorageSystem cmdlet.

-CompositeLunHead <Lun>

Attributes: Required, Position: named

Specifies the ESI LUN object. You can get the LUN object with the Get-EmcCompositeLunHead cmdlet.

-ExcludeCompositeHead <SwitchParameter>

Attributes: Optional, Position: named

Excludes the specified composite LUN head.

-CompositionConfiguration <CompositionConfiguration>

Attributes: Optional, Position: named

Specifies the composite configuration object, which can be either striped, concatenated, or both.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Getting storage system

$storage= Get-EmcStorageSystem *480

C:\PS>$compositelunhead= Get-EmcCompositeLunHead -StorageSystem $storage -ID 14

C:\PS>$compositelunmember= Get-EmcCompositeLunMember -CompositeLunHead $compositelunhead

Gets the composite LUN member or members from the specified meta or composite LUN head for the specified storage system.


Mount-EmcVnxeSnapshot

Mounts a VNXe LUN or LUN group snapshot so it is visible to hosts in the snapshot access list for the LUN or LUN group.

Note: This command is for VNXe3200 systems only.

Syntax

Mount-EmcVnxeSnapshot -Snapshot <Vnx2eSnapshot> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Snapshot <Vnx2eSnapshot>

Attributes: Required, Position: 1

Specifies the LUN or LUN group snapshot to mount.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$snap = Get-EmcVnxeSnapshot TestLunGroupSnap

Mount-EmcVnxeSnapshot -Snapshot $snap

Mounts a specified LUN group snapshot.


Mount-EmcVnxAdvancedSnapshot

Mounts/attaches the VNX advanced snapshot with specified snapshot mount point LUN.

Syntax

Mount-EmcVnxAdvancedSnapshot -AdvancedSnapshot <VnxAdvancedSnapshot> -AdvancedSnapshotMountPoint <VnxAdvancedSnapshotMountPoint> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-AdvancedSnapshot <VnxAdvancedSnapshot>

Attributes: Required, Position: named

Specifies the ESI VnxAdvancedSnapshot object. You can get a VnxAdvancedSnapshot object using Get-EmcVnxAdvancedSnapshot commandlet.

-AdvancedSnapshotMountPoint <VnxAdvancedSnapshotMountPoint>

Attributes: Required, Position: named

Specifies the ESI VnxAdvancedSnapshotMountPoint object. You can get a VnxAdvancedSnapshotMountPoint object using Get-EmcVnxAdvancedSnapshotMountPoint commandlet.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user's confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

C:\PS>$snapshot = Get-EmcVnxAdvancedSnapshot -ID "firstsnap" -BlockStorageSystem $storage

C:\PS>$smp = Get-EmcVnxAdvancedSnapshotMountPoint -ID "firstsmp" -BlockStorageSystem $storage

C:\PS>Mount-EmcVnxAdvancedSnapshot -AdvancedSnapshot $snapshot -AdvancedSnapshotMountPoint $smp

This examples attaches specified advanced snapshot with specified snapshot mount point.


New-EmcLun

Creates a new ESI LUN object.

Syntax

  • New-EmcLun -Pool <StoragePool> [-Name <String>] -Capacity <UInt64> [-ApplicationHint <String>] [StorageFolder <String>] [-Thick] [-Description <String>] [-VNXLunAllocationPolicy <VNXLunAllocationPolicy>] [-VNXTieringPolicy <VNXTieringPolicy>] [-IgnoreThresholds] [-Silent] [<CommonParameters>]
  • New-EmcLun [-Name <String>] -Capacity <UInt64> [-Description <String>] [-Silent] -StorageSystem <IVmaxStorageSystem2> [<CommonParameters>]

Parameters

-Pool <StoragePool>

Attributes: Optional, Position: named

Specifies the ESI storage pool object. You can get a storage pool object with the ESI block storage system or Get-EmcStoragePool cmdlet.

-Name <String>

Attributes: Optional, Position: named

Specifies the name of the new LUN.

-Capacity <UInt64>

Attributes: Required, Position: named

Specifies the capacity of the LUN to be created.

-ApplicationHint <String>

Attributes: Optional, Position: named

Specifies the application that the new LUN will be potentially used for. Some storage systems are application-aware. Currently, HyperV and VMware are acceptable strings for this parameter for creating a new LUN on VNXe3100, VNXe3150, or VNXe3300.

-StorageFolder <String>

Attributes: Optional, Position: named

Specifies the storage folder path that is used to create volumes for the specified XtremIO system. This parameter is for XtremIO only.

-StorageServiceNode <StorageServiceNode>

Attributes: Optional, Position: named

Specifies the ESI storage service node object, which you can get by using the Get-EmcStorageServiceNode cmdlet.

-Thick <SwitchParameter>

Attributes: Optional, Position: named

Enables thick provisioning. If the pool supports both thin provisioning and thick provisioning, thin provisioning is used by default.

-Description <String>

Attributes: Optional, Position: named

Specifies the description of the LUN.

-VNXLunAllocationPolicy <VNXLunAllocationPolicy>

Attributes: Optional, Position: named

Specifies the allocation policy of the LUN, which can be OnDemand or Automatic. This parameter only supports VNX next-generation systems (VNX5400, VNX5600, VNX5800, VNX7600, VNX8000, and so on) with the Thick LUN provisioning type.

-VNXTieringPolicy <VNXTieringPolicy>

Attributes: Optional, Position: named

Specifies the tiering policy of the LUN. The default is Unknown. The other available options are: NoMovement, AutoTier, HighestAvailable, and LowestAvailable. This feature only supports VNX storage systems with LUN pools .

-IgnoreThresholds <SwitchParameter>

Attributes: Optional, Position: named

Specifies to ignore the thresholds when creating the new LUN.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-StorageSystem <IStorageSystem>

Attributes: Required, Position: named

Specifies the storage system object. You can add the storage system object to ESI with the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get the storage system object with the Get-EmcStorageSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$p = Get-EmcStoragePool gold*

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 10gb

TaskStatus: Started

 10% : Creating the LUN...

100% : The specified LUN has been created...

TaskStatus: Completed

C:\PS>$l | select ProvisioningType, Name

ProvisioningType Name

---------------- ----

           Thin mylun_test_1

This example creates a LUN.

---------- Example 2 ----------

C:\PS>$p = Get-EmcStoragePool gold*

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 10mb -Silent -Thick

C:\PS>$l | select ProvisioningType, Name

ProvisioningType Name

---------------- ----

            Thick mylun_test_1

This example creates a LUN without thin provisioning.

---------- Example 3 ----------

C:\PS>$s = Get-EmcStorageSystem myVNX

C:\PS>$p = Get-EmcStoragePool gold*

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 10mb

This example creates a LUN with a specified pool and capacity.

---------- Example 4 ----------

C:\PS>$p = Get-EmcStoragePool gold*

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 10gb -ApplicationHint "HyperV"

This example creates a LUN with a specified pool, capacity, and application hint. The ApplicationHint parameter can be only used on storage systems such as VNXe that are application-aware.

---------- Example 5 ----------

C:\PS>$p = Get-EmcStoragePool gold*

C:\PS>$l = New-EmcLun -Pool $p -Capacity 1gb -Name mylun_test_1 -Thick -VNXLunAllocationPolicy onDemand

This example creates a LUN with a specified pool, capacity, and allocation policy. The AllocationPolicy parameter can be only used on VNX2 storage systems where the LUNProvisioningType is Thick.

---------- Example 6 ----------

C:\PS>$p = Get-EmcStoragePool gold*

C:\PS>$l = New-EmcLun -Pool $p -Capacity 1gb -Name mylun_AutoTierTest  -VNXTieringPolicy AutoTier

Creates a LUN with specified pool, capacity, and VNX tiering policy. The policy parameter can be only used on VNX family storage systems.


New-EmcSnapshotLun

Creates a snapshot LUN.

Syntax

New-EmcSnapshotLun -SourceLun <Lun> [-SnapshotPool <SnapshotPool>] [-Name <String>] [-StorageFolder <String>] [-Retention <TimeSpan>] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-SourceLun <Lun>

Attributes: Required, Position: named

Specifies the ESI (EMC Storage Integrator) Lun object. A lun object can be obtained by using ESI Storage System object or by using Get-EmcLun Cmdlet.

-SnapshotPool <SnapshotPool>

Attributes: Optional, Position: named

Specifies the ESI (EMC Storage Integrator) SnapshotPool object. A SnapshotPool object can be obtained by using ESI Storage System object or by using Get-EmcSnapshotPool Cmdlet. This parameter is not mandatory for some storage systems.

-Name <String>

Attributes: Optional, Position: named

Specify the name of the snapshot LUN.

-StorageFolder <String>

Attributes: Optional, Position: named

Specify the name of the StorageFolder(Volume Folder) where snapshot volume need to reside. This parameter is specific to XtremIO Storage System.

-Retention <TimeSpan>

Attributes: Optional, Position: named

Specify the duration that the snapshot shall be kept. This parameter is optional. Some storage systems may not support this feature.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

PipelineVariable stores the value of the current pipeline element as a variable, for any named command as it flows through the pipeline.Valid values are strings, the same as for any variable names.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$srclun = Get-EmcLun -ID testLun

C:\PS> New-EmcSnapshotLun -SourceLun $srcLun -NoActivation -Name snapshot2 -Silent

SourceLunId : 59

SnapshotPoolId :

IsActivated : False

PointInTime : 5/23/2012 7:35:17 AM

StorageSystemGlobalId : ae5107a4-0e17-4a3b-86c7-5cf84eed4e0e

ArrayPoolId : <SnapshotLunPool>

ArrayLunId : 59:snap_SnapshotApp46

Wwn : 00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00

Name : snapshot2

Capacity : 0

Description :

IsPrivate : False

CanDestroy : True

CanExtend : False

ServiceNodeIds : {}

OperationalStatus : {OK}

StatusMessages : {INACTIVE}

DisplayName :

OtherProperties : {[CreationTime, 5/23/2012 7:35:17 AM], [ExpirationTime, 5/23/2012 8:35:17 AM], [Resource, iscsi_83]}

Tag :

DefaultStringForOtherProperties : (CreationTime=5/23/2012 7:35:17 AM, ExpirationTime=5/23/2012 8:35:17 AM, Resource=iscsi_83)

This example shows how to create a SnapshotLun from a source Lun without enabling(activating) it.

---------- EXAMPLE 2 ----------

C:\PS>$srclun = Get-EmcLun -ID testLun

C:\PS>$duration = New-Object System.TimeSpan(5, 4, 0, 0)

C:\PS>New-EmcSnapshotLun -SourceLun $srcLun -NoActivation -Name snapshot3 -Retention $duration -Silent

SourceLunId : 59

SnapshotPoolId :

IsActivated : False

PointInTime : 5/23/2012 7:47:24 AM

StorageSystemGlobalId : ae5107a4-0e17-4a3b-86c7-5cf84eed4e0e

ArrayPoolId : <SnapshotLunPool>

ArrayLunId : 59:snap_SnapshotApp47

Wwn : 00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00

Name : snapshot3

Capacity : 0

Description :

IsPrivate : False

CanDestroy : True

CanExtend : False

ServiceNodeIds : {}

OperationalStatus : {OK}

StatusMessages : {INACTIVE}

DisplayName :

OtherProperties : {[CreationTime, 5/23/2012 7:47:24 AM], [ExpirationTime, 5/28/2012 11:47:24 AM], [Resource, iscsi_83]}

Tag :

DefaultStringForOtherProperties : (CreationTime=5/23/2012 7:47:24 AM, ExpirationTime=5/28/2012 11:47:24 AM, Resource=iscsi_83)

This example shows how to create a SnapshotLun from a source Lun without enabling(activating) it, and the retention for that SnapshotLun is 5 days and 4 hours.

---------- EXAMPLE 3 ----------

C:\PS>$xiostorage=Get-EmcStorageSystem -ID myxio

C:\PS>$Sourcelun=Get-EmcLun -ID 2 -BlockStorageSystem $xiostorage

C:\PS>New-EmcSnapshotLun -SourceLun $lun -Name "snap3" -StorageFolder "/"

SourceLunId : 2

SnapshotPoolId :

IsActivated : False

PointInTime : 2/5/2015 2:36:24 AM

StorageSystemGlobalId : 51eece59-1599-481d-b79f-4cb7a23fbe98

ArrayPoolIds : {}

ArrayLunId : 46

Wwn :

Name : snap3

Capacity : 7.000 GB

Description :

IsPrivate : False

CompositionInfo : <Not a composite LUN>

CanDestroy : True

CanExtend : True

ServiceNodeIds : {}

OperationalStatus : {Information}

StatusMessages :

DisplayName :

OtherProperties : {[naa, ]}

Tag :

DefaultStringForOtherProperties : (naa)]]

This example shows how to create a SnapshotLun from a source Lun by specifying name. The parameters


New-EmcStorageRegisteredHost

Registers a host for a specified storage system.

Syntax

  • New-EmcStorageRegisteredHost -HostSystem <IHostSystem> -StorageSystem <IRequireRemoteHostRegistration> [-Silent] [<CommonParameters>]

  • New-EmcStorageRegisteredHost -StorageSystem <IRequireRemoteHostRegistration> [-Silent] -HostName <String> -IpAddress <String> [-InitiatorIds <String[]>] [-AlternativeIpAddresses <String[]>] [<CommonParameters>]

Parameters

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-StorageSystem <IRequireRemoteHostRegistration>

Attributes: Required, Position: named

Specifies the storage system.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-HostName <String>

Attributes: Required, Position: named

Specifies the host name.

-IpAddress <String>

Attributes: Required, Position: named

Specifies the IP address.

-InitiatorIds <String[]>

Attributes: Optional, Position: named

Specifies the IDs of the initiators.

-AlternativeIpAddresses <String[]>

Attributes: Optional, Position: named

Specifies the alternative IP addresses.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hs = Get-EmcHostSystem TestHost.localdomain

C:\PS>$ss = Get-EmcStorageSystem storage01

C:\PS>New-EmcStorageRegisteredHost -HostSystem $hs -StorageSystem $ss

This example registers the host and host initiators with the storage array. By default, all of the initiators for that specified host will be registered together.

-------------- Example 2 --------------

C:\PS>$ss = Get-EmcStorageSystem storage01

C:\PS>New-EmcStorageRegisteredHost -HostName "TestHost.localdomain" -storageSystem $ss -IpAddress "10.2.5.23"

This example registers the host with the specified storage system, based on the specified host name and IP address.

-------------- Example 3 --------------

C:\PS>$ss = Get-EmcStorageSystem storage01

C:\PS>New-EmcStorageRegisteredHost -HostName "TestHost.localdomain" -storageSystem $ss -IpAddress "10.2.5.23" -InitiatorIds "iqn.1991-05.com.microsoft:TestHost.localdomain"

This example registers the host with the specified storage system, based on the specified host name, IP address, and the IDs of the host bus adapters.


New-EmcStorageRegisteredInitiator

Registers a host initiator on a specified storage system.

Syntax

New-EmcStorageRegisteredInitiator -RegisteredHost <RemoteHost> -InitiatorIds <String[]> [-Silent] [<CommonParameters>]

Parameters

-RegisteredHost <RemoteHost>

Attributes: Required, Position: named

Specifies the registered host for which the initiators will be registered on the storage system.

-InitiatorIds <String[]>

Attributes: Required, Position: named

Specifies the IDs of the initiators to be registered. The values for the initiator IDs can be either WWN (World Wide Name) or IQN (iSCSI Qualified Name).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$rh = Get-EmcStorageRegisteredHost TestHost.localdomain

C:\PS>New-EmcStorageRegisteredInitiator -RegisteredHost $rh -InitiatorIds "iqn.1991-05.com.microsoft:TestHost.localdomain"

This example registers an initiator for a specified registered host on the storage system. The storage system information is implied in the registered host.


New-EmcVnxeLunGroup

Creates a new LUN group on a VNXe system. LUN groups enables consistent snapshots of multiple LUNs and are used to grant hosts access to LUNs and snapshots of LUNs in the group.

Note: This command is for VNXe3200 systems only.

Syntax

New-EmcVnxeLunGroup -StorageSystem <IStorageSystem> -Name <String> [-Description <String>] [-Silent] [<CommonParameters>]

Parameters

-StorageSystem <IStorageSystem>

Attributes: Required, Position: 1

Specifies the VNXe storage system on which to create the LUN group.

-Name <String>

Attributes: Required, Position: named

Specifies the name of the LUN group.

-Description <String>

Attributes: Optional, Position: named

Specifies a description for the LUN group.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$ss = Get-EmcStorageSystem TestVNXe

$group = New-EmcVnxeLunGroup -Name TestLG

Creates a LUN group on the specified VNXe system.


Remove-EmcFileBasedDisk

Deletes a file-based disk from a hypervisor.

Syntax

Remove-EmcFileBasedDisk -Hypervisor <IHypervisor> -Path <String> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Hypervisor <IHypervisor>

Attributes: Required, Position: named

Specifies the ESI hypervisor host system object, which you can get from the host system by using the Get-EmcHostSystem cmdlet. You can add a hypervisor to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets.

-Path <String>

Attributes: Required, Position: named

Specifies the path of the file-based disk.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hypervisor = Get-EmcHostSystem *133

C:\PS>New-EmcFileBasedDisk -Hypervisor $hypervisor -Size 1GB -HostDiskType fIXeD -Path "E:\hyper-V\testESI.vhd"

C:\PS>Remove-EmcFileBasedDisk -Hypervisor $hypervisor -Path "E:\hyper-V\testESI.vhd"

This example deletes a file-based disk from a hypervisor.

------------- Example 2 --------------

C:\PS>$h= Get-EmcHostSystem *99

C:\PS>New-EmcFileBasedDisk -Hypervisor $h -Size 1GB -Path "[datastore1] VM-ESX-WS2K8R2-1/ESIQA.vmdk"

C:\PS>Remove-EmcFileBasedDisk -Hypervisor $h -Path "[datastore1] VM-ESX-WS2K8R2-1/ESIQA.vmdk"

This example deletes a file-based disk from a VMWare host.


Remove-EmcLun

Removes or destroys the LUN from the storage system.

Syntax

Remove-EmcLun [-Lun] <ConcreteLun> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Description

Removes or destroys the LUN from the storage system. For VMAX systems, the Lun.CanDestroy property setting is not accurate, because it is always set to True in PowerShell, regardless of the provider setting. So do not depend on this parameter to be correct.

Parameters

-Lun <ConcreteLun>

Attributes: Required, Position: 1

Specifies the ESI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcLun cmdlet. It is a positional parameter (position = 1).

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$p = Get-EmcStoragePool gold*

C:\PS>$l = New-EmcLun -Pool $p -Name esi_ps_test_1 -CapacityInMB 1024 -Silent

C:\PS>$l.ArrayLunId

14

C:\PS>Remove-EmcLun -Lun $l -Silent

Confirm

Are you sure you want to perform this action?

Performing operation "Remove-EmcLun" on Target "esi_ps_test_1".

[Y] Yes [A] Yes to All [N] No [L] No to All [S] Suspend [?] Help (default is "Y"): y

C:\PS>Get-EmcLUN esi_ps_test_1

WARNING: Unable to find lun(s) with the given parameters.

C:\PS>

The example creates a LUN and then destroys it.

-------------- Example 2 --------------

C:\PS>$l = Get-EmcLUN 7

C:\PS>$l.ArrayLunId

7

C:\PS>Remove-EmcLun -Lun $l -Silent -Force

C:\PS>Get-EmcLUN 7

WARNING: Unable to find lun(s) with the given parameters.

C:\PS>

This example gets a LUN and then removes it.


Remove-EmcSnapshotLun

Removes the snapshot LUN.

Syntax

Remove-EmcSnapshotLun -SnapshotLun <SnapshotLun> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-SnapshotLun <SnapshotLun>

Attributes: Required, Position: 1

Specifies the ESI (EMC Storage Integrator) SnapshotLun object. A SnapshotLun object can be obtained by using ESI Storage System object or by using Get-EmcLun or Get-EmcSnapshotLun Cmdlet. It is a positional parameter (position = 1).

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the Cmdlet to continue without asking for user's confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Describes what would happen if you executed the command without actually executing the command.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$srcLun = Get-EmcLun testLun

C:\PS>$snapshotLun = New-EmcSnapshotLun -SourceLun $srcLun -Name snapshot1 -Silent

C:\PS>Remove-EmcSnapshotLun $snapshotLun

This example shows how to remove a Snapshot Lun.


Remove-EmcStorageRegisteredHost

Removes the registered host from the storage system where it is registered.

Syntax

Remove-EmcStorageRegisteredHost [-RegisteredHost] <RemoteHost> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-RegisteredHost <RemoteHost>

Attributes: Required, Position: 1

Specifies the registered host.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$rh = Get-EmcStorageRegisteredHost TestHost.localdomain

C:\PS>Remove-EmcStorageRegisteredHost -RegisteredHost $rh

This example removes the registered host for a selected storage system. The storage system information is implied in the registered host.


Remove-EmcStorageRegisteredInitiator

Removes the specified host initiator from the storage system where the initiator host is registered.

Syntax

Remove-EmcStorageRegisteredInitiator [-RegisteredInitiator] <RemoteInitiator> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-RegisteredInitiator <RemoteInitiator>

Attributes: Required, Position: 1

Specifies the registered initiator to be removed.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$rh = Get-EmcStorageRegisteredHost TestHost.localdomain

C:\PS>Remove-EmcStorageRegisteredInitiator -RegisteredInitiator $rh.Initiators[0]

This example removes a registered initiator for a specified storage system. The storage system information is implied in the initiator object.


Remove-EmcVnxAdvancedSnapshot

Removes or deletes the specified vnx advanced snapshot.

Syntax

Remove-EmcVnxAdvancedSnapshot -AdvancedSnapshot <VnxAdvancedSnapshot> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-AdvancedSnapshot <VnxAdvancedSnapshot>

Attributes: Required, Position: 1

Specifies the ESI VnxAdvancedSnapshot object. You can get a VnxAdvancedSnapshot object using Get-EmcVnxAdvancedSnapshot commandlet.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the Cmdlet to continue without asking for user's confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Describes what would happen if you executed the command without actually executing the command.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

C:\PS>$asnapshot = Get-EmcVnxAdvancedSnapshot -ID "firstsnap" -BlockStorageSystem $storage

C:\PS>Remove-EmcVnxAdvancedSnapshot -AdvancedSnapshot $asnapshot

This example removes the specified advanced snapshot from specified storage system.


Remove-EmcVnxeLunGroup

Deletes a LUN group from a VNXe system.

Note: This command is for VNXe3200 systems only.

Syntax

Remove-EmcVnxeLunGroup -LunGroup <Vnx2eLunGroup> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-LunGroup <Vnx2eLunGroup>

Attributes: Required, Position: 1

Specifies the LUN group to remove from the system.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$group = Get-EmcVnxeLunGroup TestLG

Remove-EmcVnxeLunGroup -LunGroup $group

Deletes a LUN group.


Remove-EmcVnxeLunGroupMember

Removes one or more members from a LUN group. This command is used to remove LUNs, LUN access hosts, or snapshot access hosts from a LUN group.

Note: This command is for VNXe3200 systems only.

Syntax

  • Remove-EmcVnxeLunGroupMember -LunGroup <Vnx2eLunGroup> -Luns <Lun[]> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Remove-EmcVnxeLunGroupMember -LunGroup <Vnx2eLunGroup> [-Force] [-Silent] [-WhatIf] [-Confirm] -LunHosts <RemoteHost[]> [<CommonParameters>]
  • Remove-EmcVnxeLunGroupMember -LunGroup <Vnx2eLunGroup> [-Force] [-Silent] [-WhatIf] [-Confirm] -SnapshotHosts <RemoteHost[]> [<CommonParameters>]

Parameters

-LunGroup <Vnx2eLunGroup>

Attributes: Required, Position: named

Specifies the LUN group from which to remove one or more members.

-Luns <Lun[]>

Attributes: Required, Position: named

Specifies one or more LUNs to remove from the LUN group.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

-LunHosts <RemoteHost[]>

Attributes: Required, Position: named

Specifies one or more LUN access hosts to remove from the LUN group.

-SnapshotHosts <RemoteHost[]>

Attributes: Required, Position: named

Specifies one or more snapshot access hosts to remove from the LUN group.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$ss = Get-EmcStorageSystem TestVNXe

$lun = Get-EmcLun -BlockStorageSystem $ss TestLUN

$group = Get-EmcVnxeLunGroup TestLG

Remove-EmcVnxeLunGroupMember -LunGroup $group -Luns $lun

Remove a LUN from a LUN group.

-------------- Example 2 --------------

C:\PS>$ss = Get-EmcStorageSystem TestVNXe

$h = Get-EmcStorageRegisteredHost -StorageSystem $ss TestHost

$group = Get-EmcVnxeLunGroup TestLG

Remove-EmcVnxeLunGroupMember -LunGroup $group -LunHosts $h

Remove a LUN access host from a LUN group.

-------------- Example 3 --------------

C:\PS>$ss = Get-EmcStorageSystem TestVNXe

$h = Get-EmcStorageRegisteredHost -StorageSystem $ss TestHost

$group = Get-EmcVnxeLunGroup TestLG

Remove-EmcVnxeLunGroupMember -LunGroup $group -SnapshotHosts $h

Remove a snapshot access host from a LUN group.


Remove-EmcVnxeSnapshot

Deletes a snapshot from a VNXe system.

Note: This command is for VNXe3200 systems only.

Syntax

Remove-EmcVnxeSnapshot -Snapshot <Vnx2eSnapshot> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Snapshot <Vnx2eSnapshot>

Attributes: Required, Position: 1

Specifies the snapshot to delete.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$snap = Get-EmcVnxeSnapshot TestSnap

Remove-EmcVnxeSnapshot -Snapshot $snap

Deletes a snapshot.


Restore-EmcVnxeSnapshot

Restores a VNXe snapshot back to its source.

Note: This command is for VNXe3200 systems only.

Syntax

Restore-EmcVnxeSnapshot -Snapshot <Vnx2eSnapshot> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Snapshot <Vnx2eSnapshot>

Attributes: Required, Position: 1

Specifies the snapshot to restore.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Suppresses any user prompts while running the cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before running the cmdlet.

-<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$snap = Get-EmcVnxeSnapshot TestSnap

Restore-EmcVnxeSnapshot -Snapshot $snap

Restores the specified snapshot back to its source.


Set-EmcLun

Sets the storage service node for the specified LUN. For VNX storage systems only, sets the storage tiering policy and LUN compression and compression rate for the specified LUN.

Syntax

  • Set-EmcLun -Lun <Lun> -Pool <StoragePool> -BindToPool [-Silent] [<CommonParameters>]

  • Set-EmcLun -Lun <Lun> [-Silent] -TieringPolicy <VNXTieringPolicy> [<CommonParameters>]

  • Set-EmcLun -Lun <Lun> [-Silent] -LunCompression <VNXLunCompression> [-LunCompressionRate <VNXLunCompressionRate>] [<CommonParameters>]

  • Set-EmcLun -Lun <Lun> [-Silent] -StorageServiceNode <StorageServiceNode> [<CommonParameters>]

Parameters

-Lun <Lun>

Attributes: Required, Position: named

Specifies the ESI LUN object, which you can get with the ESI storage system object or the Get-EmcLun cmdlet.

-Pool <StoragePool>

Attributes: Required, Position: named

Specifies the storage pool object, which you can get from a block storage system or with the Get-EmcStoragePool cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-TieringPolicy <VNXTieringPolicy>

Attributes: Required, Position: named

Specifies the tiering policy of the LUN in a pool and on VNX systems only. Valid values include: NoMovement, AutoTier, HighestAvailable, or LowestAvailable.

-LunCompression <VNXLunCompression>

Attributes: Required, Position: named

Specifies the LUN compression operation of the thin LUN on VNX systems only. Valid values include: On, Off, and Modify.

-LunCompressionRate <VNXLunCompressionRate>

Attributes: Optional, Position: named

Specifies the LUN compression rate of the LUN in a pool and on VNX systems only. Valid values include: Low, Medium, and High.

-StorageServiceNode <StorageServiceNode>

Attributes: Required, Position: named

Specifies the storage service node object, which you can get with the Get-EmcStorageServiceNode cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$lun=Get-EmcLun -ID 14

C:\PS>Set-EmcLun -Lun $lun -VNXTieringPolicy AutoTier

Changes the tiering policy of the LUN to AutoTier.

-------------- Example 3 --------------

C:\PS>$s = Get-EmcStorageSystem myVNX

C:\PS>$l = Get-EmcLun -BlockStorageSystem $s

C:\PS>$serviceNodes = Get-EmcStorageServiceNode -StorageSystem $s

C:\PS>Set-EmcLun -Lun $l[10] -StorageServiceNode $serviceNodes[0]

Sets the default owner for the LUN.

-------------- Example 4 --------------

C:\PS>$storage = Get-EmcStorageSystem myVNX

C:\PS>$pool = Get-EmcStoragePool -StorageSystem $storage

C:\PS>$lun = Get-EmcLun -BlockStorageSystem $s -Pool $pool[2]

C:\PS>Set-EmcLun -Lun $lun[4] -LunCompression Off

Sets LUN compression as Off for the specified LUN.

-------------- Example 5 --------------

C:\PS>$storage = Get-EmcStorageSystem myVNX

C:\PS>$pool = Get-EmcStoragePool -StorageSystem $storage

C:\PS>$lun = Get-EmcLun -BlockStorageSystem $s -Pool $pool[2]

C:\PS>Set-EmcLun -Lun $lun[4] -LunCompression On -LunCompressionRate Low

Sets LUN compression as On and sets the compression rate as Low for the specified LUN.

-------------- Example 6 --------------

C:\PS>$storage = Get-EmcStorageSystem myVNX

C:\PS>$pool = Get-EmcStoragePool -StorageSystem $storage

C:\PS>$lun = Get-EmcLun -BlockStorageSystem $s -Pool $pool[2]

C:\PS>Set-EmcLun -Lun $lun[19] -LunCompression Modify -LunCompressionRate High

Sets the LUN compression rate as High for the specified LUN.


Set-EmcLunAccess

Masks or unmasks a LUN to a host, a cluster, an FC or iSCSI initiator.

Syntax

  • Set-EmcLunAccess -Lun <Lun> [-Hlu <UInt32>] -HostSystem <IHostSystem> -Available [-iSCSI] [-FC] [-Silent] [<CommonParameters>]

  • Set-EmcLunAccess -Lun <Lun> [-Hlu <UInt32>] -Available [-iSCSI] [-FC] [-Silent] -ClusterSystem <IClusterSystem> [<CommonParameters>]

  • Set-EmcLunAccess -Lun <Lun> [-Hlu <UInt32>] -Available [-Silent] -InitiatorId <String[]> -HostName <String> -HostIpAddress <String> [<CommonParameters>]

  • Set-EmcLunAccess -Lun <Lun> -HostSystem <IHostSystem> [-iSCSI] [-FC] [-Silent] -Unavailable [<CommonParameters>]

  • Set-EmcLunAccess -Lun <Lun> [-Silent] -InitiatorId <String[]> -HostName <String> -HostIpAddress <String> -Unavailable [<CommonParameters>]

  • Set-EmcLunAccess -Lun <Lun> [-iSCSI] [-FC] [-Silent] -ClusterSystem <IClusterSystem> -Unavailable [<CommonParameters>]

  • Set-EmcLunAccess -Lun <Lun> -Available [-iSCSI] [-FC] [-Silent] -HostBusAdapters <HostBusAdapter> [<CommonParameters>]

  • Set-EmcLunAccess -Lun <Lun> [-iSCSI] [-FC] [-Silent] -Unavailable -HostBusAdapters <HostBusAdapter> [<CommonParameters>]

Parameters

-Lun <Lun>

Attributes: Required, Position: named

Specifies the ESI LUN object, which you can get with the ESI storage system object or the Get-EmcLun cmdlet.

-Hlu <UInt32>

Attributes: Optional, Position: named

Specifies the host logical unit for a LUN.

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI with the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object with the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-Available <SwitchParameter>

Attributes: Required, Position: named

Unmasks the LUN to the specified host, cluster systems, or FC or iSCSI initiators.

-iSCSI <SwitchParameter>

Attributes: Optional, Position: named

Specifies an optional parameter through which the iSCSI HBA type filter can be filtered out.

-FC <SwitchParameter>

Attributes: Optional, Position: named

Specifies an optional parameter through which the FC HBA type filter can be filtered out.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add the cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get the cluster system object by using the Get-EmcClusterSystem cmdlet.

-InitiatorId <String[]>

Attributes: Required, Position: named

Specifies the iSCSI or FC initiator ID.

-HostName <String>

Attributes: Required, Position: named

Specifies the host name.

-HostIpAddress <String>

Attributes: Required, Position: named

Specifies the host IP address.

-Unavailable <SwitchParameter>

Attributes: Required, Position: named

Masks the LUN for the specified host, cluster systems, or FC or iSCSI initiators.

-HostBusAdapters <HostBusAdapter>

Attributes: Required, Position: named

Specifies the host bus adapters and the HBA filter type can be specified optionally.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$l = Get-EmcLun mylun*

C:\PS>$h = Get-EmcHostSystem myhost*

C:\PS>Set-EmcLunAccess -Lun $l -HostSystem $h -Available

This example unmasks the LUN on the host system.

-------------- Example 2 --------------

C:\PS>$l = Get-EmcLun mylun*

C:\PS>$h = Get-EmcHostSystem myhost*

C:\PS>Set-EmcLunAccess -Lun $l -HostSystem $h -UnAvailable

This example masks the LUN on the host system.

-------------- Example 3 --------------

C:\PS>$l = Get-EmcLun mylun*

C:\PS>$c = Get-EmcClusterSystem myCluster*

C:\PS>Set-EmcLunAccess -Lun $l -ClusterSystem $c -Available

This example unmasks the LUN on the cluster system.

-------------- Example 4 --------------

C:\PS>$l = Get-EmcLun mylun*

C:\PS>$c = Get-EmcClusterSystem myCluster*

C:\PS>Set-EmcLunAccess -Lun $l -ClusterSystem $c -Unavailable

This example masks the LUN on the cluster system.

-------------- Example 5 --------------

C:\PS>$lun = Get-EmcLun mylun*

C:\PS>$h= Get-EmcHostSystem myHost*

C:\PS>Get-EmcHostBusAdapter -HostSystem $h | select GlobalId

GlobalId

--------

20:00:00:24:FF:31:C6:BA:21:00:00:24:FF:31:C6:BA

20:00:00:24:FF:31:C6:BB:21:00:00:24:FF:31:C6:BB

iqn.1991-05.com.microsoft:vmTest.sr5dom.eng.emc.com

C:\PS>Set-EmcLunAccess -Lun $lun -InitiatorId iqn.1991-05.com.microsoft:vmTest.sr5dom.eng.emc.com -HostName $h.Name -HostIpAddress $h.IpAddress -Available

This example unmasks the specified LUN on the specified iSCSI or FC initiator.

-------------- Example 6 --------------

C:\PS>$lun = Get-EmcLun mylun*

C:\PS>$h= Get-EmcHostSystem myHost*

C:\PS>Get-EmcHostBusAdapter -HostSystem $h | select GlobalId

GlobalId

--------

20:00:00:24:FF:31:C6:BA:21:00:00:24:FF:31:C6:BA

20:00:00:24:FF:31:C6:BB:21:00:00:24:FF:31:C6:BB

iqn.1991-05.com.microsoft:vmTest.sr5dom.eng.emc.com$ip= $h | select ipaddress

C:\PS>Set-EmcLunAccess -Lun $lun -InitiatorId iqn.1991-05.com.microsoft:vmTest.sr5dom.eng.emc.com -HostName $h.Name -HostIpAddress $h.IpAddress -Unavailable

This example masks the specified LUN to the specified iSCSI or FC initiator.

-------------- Example 7 --------------

C:\PS>$l = Get-EmcLun mylun*

C:\PS>$hba = Get-EmcHostBusAdapter -HostSystem myhost*

C:\PS>Set-EmcLunAccess -Lun $l -HostBusAdapters $hba -FC -Available

This example unmasks the LUN from the specified HBAs with the FC type.


Update-EmcVnxAdvancedSnapshot

Updatesthe vnx advanced snapshot.

Syntax

Update-EmcVnxAdvancedSnapshot -AdvancedSnapshot <VnxAdvancedSnapshot> [-Name <String>] [-Description <String>] [-AllowReadWrite <Boolean>] [-AllowAutoDelete <Boolean>] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-AdvancedSnapshot <VnxAdvancedSnapshot>

Attributes: Required, Position: named

Specifies the ESI VnxAdvancedSnapshot object. You can get a VnxAdvancedSnapshot object using Get-EmcVnxAdvancedSnapshot commandlet.

-Name <String>

Attributes: Optional, Position: named

Specifies the name of the Vnx advanced snapshot.

-Description <String>

Attributes: Optional, Position: named

Specifies the description of the Vnx advanced snapshot.

-AllowReadWrite <Boolean>

Attributes: Optional, Position: named

Indicates that the snapshot created in readwrite mode.

-AllowAutoDelete <Boolean>

Attributes: Optional, Position: named

Indicates that the created snapshot's AllowAutoDelete property.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

C:\PS>$asnapshot = Get-EmcVnxAdvancedSnapshot -ID "firstsnap" -BlockStorageSystem $storage

C:\PS> Update-EmcVnxAdvancedSnapshot -AdvancedSnapshot $asnapshot -Name "newname" -Description "New description" -AllowReadWrite $true -AllowAutoDelete $false

This example updates the specified vnx advanced snapshot properties.


New-EmcVnxAdvancedSnapshot

Creates new Vnx advanced snapshot from Lun and snapshot mount point (SMP).

Syntax

New-EmcVnxAdvancedSnapshot -SourceLun <Lun> [-Name <String>] [-Description <String>] [-AllowReadWrite <Boolean>] [-AllowAutoDelete <Boolean>] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

New-EmcVnxAdvancedSnapshot [-Name <String>] [-Description <String>] [-AllowReadWrite <Boolean>] [-AllowAutoDelete <Boolean>] [-Silent] [-PipelineVariable <String>] -VnxAdvancedSnapshotMountPoint <VnxAdvancedSnapshotMountPoint> [<CommonParameters>]

Parameters

-SourceLun <Lun>

Attributes: Required, Position: named

Specifies the ESI LUN object. You can get a LUN object with the ESI storage system object or the Get-EmcLun cmdlet.

-Name <String>

Attributes: Optional, Position: named

Specifies the name of the Vnx advanced snapshot.

-Description <String>

Attributes: Optional, Position: named

Specifies the description of the Vnx advanced snapshot.

-AllowReadWrite <Boolean>

Attributes: Optional, Position: named

Indicates that the snapshot created in readwrite mode.

-AllowAutoDelete <Boolean>

Attributes: Optional, Position: named

Indicates that the created snapshot's AllowAutoDelete property.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter that turns off all informational and verbose messages. However, it still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-VnxAdvancedSnapshotMountPoint <VnxAdvancedSnapshotMountPoint>

Attributes: Required, Position: named

Specifies the ESI VnxAdvancedSnapshotMountPoint object. You can get a VnxAdvancedSnapshotMountPoint object using Get-EmcVnxAdvancedSnapshotMountPoint commandlet.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

--------- EXAMPLE 1 ----------

C:\PS>$storage=Get-EmcStorageSystem -ID vnx

C:\PS> $lun=Get-EmcLun -ID 25 -BlockStorageSystem $storage

C:\PS> New-EmcVnxAdvancedSnapshot -SourceLun $lun -Name "saisnap1" -Description "this is first snapshot" -AllowReadWrite $true -AllowAutoDelete $false

This example creates new Vnx advanced snapshot from the specified source LUN.

---------- EXAMPLE 2 ----------

C:\PS>$storage=Get-EmcStorageSystem -ID vnx
C:\PS> $smp=Get-EmcVnxAdvancedSnapshotMountPoint -ID 4075 -BlockStorageSystem $storage
C:\PS> New-EmcVnxAdvancedSnapshot -VnxAdvancedSnapshotMountPoint $smp -Name "firstsnapofsmp1" -Description "this is first snapshot of smp" -AllowReadWrite $true -AllowAutoDelete $true

This example creates new advanced snapshot(cascading snapshot) from the specified snapshot mount point.


New-EmcVnxAdvancedSnapshotMountPoint

Creates new Vnx advanced snapshot mount LUN from source LUN.

Syntax

New-EmcVnxAdvancedSnapshotMountPoint -SourceLun <Lun> [-SnapshotMountPointName <String>] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Parameters

-SourceLun <Lun>

Attributes: Required, Position: named

Specifies the ESI LUN object. You can get a LUN object with the ESI storage system object or the Get-EmcLun cmdlet.

-SnapshotMountPointName <String>

Attributes: Optional, Position: named

Specifies the name of the Vnx advanced snapshot mount point.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter that turns off all informational and verbose messages. However, it still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$storage=Get-EmcStorageSystem -ID vnx

C:\PS> $lun=Get-EmcLun -ID 25 -BlockStorageSystem $storage

C:\PS> New-EmcVnxAdvancedSnapshotMountPoint -SourceLun $lun -SnapshotMountPointName "smp1"

This example creates new Vnx advanced snapshot mount point from the specified source LUN.


New-EmcVnxeSnapshot

Creates a new snapshot on a VNXe system. VNXe allows snapshots of LUNs and LUN groups.

Note: This command is for VNXe3200 systems only.

Syntax

New-EmcVnxeSnapshot -Source <Object> [-Name <String>] [-Description <String>] [-Silent] [<CommonParameters>]

Parameters

-Source <Object>

Attributes: Required, Position: named

Specifies the source LUN or LUN group.

-Name <String>

Attributes: Optional, Position: named

Specifies the name of the snapshot. If omitted a default name will be given.

-Description <String>

Attributes: Optional, Position: named

Specifies the description of the snapshot.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$group = Get-EmcVnxeLunGroup TestLG

$snap = New-EmcVnxeSnapshot -Source $group -Name TestLGSnap

Creates a snapshot of the specified LUN group.


Restore-EmcSnapshotLun

Restores the snapshot LUN.

Syntax

Restore-EmcSnapshotLun -SnapshotLun <SnapshotLun> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-SnapshotLun <SnapshotLun>

Attributes: Required, Position: 1

Specifies the ESI (EMC Storage Integrator) SnapshotLun object. A SnapshotLun object can be obtained by using ESI Storage System object or by using Get-EmcLun or Get-EmcSnapshotLun Cmdlet. It is a positional parameter (position = 1).

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the Cmdlet to continue without asking for user's confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Describes what would happen if you executed the command without actually executing the command.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$srcLun = Get-EmcLun testLun

C:\PS>$snapshotLun = New-EmcSnapshotLun -SourceLun $srcLun -Name snapshot1 -Silent

C:\PS>Restore-EmcSnapshotLun $snapshotLun

This example shows how to restore the source Lun's content with one of its Snapshot Luns.


Restore-EmcVnxAdvancedSnapshot

Restores the vnx advanced snapshot to source LUN.

Syntax

Restore-EmcVnxAdvancedSnapshot -AdvancedSnapshot <VnxAdvancedSnapshot> [-Force] [-Silent] [-PipelineVariable <String>] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-AdvancedSnapshot <VnxAdvancedSnapshot>

Attributes: Required, Position: 1

Specifies the ESI VnxAdvancedSnapshot object. You can get a VnxAdvancedSnapshot object using Get-EmcVnxAdvancedSnapshot commandlet.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the Cmdlet to continue without asking for user's confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Describes what would happen if you executed the command without actually executing the command.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$storage = Get-EmcStorageSystem vnx

C:\PS>$asnapshot = Get-EmcVnxAdvancedSnapshot -ID "firstsnap" -BlockStorageSystem $storage

C:\PS>Restore-EmcVnxAdvancedSnapshot -AdvancedSnapshot $asnapshot

This example restores the specified advanced snapshot to source LUN.


Set-EmcVNXLunAllocationPolicy

Modifies the VNX Allocation Policy of a LUN.

Syntax

Set-EmcVNXLunAllocationPolicy -Lun <Lun> -VNXLunAllocationPolicy <VNXLunAllocationPolicy> [-Silent] [<CommonParameters>]

Parameters

-Lun <Lun>

Attributes: Required, Position: named

Specifies the ESI (EMC Storage Integrator) Lun object. A lun object can be obtained by using ESI Storage System object or by using Get-EmcLun Cmdlet.

-VNXLunAllocationPolicy <VNXLunAllocationPolicy>

Attributes: Required, Position: named

Specifies the AllocationPolicy of the LUN. It can be OnDemand or Automatic. AllocationPolicy parameter can be only used on VNX Rockies storage systems and Lun ProvisioningType is Thick.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$l = Get-EmcLun mylun*

C:\PS>Set-EmcVNXLunAllocationPolicy -Lun $l -OnDemand

Modifies the AllocationPolicy of a Lun to OnDemand.

---------- EXAMPLE 2 ----------

C:\PS>$l = Get-EmcLun mylun*

C:\PS>Set-EmcVNXLunAllocationPolicy -Lun $l -Automatic

Modifies the AllocationPolicy of a Lun to Automatic.


ESI Service PowerShell cmdlet list

This is a complete list of available ESI Service PowerShell cmdlets. You can use these cmdlets to set up the ESI Service for the ESI System Center Operations Manager (SCOM) Management Packs. The cmdlets are grouped by operation type. Within each group, the cmdlets are listed alphabetically. The syntax, parameters, and examples are provided for each cmdlet.

To get the same information, type the following at the PowerShell command prompt:

get-help <cmdlet name> -full

Entity graph

  • Get-EmcEntity: Gets one or more Entity objects from the Entity Graph of an ESI Service instance.

  • Get-EmcEntityClass: Gets the class names of Entity objects in the Entity Graph of an ESI Service instance.

  • Get-EmcEntityRelationship: Gets one or more Entity relationship objects from the Entity Graph of an ESI Service instance.

Service configuration

  • Add-EmcUser: Adds an authorized user to the ESI Service.

  • Get-EmcSecurityRole: Gets the security roles for the ESI Service.

  • Get-EmcServicePolicy: Gets the system refresh interval policy of the ESI Service.

  • Get-EmcUser: Gets the authorized users of the ESI Service.

  • Remove-EmcUser: Removes an authorized user from the ESI Service.

  • Set-EmcServicePolicy: Sets the system refresh interval policy for the ESI Service.

  • Set-EmcServiceUrl: Sets the URL to the ESI Service for the current session.

System registration

  • Add-EmcSystem: Registers storage systems with the ESI Service.

  • Disable-EMCServerCertificateValidation: Disables the server certificate validation when using SSL to communicate with the ESI Service.

  • Enable-EMCServerCertificateValidation: Enables the server certificate validation when using SSL to communicate with the ESI Service.

  • Get-EmcServiceConnectionOptions: Gets the current options for connecting to the ESI Service.

  • Get-EmcSystem: Lists all of the registered storage systems for the ESI Service.

  • Get-EmcSystemType: Lists all system types that are available for registration with the ESI Service.

  • Remove-EmcSystem: Removes the registration of, or unregisters, a specified storage system with the ESI Service.


Entity Graph reference

Overview

The Entity Graph is a component of the ESI Service that stores information about discovered storage system components and the relationships between the components. The graph exposes an HTTP API to enable client applications, such as the ESI SCOM Management Packs, to query the discovered system components and the relationships between them. The ESI Service PowerShell Toolkit also includes cmdlets for querying the Entity Graph.

Basic concepts

The Entity Graph consists of two kinds of elements, entities, and entity relationships:

  • An Entity is a representation at a selected time of a discovered system or component, such as storage systems, storage pools, disk drives, and storage volumes. Each Entity in the graph has a unique Entity ID. Entity IDs are persistable, which means that as long as the entity exists, client applications can store and use them. An Entity contains both meta-data that applies to all components, including the Entity ID, and properties that are specific to the type of component that the Entity represents. For example, you can get the AvailableCapacity for a storage pool source entity.

  • An Entity Relationship is a directional link between two entities in the graph and represents a relationship at a selected point in time between the two components. This models relationships such as a storage system and its enclosures or a storage pool and its associated storage volumes. Each Entity Relationship has a Name that indicates the type of relationship between the components. For example, you can get the PhysicalContainment and LogicalPhysicalAssociation relationship for a source entity and a target entity.

Entity graph classes

The Entity Graph meta-model consists of only two classes, Entity and EntityRelationship. Each class has the following properties:

Entity

An Entity contains both meta-properties that are available on every component as well as properties that are specific to the type of component the property represents.

Name | Type | Description
ID | String | Unique identifier that is assigned to each entity in the graph. Client applications use this ID to locate the entities and their relationships to other entities. Client applications do not interpret the format or contents.
Class | String | Type of object that the Entity represents. This is a non-localized programmatic name that only contains alphanumeric characters.
AncestorClasses | String array | Class hierarchy of the Entity that lists the class names starting with the most derived class and up to the top class in the hierarchy.
Caption | String | Short description of the Entity that client applications can only use for end-user display and not interpret as a value.
FriendlyClass | String | Name of the component that the Entity represents, which may be more recognizable to the end user. This is the same value as the Class property if there is no friendly name. Client applications can only use this for end user display and not interpret it as a value.
FriendlyName | String | Name of the component that the Entity represents, which may be more recognizable to the end user. Client applications do not interpret this value but only use it for an end-user display.
PhysicalPath | String | Physical path to the component that the Entity represents. This helps end users identify the component. Client applications do not interpret this value but only use it as an end-user display.
Properties | Property array | Properties of the component that the Entity represents. Each property consists of a Name, Type, and Value. Each type of component or Entity Class has a unique set of properties. For example, SerialNumber on StorageSystem and AvailableCapacity on StoragePool.
SnapshotTime | DataTime | Timestamp of the last time the information in the entity was synchronized with the component that it represents. Client applications can use this to determine the staleness of the entity information.

EntityRelationship

An EntityRelationship is a directional link between a source entity and a target entity. It represents a relationship between the components that the entities represent.

Name

Type

Description

Name

String

Type of relationship between the components represented by the Source and Target Entities. It can be one of the following values:

  • PhysicalContainment: Physical relationship between the source container and target member.

  • LogicalContainment: Logical relationship between the source container and target member.

  • LogicalAssociation: Association between two logical components.

  • LogicalPhysicalAssocation: Association between a logical source component and a physical target component.

  • Orphaned: Relationship between an orphaned target component and some root source container..

SourceClass

String

Class of the source entity in the relationship.

SourceID

String

ID of the source entity in the relationship.

TargetClass

String

Class of the target entity in the relationship.

TargetID

String

ID of the target entity in the relationship.


Get-EmcEntity (ESI Service)

Gets one or more Entity objects from the Entity Graph of an ESI Service instance.

Syntax

  • Get-EmcEntity [[-Pattern] <String>] [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

  • Get-EmcEntity [[-Pattern] <String>] [-ServiceUrl <String>] [-Silent] -EntityId <String> [-RelatedTarget] [-RelatedSource] [-TargetClass <String>] [-SourceClass <String>] [-Relationship <String>] [<CommonParameters>]

  • Get-EmcEntity [[-Pattern] <String>] [-ServiceUrl <String>] [-Silent] -Class <String> [<CommonParameters>]

Description

An Entity represents the state of a system or component at a particular point in time. (For example, StorageSystem, StoragePool, and DiskDrive.) This command returns one or more entity objects which satisfy the provided criteria.

Parameters

-Pattern <String>

Attributes: Optional, Position: 1

Specifies the pattern to filter the results. Wildcards are permitted.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-EntityId <String>

Attributes: Required, Position: named, Accepts pipeline input (by value or parameter name)

ID of an entity object in the Entity Graph. If specified by itself, this returns the Entity object. If combined with the -RelatedSource or -RelatedTarget flag, this will return entity objects that are related to the entity object.

-RelatedTarget <SwitchParameter>

Attributes: Required, Position: named

If specified, returns entity objects that have target relationships to the entity specified in the -EntityID parameter.

-RelatedSource <SwitchParameter>

Attributes: Optional, Position: named

If specified, returns entity objects that have source relationships to the entity specified in the -EntityID parameter.

-TargetClass <String>

Attributes: Optional, Position: named

If specified, returns entity objects which are of the specified class. Only valid with -RelatedTarget flag.

-SourceClass <String>

Attributes: Optional, Position: named

If specified, returns entity objects which are of the specified class. Only valid with -RelatedSource flag.

-Relationship <String>

Attributes: Optional, Position: named

If specified, returns entity objects with an EntityRelationship of a specific name to the entity specified by the -EntityID parameter. This is only valid with -RelatedTarget or -RelatedSource flags.

-Class <String>

Attributes: Optional, Position: named

If specified, returns entity objects of the specified class.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcEntity

Name : FNM00104000192-26.136-26.142

Model : VNX5500

SoftwareRevision : 05.32.000.5.006

SerialNumber : FNM00104000192

HealthState : Warning

EntityId : ebca9b04fc762fcdc8963271e0c94e52e3cc8336

Class : StorageSystem

EnclosureId : Bus 0 Enclosure 0

EnclosureType : DPE8

DisplayName :

HealthState : Success

EntityId : 1082eaa20bbfdcc6412979785083f33930b7e215

Class : Enclosure

EnclosureId : Bus 0 Enclosure 0

DiskId : Bus 0 Enclosure 0 Disk 0

SerialNumber : 3SE2DT96

VendorId : SEAGATE

ProductId : ST930060 CLAR300

Capacity : 268.403 GB

Type : SAS

DisplayName : Bus 0 Enclosure 0 Disk 0

HealthState : Success

EntityId : 91e6f5c112c6fecb8f2c8cac9d8b3eb5baeec9a1

Class : DiskDrive

... etc.

This example gets all of the entities.

-------------- Example 2 --------------

:\PS>Get-EmcEntity -Class StorageSystem

Name : FNM00104000192-26.136-26.142

Model : VNX5500

SoftwareRevision : 05.32.000.5.006

SerialNumber : FNM00104000192

HealthState : Warning

EntityId : ebca9b04fc762fcdc8963271e0c94e52e3cc8336

Class : StorageSystem

Name : Symmetrix DMX3-6

Model : DMX3-6

SoftwareRevision : Enginuity 5773.176

SerialNumber : 000190300186

HealthState : Error

EntityId : 5c4d33e67493dd1e33e771499333f3bd62246521

Class : StorageSystem

Name : Symmetrix VMAX40K

Model : VMAX40K

SoftwareRevision : 5876.81.57

SerialNumber : 000195700515

HealthState : Success

EntityId : 5bf28b9f543c15b707d723a803096b2563d5ba27

Class : StorageSystem

... etc...

This example gets all of the entities for the StorageSystem class.

-------------- Example 3 --------------

CC:\PS>Get-EmcEntity -EntityId ebca9b04fc762fcdc8963271e0c94e52e3cc8336 -RelatedTarget

-TargetClass "Enclosure"

EnclosureId : Bus 0 Enclosure 0

EnclosureType : DPE8

DisplayName :

HealthState : Success

EntityId : 1082eaa20bbfdcc6412979785083f33930b7e215

Class : Enclosure

EnclosureId : Bus 0 Enclosure 1

EnclosureType : DAE5S

DisplayName :

HealthState : Error

EntityId : c46767ef734e5d0bb5658199c1d7a0b14704caf8

Class : Enclosure

EnclosureId : Control Station 0

EnclosureType : Control Station Enclosure

DisplayName : Control Station 0

HealthState : Success

EntityId : 9baf33815d515940ab37ade8e7199fdd09ec0987

Class : Enclosure

EnclosureId : DME 0

EnclosureType : Data Mover Enclosure

DisplayName : DME 0

HealthState : Success

EntityId : a9e210a5290e927119fdf495c96fdf1b1c6fe0ea

Class : Enclosure

This example gets all the entities of the Enclosure class that have a target relationship with the entity.

-------------- Example 4 --------------

C:\PS>Get-EmcEntity -EntityId ebca9b04fc762fcdc8963271e0c94e52e3cc8336 -RelatedTarget

-Relationship LogicalPhysicalAssociation

EnclosureId : Bus 0 Enclosure 0

EnclosureType : DPE8

DisplayName :

HealthState : Success

EntityId : 1082eaa20bbfdcc6412979785083f33930b7e215

Class : Enclosure

EnclosureId : Bus 0 Enclosure 1

EnclosureType : DAE5S

DisplayName :

HealthState : Error

EntityId : c46767ef734e5d0bb5658199c1d7a0b14704caf8

Class : Enclosure

EnclosureId : Control Station 0

EnclosureType : Control Station Enclosure

DisplayName : Control Station 0

HealthState : Success

EntityId : 9baf33815d515940ab37ade8e7199fdd09ec0987

Class : Enclosure

EnclosureId : DME 0

EnclosureType : Data Mover Enclosure

DisplayName : DME 0

HealthState : Success

EntityId : a9e210a5290e927119fdf495c96fdf1b1c6fe0ea

Class : Enclosure

This example gets all the entities that have a target relationship named LogicalPhysicalAssociation.

-------------- Example 5 --------------

C:\PS>Get-EmcEntity -EntityId 1082eaa20bbfdcc6412979785083f33930b7e215 -RelatedSource

Name : FNM00104000192-26.136-26.142

Model : VNX5500

SoftwareRevision : 05.32.000.5.006

SerialNumber : FNM00104000192

HealthState : Warning

EntityId : ebca9b04fc762fcdc8963271e0c94e52e3cc8336

Class : StorageSystem

This example gets all the entities that have a source relationship with the entity.


Get-EmcEntityClass (ESI Service)

Gets the class names of entity objects in the Entity Graph of an ESI Service instance.

Syntax

Get-EmcEntityClass [[-Pattern] <String>] [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

Description

Each entity in an Entity Graph is of a particular class, for example, the StorageSystem class. This command returns the list of unique class names for all entities in the graph.

Parameters

-Pattern <String>

Attributes: Optional, Position: 1

Specifies the pattern to filter the results. Wildcards are permitted.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcEntityClass

StorageSystem

Enclosure

DiskDrive

PowerSupply

StandbyPowerSupply

LunStorageServiceNode

FcStoragePort

IscsiStoragePort

CPUModule

IOModule

MemoryModule

LinkControlCard

ManagementStorageServiceNode

CoolingComponent

CifsStorageServiceNode

NetworkSwitch

LunStoragePool

ConcreteLun

LunMaskingView

StorageManagementServiceEndpoint

SnapshotPool

CifsStoragePool

CifsSharedFolder

SnapshotLun

This example gets all Entity class names.

-------------- Example 2 --------------

C:\PS>Get-EmcEntityClass -Pattern *Pool

LunStoragePool

SnapshotPool

CifsStoragePool

This example gets all Entity class names that end with "Pool."


Get-EmcEntityRelationship (ESI Service)

Gets one or more Entity relationship objects from the Entity Graph of an ESI Service instance.

Syntax

  • Get-EmcEntityRelationship [-NamesOnly <SwitchParameter>] [-Relationship <String>] [-SourceId <String>] [-TargetId <String>] [-SourceClass <String>] [-TargetClass <String>] [-ServiceUrl <String>] [-Silent <SwitchParameter>] [<CommonParameters>]

  • Get-EmcEntityRelationship [-NamesOnly <SwitchParameter>] [-Relationship <String>] [-ServiceUrl <String>] [-Silent <SwitchParameter>] -EntityId <String> [-Outgoing <SwitchParameter>] [-Incoming <SwitchParameter>] [<CommonParameters>]

Description

An Entity relationship represents a directional link between two Entity objects in an Entity Graph, where one Entity is the source and the other a target. This command returns entity relationship objects that satisfy the specified parameters.

Parameters

-NamesOnly <SwitchParameter>

Attributes: Optional, Position: named

If specified, only returns the unique names of the entity relationships.

-Relationship <String>

Attributes: Optional, Position: named

If specified, only returns entity relationship objects with a specific name. For example, gets entity relationships for the LogicalContainment relationship.

-SourceId <String>

Attributes: Optional, Position: named

Specifies the ID of an entity object in the Entity Graph. If specified, the parameter returns only entity relationship objects for the source entity end of the relationship.

-TargetId <String>

Attributes: Optional, Position: named

Specifies the ID of an entity object in the Entity Graph. If specified, the parameter returns only entity relationship objects for the target class entity.

-SourceClass <String>

Attributes: Optional, Position: named

Specifies the name of an entity class. If specified, the parameter returns only entity relationship objects for the source class entity.

-TargetClass <String>

Attributes: Optional, Position: named

Specifies the name of an entity class. If specified, the parameter returns only entity relationship objects for the target entity.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-EntityId <String>

Attributes: Required, Position: named, Accepts pipeline input (by value or parameter name)

Specifies the ID of an entity in the Entity Graph. If specified, ESI returns entity relationship objects that are associated with the entity, which can be a source or target.

-Outgoing <SwitchParameter>

Attributes: Optional, Position: named

If specified, returns entity relationship objects where the entity specified in -EntityID is the source of the relationship.

-Incoming <SwitchParameter>

Attributes: Optional, Position: named

If specified, returns entity relationship objects where the entity specified in -EntityID is the target of the relationship.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcEntityRelationship

Name : LogicalPhysicalAssociation

SourceClass : StorageSystem

SourceId : 7f633007b0695172facbe3e85a0902793bfd531d

TargetClass : Enclosure

TargetId : eb96700535f14687abf6cf37da3d9907af7cd908

Name : PhysicalContainment

SourceClass : Enclosure

SourceId : eb96700535f14687abf6cf37da3d9907af7cd908

TargetClass : StandbyPowerSupply

TargetId : d02341fd431d182a3a4ebd2be09f83d4ff9e1655

...etc...

This example gets all entity relationships.

-------------- Example 2 --------------

C:\PS>Get-EmcEntityRelationship -Outgoing -EntityId 7f633007b0695172facbe3e85a0902793bfd531d

Name : LogicalPhysicalAssociation

SourceClass : StorageSystem

SourceId : 7f633007b0695172facbe3e85a0902793bfd531d

TargetClass : Enclosure

TargetId : eb96700535f14687abf6cf37da3d9907af7cd908

Name : LogicalPhysicalAssociation

SourceClass : StorageSystem

SourceId : 7f633007b0695172facbe3e85a0902793bfd531d

TargetClass : Enclosure

TargetId : 90a9f51508578c2373a66c781ff0fa3e76bd187f

This example gets all outgoing entity relationships, such as those where the specified entity is the source.

-------------- Example 3 --------------

C:\PS>Get-EmcEntityRelationship -Incoming -EntityId 3ce84415b5d38ec5076f718b33a9895325

554c3d

Name : LogicalContainment

SourceClass : StorageSystem

SourceId : 97851c102dd4728062b55ef6bf1502b59ee9244d

TargetClass : CifsStoragePool

TargetId : 3ce84415b5d38ec5076f718b33a9895325554c3d

This example gets all incoming entity relationships, such as those where the specified entity is the target.

-------------- Example 4 --------------

C:\PS>Get-EmcEntityRelationship -Outgoing -EntityId f66a10a9c404f98432310499e212188917

41dd69 -Relationship LogicalPhysicalAssociation

Name : LogicalPhysicalAssociation

SourceClass : StorageSystem

SourceId : f66a10a9c404f98432310499e21218891741dd69

TargetClass : Enclosure

TargetId : e14db631de7e701282acec39d1cb0bea8ecbc30e

Name : LogicalPhysicalAssociation

SourceClass : StorageSystem

SourceId : f66a10a9c404f98432310499e21218891741dd69

TargetClass : Enclosure

TargetId : 2c4ede2d32dcdc93f2611f07627a1ecc9924e7d9

This example gets all outgoing entity relationships where the relationship name is LogicalPhysicalAssociation.


Add-EmcUser (ESI Service)

Adds an authorized user to the ESI Service.

Syntax

Add-EmcUser [-Name] <String> [-Role] <String> [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

Description

The ESI Service can only be accessed by authorized users. This command adds a Windows user or security group with the specified role to the ESI Service.

Parameters

-Name <String>

Attributes: Required, Position: 1

Specifies the name of the user to add. This is a Windows user or security group in <Domain>\<UserName> format. This must be a valid Windows user or security group, or the user will not be added.

-Role <String>

Attributes: Required, Position: 2

Specifies the role of Administrator or Monitor to assign to the user.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Add-EmcUser "SR5DOM\ESI SCOM Agents" Monitor

Name SID Roles

---- --- -----

SR5DOM\ESI SCOM Agents S-1-5-21-1311685843-2211060-2... {Monitor}

This example adds a security group for the Monitor role.


Get-EmcSecurityRole (ESI Service)

Gets the security roles for the ESI Service.

Syntax

Get-EmcSecurityRole [[-Id] <String>] [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the role names. Wildcards are permitted.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcSecurityRole

This example lists all the security roles for the ESI Service, which includes the Administrator and Monitor roles.


Get-EmcUser (ESI Service)

Gets the authorized users of the ESI Service.

Syntax

Get-EmcUser [[-Pattern] <String>] [-Role <String>] [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

Description

This command returns the list of Windows users or security groups that have an authorized role in the ESI Service.

Parameters

-Pattern <String>

Attributes: Optional, Position: 1

If specified, filters the resulting list of users with names matching the Regex pattern.

-Role <String>

Attributes: Optional, Position: named

If specified, only returns users who have the specified role of Administrator or Monitor.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcUser

Name SID Roles

---- --- -----

SR5DOM\songd2 S-1-5-21-1311685843-2211060-2... {Administrator}

SR5DOM\ESI SCOM Agents S-1-5-21-1311685843-2211060-2... {Monitor}

This example gets all authorized users.

-------------- Example 2 --------------

C:\PS>Get-EmcUser -Role Monitor

Name SID Roles

---- --- -----

SR5DOM\ESI SCOM Agents S-1-5-21-1311685843-2211060-2... {Monitor}

This example gets all authorized users with the Monitor role.

-------------- Example 3 --------------

C:\PS>Get-EmcUser *scom*

Name SID Roles

---- --- -----

SR5DOM\ESI SCOM Agents S-1-5-21-1311685843-2211060-2... {Monitor}

This example gets the users with a name that matches a wildcard pattern.


Remove-EmcUser (ESI Service)

Removes an authorized user from the ESI Service.

Syntax

Remove-EmcUser [-Name] <String> [[-Role] <String>] [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

Description

This command removes a Windows user or security group that has been granted one or more roles in the ESI Service. It can remove a single role for the user or remove all roles.

Parameters

-Name <String>

Attributes: Required, Position: 1

The name of the user to remove.

-Role <String>

Attributes: Optional, Position: 2

If specified, removes only the specified role from the user. If omitted, the parameter removes all roles from the user.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Remove-EmcUser "SR5DOM\ESI SCOM Agents" Administrator

SR5DOM\ESI SCOM Agents removed from Administrator role

This example removes a role from a user.

-------------- Example 2 --------------

C:\PS>Remove-EmcUser SR5DOM\songd2

SR5DOM\songd2 removed from all roles

This example removes all roles from a user.


Set-EmcServicePolicy (ESI Service)

Sets the system refresh interval service policy for the ESI Service.

Syntax

Set-EmcServicePolicy -RefreshIntervalInMinutes <Int32> [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

Parameters

-RefreshIntervalInMinutes <Int32>

Attributes: Required, Position: named

Specifies the system refresh interval in minutes.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Set-EmcServicePolicy -RefreshIntervalInMinutes 5

This example sets the system refresh interval policy to five minutes for the ESI Service.


Set-EmcServiceUrl (ESI Service)

Sets the URL to the ESI Service for the current session.

Syntax

  • Set-EmcServiceUrl [-ServiceUrl] <String> [-Silent] [<CommonParameters>]

  • Set-EmcServiceUrl [-Silent] -IpAddress <String> -Port <String> [-SSL] [<CommonParameters>]

  • Set-EmcServiceUrl [-Silent] -Clear [<CommonParameters>]

Description

By default the commands in the ESI Service PowerShell Toolkit connect to an instance of the ESI Service running on the local host. This command allows you to specify a URL to another ESI Service instance.

Parameters

-ServiceUrl <String>

Attributes: Required, Position: 1

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-IpAddress <String>

Attributes: Required, Position: named

Specifies the IP address of the ESI Service URL.

-Port <String>

Attributes: Required, Position: named

Specifies the port of the ESI Service URL.

-SSL <SwitchParameter>

Attributes: Optional, Position: named

Specifies if the ESI Service URL uses the SSL protocol.

-Clear <SwitchParameter>

Attributes: Required, Position: named

Clears the service URL on the session, which enables ESI to use the default localhost or -ServiceURL value.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Set-EmcServiceUrl http://10.0.0.50:54500

This example sets the service URL to http://10.0.0.50:54500.

-------------- Example 2 --------------

C:\PS>Set-EmcServiceUrl -IpAddress 10.0.0.50 -Port 54500 -SSL

This example sets the service URL to https://10.0.0.50:54500, which uses the SSL protocol.

-------------- Example 3 --------------

C:\PS>Set-EmcServiceUrl -Clear

This example clears the service URL and uses the default value of https://localhost:54501.


Add-EmcSystem (ESI Service)

Registers storage systems with the ESI Service.

Syntax

  • Add-EmcSystem [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

  • Add-EmcSystem [-ServiceUrl <String>] [-Silent] -Params <Hashtable> -SystemType <String> -UserFriendlyName <String> [<CommonParameters>]

Parameters

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-Params <Hashtable>

Attributes: Required, Position: named

Specifies the key value pair of the creation parameters for the system to be registered.

-SystemType <String>

Attributes: Required, Position: named

Specifies the storage system type, which you can also get with the Get-EmcSystemType cmdlet.

-UserFriendlyName <String>

Attributes: Required, Position: named

Specifies the user-friendly name for the system registered.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$p = @{"SerialNumber" ="000194900300";"Host" = "10.25.0.200";"Port"=5988}

C:\PS>$p

C:\PS>Add-EmcSystem -SystemType VMAX -Params $p -UserFriendlyName MyVMAX

This example creates a key value pair of the creation parameters for the VMAX system and registers the system with a user-friendly name of MyVMAX.

-------------- Example 2 --------------

C:\PS>$p = @{"Username"="admin";
 "Password"="pswd";"SpaIpAddress"="10.25.0.200";
 "SpbIpAddress"= "10.25.0.201"}

C:\PS>$p

C:\PS>Add-EmcSystem -SystemType VNX-Block -Params $p -UserFriendlyName MyVNX

This example creates a key value pair of the creation parameters for a VNX-Block system and registers the system with a user-friendly name of MyVNX.

-------------- Example 3 --------------

C:\PS>Add-EmcSystem

When you run this cmdlet in this example, you are prompted to specify the parameters to register the system for the ESI Service.


Disable-EMCServerCertificateValidation (ESI Service)

Disables the server certificate validation when using SSL to communicate with the ESI Service.

Syntax

Disable-EmcServerCertificateValidation [-Silent] [<CommonParameters>]

Description

The ESI Service commands can be configured to use a secured channel (SSL) when connecting to the ESI Service by specifying an https URL in the Set-EmcServiceUrl cmdlet or via the ServiceURL parameter. This command disables the validation of the server certificate as part of establishing the SSL connection. This is necessary if the ESI Service is configured to use a self-signed certificate.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Disable-EmcServerCertificateValidation

This example disables the server SSL certificate validation for the ESI Service.


Enable-EMCServerCertificateValidation (ESI Service)

Enables the server certificate validation when using SSL to communicate with the ESI Service.

Syntax

Enable-EmcServerCertificateValidation [-Silent] [<CommonParameters>]

Description

The ESI Service commands can be configured to use a secured channel (SSL) when connecting to the ESI Service by specifying an https URL in the Set-EmcServiceUrl cmdlet or via the ServiceURL parameter. This command enables the validation of the server certificate as part of establishing the SSL connection.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Enable-EmcServerCertificateValidation

This example enables the server SSL certificate validation for the ESI Service.


Get-EmcServiceConnectionOptions (ESI Service)

Gets the current options for connecting to the ESI Service.

Syntax

Get-EmcServiceConnectionOptions [-Silent] [<CommonParameters>]

Description

Returns the current Service URL and other options for the ESI Service connection.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcServiceConnectionOptions

ServiceURL ValidateServerCertificate

---------------------------------------------------------------------------------------------------

https://localhost:54501 False

This example gets the current options for connecting to the ESI Service.


Get-EmcSystem (ESI Service)

Lists all of the registered storage systems for the ESI Service.

Syntax

Get-EmcSystem [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

Parameters

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

FriendlyName : My VMAX

SystemType : VMAX

EntityId : f66a10a9c404f98432310499e21218891741dd69

LastSyncTimeUTC : 1/30/2015 9:30:13 PM

ElapsedMilliSeconds : 126062

NumEntities : 758

Properties : {SerialNumber=000194900376, Host=10.5.222.240, Port=5988, UseSSL=False...}

FriendlyName : My VNX-Block

SystemType : VNX-Block

EntityId : ad43421b21f152714874aad685677c7ef9b3e470

LastSyncTimeUTC : 1/30/2015 9:28:43 PM

ElapsedMilliSeconds : 35637

NumEntities : 164

Properties : {Username=nasadmin, Password=*****, ControlStationIPAddress=10.5.223.240, ControlStationPort=443...}

This example lists all registered storage systems for a specific ESI Service.


Get-EmcSystemType (ESI Service)

Lists all system types that are available for registration with the ESI Service.

Syntax

Get-EmcSystemType [-ServiceUrl <String>] [-Silent] [<CommonParameters>]

Parameters

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>PS C:\Work> Get-EmcSystemType

SystemType ProviderType Properties

---------------------------------------------------------

VNX-File Storage {Username, Password, ControlStationI...

VNX-Block Storage {Username, Password, SpaIpAddress, S...

VNX-F Storage {Username, Password, SpaIpAddress, S...

VMAX Storage {SerialNumber, Host, Port, UseSSL...}

VNX Storage {Block-Username, Block-Password, Spa...

VNXe Storage {ManagementIP, Username, Password}

VPLEX Storage {Username, Password, IpAddress, Port}

This example lists all the system types that are available for registration with the ESI Service.


Remove-EmcSystem (ESI Service)

Removes the registration of, or unregisters, a specified storage system with the ESI Service.

Syntax

  • Remove-EmcSystem -SystemName <String> [-Force] [-ServiceUrl <String>] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Remove-EmcSystem [-Force] [-ServiceUrl <String>] [-Silent] [-WhatIf] [-Confirm] -System <RegisteredSystem> [<CommonParameters>]

Parameters

-SystemName <String>

Attributes: Required, Position: named

Specifies the name of the system you want to unregister.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-ServiceUrl <String>

Attributes: Optional, Position: named

Specifies the base URL for the ESI Service. This must contain only the scheme, host, and port. If no value is specified, ESI uses the default of localhost or the value set by using the Set-EmcServiceUrl cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

-System <RegisteredSystem>

Attributes: Required, Position: named, accepts pipeline input (by value)

Specifies the system object you want to unregister.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Remove-EmcSystem -SystemName MyVNX

This example unregisters the system with the name MyVNX.

-------------- Example 2 --------------

C:\PS>$s = Get-EmcSystem

C:\PS> Remove-EmcSystem -System $s[0]

This example gets all the registered systems and unregisters the first system object.


Add-EmcHostDiskToCluster

Adds a disk to a cluster.

Syntax

  • Add-EmcHostDiskToCluster -HostLunIdentifier <HostLunIdentifier> -ClusterSystem <IClusterSystem> -ClusterGroupName <String> [-Silent] [<CommonParameters>]

  • Add-EmcHostDiskToCluster -HostLunIdentifier <HostLunIdentifier> -ClusterSystem <IClusterSystem> [-Silent] -AddToClusterSharedVolume [<CommonParameters>]

  • Add-EmcHostDiskToCluster -ClusterSystem <IClusterSystem> -ClusterGroupName <String> [-Silent] -HostDisk <Disk> [<CommonParameters>]

  • Add-EmcHostDiskToCluster -ClusterSystem <IClusterSystem> [-Silent] -AddToClusterSharedVolume -HostDisk <Disk> [<CommonParameters>]

Parameters

-HostLunIdentifier <HostLunIdentifier>

Attributes: Required, Position: named

Specifies the ESI HostLunIdentifier object, which you can get from the ESI host disk object, the ESI cluster disk object, or by using the Get-EmcHostLunIdentifier cmdlet.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add the cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get the cluster system object by using the Get-EmcClusterSystem cmdlet.

-ClusterGroupName <String>

Attributes: Optional, Position: named

Specifies the cluster group name. If the cluster group name is not specified, the cmdlet adds the disk to the available storage group.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-AddToClusterSharedVolume <SwitchParameter>

Attributes: Required, Position: named

Adds to the cluster shared volume.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 1gb -Silent

C:\PS>$c = Get-EmcClusterSystem myclus*

C:\PS>Set-EmcLunAccess -Lun $l -ClusterSystem $c -Available -silent

C:\PS>$hd = Find-EmcHostDisk -ClusterSystem $c -Lun $l -Silent

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive5

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -ClusterSystem $c -PartitionStyle gpt

C:\PS>New-EmcVolume -ClusterSystem $c -HostDisk $hd -Label volume_1

C:\PS>$cd = Add-EmcHostDiskToCluster -ClusterSystem $c -HostDisk $hd -ClusterGroupName App1

Or

C:\PS>$cd = Add-EmcHostDiskToCluster -ClusterSystem $c -HostDisk $hd -ClusterGroupName AvailableStorage

This example creates a LUN, unmasks the LUN to a cluster system, finds the corresponding disk, initializes it, creates a volume, and adds the disk to a cluster. If the cluster group name is specified with AvailableStorage, the disk is added to the available storage group.

-------------- Example 2 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 1gb -Silent

C:\PS>$h = Get-EmcClusterSystem myclus*

C:\PS>Set-EmcLunAccess -Lun $l -ClusterSystem $h -Available -silent

C:\PS>$hd = Find-EmcHostDisk -ClusterSystem $h -Lun $l -Silent

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive5

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -ClusterSystem $h -PartitionStyle gpt

C:\PS>New-EmcVolume -ClusterSystem $h -HostDisk $hd -Label volume_1

C:\PS>$cd = Add-EmcHostDiskToCluster -ClusterSystem $c -HostDisk $hd -AddToClusterSharedVolume

This example creates a LUN, unmasks the LUN onto a cluster system, finds the corresponding disk, initializes it, creates a volume, and adds it to the cluster shared volume group.


Clear-EmcHostDiskSignature

Clears the host disk signatures and assigns new ones.

Syntax

Clear-EmcHostDiskSignature -HostDisk <Disk> [-Silent] [<CommonParameters>]

Parameters

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$hd = $h.HostDisks[6]

C:\PS>$hd.MbrDiskSignature

3452748690

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive6

C:\PS>Clear-EmcHostDiskSignature -HostDisk $hd

TaskStatus: Started

0% : Clearing host disk signature...

100% : Host disk signature successfully cleared.

TaskStatus: Completed

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$hd = $h.HostDisks[6]

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive6

C:\PS>$hd.MbrDiskSignature

3452748691

C:\PS>

This example clears the host disk signature and assigns a new one.


Expand-EmcHostVolume

Expands the volume of a host.

Syntax

  • Expand-EmcHostVolume -HostSystem <IHostSystem> -Volume <Volume> [-CapacityToAdd <UInt64>] [-Silent] [<CommonParameters>]

  • Expand-EmcHostVolume -Volume <Volume> [-CapacityToAdd <UInt64>] [-Silent] -ClusterSystem <IWindowsFailoverClusterSystem> [<CommonParameters>]

Parameters

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-Volume <Volume>

Attributes: Required, Position: named

Specifies the volume of host.

-CapacityToAdd <UInt64>

Attributes: Optional, Position: named

Specifies the new capacity to be added to host.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ClusterSystem <IWindowsFailoverClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$s=Get-EmcStorageSystem -Id *124

C:\PS>$pool = Get-EmcStoragePool -ID *1000 -StorageSystem $s

C:\PS>$system=Get-EmcHostSystem *43

C:\PS&gt;$lun = new-emclun -Pool $pool -Capacity 1GB -Name &quot;lun_1&quot;

C:\PS>Set-EmcLunAccess -HostSystem $system -Lun $lun -Available

C:\PS>$disk = Find-EmcHostDisk -HostSystem $system -Lun $lun

C:\PS>Initialize-EmcHostDisk -HostSystem $system -HostDisk $disk -PartitionStyle mbr

C:\PS>$volume = New-EmcVolume -HostSystem $system -HostDisk $disk -FileSystemType ntfs -AllocationUnitSizeInBytes 64KB -Label lun_1

C:\PS>Expand-EmcLun -Lun $lun -NewCapacity 5GB

C:\PS>Expand-EmcHostVolume -HostSystem $system -Volume $volume

This example expands the host volume.

-------------- Example 2 --------------

C:\PS>$s=Get-EmcStorageSystem -Id *124

C:\PS>$pool = Get-EmcStoragePool -ID *1000 -StorageSystem $s

C:\PS>$system=Get-EmcClusterSystem *220

C:\PS>$lun = new-emclun -Pool $pool -Capacity 1GB -Name "lun_1"

C:\PS>Set-EmcLunAccess -ClusterSystem $system -Lun $lun -Available

C:\PS>$disk = Find-EmcHostDisk -ClusterSystem $system -Lun $lun

C:\PS>Initialize-EmcHostDisk -ClusterSystem $system -HostDisk $disk -PartitionStyle mbr

C:\PS>$volume = New-EmcVolume -ClusterSystem $system -HostDisk $disk -FileSystemType ntfs -AllocationUnitSizeInBytes 64KB -Label lun_1

C:\PS>Add-EmcHostDiskToCluster -HostLunIdentifier $disk.HostLunIdentifier -ClusterSystem $cluster -ClusterGroupName "Available Storage"

C:\PS>Expand-EmcLun -Lun $lun -NewCapacity 5GB

C:\PS>Expand-EmcHostVolume -ClusterSystem $system -Volume $volume

This example expands the host volume of a cluster.


Find-EmcHostDisk

Finds the ESI host disk associated with an ESI LUN, host LUN identifier, or VM disk configuration on a host or cluster system.

Syntax

  • Find-EmcHostDisk -HostSystem <IHostSystem> -HostLunIdentifier <HostLunIdentifier> [-RescanCount <UInt32>] [-Silent] [<CommonParameters>]

  • Find-EmcHostDisk -HostSystem <IHostSystem> [-RescanCount <UInt32>] [-Silent] -Lun <Lun> [<CommonParameters>]

  • Find-EmcHostDisk [-RescanCount <UInt32>] [-Silent] -Lun <Lun> -ClusterSystem <IClusterSystem> [<CommonParameters>]

  • Find-EmcHostDisk [-RescanCount <UInt32>] [-Silent] -VirtualMachine <IHostSystem> -VmDiskConfig <VmScsiDiskConfiguration> [<CommonParameters>]

Description

This cmdlet finds the ESI host disk associated with the specified LUN or HostLunIdentifier or VmDiskConfiguration on a specified host system or cluster system by updating or refreshing the host disks.

Parameters

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-HostLunIdentifier <HostLunIdentifier>

Attributes: Required, Position: named

Specifies the ESI HostLunIdentifier object, which you can get from the ESI host disk object, the ESI cluster disk object, or by using the Get-EmcHostLunIdentifier cmdlet.

-RescanCount <UInt32>

Attributes: Optional, Position: named

Specifies the rescan count number for the LUN.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. However, it still displays errors.

-Lun <Lun>

Attributes: Required, Position: named

Specifies the ESI LUN object, which you can get by using ESI storage system object or by using the Get-EmcLun cmdlet.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-VirtualMachine <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI virtual machine host system object. The ESI virtual machine is derived from the host system. You can add a virtual machine to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets, the same as the host system. You can get a virtual machine host system object by using the Get-EmcHostSystem cmdlet.

-VmDiskConfig <VmDiskConfiguration>

Attributes: Required, Position: named

Specifies the ESI VmDiskConfiguration object, which encapsulates the attached file-based disk or pass-through disk configuration information such as the SCSI controller ID, index, and attached LUN number. The object can be used to find the disk in the virtual machine if a file-based or pass-through disk is attached to a virtual machine from a hypervisor. The Add-EmcFilebasedDiskToVirtualMachine and Add-EmcPassthroughDiskToVirtualMachine cmdlets return the VmDiskConfiguration object.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS&gt;$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 2GB -Silent

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>Set-EmcLunAccess -Lun $l -HostSystem $h -Available

TaskStatus: Started

10% : Unmasking the LUN to the specified host(s)...

100% : The specified LUN has been unmasked to the specified initiators...

TaskStatus: Completed

C:\PS>$hd = Find-EmcHostDisk -HostSystem $h -Lun $l -Silent

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive7

This example creates a LUN, unmasks the LUN to a host system, and finds the corresponding disk.

-------------- Example 2 --------------

C:\PS&gt;$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 2GB -Silent

C:\PS>$h = Get-EmcClusterSystem myclus*

C:\PS>Set-EmcLunAccess -Lun $l -ClusterSystem $h -Available -silent

C:\PS>$hd = Find-EmcHostDisk -ClusterSystem $h -Lun $l -Silent

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive5

This example creates a LUN, unmasks the LUN to a cluster system, and finds the corresponding disk.

-------------- Example 3 --------------

C:\PS>$h = Get-EmcHostSystem *.133

C:\PS>$h.Model

Hyper-V, PowerEdge R710

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.Model

Virtual Machine

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$locations =Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration $vmconfig -ScsiControllerIndex 0

C:\PS>$passthroughDisks = $h | Get-EmcAvailableEmcPassthroughDiskCandidate

C:\PS>$diskConfig = Add-EmcPassthroughDiskToVirtualMachine -VirtualMachineConfiguration $vmconfig -HostDisk $passthroughDisks[0] -Location $locations[0]

C:\PS>$hd = Find-EmcHostDisk -VirtualMachine $vm -VmDiskConfig $diskConfig

C:\PS>Remove-EmcVirtualDiskFromVm -VirtualMachineConfiguration $vmconfig -Location $locations[0] -force

This example attaches a pass-through disk to a virtual machine with the VmDiskConfiguration cmdlet. The Find-EmcHostDisk cmdlet finds the corresponding disk in the virtual machine.

-------------- Example 4 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 2GB -Silent

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>Set-EmcLunAccess -Lun $l -HostSystem $h -Available

TaskStatus: Started

10% : Unmasking the LUN to the specified host(s)...

100% : The specified LUN has been unmasked to the specified initiators...

TaskStatus: Completed

C:\PS>$lunIdentifier = Get-EmcHostLunIdentifier -Lun $l

C:\PS>$hd = Find-EmcHostDisk -HostSystem $h -HostLunIdentifier $lunIdentifier -RecanCount 10 -Silent

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive7

This example creates a LUN, un-masks the LUN to the specified host system, and finds the corresponding disk for the LUN identifier.


Get-EmcAvailableDriveLetter

Gets the available drive letters on a host system or a cluster system.

Syntax

  • Get-EmcAvailableDriveLetter [-HostSystem] <IHostSystem> [-Silent] [<CommonParameters>]

  • Get-EmcAvailableDriveLetter [-Silent] [-ClusterSystem] <IClusterSystem> [<CommonParameters>]

Parameters

-HostSystem <IHostSystem>

Attributes: Required, Position: 1

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: 1

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. It can be a stand-alone host system, a virtual machine, or a hypervisor.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>$drives = Get-EmcAvailableDriveLetter -HostSystem $h

C:\PS>$drives[0]

G

C:\PS>$drives.count

20

This example gets the available drive letters from a host system.

-------------- Example 2 --------------

C:\PS>$c = Get-EmcClusterSystem

C:\PS>$drives = $c | Get-EmcAvailableDriveLetter

C:\PS>$drives.count

15

C:\PS>$drives[14]

Y

C:\PS>

This example gets the available drive letters from a cluster system.


Get-EmcClusterDisk

Gets the list of cluster disks.

Syntax

  • Get-EmcClusterDisk [[-ID] <String>] [-ClusterSystem <IWindowsFailoverClusterSystem>] [-ClusterGroupName <String>] [-Silent] [<CommonParameters>]

  • Get-EmcClusterDisk [[-ID] <String>] [-ClusterSystem <IWindowsFailoverClusterSystem>] [-Silent] [-ClusterSharedVolume] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the cluster disk resource name. Wildcards are permitted. It is a positional parameter (position = 1).

-ClusterSystem <IWindowsFailoverClusterSystem>

Attributes: Optional, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-ClusterGroupName <String>

Attributes: Optional, Position: named

Specifies the cluster group name to filter the cluster disks based on the group name.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ClusterSharedVolume <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to cluster shared volume disks.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcClusterDisk

C:\PS>Get-EmcClusterDisk -ClusterSharedVolume

C:\PS>Get-EmcClusterDisk -ClusterGroupName "Available Storage"

This example gets the cluster disks from all the connected cluster systems.

-------------- Example 2 --------------

C:\PS>Get-EmcClusterSystem | Get-EmcClusterDisk

C:\PS>Get-EmcClusterSystem | Get-EmcClusterDisk -ClusterSharedVolume

C:\PS>Get-EmcClusterSystem | Get-EmcClusterDisk -ClusterGroupName "Available Storage"

This example gets the cluster disks from the cluster system.

-------------- Example 3 --------------

C:\PS>Get-EmcClusterSystem | Get-EmcClusterDisk "Cluster Disk*"

C:\PS>Get-EmcClusterSystem | Get-EmcClusterDisk -id "Cluster Disk*"

C:\PS>Get-EmcClusterSystem | Get-EmcClusterDisk "Cluster Disk 96056475"

This example gets the cluster disks based on cluster disk resource name. Because the ID parameter is positional, you can omit the name.


Get-EmcClusterGroup

Gets the list of cluster groups.

Syntax

Get-EmcClusterGroup [-ClusterSystem] <IWindowsFailoverClusterSystem> [-Silent] [<CommonParameters>]

Parameters

-ClusterSystem <IWindowsFailoverClusterSystem>

Attributes: Required, Position: 1

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcClusterSystem | Get-EmcClusterGroup -Silent | select name

Name

----

Available Storage

App1

App2

This example gets the cluster groups of the cluster system.


Get-EmcClusterSystem

Gets connected cluster systems.

Syntax

  • Get-EmcClusterSystem [[-ID] <String>] [-Silent] [<CommonParameters>]

  • Get-EmcClusterSystem [-Silent] -ClusterDisk <WindowsBasicClusterDisk> [<CommonParameters>]

Description

Gets connected cluster systems. A cluster system can be added to ESI using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets.

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the cluster name, IP address, or global ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ClusterDisk <WindowsBasicClusterDisk>

Attributes: Required, Position: named

Specifies the ESI cluster disk object. You can get the object from the ESI cluster system object or by using the Get-EmcClusterDisk cmdlet. You can add the object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>Get-EmcClusterSystem

This example gets all the connected cluster systems.

-------------- Example 2 --------------

C:\PS>Get-EmcClusterSystem -Id mycluster*

C:\PS>Get-EmcClusterSystem -Id 10.x.y.*

C:\PS>Get-EmcClusterSystem 2cc75087-8ddf*

This example gets the cluster system based on the specified cluster name, IP address, or global ID. Wildcards are permitted. Because the ID parameter is positional, you can omit the name.

-------------- Example 3 --------------

C:\PS>$cd = Get-EmcClusterDisk -Silent

C:\PS>$cd[0].ClusterDiskResourceName

Cluster Disk 195783575

C:\PS>$cd[0] | Get-EmcClusterSystem

This example gets the cluster system based on the specified cluster disk.


Get-EmcClusterNode

Gets the list of cluster nodes.

Syntax

Get-EmcClusterNode [-ClusterSystem] <IWindowsFailoverClusterSystem> [-Silent] [<CommonParameters>]

Parameters

-ClusterSystem <IWindowsFailoverClusterSystem>

Attributes: Required, Position: 1

Specifies the ESI Cluster System object. A cluster system object can be added to ESI using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. A cluster system object can be obtained by using the Get-EmcClusterSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcClusterSystem | Get-EmcClusterNode -Silent | select name

Name

----

AppSite1

AppSite2

This example gets the cluster nodes of specified cluster systems.


Get-EmcHostSystem

Gets connected host systems.

Syntax

  • Get-EmcHostSystem [[-Id] <String>] [-HostSystemType <HostSystemType>] [-Silent] [<CommonParameters>]

  • Get-EmcHostSystem [-Silent] -HostDisk <Disk> [<CommonParameters>]

  • Get-EmcHostSystem [-Silent] -Volume <Volume> [<CommonParameters>]

  • Get-EmcHostSystem [-Silent] -VirtualMachineConfiguration <VirtualMachineConfiguration> [<CommonParameters>]

  • Get-EmcHostSystem [-Silent] -MailboxServer <MailboxServer> [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the host name, IP address, or global ID. Wildcards are permitted. It is a positional parameter (position = 1).

-HostSystemType <HostSystemType>

Attributes: Optional, Position: named

Specifies the host system type. Valid values are Hypervisor, VirtualMachine, Windows, HyperV, VMwareEsxHost, HyperV_VirtualMachine, or VMware_VirtualMachine.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-Volume <Volume>

Attributes: Required, Position: named

Specifies the ESI volume object, which you can get from the ESI host system object or by using the Get-EmcHostVolume cmdlet.

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: named

Specifies the ESI virtual machine configuration object, which you can get from the ESI hypervisor host system object VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet.

-MailboxServer <MailboxServer>

Attributes: Required, Position: named

Specifies the mailbox server associated with the host system.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcHostSystemCredential

C:\PS>$Host1 = $h | Connect-EmcHostSystem

C:\PS>Get-EmcHostSystem

This example gets the connected host systems.

-------------- Example 2 --------------

C:\PS>$Disk = Get-EmcHostDisk -id 4074289894

C:\PS>$Disk

C:\PS>Get-EmcHostSystem -HostDisk $Disk

This example gets the host system of the specified disk.

-------------- Example 3 --------------

C:\PS>$Volume = Get-EmcHostVolume *Site2Farm94*Data*

C:\PS>$Volume

C:\PS>Get-EmcHostSystem -Volume $Volume

This example gets the host system of the specified volume.

-------------- Example 4 --------------

C:\PS>Get-EmcHostSystem <HostName>

C:\PS>Get-EmcHostSystem <HostIP address>

C:\PS>Get-EmcHostSystem <HostGlobalId>

This example gets the host system with the specified host name, IP address, or global ID. Wildcards are permitted.

-------------- Example 5 --------------

C:\PS>Get-EmcHostSystem -HostSystemType hyperV

This example gets all of the Hyper-V systems.

-------------- Example 6 --------------

C:\PS>Get-EmcHostSystem -HostSystemType hyperV <HostIpAddress>

This example gets the Hyper-V system with a specified IP address. Wildcards are permitted.

-------------- Example 7 --------------

C:\PS>Get-EmcHostSystem -HostSystemType VMwareESXHost

This example gets all of the VMware ESX Hosts.

-------------- Example 8 --------------

C:\PS>Get-EmcHostSystem -HostSystemType VMware_VirtualMachine

This example gets all of the virtual machines of the VMware systems.

-------------- Example 9 --------------

C:\PS>$vm = Get-EmcHostSystemCredential | Connect-EmcSystem

C:\PS>$vmconfig = Get-EmcVirtualMachineConfiguration -VirtualMachine $vm

C:\PS>Get-EmcHostSystem -VirtualMachineConfiguration $vmconfig

This example gets the virtual machines for a specified configuration.

-------------- Example 10 --------------

C:\PS>$ms = Get-EmcMailboxServer MS1

C:\PS>Get-EmcHostSystem -MailboxServer $ms

This example gets the host system of the MS1 mailbox server.


Get-EmcHostBusAdapter

Gets the list of host bus adapters for the specified hosts.

Syntax

  • Get-EmcHostBusAdapter -HostSystem <IHostSystem> [-iSCSI] [-FC] [-Silent] [<CommonParameters>]

  • Get-EmcHostBusAdapter -ClusterSystem <IClusterSystem> [-iSCSI] [-FC] [-Silent] [<CommonParameters>]

  • Get-EmcHostBusAdapter -ReplicationSystem <ReplicationSystem> [-iSCSI] [-FC] [-Silent] [<CommonParameters>]

  • Get-EmcHostBusAdapter -ReplicationServiceSite <ReplicationServiceSite> [-iSCSI] [-FC] [-Silent] [<CommonParameters>]

Parameters

-HostSystem <IHostSystem>

Attributes: Required, Position: 1

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

ClusterSystem <IClusterSystem>

Attributes: Required, Position: 1

Specifies the ESI cluster system object, which you can add to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get the cluster system object by using the Get-EmcClusterSystem cmdlet.

-ReplicationSystem <ReplicationSystem>

Attributes: Required, Position: 1

Specifies the replication system, which is an individual replication appliance that performs and facilitates replication.

-ReplicationServiceSite <ReplicationServiceSite>

Attributes: Required, Position: 1

Specifies the replication service site in which the replication system resides.

-iSCSI <SwitchParameter>

Attributes: Optional, Position: named

Specifies an optional parameter through which the iSCSI HBA type filter can be filtered out.

-FC <SwitchParameter>

Attributes: Optional, Position: named

Specifies an optional parameter through which the FC HBA type filter can be filtered out.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>Get-EmcHostBusAdapter -HostSystem $h

This example gets the host bus adapter of the specified host system.

-------------- Example 2 --------------

C:\PS>$c = Get-EmcClusterSystem *.157

C:\PS>Get-EmcHostBusAdapter -ClusterSystem $c

This example gets the host bus adapter of the specified cluster system.

-------------- Example 3 --------------

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>Get-EmcHostBusAdapter -HostSystem $h -FC

This example gets all host bus adapters for the specified host system with the FC type.

-------------- Example 4 --------------

C:\PS>$c = Get-EmcClusterSystem *.157

C:\PS>Get-EmcHostBusAdapter -ClusterSystem $c -iSCSI

This example gets the host bus adapter of the specified cluster system with the iSCSI type.


Get-EmcHostDisk

Gets a list of host disk objects.

Syntax

  • Get-EmcHostDisk [[-ID] <String>] [-Lun <Lun>] [-Silent] [<CommonParameters>]

  • Get-EmcHostDisk [[-ID] <String>] [-Lun <Lun>] [-Silent] -HostSystem <IHostSystem> [<CommonParameters>]

  • Get-EmcHostDisk [[-ID] <String>] [-Lun <Lun>] [-Silent] -ClusterSystem <IClusterSystem> [<CommonParameters>]

  • Get-EmcHostDisk [[-ID] <String>] [-Silent] -ClusterSystem <IClusterSystem> -Volume <Volume> [<CommonParameters>]

  • Get-EmcHostDisk [[-ID] <String>] [-Silent] -ClusterSystem <IClusterSystem> -AllNodeHostDisk [<CommonParameters>]

  • Get-EmcHostDisk [[-ID] <String>] [-Silent] -ClusterSystem <IClusterSystem> -ClusteredHostDisk [<CommonParameters>]

  • Get-EmcHostDisk [[-ID] <String>] [-Silent] -MailboxDatabase <MailboxDatabase> [-MailboxDatabaseFileType <MailBoxDatabaseFileType>] [<CommonParameters>]

  • Get-EmcHostDisk [[-ID] <String>] [-Silent] [-MailboxDatabaseFileType <MailBoxDatabaseFileType>] -MailboxDatabaseCopy <MailboxDatabaseCopy> [<CommonParameters>]

  • Get-EmcHostDisk [[-ID] <String>] [-Silent] -ClusterNode <WindowsFailoverClusterNode> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the host disks HostDiskIdentifier, MbrDiskSignature, or GptDiskGuid. Wildcards are permitted. It is a positional parameter (position = 1).

-Lun <Lun>

Attributes: Optional, Position: named

Specifies the ESI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. It can be a stand-alone host system, a virtual machine, or a hypervisor.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-Volume <Volume>

Attributes: Required, Position: named

Specifies the ESI volume object, which you can get from the ESI host system object or by using the Get-EmcHostVolume cmdlet.

-AllNodeHostDisk <SwitchParameter>

Attributes: Required, Position: named

Indicates that this cmdlet queries host disks on all the nodes of the specified cluster.

-ClusteredHostDisk <SwitchParameter>

Attributes: Required, Position: named

Indicates that this cmdlet queries host disks that are clustered.

-MailboxDatabase <MailboxDatabase>

Attributes: Required, Position: named

Specifies the mailbox database associated with the host disk.

-MailboxDatabaseFileType <MailBoxDatabaseFileType>

Attributes: Optional, Position: named

Specifies the mailbox database file type associated with the host disk. It can be passed as edbfile, logs or ALL. By Default its set to All.

-MailboxDatabaseCopy <MailboxDatabaseCopy>

Attributes: Required, Position: named

Specifies the mailbox database copy.

-ClusterNode <WindowsFailoverClusterNode>

Attributes: Required, Position: named

Specifies the cluster node on which the host disks are located.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$h.RefreshDisks()

C:\PS>Get-EmcHostDisk -HostSystem $h

C:\PS>$h | Update-EmcSystem

C:\PS>Get-EmcHostDisk -HostSystem $h

This example gets all disks of the specified host.

-------------- Example 2 --------------

C:\PS>Get-EmcHostSystem | Update-EmcSystem

C:\PS>Get-EmcHostDisk

This example gets all disks on all of the connected hosts.

-------------- Example 3 --------------

C:\PS>$h = Get-EmcHostSystem *myhost*

C:\PS>$h | Update-EmcSystem

C:\PS>Get-EmcHostDisk -ID \\?\PhysicalDrive8 -HostSystem $h

C:\PS>Get-EmcHostDisk -ID *Drive8* -HostSystem $h

C:\PS>Get-EmcHostDisk \\?\PhysicalDrive8 -HostSystem $h

C:\PS>Get-EmcHostDisk *Drive8* -HostSystem $h

This example gets the host disks of the specified host system with the specified HostDiskIdentifier, MbrDiskSignature, or GptDiskGuid (accepts wildcard).

-------------- Example 4 --------------

C:\PS>Get-EmcHostSystem | Update-EmcSystem

C:\PS>Get-EmcHostDisk -ID \\?\PhysicalDrive8

C:\PS>Get-EmcHostDisk -ID *Drive8*

C:\PS>Get-EmcHostDisk \\?\PhysicalDrive8

C:\PS>Get-EmcHostDisk *Drive8*

This example gets the host disks of all connected host systems with the specified HostDiskIdentifier, MbrDiskSignature, or GptDiskGuid (accepts wildcard).

-------------- Example 5 --------------

C:\PS>$l = Get-EmcLUN mylun*

C:\PS>$l

C:\PS>Get-EmcHostDisk -Lun $l

C:\PS>$l | Get-EmcHostDisk

C:\PS>$h = Get-EmcHostSystem *myhost*

C:\PS>$h | Update-EmcSystem

C:\PS>$l | Get-EmcHostDisk -hostsystem $h

C:\PS>$s = Get-EmcStorageSystem

C:\PS>$s | Update-EmcSystem -Silent

C:\PS>$s.Luns | Get-EmcHostDisk foo*

C:\PS>$c = Get-EmcClusterSystem

C:\PS>$l = Get-EmcStoragePool gold* | Get-EmcLUN

C:\PS>$l | Get-EmcHostDisk -ClusterSystem $c

This example gets the host disks associated with the specified LUN object.

-------------- Example 6 --------------

C:\PS>Get-EmcHostVolume | Get-EmcHostDisk

C:\PS>$h = Get-EmcHostSystem *myhost*

C:\PS>$h | Update-EmcSystem

C:\PS>$v = Get-EmcHostVolume c:* -HostSystem $h

C:\PS>$v | Get-EmcHostDisk

This example gets the host disks associated with the specified volume object.

-------------- Example 7 --------------

C:\PS>$cluster = Get-EmcClusterSystem myCluster

C:\PS>$lun = Get-EmcLun myLunForCluster

C:\PS>Get-EmcHostDisk -Lun $lun - ClusterSystem $cluster

This example gets the host disks associated with a cluster system and a LUN.

-------------- Example 8 --------------

C:\PS>$cluster = Get-EmcClusterSystem myCluster

C:\PS>$cd = Get-EmcClusterDisk "Cluster Disk 1" -ClusterSystem $cluster

C:\PS>$vol = Get-EmcVolume "J:" -ClusterDisk $cd

C:\PS>Get-EmcHostDisk -Volume $vol - ClusterSystem $cluster

This example gets the host disks associated with a cluster system and a volume.

-------------- Example 9 --------------

C:\PS>$cluster = Get-EmcClusterSystem myCluster

C:\PS>Get-EmcHostDisk -ClusterSystem $cluster -AllNodeHostdisk

This example gets all host disks on the specified cluster.

-------------- Example 10 --------------

C:\PS>$cluster = Get-EmcClusterSystem myCluster

C:\PS>Get-EmcHostDisk -ClusterSystem $cluster -ClusteredHostdisk

This example gets all host disks that are clustered on the specified cluster.

-------------- Example 11 --------------

C:\PS>$cluster = Get-EmcClusterSystem myCluster

C:\PS>$nodes = Get-EmcClusterNode -ClusterSystem $cluster

C:\PS>Get-EmcHostDisk -ClusterNode $nodes[0]

This example gets all host disks on the specified node.

-------------- Example 12 --------------

C:\PS>$db= Get-EmcMailboxDatabase rvdb20

C:\PS>Get-EmcHostDisk -MailboxDatabase $db -MailboxDatabaseFileType edbFile

This example gets the host disks for edbfile that are associated with the specified mailbox database.

-------------- Example 13 --------------

C:\PS>$dbCopy= Get-EmcMailboxDatabaseCopy rvdb*

C:\PS>Get-EmcHostDisk -MailboxDatabaseCopy $dbCopy[0] -MailboxDatabaseFileType edbFile

This example gets the host disks for edbfile that are associated with the specified mailbox database copy.


Get-EmcHostLunIdentifier

Gets the host LUN identifier.

Syntax

  • Get-EmcHostLunIdentifier [-Lun] <Lun> [-Silent] [<CommonParameters>]

  • Get-EmcHostLunIdentifier [-Lun] <Lun> [-Silent] -ClusterSystem <IClusterSystem> [<CommonParameters>]

  • Get-EmcHostLunIdentifier [-Lun] <Lun> [-Silent] -HostSystem <IHostSystem> [<CommonParameters>]

Parameters

-Lun <Lun>

Attributes: Required, Position: 1

Specifies the ESI LUN object. You can get a LUN object by using the ESI storage system object or by using the Get-EmcLun cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcHostSystemCredential

C:\PS>$Host1 = $h | Connect-EmcSystem

C:\PS>$Lun95 = Get-EmcLUN Site2*Farm95*

C:\PS>Get-EmcHostLunIdentifier -Lun $Lun95 -HostSystem $Host1

This example gets the host LUN identifier for the specified LUN and host system.

-------------- Example 2 --------------

C:\PS>$Cluser1 = Get-EmcClusterSystem

C:\PS>$Cluser1

C:\PS>$Lun29 = Get-EmcLUN 11529*

C:\PS>$Lun29

C:\PS>Get-EmcHostLunIdentifier -Lun $Lun29 -ClusterSystem $Cluster1

This example gets the host LUN identifier for the specified LUN and cluster system.

-------------- Example 3 --------------

C:\PS>$l = Get-EmcLUN mylun*

C:\PS>Get-EmcHostLunIdentifier -Lun $l

This example gets the host LUN identifier for the specified LUN.


Get-EmcHostVolume

Gets the list of host volumes.

Syntax

  • Get-EmcHostVolume [[-ID] <String>] [-HostDisk <Disk>] [-Silent] [<CommonParameters>]

  • Get-EmcHostVolume [[-ID] <String>] [-HostDisk <Disk>] [-Silent] -ClusterSystem <IClusterSystem> [<CommonParameters>]

  • Get-EmcHostVolume [[-ID] <String>] [-Silent] -HostSystem <IHostSystem> [<CommonParameters>]

  • Get-EmcHostVolume [[-ID] <String>] [-Silent] -ClusterDisk <WindowsBasicClusterDisk> [<CommonParameters>]

  • Get-EmcHostVolume [[-ID] <String>] [-Silent] -MailboxDatabase <MailboxDatabase> [-MailboxDatabaseFileType <MailBoxDatabaseFileType>] [<CommonParameters>]

  • Get-EmcHostVolume [[-ID] <String>] [-Silent] [-MailboxDatabaseFileType <MailBoxDatabaseFileType>] -MailboxDatabaseCopy <MailboxDatabaseCopy> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the host volume label, drive letter, mount path, or HostVolumeIdentifier. Wildcards are permitted. It is a positional parameter (position = 1).

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object. You can get this from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-ClusterDisk <WindowsBasicClusterDisk>

Attributes: Required, Position: named

Specifies the ESI cluster disk object. You can get a cluster disk object from the ESI cluster system object or by using the Get-EmcClusterDisk cmdlet.

-MailboxDatabase <MailboxDatabase>

Attributes: Required, Position: named

Specifies the name of the mailbox database.

-MailboxDatabaseFileType <MailBoxDatabaseFileType>

Attributes: Optional, Position: named

Specifies the mailbox database file type associated with the host volume. It can be passed as an edbfile, logs, or All. By default it is set to All.

-MailboxDatabaseCopy <MailboxDatabaseCopy>

Attributes: Required, Position: named

Specifies the mailbox database copy.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hBlob = Get-EmcHostSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$h.RefreshDisks()

C:\PS>Get-EmcHostVolume -HostSystem $h

C:\PS>$h | Update-EmcSystem

C:\PS>Get-EmcHostVolume -HostSystem $h

This example gets all volumes of the specified host.

-------------- Example 2 --------------

C:\PS>Get-EmcHostSystem | Update-EmcSystem

C:\PS>Get-EmcHostVolume

This example gets all host volumes on all connected hosts.

-------------- Example 3 --------------

C:\PS>$cBlob = Get-EmcClusterSystemCredential

C:\PS>$c = $cBlob | Connect-EmcSystem

C:\PS>$c.RefreshClusterDisks()

C:\PS>Get-EmcHostVolume -ClusterSystem $c

C:\PS>$c | Update-EmcSystem

C:\PS>Get-EmcHostVolume -ClusterSystem $c

C:\PS>Get-EmcClusterDisk | Get-EmcHostVolume | select mountpath

MountPath

---------

F:\

B:\

This example gets the volumes of cluster disks or cluster systems.

-------------- Example 4 --------------

C:\PS>Get-EmcHostSystem | Update-EmcSystem

C:\PS>Get-EmcClusterSystem | Update-EmcSystem

C:\PS>Get-EmcHostVolume c:\

C:\PS>Get-EmcHostVolume c*

C:\PS>Get-EmcHostVolume volume_label_1

C:\PS>Get-EmcHostVolume -id "c:\mountpath\*"

C:\PS>Get-EmcHostVolume -id \\?\*

This example gets the volumes based on the drive letter or mount path or label or volume identifier. Wildcards are permitted. Because the ID parameter is positional, you can omit the name.

-------------- Example 5 --------------

C:\PS>$cluster = Get-EmcClusterSystem myCluster

C:\PS>$cd = Get-EmcClusterDisk "Cluster Disk 1" -ClusterSystem $cluster

C:\PS>$vol = Get-EmcHostVolume "J:" -ClusterDisk $cd

C:\PS>$disk = Get-EmcHostDisk -Volume $vol -ClusterSystem $cluster

C:\PS>$vol = Get-EmcHostVolume -Host $disk - ClusterSystem $cluster

This example gets the host volumes associated with a cluster and a host disk, and gets the host disks associated with a cluster and a volume.

-------------- Example 6 --------------

C:\PS>$db= Get-EmcMailboxDatabase rvdb20

C:\PS>Get-EmcHostVolume -MailboxDatabase $db -MailboxDatabaseFileType All

This example gets the host volumes for the edbfile and log folder associated with the specified mailbox database.

-------------- Example 7 --------------

C:\PS>$database = Get-EmcMailboxDatabase db1

C:\PS>$vol = Get-EmcHostVolume -MailboxDatabase $database

This example shows how to get host volumes associated with a mailbox database.

-------------- Example 8 --------------

C:\PS>$databasecopy = Get-EmcMailboxDatabaseCopy db1\MS2

C:\PS>$vol = Get-EmcHostVolume -MailboxDatabase $databasecopy

This example shows how to get host volumes associated with a mailbox database copy.


Initialize-EmcHostDisk

Initializes a host disk by bringing the disk online and setting a specified partition style in a host or cluster system.

Syntax

  • Initialize-EmcHostDisk [-PartitionStyle <PSPartitionStyle>] -HostDisk <Disk> -HostSystem <IHostSystem> [-Silent] [<CommonParameters>]

  • Initialize-EmcHostDisk [-PartitionStyle <PSPartitionStyle>] -HostDisk <Disk> [-Silent] -ClusterSystem <IClusterSystem> [<CommonParameters>]

Parameters

-PartitionStyle <PSPartitionStyle>

Attributes: Optional, Position: named

Specifies the partition style. Valid values are Mbr and Gpt. The default value is Mbr.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -CapacityInMB 1024 -Silent

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>Set-EmcLunAccess -Lun $l -HostSystem $h -Available

TaskStatus: Started

10% : Unmasking the LUN to the specified host(s)...

100% : The specified LUN has been unmasked to the specified initiators...

TaskStatus: Completed

C:\PS>$hd = Find-EmcHostDisk -HostSystem $h -Lun $l -Silent

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -HostSystem $h

This example creates a LUN, unmasks onto a host system, finds the corresponding disk, and initializes it, which by default is set to the partition style of Mbr.

-------------- Example 2 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -CapacityInMB 1024 -Silent

C:\PS>$h = Get-EmcClusterSystem myclus*

C:\PS>Set-EmcLunAccess -Lun $l -ClusterSystem $h -Available -silent

C:\PS>$hd = Find-EmcHostDisk -ClusterSystem $h -Lun $l -Silent

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive5

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -ClusterSystem $h -PartitionStyle gpt

This example creates a LUN, unmasks it to a cluster system, finds the corresponding disk, and initializes it.


New-EmcVolume

Creates a volume.

Syntax

  • New-EmcVolume -HostSystem <IHostSystem> [-AllocationUnitSizeInBytes <UInt32>] [-FileSystemType <PSFileSystemType>] -Label <String> [-Silent] [<CommonParameters>]

  • New-EmcVolume [-AllocationUnitSizeInBytes <UInt32>] [-FileSystemType <PSFileSystemType>] -Label <String> [-Silent] -HostLunIdentifier <HostLunIdentifier> [<CommonParameters>]

  • New-EmcVolume [-AllocationUnitSizeInBytes <UInt32>] [-FileSystemType <PSFileSystemType>] -Label <String> [-Silent] -ClusterSystem <IClusterSystem> [<CommonParameters>]

  • New-EmcVolume [-AllocationUnitSizeInBytes <UInt32>] [-FileSystemType <PSFileSystemType>] -Label <String> [-Silent] -HostLunIdentifier <HostLunIdentifier> -ClusterSystem <IClusterSystem> [<CommonParameters>]

Parameters

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-AllocationUnitSizeInBytes <UInt32>

Attributes: Optional, Position: named

Specifies the cluster size or allocation unit size of the disk in bytes. This represents the smallest amount of disk space that can be allocated to hold a file. For NTFS file systems, the default value is 65536 bytes.

-FileSystemType <PSFileSystemType>

Attributes: Optional, Position: named

Specifies the type of the file system. For MBR or GPT partition types, the valid value is NTFS (New Technology File System), which is also the default value.

-Label <String>

Attributes: Optional, Position: named

Specifies the volume label.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-HostLunIdentifier <HostLunIdentifier>

Attributes: Required, Position: named

Specifies the ESI HostLunIdentifier object, which you can get from the ESI host disk object, the ESI cluster disk object, or by using the Get-EmcHostLunIdentifier cmdlet.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -CapacityInMB 1024 -Silent

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>Set-EmcLunAccess -Lun $l -HostSystem $h -Available

TaskStatus: Started

10% : Unmasking the LUN to the specified host(s)...

100% : The specified LUN has been unmasked to the specified initiators...

TaskStatus: Completed

C:\PS>$hd = Find-EmcHostDisk -HostSystem $h -Lun $l -Silent

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -HostSystem $h

C:\PS>New-EmcVolume -HostSystem $h -HostDisk $hd -Label volume_1

This example creates a LUN, unmasks onto a host system, finds the corresponding disk, initializes it, and creates a volume.

-------------- Example 2 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 2GB -Silent

C:\PS>$c = Get-EmcClusterSystem myclus*

C:\PS>Set-EmcLunAccess -Lun $l -ClusterSystem $c -Available -silent

C:\PS>$hd = Find-EmcHostDisk -ClusterSystem $c -Lun $l -Silent

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive5

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -ClusterSystem $c -PartitionStyle gpt

C:\PS>New-EmcVolume -ClusterSystem $c -HostDisk $hd -Label volume_1

This example creates a LUN, unmasks onto a cluster system, finds the corresponding disk, initializes it, and creates a volume.

-------------- Example 3 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 2GB -Silent

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>Set-EmcLunAccess -Lun $l -HostSystem $h -Available

C:\PS>$hd = Find-EmcHostDisk -HostSystem $h -Lun $l -Silent

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -HostSystem $h

C:\PS>$lunIdentifier = Get-EmcHostLunIdentifier -Lun $lun -HostSystem $h

C:\PS>New-EmcVolume -HostSystem $h -HostLunIdentifier $lunIdentifier -Label volume_1

This example creates a LUN, unmasks onto a host system, finds the corresponding disk, initializes it, and creates a volume using the host LUN identifier.


Remove-EmcHostDiskFromCluster

Removes a disk from a cluster.

Syntax

  • Remove-EmcHostDiskFromCluster [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Remove-EmcHostDiskFromCluster [-Force] [-Silent] [-WhatIf] [-Confirm] -ClusterSystem <IClusterSystem> -HostDisk <Disk> [<CommonParameters>]

  • Remove-EmcHostDiskFromCluster [-Force] [-Silent] [-WhatIf] [-Confirm] -ClusterSystem <IClusterSystem> -HostLunIdentifier <HostLunIdentifier> [<CommonParameters>]

Parameters

-ClusterDisk <WindowsBasicClusterDisk>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

-HostLunIdentifier <HostLunIdentifier>

Attributes: Required, Position: named

Specifies the ESI HostLunIdentifier object, which you can get from the ESI host disk object, the ESI cluster disk object, or by using the Get-EmcHostLunIdentifier cmdlet.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcClusterSystem | Update-EmcSystem -Silent

C:\PS>$cd = Get-EmcClusterDisk cluster*33*

C:\PS>$cd.ClusterDiskResourceName

Cluster Disk 3314428452

C:\PS>Remove-EmcHostDiskFromCluster -ClusterDisk $cd -Silent

Confirm

Are you sure you want to perform this action?

Performing operation "Remove-EmcDiskFromCluster" on Target "[Cluster Disk 3314428452.]".

[Y] Yes [A] Yes to All [N] No [L] No to All [S] Suspend [?] Help (default is "Y"): y

This example removes the disk from the cluster.

-------------- Example 2 --------------

C:\PS>$l = Get-EmcLun testlun

C:\PS>Set-EmcLunAccess -Lun $lun -ClusterSystem $cluster -Available

C:\PS>$disk = Find-EmcHostDisk -Lun $lun -ClusterSystem $cluster

C:\PS>Initialize-EmcHostDisk -HostDisk $disk -Cluster System $cluster

C:\PS>New-EmcVolume -ClusterSystem $cluster -HostDisk $disk -Label “New Volume”

C:\PS>Add-EmcHostDiskToCluster -HostDisk $disk -ClusterSystem $c -ClusterGroupName “Available Storage”

C:\PS>$lid = Get-EmcHostLunIdentifier -Lun $l

C:\PS>Remove-EmcHostDiskFromCluster -HostLunIdentifier $lid -ClusterSystem $c -Force

Or

C:\PS>Remove-EmcHostDiskFromCluster -HostDisk $disk -ClusterSystem $c -Force

This example removes the disk from the cluster by using the LUN.


Remove-EmcVolumeMountPoint

Removes or unmounts the specified volume.

Syntax

  • Remove-EmcVolumeMountPoint -Volume <Volume> -HostSystem <IHostSystem> [-Silent] [<CommonParameters>]

  • Remove-EmcVolumeMountPoint -Volume <Volume> [-Silent] -ClusterSystem <IClusterSystem> [<CommonParameters>]

Parameters

-Volume <Volume>

Attributes: Required, Position: named

Specifies the ESI volume object, which you can get from the ESI host system object or by using the Get-EmcHostVolume cmdlet.

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$h.HostVolumes[5].mountpath

F:\

C:\PS>$h.HostVolumes[5].HostVolumeIdentifier

\\?\GLOBALROOT\Device\HarddiskVolume6

C:\PS>Remove-EmcVolumeMountPoint -Volume $h.HostVolumes[5] -HostSystem $h

TaskStatus: Started

10% : Unmounting the volume...

100% : The specified volume has been unmounted...

TaskStatus: Completed

C:\PS>$h.HostVolumes[5].mountpath

C:\PS>$h.HostVolumes[5].HostVolumeIdentifier

\\?\GLOBALROOT\Device\HarddiskVolume6

C:\PS>

This example unmounts the specified volume.


Set-EmcHostDiskOnlineState

Changes the online state of the specified disk.

Syntax

  • Set-EmcHostDiskOnlineState -HostDisk <Disk> -Online [-Silent] [<CommonParameters>]

  • Set-EmcHostDiskOnlineState -HostDisk <Disk> [-Silent] -Offline [<CommonParameters>]

Parameters

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-Online <SwitchParameter>

Attributes: Required, Position: named

Changes the disk state to online.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-Offline <SwitchParameter>

Attributes: Required, Position: named

Changes the disk state to offline.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$h.HostDisks | select hostdiskidentifier

HostDiskIdentifier

------------------

\\?\PhysicalDrive4

\\?\PhysicalDrive7

\\?\PhysicalDrive1

\\?\PhysicalDrive2

\\?\PhysicalDrive3

\\?\PhysicalDrive5

\\?\PhysicalDrive6

C:\PS>$hd = $h.HostDisks[1]

C:\PS>Set-EmcHostDiskOnlineState -HostDisk $hd -Offline

This example changes the disk state to offline.

-------------- Example 2 --------------

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>$h.RefreshDisks()

C:\PS>$h.HostDisks | select hostdiskidentifier

HostDiskIdentifier

------------------

\\?\PhysicalDrive4

\\?\PhysicalDrive7

\\?\PhysicalDrive1

\\?\PhysicalDrive2

\\?\PhysicalDrive3

\\?\PhysicalDrive5

\\?\PhysicalDrive6

C:\PS>$hd = $h.HostDisks[1]

C:\PS>Set-EmcHostDiskOnlineState -HostDisk $hd -Online

This example changes the disk state to online.


Set-EmcHostDiskReadonlyState

Changes the read-only state for the specified disk.

Syntax

  • Set-EmcHostDiskReadonlyState -HostDisk <Disk> -Readonly [-Silent] [<CommonParameters>]

  • Set-EmcHostDiskReadonlyState -HostDisk <Disk> [-Silent] -ReadWrite [<CommonParameters>]

Parameters

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-Readonly <SwitchParameter>

Attributes: Required, Position: named

Changes the disk state to read-only.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ReadWrite <SwitchParameter>

Attributes: Required, Position: named

Changes the disk state to read-only.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$h.HostDisks | select hostdiskidentifier

HostDiskIdentifier

------------------

\\?\PhysicalDrive4

\\?\PhysicalDrive7

\\?\PhysicalDrive1

\\?\PhysicalDrive2

\\?\PhysicalDrive3

\\?\PhysicalDrive5

\\?\PhysicalDrive6

C:\PS>$hd = $h.HostDisks[1]

C:\PS>Set-EmcHostDiskReadonlyState -Readonly -HostDisk $hd

This example changes the disk state to read-only.

-------------- Example 2 --------------

C:\PS>C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>$h.RefreshDisks()

C:\PS>$h.HostDisks | select hostdiskidentifier

HostDiskIdentifier

------------------

\\?\PhysicalDrive4

\\?\PhysicalDrive7

\\?\PhysicalDrive1

\\?\PhysicalDrive2

\\?\PhysicalDrive3

\\?\PhysicalDrive5

\\?\PhysicalDrive6

C:\PS>$hd = $h.HostDisks[1]

C:\PS>Set-EmcHostDiskReadonlyState -HostDisk $hd -ReadWrite

This example changes the disk state to read-and-write.


Set-EmcVolumeMountPoint

Sets the drive letter or mount path for the volume.

Syntax

  • Set-EmcVolumeMountPoint -HostSystem <IHostSystem> -DriveLetter <String> -Volume <Volume> [-Silent] [<CommonParameters>]

  • Set-EmcVolumeMountPoint -HostSystem <IHostSystem> -Volume <Volume> [-Silent] -MountPath <String> [<CommonParameters>]

  • Set-EmcVolumeMountPoint -DriveLetter <String> -Volume <Volume> [-Silent] -ClusterSystem <IClusterSystem> [<CommonParameters>]

  • Set-EmcVolumeMountPoint -Volume <Volume> [-Silent] -MountPath <String> -ClusterSystem <IClusterSystem> [<CommonParameters>]

Parameters

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can add a host system object to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a host system object by using the Get-EmcHostSystem cmdlet. The object can be a stand-alone host system, a virtual machine, or a hypervisor.

-DriveLetter <String>

Attributes: Required, Position: named

Specifies the drive letter.

-Volume <Volume>

Attributes: Required, Position: named

Specifies the ESI volume object, which you can get from the ESI host system object or by using the Get-EmcHostVolume cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-MountPath <String>

Attributes: Required, Position: named

Specifies the mount path.

-ClusterSystem <IClusterSystem>

Attributes: Required, Position: named

Specifies the ESI cluster system object. You can add a cluster system object to ESI by using the Get-EmcClusterSystemCredential and Connect-EmcSystem cmdlets. You can get a cluster system object by using the Get-EmcClusterSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -CapacityInMB 1024 -Silent

C:\PS>$h = Get-EmcHostSystem *.148

C:\PS>Set-EmcLunAccess -Lun $l -HostSystem $h -Available

TaskStatus: Started

C:\PS>$hd = Find-EmcHostDisk -HostSystem $h -Lun $l -Silent

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -HostSystem $h

C:\PS>$v = New-EmcVolume -HostSystem $h -HostDisk $hd -Label volume_1 -silent

C:\PS>$drives = Get-EmcAvailableDriveLetter -HostSystem $h

C:\PS>$drives[0]

G

C:\PS>Set-EmcVolumeMountPoint -HostSystem $h -Volume $v -DriveLetter $drives[0] -Silent

C:\PS>Set-EmcVolumeMountPoint -HostSystem $h -Volume $v -MountPath "c:\foo" -silent

This example creates a LUN, unmasks onto a host system, finds the corresponding disk, initializes it, creates a volume, and sets a mount point to a drive letter or mount path.

-------------- Example 2 --------------

C:\PS>$l = New-EmcLun -Pool $p -Name mylun_test_1 -Capacity 2GB -Silent

C:\PS>$h = Get-EmcClusterSystem myclus*

C:\PS>Set-EmcLunAccess -Lun $l -ClusterSystem $h -Available -silent

C:\PS>$hd = Find-EmcHostDisk -ClusterSystem $h -Lun $l -Silent

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive5

C:\PS>Initialize-EmcHostDisk -HostDisk $hd -ClusterSystem $h -PartitionStyle gpt

C:\PS>$v = New-EmcVolume -ClusterSystem $h -HostDisk $hd -Label volume_1 -Silent

C:\PS>$drives = $h | Get-EmcAvailableDriveLetter

C:\PS>Set-EmcVolumeMountPoint -ClusterSystem $h -Volume $v -DriveLetter $drives[0] -Silent

C:\PS>Set-EmcVolumeMountPoint -ClusterSystem $h -Volume $v

-MountPath "c:\foo" -silent

This example creates a LUN, unmasks onto a cluster system, finds the corresponding disk, initializes it, creates a volume, and sets a mount point to a drive letter or mount path.


Add-EmcPassthroughDiskToVirtualMachine

Adds or attaches a pass-through disk to a virtual machine.

Syntax

  • Add-EmcPassthroughDiskToVirtualMachine -DiskId <String> -VirtualMachineConfiguration <VirtualMachineConfiguration> -Location <UInt32> [-ScsiControllerId <String>] [-ScsiControllerIndex <Int32>] [-Silent] [<CommonParameters>]

  • Add-EmcPassthroughDiskToVirtualMachine -VirtualMachineConfiguration <VirtualMachineConfiguration> -Location <UInt32> [-ScsiControllerId <String>] [-ScsiControllerIndex <Int32>] [-Silent] -DiskNumber <UInt32> [<CommonParameters>]

  • Add-EmcPassthroughDiskToVirtualMachine -VirtualMachineConfiguration <VirtualMachineConfiguration> -Location <UInt32> [-ScsiControllerId <String>] [-ScsiControllerIndex <Int32>] [-Silent] -HostDisk <Disk> [<CommonParameters>]

  • Add-EmcPassthroughDiskToVirtualMachine -VirtualMachineConfiguration <VirtualMachineConfiguration> -Location <UInt32> [-ScsiControllerId <String>] [-ScsiControllerIndex <Int32>] [-Silent] -ScsiLun <ScsiLun> [-Persistence <VirtualDevicePersistence>] [-Compatibility <RdmCompatibilityMode>] [-Datastore <Datastore>] [<CommonParameters>]

Parameters

-DiskId <String>

Attributes: Required, Position: named

Specifies the pass-through disk identifier in the hypervisor.

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: named

Specifies the ESI virtual machine configuration object, which you can get from the ESI hypervisor host system VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet.

-Location <UInt32>

Attributes: Required, Position: named

Specifies the available location or LUN number of the specified SCSI controller for adding the file-based disk. You can get the available SCSI controller location from the virtual machine hypervisor object or by using the Get-EmcAvailableScsiControllerLocation cmdlet.

-ScsiControllerId <String>

Attributes: Optional, Position: named

Specifies the SCSI controller ID for attaching the specified file-based disk. You can get the ID from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-ScsiControllerIndex <UInt32>

Attributes: Optional, Position: named

Specifies the SCSI controller zero-based index to add or attach a specified file-based disk. You can get the virtual machine controller information from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-DiskNumber <UInt32>

Attributes: Required, Position: named

Specifies the pass-through disk number in hypervisor.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-ScsiLun <ScsiLun>

Attributes: Required, Position: named

Specifies the ESI ScsiLun object. A ScsiLun object can be obtained by using a ESI Storage System object or by using the Get-EmcScsiLun cmdlet.

-Persistence <VirtualDevicePersistence>

Attributes: Optional, Position: named

Specify VMware virtual disk mode. Valid values are Persistent, IndependentPersistent, and IndependentNonPersistent.

-Compatibility <RDMCompatibilityMode>

Attributes: Optional, Position: named

Specifies the compatibility modes for raw disk mappings. Valid values are Physical and Virtual.

-Datastore <Datastore>

Attributes: Optional, Position: named

Specifies the ESI VMware datastore object, which you can get by using the Get-EmcDatastore cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hyperv = Get-EmcHostSystem *.133

C:\PS>$hyperv.Model

Hyper-V, PowerEdge R710

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.Model

Virtual Machine

C:\PS>$hyperv.RefreshVirtualMachinesConfigurations()

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration; $vmconfig

C:\PS>$locations =Get-EmcAvailableScsiControllerLocation -Hypervisor $h -VirtualMachineConfiguration $vmconfig -ScsiControllerIndex 0

C:\PS>$diskConfig = Add-EmcPassthroughDiskToVirtualMachine -Hypervisor $h -VirtualMachineConfiguration $vmconfig -HostDisk $hyperv.AvailablePassthroughDiskCandidates[0] -Location $locations[0]

C:\PS>$hd = Find-EmcHostDisk -VirtualMachine $vm -VmDiskConfig $diskConfig

C:\PS>Remove-EmcVirtualDiskFromVm -Hypervisor $h -VirtualMachineConfiguration $vmconfig -Location $locations[0] -force

This example adds or attaches a pass-through disk to a virtual machine (VM), gets a hypervisor and VM system objects, refreshes VM configurations in the hypervisor, gets the VM configuration, gets the available locations of the SCSI controller, adds or attaches one of the pass-through disk candidates to the VM, finds the added or attached pass-through disk in the VM, and then removes the disk.

-------------- Example 2 --------------

C:\PS>$h = Get-EmcHostSystem *.133

C:\PS>$h.Model

Hyper-V, PowerEdge R710

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.Model

Virtual Machine

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$locations =Get-EmcAvailableScsiControllerLocation -Hypervisor $h -VirtualMachineConfiguration $vmconfig -ScsiControllerIndex 0

C:\PS>$passthroughDisks = $h | Get-EmcAvailablePassthroughDiskCandidate

C:\PS>$diskConfig = Add-EmcPassthroughDiskToVirtualMachine -Hypervisor $h -VirtualMachineConfiguration $vmconfig -HostDisk $passthroughDisks[0] -Location $locations[0]

C:\PS>$hd = Find-EmcHostDisk -VirtualMachine $vm -VmDiskConfig $diskConfig

C:\PS>Remove-EmcVirtualDiskFromVm -Hypervisor $h -VirtualMachineConfiguration $vmconfig -Location $locations[0] –force

This example adds or attaches a pass-through disk to a virtual machine, similar to the first example. However, this example uses the Update-EmcSystem cmdlet to refresh virtual machine configurations in the hypervisor and uses the Get-EmcAvailableEmcPassthroughDiskCandidate cmdlet to get the pass-through disk candidates.

-------------- Example 3 --------------

C:\PS>$esxhost = Get-EmcESXHost *99

C:\PS>$vm = Get-EmcHostSystem *.229

C:\PS>$vm.Model

Virtual Machine

C:\PS>$esxhost | Update-EmcSystem

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration; $vmconfig

C:\PS>$scsicontroller = Get-EmcVirtualMachineScsiController -VirtualMachineConfiguration $vmconfig

C:\PS>$locations = Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration $vmconfig -ScsiControllerIndex 0

C:\PS>$scsiluns = Get-EmcAvailablePassthroughDiskCandidate -Hypervisor $esxhost

C:\PS>$datastore = Get-EmcDatastore *mydatastore*

C:\PS>$diskConfig = Add-EmcPassthroughDiskToVirtualMachine -ScsiLun $scsiluns[0] -Persistence Persistent -Compatibility Physical -Datastore $datastore -VirtualMachineConfiguration $vmconfig -Location $locations[0] -ScsiControllerIndex 0

This example adds, or attaches, a pass-through disk to a virtual machine and removes it. It then gets VMware and virtual machine system objects, updates them, gets the virtual machine configuration, gets the available locations of the SCSI controller, gets the datastore, and adds one of the SCSI LUNs to the virtual machine with the specified Persistence and Compatibility modes.


Get-EmcAvailablePassthroughDiskCandidate

Gets available pass-through disk candidates to attach or add to a virtual machine for a specified hypervisor.

Syntax

  • Get-EmcAvailablePassthroughDiskCandidate [-Hypervisor] <IHypervisor> [-Silent] [<CommonParameters>]

  • Get-EmcAvailablePassthroughDiskCandidate [-EsxHostSystem] <IEsxHostSystem> [-Silent] [<CommonParameters>]

Parameters

-Hypervisor <IHypervisor>

Attributes: Required, Position: 1

Specifies the ESI hypervisor host system object, which you can get from the host system by using the Get-EmcHostSystem cmdlet. You can add a hypervisor by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets.

-EsxHostSystem <IESXHostSystem>

Attributes: Required, Position: 1

Specifies the ESI ESX host system object, which you can get by using the Get-EmcESXHost cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcHostSystem *.133

C:\PS>$h.Model

Hyper-V, PowerEdge R710

C:\PS>$hds = $h | Get-EmcAvailablePassthroughDiskCandidate

C:\PS>$hds[0].hostdiskidentifier

\\?\PhysicalDrive3

C:\PS>$hds[1].hostdiskidentifier

\\?\PhysicalDrive4

C:\PS>$h.AvailablePassthroughDiskCandidates[0].hostdiskidentifier

\\?\PhysicalDrive3

C:\PS>$h.AvailablePassthroughDiskCandidates[1].hostdiskidentifier

\\?\PhysicalDrive4

This example gets the available pass-through disk candidates of a hypervisor. You can also get the same information from the hypervisor object.

-------------- Example 2 --------------

C:\PS>$h = Get-EmcESXHost *.99

C:\PS>$h.Model

VMware ESXi 5.0.0 build-469512

C:\PS>$hds = Get-EmcAvailablePassthroughDiskCandidate -EsxHostSystem $h

C:\PS>$hds[0].hostdiskidentifier

0200000000600601607f412e00d0d921654fa6e111565241494420

C:\PS>$hds[0].CanonicalName

naa.600601607f412e00d0d921654fa6e111

C:\PS>$h.AvailablePassthroughDiskCandidates[0].hostdiskidentifier

0200000000600601607f412e00d0d921654fa6e111565241494420

C:\PS>$h.AvailablePassthroughDiskCandidates[0].CanonicalName

naa.600601607f412e00d0d921654fa6e111

This example gets the available passthrough-disk candidates for a VMware ESX host. You can also get the same information from the ESX host object.


Get-EmcAvailableScsiControllerLocation

Gets the list of available SCSI controllers for a virtual machine that you can use to attach file-based or pass-through disks.

Syntax

  • Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration <VirtualMachineConfiguration> -ScsiControllerIndex <UInt32> [-Silent] [<CommonParameters>]

  • Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration <VirtualMachineConfiguration> [-Silent] -ScsiControllerId <String> [<CommonParameters>]

Parameters

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: named

Specifies the ESI virtual machine configuration object, which you can get from the ESI hypervisor host system object VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet. This cmdlet encapsulates the virtual machine configuration information such as status, MAC addresses, GUID, and attached file-based or pass-through disks.

-ScsiControllerIndex <UInt32>

Attributes: Required, Position: named

Specifies the SCSI controller zero-based index to attach a file-based disk. You can get the SCSI controller information from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ScsiControllerId <String>

Attributes: Required, Position: named

Specifies the SCSI controller ID to attach a file-based disk. You can get the virtual machine’s SCSI controller information from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hyperv = Get-EmcHostSystem *.133

C:\PS>$hyperv.Model

Hyper-V, PowerEdge R710

C:\PS>Get-EmcHostSystem | Update-EmcSystem -Silent

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.model

Virtual Machine

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$vmconfig.status

Running

C:\PS >$sc = Get-EmcVirtualMachineScsiController -VirtualMachineConfiguration $vmconfig

C:\PS >$sc.ScsiControllerIndex

0

C:\PS>$locations =Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration $vmconfig -ScsiControllerIndex 0

C:\PS>$locations[0]

0

This example gets the available SCSI controllers of a virtual machine.

---------- Example 2 ----------

C:\PS>$hyperv = Get-EmcHostSystem *.133

C:\PS>$hyperv.Model

Hyper-V, PowerEdge R710

C:\PS>Get-EmcHostSystem | Update-EmcSystem -Silent

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.model

Virtual Machine

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$vmconfig.status

Running

C:\PS>Get-EmcVirtualMachineScsiController -VirtualMachineConfiguration $vmconfig

VmName ScsiControllerIndex ScsiControllerId

------ ------------------- ----------------

RG-3 0 {7CDBA5E3-71DB-495A-9289-2452689320E4}

C:\PS>$locations = Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration $vmconfig -ScsiControllerId "{7CDBA5E3-71DB-495A-9289-2452689320E4}"

C:\PS>$locations[0]

0

This example gets the available SCSI controllers of a virtual machine using the ScsiControllerId parameter.


Get-EmcDatastore

Gets the list of VMware datastores.

Syntax

  • Get-EmcDatastore [[-ID] <String>] [-VcenterSystem <IVcenterSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcDatastore [[-ID] <String>] [-Silent] [-ESXHostSystem <IEsxHostSystem>] [<CommonParameters>]

  • Get-EmcDatastore [[-ID] <String>] [-Silent] [-ScsiLun <ScsiLun>] [<CommonParameters>]

  • Get-EmcDatastore [[-ID] <String>] [-Silent] [-Lun <Lun>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the VMware datastore name or Uuid. Wildcards are permitted. It is a positional parameter (position = 1).

-VcenterSystem <IVcenterSystem>

Attributes: Optional, Position: named

Specifies the vCenter server.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ESXHostSystem <IESXHostSystem>

Attributes: Optional, Position: named

Specifies the ESI ESX host system object, which you can get by using the Get-EmcESXHost cmdlet.

-ScsiLun <ScsiLun>

Attributes: Optional, Position: named

Specifies the ESI SCSI LUN object, which you can get by using the ESI VMware system or ESX host system object, or by using the Get-EmcScsiLun cmdlet.

-Lun <Lun>

Attributes: Optional, Position: named

Specifies the ESI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcLun cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hBlob = Get-EmcVmWareSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>Get-EmcDatastore -VcenterSystem $h

C:\PS>$h | Update-EmcSystem

C:\PS>Get-EmcDatastore -VcenterSystem $h

This example gets all datastores of the specified Vcenter system.

-------------- Example 2 --------------

C:\PS>$h = Get-EmcHostSystem *myVMware*

C:\PS>$h | Update-EmcSystem

C:\PS>$h | Get-EmcDatastore -ID *datastore1

C:\PS>$h | Get-EmcDatastore *datastore1

This example gets the datastores of the specified VMware system with the specified name. Wildcards are permitted. Because the ID parameter is positional, you can omit the name.

-------------- Example 3 --------------

C:\PS>$vc = Get-EmcVcenterSystem *myVcenter*

C:\PS>$esxhost = Get-EmcESXHost -VcenterSystem $vc

C:\PS>Get-EmcDatastore -ESXHostSystem $esxhost

This example gets all datastores of the specified ESX host system.

-------------- Example 4 --------------

C:\PS>$lun = Get-EmcLUN -ID 298

C:\PS> Get-EmcDatastore -Lun $lun

This example gets the datastores associated with the specified LUN object.

-------------- Example 5 --------------

C:\PS>$sl = Get-EmcScsiLun -ID *myScsiLun*

C:\PS> Get-EmcDatastore -ScsiLun $sl

This example gets the datastores associated with the specified SCSI LUN object.


Get-EmcESXCluster

Gets the list of VMware ESX clusters.

Syntax

  • Get-EmcESXCluster [[-ID] <String>] [-VcenterSystem <IVcenterSystem>] [-Silent] [-PipelineVariable <String>]  [<CommonParameters>]

  • Get-EmcESXCluster [-ID <String>] [-Silent] [-PipelineVariable <String>] -ESXHostSystem <IEsxHostSystem> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the VMware ESX clustername. Wildcards are permitted.

-VcenterSystem <IVcenterSystem>

Attributes: Required, Position: named

Specifies the Vcenter server.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-ESXHostSystem <IEsxHostSystem>

Attributes: Required, Position: named

Specifies the ESI (EMC Storage Integrator) ESX host System object. An ESX host system object can be obtained by using Get-EmcESXHost Cmdlet.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>$hBlob = Get-EmcVmWareSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>Get-EmcESXCluster -VcenterSystem $h

Gets all ESX Clsuters of the given Vcenter system.

---------- EXAMPLE 2 ----------

C:\PS>$hBlob = Get-EmcVmWareSystemCredential

C:\PS>$vcenter = $hBlob | Connect-EmcSystem

C:\PS>$esxhosts=Get-EmcESXHost -VcenterSystem $vcenter

C:\PS>Get-EmcESXCluster -ESXHostSystem $esxhosts[0]

Gets ESX Clsuter of the given ESX host system.


Get-EmcESXHost

Gets the list of VMware ESX hosts.

Syntax

  • Get-EmcESXHost [[-ID] <String>] [-VcenterSystem <IVcenterSystem>] [-Silent] [<CommonParameters>]

  • Get-EmcESXHost [-Silent] -ScsiLun <ScsiLun> [<CommonParameters>]

  • Get-EmcESXHost [-Silent] -Datastore <Datastore> [<CommonParameters>]

  • Get-EmcESXHost [-Silent] -VirtualMachineConfiguration <VirtualMachineConfiguration> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the VMware ESX host name or Uuid. Wildcards are permitted. It is a positional parameter (position = 1).

-VcenterSystem <IVcenterSystem>

Attributes: Optional, Position: named

Specifies the vCenter server.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ScsiLun <ScsiLun>

Attributes: Required, Position: named

Specifies the ESI SCSI LUN object, which you can get by using the ESI storage system object or by using the Get-EmcScsiLun cmdlet.

-Datastore <Datastore>

Attributes: Required, Position: named

Specifies the ESI VMware datastore object, which you can get by using the Get-EmcDatastore cmdlet.

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: named

Specifies the ESI Virtual Machine configuration object, which you can get by using the VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet. This cmdlet encapsulates VM configuration information, including status, MAC addresses, GUID, and attached file-based or pass-through disks.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$vc = Get-EmcVcenterSystem *myVcenter*

C:\PS>Get-EmcESXHost -VcenterSystem $vc

This example gets the ESX host system of a vCenter server.

-------------- Example 2 --------------

C:\PS>$sl = Get-EmcScsiLun *myScsiLun*

C:\PS>Get-EmcESXHost -ScsiLun $sl

This example gets the ESX host system of the specified SCSI LUN.

-------------- Example 3 --------------

C:\PS>$ds = Get-EmcDatastore *myDatastore*

C:\PS>Get-EmcESXHost -Datastore $ds

This example gets the ESX host system of the specified datastore.

-------------- Example 4 --------------

C:\PS>$vc = Get-EmcVcenterSystem *myVcenter*

C:\PS>$vc | Update-EmcSystem

C:\PS>$vm = Get-EmcHostSystem myVM

C:\PS>$vmconfig = Get-EmcVirtualMachineConfiguration -VirtualMachine $vm

C:\PS>Get-EmcESXHost -VirtualMachineConfiguration $vmconfig

This example gets the ESX host system of the specified virtual machine configuration.


Get-EmcHyperVSystemCredential

Gets the credentials for Microsoft Hyper-V to connect ESI.

Syntax

Get-EmcHyperVSystemCredential [-Silent] [<CommonParameters>]

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$sBlob = Get-EmcHyperVSystemCredential

C:\PS>$s = $sBlob | Connect-EmcSystem

C:\PS>$s = Connect-EmcSystem -CreationBlob $sBlob

This example returns the creation BLOB, which is used to connect or add Microsoft Hyper-V systems to ESI.


Get-EmcHyperVSystem

Gets the list of connected Hyper-V systems.

Syntax

  • Get-EmcHyperVSystem [[-Id] <String>] [-Silent] [<CommonParameters>]

  • Get-EmcHyperVSystem [-Silent] -HostDisk <Disk> [<CommonParameters>]

  • Get-EmcHyperVSystem [-Silent] -Volume <Volume> [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the host name, IP address, or global ID. Wildcards are permitted. It is a positional parameter (position = 1).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-Volume <Volume>

Attributes: Required, Position: named

Specifies the ESI Volume object, which you can get from the ESI Host System object or by using the Get-EmcHostVolume cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcHyperVSystem

This example gets all the Hyper-V systems.

-------------- Example 2 --------------

C:\PS>Get-EmcHyperVSystem <HostIpAddress>

This example gets the Hyper-V system with the specified host IP address, which accepts wildcards.

-------------- Example 3 --------------

C:\PS>$Disk = Get-EmcHostDisk -id 4074289894

C:\PS>$Disk

C:\PS>Get-EmcHyperVSystem -HostDisk $Disk

This example gets the Hyper-V system of the specified disk.

-------------- Example 4 --------------

C:\PS>$volume = Get-EmcHostVolume *myvol*

C:\PS>Get-EmcHyperVSystem -Volume $volume

This example gets the Hyper-V system of the specified volume.


Get-EmcVcenterSystem

Gets the list of vCenter systems.

Syntax

  • Get-EmcVcenterSystem [[-ID] <String>] [-Silent] [<CommonParameters>]

  • Get-EmcVcenterSystem [-Silent] [-ESXHostSystem <IEsxHostSystem>] [<CommonParameters>]

  • Get-EmcVcenterSystem [-Silent] -ScsiLun <ScsiLun> [<CommonParameters>]

  • Get-EmcVcenterSystem [-Silent] -Datastore <Datastore> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the vCenter name or Uuid. Wildcards are permitted. It is a positional parameter (position = 1).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ESXHostSystem <IEsxHostSystem>

Attributes: Optional, Position: named

Specifies the ESI ESX host system object, which you can get by using the Get-EmcESXHost cmdlet.

-ScsiLun <ScsiLun>

Attributes: Required, Position: named

Specifies the ESI SCSI LUN object, which you can get by using the ESX host system object, or by using the Get-EmcScsiLun cmdlet.

-Datastore <Datastore>

Attributes: Required, Position: named

Specifies the ESI datastore object, which you can get by using the Get-EmcDatastore cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$vc = Get-EmcVcenterSystem *myVcenter*

This example gets a list of all the vCenter servers with myVcenter in the name.

-------------- Example 2 --------------

C:\PS>$esx = Get-EmcESXHost *99

C:\PS>$vc = Get-EmcVcenterSystem -ESXHostSystem $esx

This example gets the vCenter server of a specified ESX host.

-------------- Example 3 --------------

C:\PS>$sc = Get-EmcScsiLun naa.60000970000192605412533032313036

C:\PS>$vc = Get-EmcVcenterSystem -ScsiLun $sc

This example gets the vCenter server of a specified SCSI Lun.

-------------- Example 4 --------------

C:\PS>$datastore = Get-EmcDatastore DatastoreTest

C:\PS>$vc = Get-EmcVcenterSystem -Datastore $datastore

This example gets the vCenter server of a specified datastore.


Get-EmcVirtualMachineScsiController

Gets the SCSI controllers from the virtual machine configurations.

Syntax

  • Get-EmcVirtualMachineScsiController [-VirtualMachineConfiguration] <VirtualMachineConfiguration> [-Silent] [<CommonParameters>]

  • Get-EmcVirtualMachineScsiController [-VirtualMachine] <IHostSystem> [-Silent] [<CommonParameters>]

Parameters

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: 1

Specifies the ESI virtual machine configuration object, which you can get from the ESI hypervisor host system VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet. It encapsulates the virtual machine configuration information such as status, MAC addresses, GUID, attached file-based disks, and pass-through disks.

-VirtualMachine <IHostSystem>

Attributes: Required, Position: 1

Specifies the ESI virtual machine host system object, which is derived from the host system. A virtual machine can be added to ESI using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets just like the host system. A virtual machine (host system) object can be obtained by using the Get-EmcHostSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hyperv = Get-EmcHostSystem *133

C:\PS>$hyperv | Update-EmcSystem -Silent

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.model

Virtual Machine

C:\PS>$scsi = $vm | Get-EmcVirtualMachineScsiController

C:\PS>$scsi.ScsiControllerIndex

0

C:\PS>$scsi.ScsiControllerId

{9052A0C0-C066-4C6E-95EC-A66CF32336A3}

C:\PS>

This example gets the SCSI controllers from the virtual machine.

-------------- Example 2 --------------

C:\PS>$hyperv = Get-EmcHostSystem *133

C:\PS>$hyperv | Update-EmcSystem -Silent

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.model

Virtual Machine

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$vmconfig.status

Running

C:\PS>$scsi = $vmconfig | Get-EmcVirtualMachineScsiController

C:\PS>$scsi.ScsiControllerIndex

0

C:\PS>$scsi.ScsiControllerId

{9052A0C0-C066-4C6E-95EC-A66CF32336A3}

This example gets the SCSI controllers from the virtual machine configuration.

-------------- Example 3 --------------

C:\PS>$h = Get-EmcHostSystem *.133

C:\PS>$h.model

Hyper-V, PowerEdge R710

C:\PS>$scsi = $h.VirtualMachinesConfigurations | Get-EmcVirtualMachineScsiController

C:\PS>$scsi.count

12

C:\PS>$scsi[10].ScsiControllerIndex

2

C:\PS>$scsi[10].ScsiControllerId

{4DCFAEF8-A85A-4641-9322-BB9A5A1CE923}

C:\PS>$scsi[11].ScsiControllerId

{CF06199A-D7C0-4CEE-A87D-FC81A5D96078}

C:\PS>$scsi[11].ScsiControllerIndex

3

C:\PS>

This example gets the SCSI controllers from the virtual machine configurations.


Get-EmcVMwareSystemCredential

Gets the encrypted connection parameters BLOB or the system object creation parameters for VMware systems. You can use this cmdlet and the Connect-EmcSystem cmdlet to add or connect storage systems to ESI.

Syntax

Get-EmcVMwareSystemCredential [-Silent] [<CommonParameters>]

Description

Creates a BLOB or encrypted string by using the specified connection or system object creation parameters. ESI prompts you for the server IP address and credentials and then uses these parameters to create a BLOB. You can use the BLOB to connect or add VMware systems to ESI by using the Connect-EmcSystem cmdlet. You can click Test Connection in ESI to test the connection with the specified parameters.

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hBlob = Get-EmcVMwareSystemCredential

C:\PS>$h = $hBlob | Connect-EmcSystem

C:\PS>$h = Connect-EmcSystem -CreationBlob $hBlob

This example returns the creation BLOB and then uses the BLOB to connect or add a VMware system to ESI.


Get-EmcVirtualDiskConfiguration

Gets the virtual disk configuration for the specified host disk of a virtual machine, which can be either a file-based or pass-through disk.

Syntax

  • Get-EmcVirtualDiskConfiguration -Hypervisor <IHypervisor> [-Silent] [<CommonParameters>]

  • Get-EmcVirtualDiskConfiguration [-Silent] -HostDisk <Disk> [<CommonParameters>]

  • Get-EmcVirtualDiskConfiguration [-Silent] -HostSystem <IHostSystem> [<CommonParameters>]

  • Get-EmcVirtualDiskConfiguration [-Silent] -VirtualMachineConfiguration <VirtualMachineConfiguration> [<CommonParameters>]

Parameters

-Hypervisor <IHypervisor>

Attributes: Required, Position: named

Specifies the hypervisor object for the ESI virtual machine, which you can get by using the Get-EmcVirtualMachineHypervisor cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-HostDisk <Disk>

Attributes: Required, Position: named

Specifies the ESI host disk object, which you can get from the ESI host system object or by using the Get-EmcHostDisk or Find-EmcHostDisk cmdlets.

-HostSystem <IHostSystem>

Attributes: Required, Position: named

Specifies the ESI host system object. You can use the EmcHostSystemCredential and Connect-EmcSystem cmdlets to add a host system object to ESI. You can use the Get-EmcHostSystem cmdlet to get a host system object. The host system can either a stand-alone host system, a virtual machine, or a hypervisor.

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: named

Specifies the ESI virtual machine configuration object, which you can get from the ESI hypervisor host system VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hyperv = Get-EmcHostSystem *.200

C:\PS>$hyperv.Model

Hyper-V, PowerEdge R710

C:\PS>$hyperv|Update-EmcSystem -Silent

$vm = Get-EmcHostSystem *.148

C:\PS>$vm | Update-EmcSystem -Silent

C:\PS>$vm.model

Virtual Machine

C:\PS>$hd = $vm.HostDisks[3]

C:\PS>$hd.HostDiskIdentifier

\\?\PhysicalDrive8

C:\PS>$hd.DiskType

FilebasedVmDisk

C:\PS>$diskconfig = $hd | Get-EmcVirtualDiskConfiguration

C:\PS>$diskconfig.Path

E:\ps_test1.vhd

C:\PS>$diskconfig.server

This example gets the virtual disk configuration of a file-based disk in a virtual machine.

-------------- Example 2 --------------

C:\PS>$hyperv = Get-EmcHostSystem *.200

C:\PS>$hyperv.Model

Hyper-V, PowerEdge R710

C:\PS>$hyperv|Update-EmcSystem -Silent

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm | Update-EmcSystem -Silent

C:\PS>$diskconfigs = $vm.HostDisks | Get-EmcVirtualDiskConfiguration

C:\PS>$diskconfigs.path

E:\ps_test1.vhd

C:\PS>$diskconfigs.ScsiControllerIndex

0

C:\PS>$diskconfigs.HostLunIdentifier.ScsiControllerId

{9052A0C0-C066-4C6E-95EC-A66CF32336A3}

C:\PS>

This example gets virtual machine configurations of all disks.

-------------- Example 3 --------------

C:\PS>$vm = Get-EmcHostSystem *.150

C:\PS>$vm | Update-EmcSystem -Silent

C:\PS>$vm.model

Virtual Machine

C:\PS>$hyperv = Get-EmcHostSystem *.200

C:\PS>$hyperv | Update-EmcSystem -Silent

C:\PS>$vm.model

Hyper-V, PowerEdge R710

C:\PS>$diskconfig = $vm | Get-EmcVirtualDiskConfiguration

This example gets the virtual disk configurations of a virtual machine. You must update the virtual machine hypervisor before retrieving the disk configuration.

-------------- Example 4 --------------

C:\PS>$hyperv = Get-EmcHostSystem *.200

C:\PS>$hyperv | Update-EmcSystem -Silent

C:\PS>$vm.model

Hyper-V, PowerEdge R710

C:\PS>$vmconfig = Get-EmcVirtualMachineConfiguration -Hypervisor $hyperv

C:\PS>$vmconfig

C:\PS>$diskconfig = $vmconfig[1] | Get-EmcVirtualDiskConfiguration

or

C:\PS>$diskconfig = $vmconfig | Get-EmcVirtualDiskConfiguration

This example updates the hypervisor and gets the virtual machine configurations. It then gets the virtual disk configurations for the virtual machine configuration.


Get-EmcVirtualMachineConfiguration

Gets the virtual machine configuration.

Syntax

  • Get-EmcVirtualMachineConfiguration [[-ID] <String>] [[-Hypervisor] <IHypervisor>] [-Silent] [<CommonParameters>]

  • Get-EmcVirtualMachineConfiguration [[-ID] <String>] [-VirtualMachine] <IHostSystem> [-Silent] [<CommonParameters>]

  • Get-EmcVirtualMachineConfiguration [[-ID] <String>] [[-VcenterSystem] <IVcenterSystem>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name of the virtual machine. Wildcards are permitted. It is a positional parameter (position = 1).

-VirtualMachine <IHostSystem>

Attributes: Required, Position: 1

Specifies the ESI virtual machine host system object, which is derived from the host system. A virtual machine can be added to ESI by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets, the same as the host system. A virtual machine (host system) object can be obtained by using the Get-EmcHostSystem cmdlet.

-Hypervisor <IHypervisor>

Attributes: Optional, Position: 1

Specifies the hypervisor object for the ESI virtual machine, which you can get by using the Get-EmcVirtualMachineHypervisor cmdlet.

-VirtualMachine <IHostSystem>

Attributes: Required, Position: 1

Specifies the ESI virtual machine host system object, which is derived from the host system. You can add a virtual machine to ESI using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets. You can get a virtual machine host system object by using the Get-EmcHostSystem cmdlet.

-VcenterSystem <IVcenterSystem>

Attributes: Optional, Position: 1

Specifies the vCenter server.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcHostSystem | Update-EmcSystem -Silent

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.model

Virtual Machine

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$vmconfig.status

Running

C:\PS>$vmconfig.vmid.guid

C4908C4C-6564-4688-B8EC-E47E7758E17E

C:\PS>$vmconfig.FileBasedVmScsiDiskConfigs[0].Descriptor.Source

E:\ps_test1.vhd

This example gets the virtual machine configuration.

-------------- Example 2 --------------

C:\PS>$hyperv = Get-EmcHyperVSystem | Connect-EmcSystem

C:\PS>$hyperv | Update-EmcSystem -Silent

C:\PS>Get-EmcVirtualMachineConfiguration -Hypervisor $hyperv

This example gets the virtual machine configurations of all of the virtual machines on a Hyper-V hypervisor.

-------------- Example 3 --------------

C:\PS>$vcenter = Get-EmcVcenterSystem

C:\PS>$vcenter | Update-EmcSystem -Silent

C:\PS>Get-EmcVirtualMachineConfiguration -VcenterSystem $vcenter

This example gets the virtual machine configurations of all of the virtual machines on vSphere hypervisor.


Get-EmcVirtualMachineHypervisor

Gets the virtual machine hypervisor.

Syntax

  • Get-EmcVirtualMachineHypervisor [-VirtualMachineConfiguration] <VirtualMachineConfiguration> [-Silent] [<CommonParameters>]

  • Get-EmcVirtualMachineHypervisor [-VirtualMachine] <IHostSystem> [-Silent] [<CommonParameters>]

Parameters

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: 1

Specifies the ESI virtual machine configuration object, which you can get from the ESI hypervisor host system object VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet. This cmdlet encapsulates the virtual machine configuration information such as status, MAC addresses, GUID, attached file-based disks, and pass-through disks.

-VirtualMachine <IHostSystem>

Attributes: Required, Position: 1

Specifies the ESI virtual machine host system object, which is derived from the host system. A virtual machine can be added to ESI using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets just like the host system. A virtual machine (host system) object can be obtained by using the Get-EmcHostSystem cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcVirtualMachineConfiguration

C:\PS>Get-EmcHostSystem | Update-EmcSystem -Silent

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.model

Virtual Machine

C:\PS>$h = $vm | Get-EmcVirtualMachineHypervisor

C:\PS>$h.Model

Hyper-V, PowerEdge R710

C:\PS>

This example gets the hypervisor from the virtual machine.

------------- Example 2 --------------

C:\PS>Get-EmcVirtualMachineConfiguration

C:\PS>Get-EmcHostSystem | Update-EmcSystem -Silent

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.model

Virtual Machine

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$vmconfig.status

Running

C:\PS>$h = $vmconfig | Get-EmcVirtualMachineHypervisor

C:\PS>$h.Model

Hyper-V, PowerEdge R710

C:\PS>

This example gets the hypervisor from the virtual machine configuration and the status of the hypervisor.


New-EmcFileBasedDisk

Creates a file-based disk for a specified hypervisor.

Syntax

  • New-EmcFileBasedDisk [-VhdType <VhdType>] -Hypervisor <IHypervisor> -Path <String> -Size <UInt64> [-Silent <SwitchParameter>] [<CommonParameters>]

  • New-EmcFileBasedDisk -Hypervisor <IHypervisor> -Path <String> -Size <UInt64> [-Silent <SwitchParameter>] [-VmdkType <VmdkType>] [<CommonParameters>]

Parameters

-VhdType <VhdType>

Attributes: Optional, Position: named

Specifies the file-based disk type of VHD or VHDX for Hyper-V systems. Valid values are Fixed and Dynamic.

-Hypervisor <IHypervisor>

Attributes: Required, Position: named

Specifies the ESI hypervisor host system object, which you can get from the host system by using the Get-EmcHostSystem cmdlet. You can add a hypervisor by using the Get-EmcHostSystemCredential and Connect-EmcSystem cmdlets.

-Path <String>

Attributes: Required, Position: named

Specifies the path of the file-based disk.

-Size <UInt64>

Attributes: Required, Position: named

Specifies the size of the file-based disk.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-VmdkType <VmdkType>

Attributes: Optional, Position: named

Specifies the file-based disk type for VMDK files for VMware systems. Valid values are Lazy Zeroed Thick, Thin, and Eager Zeroed Thick.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hyperv = Get-EmcHostSystem *.133

C:\PS>$hyperv.Model

Hyper-V, PowerEdge R710

C:\PS>New-EmcFileBasedDisk -Hypervisor $hyperv -SizeInGB 1 -DiskType fixed -Path "E:\ps_test1.vhd"

This example creates a file-based disk in a Hyper-V hypervisor.

-------------- Example 2 --------------

C:\PS>$h= Get-EmcHostSystem *99

C:\PS>New-EmcFileBasedDisk -Hypervisor $h -Size 1GB -Path "[datastore1] VM-ESX-WS2K8R2-1/ESIQA.vmdk" -VmdkType EagerZeroedThick

This example creates a file-based disk in a VMware hypervisor.

-------------- Example 3 --------------

C:\PS>$h= Get-EmcHyperVSystem *109

C:\PS>New-EmcFileBasedDisk -Hypervisor $h -VhdType Dynamic -Path "C:\VHDs\VM24.vhdx" -Size 5GB

This example creates a file-based disk in a Hyper-V hypervisor with the VHDX type disk format.


New-EmcDatastore

Creates a new datastore.

Syntax

New-EmcDatastore -Name <String> -ScsiLun <ScsiLun> [-FileSystemVersion <VmfsVersion>] [-Silent] [<CommonParameters>]

Parameters

-Name <String>

Attributes: Required, Position: named

Specifies the name of the new datastore.

-ScsiLun <ScsiLun>

Attributes: Required, Position: named

Specifies the ESI SCSI LUN object, which you can get by using the ESI VMware system or ESI ESX host system objects, or by using Get-EmcScsiLun cmdlet.

-FileSystemVersion <VmfsVersion>

Attributes: Optional, Position: named

Specifies the version of the VMFS for the datastore. Valid values are VMFS_5 and VMFS_3. The default value is VMFS_5.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcVcenterSystem

PS C:\> $h | Update-EmcSystem -Silent

PS C:\> $l = Get-EmcLun lun2

PS C:\> $sc = Get-EmcScsiLun -Lun $l

PS C:\> $sc.hostdiskidentifier

02000600006000097000019260541253303230443353594d4d4554

PS C:\> New-EmcDatastore -Name esi-ds-1 -ScsiLun $sc -Silent

Name : esi-ds-1

Type : VMFS5

Capacity : 1.750 GB

FreeSpace : 1.206 GB

Url : ds:///vmfs/volumes/50c3a51b-45835678-9840-a4badb394393/

Uuid : 50c3a51b-45835678-9840-a4badb394393

VcenterUuid : e942d303-eff4-4098-a3cf-e249894bd63b

HostLunIdentifiers : {Wwn=60:00:09:70:00:01:92:60:54:12:53:30:32:30:44:33}

CanonicalNames : {naa.60000970000192605412533032304433}

EsxHosts : {x.x.x.x, y.y.y.y }

This example creates a VMFS_5 datastore.

-------------- Example 2 --------------

C:\PS>$h = Get-EmcVcenterSystem

PS C:\> $h | Update-EmcSystem -Silent

PS C:\> $l = Get-EmcLun lun2

PS C:\> $sc = Get-EmcScsiLun -Lun $l

PS C:\> $sc.hostdiskidentifier

02000600006000097000019260541253303230443353594d4d4554

PS C:\> New-EmcDatastore -Name esi-ds-1 -ScsiLun $sc -FileSystemVersion vmfs_3 -Silent

Name : esi-ds-1

Type : VMFS3

Capacity : 1.750 GB

FreeSpace : 1.229 GB

Url : ds:///vmfs/volumes/50c3a81b-db1ccdf6-10da-a4badb394393/

Uuid : 50c3a81b-db1ccdf6-10da-a4badb394393

VcenterUuid : e942d303-eff4-4098-a3cf-e249894bd63b

HostLunIdentifiers : {Wwn=60:00:09:70:00:01:92:60:54:12:53:30:32:30:44:33}

CanonicalNames : {naa.60000970000192605412533032304433}

EsxHosts : {x.x.x.x}

This example creates a VMFS_3 datastore.


Remove-EmcDatastore

Deletes the specified datastore.

Syntax

  • Remove-EmcDatastore -EsxHostSystem <IEsxHostSystem> -Name <String> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Remove-EmcDatastore -EsxHostSystem <IEsxHostSystem> [-Force] [-Silent] [-WhatIf] [-Confirm] -Datastore <Datastore> [<CommonParameters>]

Parameters

-ESXHostSystem <IESXHostSystem>

Attributes: Required, Position: named

Specifies the ESI ESX host system object, which you can get by using the Get-EmcESXHost cmdlet.

-Name <String>

Attributes: Required, Position: named

Specifies the name of the new datastore.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

-Datastore <Datastore>

Attributes: Required, Position: named

Specifies the ESI VMware datastore object, which you can get by using Get-EmcDatastore cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$h = Get-EmcVcenterSystem

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$l = Get-EmcLun lun2

C:\PS>$sc = Get-EmcScsiLun -Lun $l

C:\PS>$sc.hostdiskidentifier

02000600006000097000019260541253303230443353594d4d4554

C:\PS>$datastore = New-EmcDatastore -Name esi-ds-1 -ScsiLun $sc -Silent

C:\PS>$datastore

Name : esi-ds-1

Type : VMFS5

Capacity : 1.750 GB

FreeSpace : 1.206 GB

Url : ds:///vmfs/volumes/50c3a51b-45835678-9840-a4badb394393/

Uuid : 50c3a51b-45835678-9840-a4badb394393

VcenterUuid : e942d303-eff4-4098-a3cf-e249894bd63b

HostLunIdentifiers : {Wwn=60:00:09:70:00:01:92:60:54:12:53:30:32:30:44:33}

CanonicalNames : {naa.60000970000192605412533032304433}

EsxHosts : {x.x.x.x, y.y.y.y }

C:\PS>$h.SystemObjectType

vSphere/vCenter Server

C:\PS>$ex = Get-EmcESXHost -ScsiLun $sc[0]

C:\PS>Remove-EmcDatastore -Name esi-ds-1 -EsxHostSystem $ex

OR

C:\PS>Remove-EmcDatastore -Datastore $datastore -EsxHostSystem $ex -Force

This example creates a datastore and then deletes it.


Remove-EmcVirtualDiskFromVm

Removes a file-based or pass-through disk from the virtual machine.

Syntax

Remove-EmcVirtualDiskFromVm [-Force] -VirtualMachineConfiguration <VirtualMachineConfiguration> -Location <UInt32> [-ScsiControllerId <String>] [-ScsiControllerIndex <Int32>] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: named

Specifies the ESI virtual machine configuration object, which you can get from the ESI hypervisor host system object VirtualMachinesConfigurations parameter or by using the Get-EmcVirtualMachineConfiguration cmdlet. This cmdlet encapsulates the virtual machine configuration information, including status, MAC addresses, GUID, attached file-based disks, and pass-through disks.

-Location <UInt32>

Attributes: Required, Position: named

Specifies the available location or LUN number for the specified SCSI controller to add the file-based disk. You can get an available SCSI controller location from the virtual machine’s hypervisor object or by using the Get-EmcAvailableScsiControllerLocation cmdlet.

-ScsiControllerId <String>

Attributes: Optional, Position: named

Specifies the SCSI controller ID for the specified file-based disk. You can get the virtual machine SCSI controller information from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-ScsiControllerIndex <UInt32>

Attributes: Optional, Position: named

Specifies the SCSI controller zero-based index for the specified file-based disk. You can get the virtual machine SCSI controller information from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hyperv = Get-EmcHostSystem *.133

C:\PS>$hyperv.Model

Hyper-V, PowerEdge R710

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.Model

Virtual Machine

C:\PS>$hyperv | Update-EmcSystem -Silent

C:\PS>$vm | Update-EmcSystem -Silent

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$vmconfig.VmId.guid

C4908C4C-6564-4688-B8EC-E47E7758E17E

C:\PS>New-EmcFileBasedDisk -Hypervisor $hyperv -Size 1GB -VhdType fixed -Path "E:\ps_test1.vhd"

TaskStatus: Started

10% : Creating file-based disk...

100% : Successfully created FileBasedDisk

TaskStatus: Completed

C:\PS>$locations =Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration $vmconfig -ScsiControllerIndex 0

C:\PS>$locations[0]

0

C:\PS>$diskConfig = Add-EmcFilebasedDiskToVirtualMachine -VirtualMachineConfiguration $vmconfig -Path "E:\ps_test1.vhd" -Location $locations[0] -ScsiControllerIndex 0

C:\PS>Remove-EmcVirtualDiskFromVm -VirtualMachineConfiguration $vmconfig -Location $locations[0] -ScsiControllerIndex 0 -force

This example adds a file-based disk to a virtual machine and then removes it.

-------------- Example 2 --------------

C:\PS>$h = Get-EmcHostSystem *.133

C:\PS>$h.Model

Hyper-V, PowerEdge R710

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.Model

Virtual Machine

C:\PS>$h | Update-EmcSystem -Silent

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$locations =Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration $vmconfig -ScsiControllerIndex 0

C:\PS>$passthroughDisks = $h | Get-EmcAvailableEmcPassthroughDiskCandidate

C:\PS>$diskConfig = Add-EmcPassthroughDiskToVirtualMachine -VirtualMachineConfiguration $vmconfig -HostDisk $passthroughDisks[0] -Location $locations[0] -ScsiControllerIndex 0

C:\PS>$hd = Find-EmcHostDisk -VirtualMachine $vm -VmDiskConfig $diskConfig

C:\PS>Remove-EmcVirtualDiskFromVm -VirtualMachineConfiguration $vmconfig -Location $locations[0] -ScsiControllerIndex 0 -force

This example adds a pass-through disk to a virtual machine and then removes it.


Add-EmcFileBasedDiskToVirtualMachine

Adds or attaches a file-based disk to a virtual machine.

Syntax

Add-EmcFilebasedDiskToVirtualMachine -Path <String> [-Persistence <VirtualDevicePersistence>] [-Datastore

<Datastore>] -VirtualMachineConfiguration <VirtualMachineConfiguration> -Location <UInt32> [-

ScsiControllerId <String>] [-ScsiControllerIndex <Int32>] [-Silent] [<CommonParameters>]

Parameters

-Path <String>

Attributes: Required, Position: named

Specifies the file-based disk path.

-Persistence <VirtualDevicePersistence>

Attributes: Optional, Position: named

Specifies VMware virtual disk mode. Valid values are Persistent , IndependentPersistent , and IndependentNonPersistent .

-Datastore <Datastore>

Attributes: Optional, Position: named

Specifies the ESI VMware datastore object, which you can get by using the Get-EmcDatastore cmdlet.

-VirtualMachineConfiguration <VirtualMachineConfiguration>

Attributes: Required, Position: named

Specifies the ESI virtual machine configuration object, which you can get by using the VirtualMachinesConfigurations parameter or

the Get-EmcVirtualMachineConfiguration cmdlet. This object encapsulates VM configuration information, including status, MAC

addresses, GUID, attached file-based disks, pass-through disks, and other disks.

-Location <UInt32>

Attributes: Required, Position: named

Specifies the available location or LUN number of the specified SCSI controller to add or attach the file-based disk. You can get the

available SCSI controller location from the virtual machine hypervisor object or by using the Get-

EmcAvailableScsiControllerLocation cmdlet.

-ScsiControllerId <String>

Attributes: Optional, Position: named

Specifies the SCSI Controller ID to add (attach) to a specified file-based disk. You can get virtual machine controller information from the

ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-ScsiControllerIndex <Int32>

Attributes: Optional, Position: named

Specifies the SCSI controller zero-based index to add or attach a specified file-based disk. You can get the virtual machine controller

information from the ESI hypervisor object or by using the Get-EmcVirtualMachineScsiController cmdlet.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose , Debug , ErrorAction , ErrorVariable , WarningAction ,

WarningVariable , OutBuffer , and OutVariable . Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$hyperv = Get-EmcHostSystem *.133

C:\PS>$hyperv.Model

Hyper-V, PowerEdge R710

C:\PS>$vm = Get-EmcHostSystem *.148

C:\PS>$vm.Model

Virtual Machine

C:\PS>$hyperv | Update-EmcSystem -Silent

C:\PS>$vm | Update-EmcSystem -Silent

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$vmconfig.VmId.guid

C4908C4C-6564-4688-B8EC-E47E7758E17E

C:\PS>New-EmcFileBasedDisk -Hypervisor $hyperv -SizeInGB 1 -DiskType fIXeD -Path "E:\ps_test1.vhd"

TaskStatus: Started

10% : Creating file-based disk...

100% : Successfully created FileBasedDisk

TaskStatus: Completed

C:\PS>$locations =Get-EmcAvailableScsiControllerLocation -Hypervisor $hyperv -VirtualMachineConfiguration

$vmconfig -ScsiControllerIndex 0

C:\PS>$locations[0]

0

C:\PS>$diskConfig = Add-EmcFilebasedDiskToVirtualMachine -Hypervisor $hyperv -VirtualMachineConfiguration

$vmconfig -Path "E:\ps_test1.vhd" -Location $locations[0]

The example attaches a file-based disk to a virtual machine and gets the hypervisor and virtual machine system objects. It then updates

the objects, gets the virtual machine configuration, creates a file-based disk, gets the available SCSI controller locations, and attaches the

created file-based disk to the virtual machine.

-------------- Example 2 --------------

C:\PS>$esxhost = Get-EmcESXHost *99

C:\PS>$vm = Get-EmcHostSystem *.229

C:\PS>$vm.Model

Virtual Machine

C:\PS>$esxhost | Update-EmcSystem

C:\PS>$vmconfig = $vm | Get-EmcVirtualMachineConfiguration

C:\PS>$scsicontroller = Get-EmcVirtualMachineScsiController -VirtualMachineConfiguration $vmconfig

C:\PS>$locations = Get-EmcAvailableScsiControllerLocation -VirtualMachineConfiguration $vmconfig -

ScsiControllerIndex 0

C:\PS>$datastore = Get-EmcDatastore mydatastore

C:\PS>New-EmcFileBasedDisk -VmdkType "LazyZeroedThick" -Hypervisor $esxhost -Size 1GB -Path

“[mydatastore]VM-Test/filebaseddisk.vmdk"

C:\PS>$diskConfig = Add-EmcFileBasedDiskToVirtualMachine -Persistence Persistent -Datastore $datastore -

VirtualMachineConfiguration $vmconfig -Location $locations[0] -ScsiControllerIndex 0 -Path “[mydatastore]VMTest/

filebaseddisk.vmdk"

This example attaches a file-based disk to a VMware virtual machine. It then gets a vSphere ESX host and virtual machine system

objects, updates them, gets the virtual machine configuration, creates a file-based disk, gets the available SCSI controller locations and

attaches the created file-based disk to the virtual machine.


Dismount-EmcAppSyncCopy

Dismounts a copy of a SQL Server database or an Exchange database for AppSync replication in ESI.

Syntax

  • Dismount-EmcAppSyncCopy -SqlServerDatabaseCopy <SqlServerDatabase> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Dismount-EmcAppSyncCopy -ExchangeDatabaseCopy <ExchangeDatabase> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-SqlServerDatabaseCopy <SqlServerDatabase>

Attributes: Required, Position: 1

Specifies the copy of the SQL Server database to dismount. It is a positional parameter (position = 1).

-ExchangeDatabaseCopy <ExchangeDatabase>

Attributes: Required, Position: 1

Specifies the copy of the Exchange database to dismount. It is a positional parameter (position = 1).

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Dismount-EmcAppSyncCopy -SqlServerDatabaseCopy $sqlDatabase

Dismounts a copy of a SQL Server database.

-------------- Example 2 --------------

C:\PS>Dismount-EmcAppSyncCopy -ExchangeDatabaseCopy $exchangeDatabase

Dismounts a copy of an Exchange database.


Get-EmcAppSyncCopy

Gets the copies of SQL Server databases or Exchange databases according to the specified criteria.

Syntax

  • Get-EmcAppSyncCopy [-ID <String>] -ServicePlan <ServicePlan> [-Silent] [<CommonParameters>]

  • Get-EmcAppSyncCopy [-ID <String>] [-Silent] -SqlServerDatabase <SqlServerDatabase> [<CommonParameters>]
  • Get-EmcAppSyncCopy [-ID <String>] [-Silent] -ExchangeDatabase <ExchangeDatabase> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name or ID of one or more copies. Wildcards are permitted. It is a positional parameter (position = 1).

-ServicePlan <ServicePlan>

Attributes: Required, Position: named

Specifies the service plan. All copies subscribing to the specified service plan will be returned.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-SqlServerDatabase <SqlServerDatabase>

Attributes: Required, Position: named

Specifies the source SQL Server database for the copies.

-ExchangeDatabase <ExchangeDatabase>

Attributes: Required, Position: named

Specifies the source Exchange database for the copies.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcAppSyncCopy -ServicePlan $sqlServicePlan

Gets all the copies subscribing to a specified service plan.

-------------- Example 2 --------------

C:\PS>Get-EmcAppSyncCopy -SqlServerDatabase $sqlDatabase

Gets the copies of the specified SQL Server database.

-------------- Example 3 --------------

C:\PS>Get-EmcAppSyncCopy -ExchangeDatabase $exchangeDatabase

Gets the copies of the specified Exchange database.


Get-EmcAppSyncExchangeDatabase

Gets the Exchange databases according to the specified criteria.

Syntax

  • Get-EmcAppSyncExchangeDatabase [-ID <String>] -AppSyncSystem <IAppSyncSystem> [-Silent] [<CommonParameters>]

  • Get-EmcAppSyncExchangeDatabase [-ID <String>] [-Silent] -ExchangeServer <ExchangeServer> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the Exchange databases. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ExchangeServer <ExchangeServer>

Attributes: Required, Position: named

Specifies the Exchange server registered on AppSync system.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcAppSyncExchangeDatabase -AppSyncSystem $appsync

Gets all the Exchange databases on the specified AppSync system.

-------------- Example 2 --------------

C:\PS>Get-EmcAppSyncExchangeDatabase -ExchangeServer $exchangeServer

Gets all the Exchange databases of the specified Exchange server.


Get-EmcAppSyncExchangeServer

Gets the Exchange servers according to the specified criteria.

Syntax

Get-EmcAppSyncExchangeServer [-ID <String>] -AppSyncSystem <IAppSyncSystem> [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name or ID of one or more Exchange servers. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcAppSyncExchangeServer -AppSyncSystem $appsync

Gets all the Exchange servers on the specified AppSync system.


Get-EmcAppSyncManifest

Gets the manifest information of the specified AppSync system.

Syntax

Get-EmcAppSyncManifest -AppSyncSystem <IAppSyncSystem> [-Silent] [<CommonParameters>]

Parameters

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: 1

Specifies the AppSync system. It is a positional parameter (position = 1).

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcAppSyncManifest -AppSyncSystem $appsyncSystem

Gets the manifest of the given AppSync system.


Get-EmcAppSyncRegisteredHost

Gets the hosts that are registered with the specified AppSync system.

Syntax

Get-EmcAppSyncRegisteredHost [-ID <String>] -AppSyncSystem <IAppSyncSystem> [-MapToConnectedSystem] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the hosts. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-MapToConnectedSystem <SwitchParameter>

Attributes: Optional, Position: named

Specifies that results are converted or translated to host systems registered with ESI.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcAppSyncRegisteredHost -AppSyncSystem $appsyncSystem

Gets the registered hosts on the specified AppSync system.


Get-EmcAppSyncRegisteredRecoverPointSystem

Gets the RecoverPoint systems that are registered on the specified AppSync system.

Syntax

Get-EmcAppSyncRegisteredRecoverPointSystem [-ID <String>] -AppSyncSystem <IAppSyncSystem> [-MapToConnectedSystem] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the RecoverPoint systems. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-MapToConnectedSystem <SwitchParameter>

Attributes: Optional, Position: named

Specifies that results are converted or translated to host systems registered with ESI.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcAppSyncRegisteredRecoverPointSystem -AppSyncSystem $appsyncSystem

Gets the registered RecoverPoint systems on the specified AppSync system.

-------------- Example 2 --------------

C:\PS>Get-EmcAppSyncRegisteredRecoverPointSystem -AppSyncSystem $appsyncSystem -MapToConnectedSystem

Gets the registered RecoverPoint systems on the specified AppSync system, and translates the results to the RecoverPoint systems that are registered with ESI.


Get-EmcAppSyncRegisteredStorageSystem

Gets the storage systems that are registered on the specified AppSync system.

Syntax

Get-EmcAppSyncRegisteredStorageSystem [-ID <String>] -AppSyncSystem <IAppSyncSystem> [-MapToConnectedSystem] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the storage systems. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-MapToConnectedSystem <SwitchParameter>

Attributes: Optional, Position: named

Specifies to include storage systems that are registered with ESI.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcAppSyncRegisteredStorageSystem -AppSyncSystem $appsyncSystem

Gets the registered storage systems for the specified AppSync system.

-------------- Example 2 --------------

C:\PS>Get-EmcAppSyncRegisteredStorageSystem -AppSyncSystem $appsyncSystem -MapToConnectedSystem

Gets the registered storages on the specified AppSync system, and translates the results to the storage systems that are registered with ESI.


Get-EmcAppSyncServicePlan

Gets the service plans according to the specified criteria.

Syntax

Get-EmcAppSyncServicePlan [-ID <String>] -AppSyncSystem <IAppSyncSystem> [-BuiltIn] [-Custom] [-SqlServer] [-Exchange] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the service plans. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-BuiltIn <SwitchParameter>

Attributes: Optional, Position: named

Specifies to include built-in service plans.

-Custom <SwitchParameter>

Attributes: Optional, Position: named

Specifies to include custom service plans.

-SqlServer <SwitchParameter>

Attributes: Optional, Position: named

Specifies to include the service plans for SQL Server.

-Exchange <SwitchParameter>

Attributes: Optional, Position: named

Specifies to include service plans for Exchange.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcAppSyncServicePlan -AppSyncSystem $appsyncSystem

Gets all the service plans on the specified AppSync system.

-------------- Example 2 --------------

C:\PS>Get-EmcAppSyncServicePlan -AppSyncSystem $appsyncSystem -BuiltIn

Gets all built-in service plans on the specified AppSync system.

-------------- Example 3 --------------

C:\PS>Get-EmcAppSyncServicePlan -AppSyncSystem $appsyncSystem -SqlServer

Gets all service plans for SQL Server on the specified AppSync system.

-------------- Example 4 --------------

C:\PS>Get-EmcAppSyncServicePlan -AppSyncSystem $appsyncSystem -Custom -Exchange

Gets all custom service plans for Exchange on the specified AppSync system.


Get-EmcAppSyncServicePlanSubscription

Gets the subscription information of the specified service plan.

Syntax

Get-EmcAppSyncServicePlanSubscription [-ID <String>] -ServicePlan <ServicePlan> [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the subscriptions. Wildcards are permitted. It is a positional parameter (position = 1).

-ServicePlan <ServicePlan>

Attributes: Required, Position: named

Specifies the service plan.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcAppSyncServicePlanSubscription -ServicePlan $servicePlan

Gets the subscriptions to the given service plan.


Get-EmcAppSyncSqlServerDatabase

Gets the SQL Server databases according to the specified criteria.

Syntax

  • Get-EmcAppSyncSqlServerDatabase [-ID <String>] -AppSyncSystem <IAppSyncSystem> [-UserDatabase] [-Silent] [<CommonParameters>]

  • Get-EmcAppSyncSqlServerDatabase [-ID <String>] [-UserDatabase] [-Silent] -SqlServerInstance <SqlServerInstance> [<CommonParameters>]

Parameters

ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the SQL Server databases. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-UserDatabase <SwitchParameter>

Attributes: Optional, Position: named

Specifies to only include user databases. System databases are excluded.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-SqlServerInstance <SqlServerInstance>

Attributes: Required, Position: named

Specifies the SQL Server instance of the SQL Server databases.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Get-EmcAppSyncSqlServerDatabase -AppSyncSystem $appsyncSystem -UserDatabase

Gets the user databases for the specified AppSync system.

-------------- Example 2 --------------

C:\PS>Get-EmcAppSyncSqlServerDatabase -SqlServerInstance $sqlInstance

Gets all the databases for the specified SQL Server instance.


Get-EmcAppSyncSqlServerInstance

Gets the SQL Server instances on the specified AppSync system.

Syntax

Get-EmcAppSyncSqlServerInstance [-ID <String>] [-AppSyncSystem <IAppSyncSystem>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the SQL Server instances. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcAppSyncSqlServerInstance -AppSyncSystem $appsyncSystem

Gets all the SQL Server instances on the specified AppSync system.


Get-EmcAppSyncSystemAlert

Gets the alerts for the specified AppSync system.

Syntax

Get-EmcAppSyncSystemAlert [-ID <String>] -AppSyncSystem <IAppSyncSystem> [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the names or IDs of the system alerts. Wildcards are permitted. It is a positional parameter (position = 1).

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Get-EmcAppSyncSystemAlert -AppSyncSystem $appsyncSystem

Gets all alerts for the specified AppSync system.


Mount-EmcAppSyncExchangeDatabaseCopy

Mounts an Exchange database copy according to the specified criteria.

Syntax

Mount-EmcAppSyncExchangeDatabaseCopy -ExchangeDatabaseCopy <ExchangeDatabase> -TargetHost <Host> [-MountPath <String>] [-Readonly] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-ExchangeDatabaseCopy <ExchangeDatabase>

Attributes: Required, Position: 1

Specifies the Exchange database copy to mount.

-TargetHost <Host>

Attributes: Required, Position: named

Specifies the target host on which to mount the copy.

-MountPath <String>

Attributes: Optional, Position: named

Specifies the mount path for the copy.

-Readonly <SwitchParameter>

Attributes: Optional, Position: named

Mounts the copy in read-only mode.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Mount-EmcAppSyncExchangeDatabaseCopy -ExchangeDatabaseCopy $exchangeDatabaseCopy -TargetHost $targetHost -MountPath 'd:\DbMount'

Mounts the Exchange database to the specified path on the target host.

-------------- Example 2 --------------

C:\PS>Mount-EmcAppSyncExchangeDatabaseCopy -ExchangeDatabaseCopy $exchangeDatabaseCopy -TargetHost $targetHost -Readonly

Mounts the Exchange database to the default path on the specified target host, in read-only mode.


Mount-EmcAppSyncSqlServerDatabaseCopy

Mounts the SQL Server database copy according to the specified criteria.

Syntax

Mount-EmcAppSyncSqlServerDatabaseCopy -SqlServerDatabaseCopy <SqlServerDatabase> -TargetHost <Host> [-MountPath <String>] [-Readonly] [-RecoveryType <SqlServerDatabaseRecoveryType>] [-RecoveryInstance <SqlServerInstance>] [-RecoveryDatabaseNameSuffix <String>] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-SqlServerDatabaseCopy <SqlServerDatabase>

Attributes: Required, Position: 1

Specifies the SQL Server database copy to mount.

-TargetHost <Host>

Attributes: Required, Position: named

Specifies the target host on which to mount the copy.

-MountPath <String>

Attributes: Optional, Position: named

Specifies the mount path for the copy.

-Readonly <SwitchParameter>

Attributes: Optional, Position: named

Indicates to mount the copy in read-only mode.

-RecoveryType <SqlServerDatabaseRecoveryType>

Attributes: Optional, Position: named

Specifies the recovery type. Valid values are Recovery, NoRecovery, and Standby.

-RecoveryInstance <SqlServerInstance>

Attributes: Optional, Position: named

Specifies the SQL Server instance on which to attach the database copy.

-RecoveryDatabaseNameSuffix <String>

Attributes: Optional, Position: named

Specifies the suffix name.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Mount-EmcAppSyncSqlServerDatabaseCopy -SqlServerDatabaseCopy $sqlDatabaseCopy -TargetHost $targetHost -MountPath 'D:\TestDbs' -RecoveryType Recover -RecoveryInstance $sqlInstance -RecoveryDatabaseNameSuffix 'test001'

Mounts the SQL Server database copy to the specified path and attaches it to the specified SQL Server instance with the suffix appended to its original database name.

-------------- Example 2 --------------

C:\PS>Mount-EmcAppSyncSqlServerDatabaseCopy -SqlServerDatabaseCopy $sqlDatabaseCopy -TargetHost $targetHost -Readonly

Mounts the specified SQL Server database copy to the default path in read-only mode, but doesn't attach it to a SQL Server instance.


New-EmcAppSyncExchangeDatabaseCopy

Protects the specified Exchange database by making a copy according to the criteria set by the specified service plan.

Syntax

New-EmcAppSyncExchangeDatabaseCopy -ExchangeDatabase <ExchangeDatabase> -ServicePlan <ServicePlan> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-ExchangeDatabase <ExchangeDatabase>

Attributes: Required, Position: 1

Specifies the source Exchange database for the copy.

-ServicePlan <ServicePlan>

Attributes: Required, Position: named

Specifies the service plan for the copy.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>New-EmcAppSyncExchangeDatabaseCopy -ExchangeDatabase $exchangeDatabase -ServicePlan $servicePlan

Makes a copy of the Exchange database based on the specified service plan.


New-EmcAppSyncServicePlanCopies

Runs the specified service plan and creates copies of applications that subscribe to that service plan.

Syntax

New-EmcAppSyncServicePlanCopies -ServicePlan <ServicePlan> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-ServicePlan <ServicePlan>

Attributes: Required, Position: 1

Specifies the service plan for the database.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>New-EmcAppSyncServicePlanCopies -ServicePlan $servicePlan

Runs the specified service plan and creates copies for applications that subscribe to that service plan.


New-EmcAppSyncServicePlanSubscription

Subscribes the specified SQL Server database or Exchange database to the specified service plan.

Syntax

  • New-EmcAppSyncServicePlanSubscription -ServicePlan <ServicePlan> -SqlServerDatabase <SqlServerDatabase> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • New-EmcAppSyncServicePlanSubscription -ServicePlan <ServicePlan> [-Force] [-Silent] [-WhatIf] [-Confirm] -ExchangeDatabase <ExchangeDatabase> [<CommonParameters>]

Parameters

-ServicePlan <ServicePlan>

Attributes: Required, Position: 1

Specifies the service plan for the database.

-SqlServerDatabase <SqlServerDatabase>

Attributes: Required, Position: named

Specifies which SQL Server database to subscribe to the service plan.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

-ExchangeDatabase <ExchangeDatabase>

Attributes: Required, Position: named

Specifies which Exchange database to subscribe to the service plan.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

-------------- Example 1 --------------

C:\PS>New-EmcAppSyncServicePlanSubscription -ServicePlan $sqlServicePlan -SqlServerDatabase $sqlDatabase

Subscribes the SQL Server database to the specified service plan.

-------------- Example 2 --------------

C:\PS>New-EmcAppSyncServicePlanSubscription -ServicePlan $exchangeServicePlan -ExchangeDatabase $exchangeDatabase

Subscribes the Exchange database to the specified service plan.


New-EmcAppSyncSqlServerDatabaseCopy

Protects the specified SQL Server database by making a copy according to the criteria set by the specified service plan.

Syntax

New-EmcAppSyncSqlServerDatabaseCopy -SqlServerDatabase <SqlServerDatabase> -ServicePlan <ServicePlan> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

SqlServerDatabase <SqlServerDatabase>

Attributes: Required, Position: 1

Specifies the SQL Server source database for the copy.

-ServicePlan <ServicePlan>

Attributes: Required, Position: named

Specifies the service plan for the copy.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>New-EmcAppSyncSqlServerDatabaseCopy -SqlServerDatabase $sqlDatabase -ServicePlan $servicePlan

Makes a copy of the SQL Server database according to the criteria set by the specified service plan.


Remove-EmcAppSyncCopy

Expires or removes the specified SQL Server database copy or Exchange database copy.

Syntax

  • Remove-EmcAppSyncCopy -SqlServerDatabaseCopy <SqlServerDatabase> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Remove-EmcAppSyncCopy -ExchangeDatabaseCopy <ExchangeDatabase> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-SqlServerDatabaseCopy <SqlServerDatabase>

Attributes: Required, Position: 1

Specifies the SQL Server database copy to expire.

-ExchangeDatabaseCopy <ExchangeDatabase>

Attributes: Required, Position: 1

Specifies the Exchange database copy to expire.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you run the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Remove-EmcAppSyncCopy -SqlServerDatabaseCopy $sqlDatabase

Expires or removes the specified SQL Server database copy.

-------------- Example 2 --------------

C:\PS>Remove-EmcAppSyncCopy -ExchangeDatabaseCopy $exchangeDatabase

Expires or removes the specified Exchange database copy.


Remove-EmcAppSyncServicePlanSubscription

Removes the specified subscription.

Syntax

Remove-EmcAppSyncServicePlanSubscription -Subscription <ServicePlanSubscription> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Subscription <ServicePlanSubscription>

Attributes: Required, Position: 1

Specifies the subscription to remove.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Remove-EmcAppSyncServicePlanSubscription -Subscription $subscription

Removes the specified subscription from its service plan.


Restore-EmcAppSyncExchangeDatabaseCopy

Restores the source Exchange database by using the specified copy.

Syntax

Restore-EmcAppSyncExchangeDatabaseCopy -ExchangeDatabaseCopy <ExchangeDatabase> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-ExchangeDatabaseCopy <ExchangeDatabase>

Attributes: Required, Position: 1

Specifies the Exchange database copy.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Restore-EmcAppSyncExchangeDatabaseCopy -ExchangeDatabaseCopy $exchangeDatabaseCopy

Restores the source Exchange database using the specified copy.


Restore-EmcAppSyncSqlServerDatabaseCopy

Restores the source SQL Server database by using the specified copy.

Syntax

Restore-EmcAppSyncSqlServerDatabaseCopy -SqlServerDatabaseCopy <SqlServerDatabase> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-SqlServerDatabaseCopy <SqlServerDatabase>

Attributes: Required, Position: 1

Specifies the SQL Server database copy.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>Restore-EmcAppSyncSqlServerDatabaseCopy -SqlServerDatabaseCopy $sqlDatabaseCopy

Restores the source SQL Server database using the specified copy.


Update-EmcAppSyncSystem

Updates the AppSync system by discovering applications.

Syntax

Update-EmcAppSyncSystem -AppSyncSystem <IAppSyncSystem> [-SqlServer] [-Exchange] [-Silent] [-PipelineVariable <String>] [<CommonParameters>]

Update-EmcAppSyncSystem [-SqlServer] [-Exchange] [-Silent] [-PipelineVariable <String>] -RegisteredHost <Host> [<CommonParameters>]

Update-EmcAppSyncSystem [-Silent] [-PipelineVariable <String>] -SqlServerInstance <SqlServerInstance> [<CommonParameters>]

Update-EmcAppSyncSystem [-Silent] [-PipelineVariable <String>] -ExchangeServer <ExchangeServer> [<CommonParameters>]

Parameters

-AppSyncSystem <IAppSyncSystem>

Attributes: Required, Position: named

Specifies the AppSync system.

-SqlServer <SwitchParameter>

Attributes: Optional, Position: named

Indicates the discovery should include SQL Server.

-Exchange <SwitchParameter>

Attributes: Optional, Position: named

Indicates the discovery should include Exchange.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

An optional parameter to turn off all the informational and verbose messages. It still displays errors.

-PipelineVariable <String>

Attributes: Optional, Position: named

-RegisteredHost <Host>

Attributes: Required, Position: named

Specifis the registered host on AppSync.

-SqlServerInstance <SqlServerInstance>

Attributes: Required, Position: named

Specifis the SQL Server instance on which the discovery is performed.

-ExchangeServer <ExchangeServer>

Attributes: Required, Position: named

Specifis the Exchange server on which the discovery is performed.

<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer and OutVariable. For more information, type "get-help about_commonparameters"

Examples

---------- EXAMPLE 1 ----------

C:\PS>Update-EmcAppSyncSystem -AppSyncSystem $appsyncSystem

Performs the full discovery for all applications (including SQL Server and Exchange) on the given AppSync system.

---------- EXAMPLE 2 ----------

C:\PS>Update-EmcAppSyncSystem -AppSyncSystem $appsyncSystem -SqlServer

Performs the discovery for SQL Server only on the given AppSync system.

---------- EXAMPLE 3 ----------

C:\PS>Update-EmcAppSyncSystem -RegisteredHost $host -SqlServer

Performs the discovery for SQL Server on the given registered host on AppSync.

---------- EXAMPLE 4 ----------

C:\PS>Update-EmcAppSyncSystem -SqlServerInstance $sqlInstance

Performs the discovery of databases on the given SQL Server instance.

---------- EXAMPLE 5 ----------

C:\PS>Update-EmcAppSyncSystem -ExchangeServer $exchangeServer

Performs the discovery of databases on the given Exchange server.


Disable-EmcReplicaCopy

Disables a replica copy to stop the replication of that copy.

Syntax

Disable-EmcReplicaCopy -Copy <ReplicaCopy> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Copy <ReplicaCopy>

Attributes: Required, Position: Named

The replica copy to disable.

-Force <SwitchParameter>

Attributes: Optional, Position: Named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: Named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: Named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: Named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

C:\PS>Disable-EmcReplicaCopy -Copy $copy

This example disables a replica copy.


Disable-EmcReplicaCopyImageAccess

Disables a replica copy image access so that it is not available for mounting, and replication changes are again propagated to the copy.

Syntax

Disable-EmcReplicaCopyImageAccess -Copy <ReplicaCopy> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Copy <ReplicaCopy>

Attributes: Required, Position: Named

The replica copy for which image access will be disabled.

-Force <SwitchParameter>

Attributes: Optional, Position: Named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: Named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: Named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: Named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

C:\PS>Disable-EmcReplicaCopyImageAccess -Copy $copy

This example disables the image access for a replica copy.


Disconnect-EmcReplicationService

Disconnects replication services.

Syntax

  • Disconnect-EmcReplicationService [[-Id] <String>] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

  • Disconnect-EmcReplicationService [-Force] [-Silent] [-WhatIf] [-Confirm] [-System <IReplicationService>] [<CommonParameters>]

Parameters

-Id <String>

Attributes: Optional, Position: 1

Specifies the friendly name, service name, or global ID of the replication service. Wildcards are permitted.

-Force <SwitchParameter>

Attributes: Optional, Position: Named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: Named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: Named

Shows what would happen if the cmdlet were run without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: Named

Prompts you for confirmation before executing the command.

-System <IReplicationService>

Attributes: Optional, Position: Named

Specifies the ESI storage system object. You can add a storage system object to ESI by using the Get-EmcStorageSystemCredential and Connect-EmcSystem cmdlets. You can get a storage system object by using the Get-EmcStorageSystem cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>Disconnect-EmcReplicationService -ID *60*

This example disconnects ID *60* from a replication service.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

Disconnect-EmcReplicationService -System $service

This example disconnects a system object from a replication service.


Enable-EmcReplicaCopy

Enables a replica copy to start replication on that copy.

Syntax

Enable-EmcReplicaCopy -Copy <ReplicaCopy> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Copy <ReplicaCopy>

Attributes: Required, Position: named

The replica copy to enable.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Describes what would happen if you ran the cmdlet without actually running the cmdlet.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

C:\PS>Enable-EmcReplicaCopy -Copy $copy

This example enables a replica copy.


Enable-EmcReplicaCopyImageAccess

Enables a replica copy image access so that it can be available for mounting. Replication changes are not propagated to the copy while image access is enabled.

When image access is enabled for replica snapshots, ESI automatically uses the RecoverPoint Image Access mode of Logged Access. This mode ensures the snapshot resides on the replica LUN and not the journal.

Syntax

Enable-EmcReplicaCopyImageAccess -Copy <ReplicaCopy> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Copy <ReplicaCopy>

Attributes: Required, Position: named

The replica copy for which image access will be enabled.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-ImageAccessScenario <ImageAccessScenario>

Attributes: Optional, Position: named

The type of operation for a replica copy. The available options are Failover and RecoverProduction. ESI automatically uses the RecoverPoint Image Access mode of Logged Access, which is the only supported mode in ESI.

-Snapshot <SnapshotBase>

Attributes: Optional, Position: named

Point-in-time marked by the system for the recovery.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Describes what would happen if you ran the cmdlet without actually running the cmdlet.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

C:\PS>Enable-EmcReplicaCopy –Copy $copy

C:\PS>Enable-EmcReplicaCopyImageAccess -Copy $copy

Enables image access for a replica copy.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

C:\PS>Enable-EmcReplicaCopy –Copy $copy

C:\PS>$snapshots = Get-EmcReplicaCopySnapshots -Copy $copy

C:\PS>Enable-EmcReplicaCopyImageAccess -Copy $copy -Snapshot $snapshots[0]

Enables a replica copy's image access for the retrieved snapshot.

-------------- Example 3 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

C:\PS>Enable-EmcReplicaCopy –Copy $copy

C:\PS>$snapshots = Get-EmcReplicaCopySnapshots -Copy $copy

C:\PS>$snapshot = $snapshots[1].PreviousSnapshot

C:\PS>Enable-EmcReplicaCopyImageAccess -Copy $copy -Snapshot $snapshot

Enables a replica copy's image access for the previous snapshot of the retrieved snapshot.


Get-EmcConsistencyGroup

Retrieves consistency groups that are used to protect LUNs.

Syntax

  • Get-EmcConsistencyGroup [[-ID] <String>] [-Silent] [<CommonParameters>]

  • Get-EmcConsistencyGroup [[-ID] <String>] [-Silent] -ReplicationServiceCluster <ReplicationServiceCluster> [<CommonParameters>]

  • Get-EmcConsistencyGroup [[-ID] <String>] [-Silent] -ReplicaLun <ReplicaLun> [<CommonParameters>]

  • Get-EmcConsistencyGroup [[-ID] <String>] [-Silent] -Lun <Lun> [<CommonParameters>]

  • Get-EmcConsistencyGroup [[-ID] <String>] [-Silent] -MailboxDatabase <MailboxDatabase> [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name or ID of the consistency group. Wildcards are permitted.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ReplicationServiceCluster <ReplicationServiceCluster>

Attributes: Required, Position: named

Specifies the replication cluster that owns and manages the consistency group.

-ReplicaLun <ReplicaLun>

Attributes: Required, Position: named

Specifies a replica LUN that is owned and managed by the consistency group.

-Lun <Lun>

Attributes: Required, Position: named

Specifies a storage system LUN that is owned and managed by the consistency group.

-MailboxDatabase <MailboxDatabase>

Attributes: Required, Position: named

Specifies a mailbox database that is owned and managed by the consistency group. You can get the MailBoxDatabase object with the Get-EmcMailBoxDatabase cmdlet.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID CG_PSTest

This example get a consistency group with a specified replication service cluster.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$lun = Get-EmcReplicaLun -ReplicationService $service -ID *RP_Set1*

$group = Get-EmcConsistencyGroup -ReplicaLun $lun

This example gets a consistency group with a specified replica LUN.

-------------- Example 3 --------------

C:\PS>$storageSystem = Get-EmcStorageSystem -ID *6439

$storagePool = Get-EmcStoragePool -StorageSystem $storageSystem -ID *RaidGroup*0*

$lun = Get-EmcLun -Pool $storagePool -ID *RP_Set1*

$group = Get-EmcConsistencyGroup -Lun $lun

This example gets a consistency group with a specified storage system LUN.

-------------- Example 4 --------------

C:\PS>$db = Get-EmcMailboxDatabase -ID *mailboxID* $group = Get-EmcConsistencyGroup -MailboxDatabase $db

This example gets a consistency group with a specified mailbox database.


Get-EmcReplicaCopy

Gets the list of replica copies that specify the copies within a consistency group.

Syntax

  • Get-EmcReplicaCopy [[-ID] <String>] [-ReplicationServiceCluster <ReplicationServiceCluster>] [-Role <ReplicaCopyRole>] [-Silent] [<CommonParameters>]

  • Get-EmcReplicaCopy [[-ID] <String>] [-Role <ReplicaCopyRole>] [-Silent] [-ConsistencyGroup <ConsistencyGroup>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name or ID of the replica copy. Wildcards are permitted.

-ReplicationServiceCluster <ReplicationServiceCluster>

Attributes: Optional, Position: named

Specifies the replication cluster that owns and manages the replica copy.

-Role <ReplicaCopyRole>

Attributes: Optional, Position: named

Specifies the replica copy Role Type. The value can be any combination of the following:

  • ProductionCopy: Replica copies with a Production Copy role.

  • LocalCopy: Replica copies with a Local Copy role.

  • RemoteCopy: Replica copies with a Remote Copy role.

  • Unknown: Replica copies with an Unknown role.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ConsistencyGroup <ConsistencyGroup>

Attributes: Optional, Position: named

Specifies the consistency group that owns and manages the replica copy.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role ProductionCopy

This example gets a replica copy for a specified replication service cluster.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID CG_PSTest

C:\PS>$copy = Get-EmcReplicaCopy -ConsistencyGroup $group -Role ProductionCopy,LocalCopy

This example gets a replica copy for a specified consistency group.


Get-EmcReplicaLink

Gets the list of replica links that specify the replication connection and direction between two replica copies within a consistency group.

Syntax

  • Get-EmcReplicaLink [[-ID] <String>] [-ReplicationService <IReplicationService>] [-LinkType <GetEmcReplicaLinkCmdlet+LinkTypeValues>] [-Silent] [<CommonParameters>]

  • Get-EmcReplicaLink [[-ID] <String>] [-LinkType <GetEmcReplicaLinkCmdlet+LinkTypeValues>] [-Silent] [-ConsistencyGroup <ConsistencyGroup>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the ID of the source or target replica copies of the replica link. Wildcards are permitted.

-ReplicationService <IReplicationService>

Attributes: Optional, Position: named

Specifies the replication service that owns and manages the replica link.

-LinkType <GetEmcReplicaLinkCmdlet+LinkTypeValues>

Attributes: Optional, Position: named

Specifies the link type. The value can be one of the following:

  • Active: Only gets active links

  • Passive: Only gets passive links

  • All: Gets both Active and passive links

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ConsistencyGroup <ConsistencyGroup>

Attributes: Optional, Position: named

Specifies the consistency group that owns and manages the replica link.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$link = Get-EmcReplicaLink -ReplicationService $service -LinkType Active -ID Copy_Prod

This example gets a replica link for a specified replication service.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID CG_PSTest

$link = Get-EmcReplicaLink -ConsistencyGroup $group -LinkType All -ID Copy_Prod

This example gets a replica link for a specified consistency group.


Get-EmcReplicaLun

Gets the replica LUNs for replication.

Syntax

  • Get-EmcReplicaLun [[-ID] <String>] [-ReplicationService <IReplicationService>] [-Silent] [<CommonParameters>]

  • Get-EmcReplicaLun [[-ID] <String>] [-Role <ReplicaCopyRole>] [-Silent] [-ConsistencyGroup <ConsistencyGroup>] [<CommonParameters>]

  • Get-EmcReplicaLun [[-ID] <String>] [-Role <ReplicaCopyRole>] [-Silent] [-ReplicaSet <ReplicaSet>] [<CommonParameters>]

  • Get-EmcReplicaLun [[-ID] <String>] [-Role <ReplicaCopyRole>] [-Silent] [-ReplicaCopy <ReplicaCopy>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name or world wide name (WWN) of the LUN. Wildcards are permitted.

-ReplicationService <IReplicationService>

Attributes: Optional, Position: named

Specifies the replication service that owns and manages the replica LUN.

-Role <ReplicaCopyRole>

Attributes: Optional, Position: named

Specifies the replica copy role type. This value can be any combination of the following roles with replica copies: production copy, local copy, remote copy, or unknown.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ConsistencyGroup <ConsistencyGroup>

Attributes: Optional, Position: named

Specifies the consistency group that owns and manages the replica LUN.

-ReplicaSet <ReplicaSet>

Attributes: Optional, Position: named

Specifies the replica set that owns and manages the replica LUN.

-ReplicaCopy <ReplicaCopy>

Attributes: Optional, Position: named

Specifies the replica copy that owns and manages the replica LUN.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$lun = Get-EmcReplicaLun -ReplicationService $service -ID *RP_Set1*

This example gets a replica LUN for a specified replication service.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID CG_PSTest

$lun = Get-EmcReplicaLun -ConsistencyGroup $group -ID *RP_Set1*

This example gets a replica LUN for a specified consistency group.

-------------- Example 3 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID CG_PSTest

$set = Get-EmcReplicaSet -ConsistencyGroup $group -ID Set_S1

$lun = Get-EmcReplicaLun -ReplicaSet $set -ID *RP_Set1*

This example gets a replica LUN for a specified replica set.

-------------- Example 4 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID CG_PSTest

$copy = Get-EmcReplicaCopy -ConsistencyGroup $group -Role ProductionCopy,LocalCopy

$lun = Get-EmcReplicaLun -ReplicaCopy $copy[1] -ID *RP_Set1*

This example gets a replica LUN for a specified replica copy.


Get-EmcReplicaSet

Gets replica sets that contain the LUNs for the replication of source LUNs.

Syntax

  • Get-EmcReplicaSet [[-ID] <String>] [-ReplicationService <IReplicationService>] [-Silent] [<CommonParameters>]

  • Get-EmcReplicaSet [[-ID] <String>] [-Silent] [-ConsistencyGroup <ConsistencyGroup>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the name or ID of the replica set. Wildcards are permitted.

-ReplicationService <IReplicationService>

Attributes: Optional, Position: named

Specifies the replication service that owns and manages the replica set.

-ConsistencyGroup <ConsistencyGroup>

Attributes: Optional, Position: named

Specifies the consistency group that owns and manages the replica set.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$set = Get-EmcReplicaSet -ReplicationService $service -ID Set_S1

This example gets a replica set for a specified replication service.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID CG_PSTest

$set = Get-EmcReplicaSet -ConsistencyGroup $group -ID Set_S1

This example gets a replica set for a specified consistency group.


Get-EmcReplicationService

Gets the list of replication services. The replication service is the primary object for managing replication clusters, sites, and systems.

Syntax

Get-EmcReplicationService [[-ID] <String>] [-Silent] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the friendly name, service name, or global ID of the replication service. Wildcards are permitted.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

This example gets a replication service for a specified ID.


Get-EmcReplicationServiceCluster

Gets the list of replication clusters, which contains all the replication sites and systems in a replication service.

Syntax

  • Get-EmcReplicationServiceCluster [[-ID] <String>] [-ReplicationService <IReplicationService>] [-Silent] [<CommonParameters>]

  • Get-EmcReplicationServiceCluster [[-ID] <String>] [-Silent] [-StorageSystem <IBlockStorageSystem>] [<CommonParameters>]

  • Get-EmcReplicationServiceCluster [[-ID] <String>] [-Silent] [-Lun <Lun>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the cluster name of the replication cluster. Wildcards are permitted.

-ReplicationService <IReplicationService>

Attributes: Optional, Position: named

Specifies the replication service that owns and manages the replication cluster.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-StorageSystem <IBlockStorageSystem>

Attributes: Optional, Position: named

Specifies a storage system that is detected as being connected to the replication cluster.

-Lun <Lun>

Attributes: Optional, Position: named

Specifies a LUN that is used by a storage system that is detected as being connected to the replication cluster.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

This example gets a replication service cluster for a specified replication service.

-------------- Example 2 --------------

C:\PS>$storageSystem = Get-EmcStorageSystem -ID *6439

C:\PS>$cluster = Get-EmcReplicationServiceCluster -StorageSystem $storageSystem

This example gets a replication service cluster for a specified storage system.

-------------- Example 3 --------------

C:\PS>$storageSystem = Get-EmcStorageSystem -ID *6439

C:\PS>$storagePool = Get-EmcStoragePool -StorageSystem $storageSystem -ID *RaidGroup*0*

C:\PS>$lun = Get-EmcLun -Pool $storagePool -ID *RP_Set1*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -Lun $lun

This example gets a replication service cluster for a specified LUN.


Get-EmcReplicationServiceSite

Gets the list of replication sites, which contains all of the replication systems in the site.

Syntax

  • Get-EmcReplicationServiceSite [[-ID] <String>] [-ReplicationService <IReplicationService>] [-Silent] [<CommonParameters>]

  • Get-EmcReplicationServiceSite [[-ID] <String>] [-Silent] [-ReplicationServiceCluster <ReplicationServiceCluster>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the site name or site ID of the replication site. Wildcards are permitted.

-ReplicationService <IReplicationService>

Attributes: Optional, Position: named

Specifies the replication service that owns and manages the replication site.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ReplicationServiceCluster <ReplicationServiceCluster>

Attributes: Optional, Position: named

Specifies the replication cluster that owns and manages the replication site.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$site = Get-EmcReplicationServiceSite -ReplicationService $service -ID *Site4*

This example gets a replication service site for a specified replication service.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$site = Get-EmcReplicationServiceSite -ReplicationServiceCluster $cluster -ID *Site4*

This example gets a replication service site for a specified replication service cluster.


Get-EmcReplicationSystem

Gets the list of replication systems. A replication system is an individual replication appliance that performs and facilitates replication.

Syntax

  • Get-EmcReplicationSystem [[-ID] <String>] [-ReplicationService <IReplicationService>] [-Silent] [<CommonParameters>]

  • Get-EmcReplicationSystem [[-ID] <String>] [-Silent] [-ReplicationServiceCluster <ReplicationServiceCluster>] [<CommonParameters>]

  • Get-EmcReplicationSystem [[-ID] <String>] [-Silent] [-ReplicationServiceSite <ReplicationServiceSite>] [<CommonParameters>]

Parameters

-ID <String>

Attributes: Optional, Position: 1

Specifies the system name or system ID of the replication system. Wildcards are permitted.

-ReplicationService <IReplicationService>

Attributes: Optional, Position: named

Specifies the replication service that owns and manages the replication system.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-ReplicationServiceCluster <ReplicationServiceCluster>

Attributes: Optional, Position: named

Specifies the replication cluster that owns and manages the replication system.

-ReplicationServiceSite <ReplicationServiceSite>

Attributes: Optional, Position: named

Specifies the replication site in which the replication system resides.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$system = Get-EmcReplicationSystem -ReplicationService $service -ID *Site4*RPA*1*

This example gets a replication system for a specified replication service.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$system = Get-EmcReplicationSystem -ReplicationServiceCluster $cluster -ID *Site4*RPA*1*

This example gets a replication system for a specified replication service cluster.

-------------- Example 3 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$site = Get-EmcReplicationServiceSite -ReplicationServiceCluster $cluster -ID *Site4*

$system = Get-EmcReplicationSystem -ReplicationServiceSite $site -ID *Site4*RPA*1*

This example gets a replication system for a specified replication service site.


Get-EmcReplicationServiceCredential

Gets the encrypted connection string or BLOB. You can use this cmdlet along with the Connect-EmcSystem cmdlet to connect or add replication services to ESI.

Syntax

Get-EmcReplicationServiceCredential [-Silent] [<CommonParameters>]

Parameters

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$blob = Get-EmcReplicationServiceCredential

C:\PS>$service = Connect-EmcSystem -CreationBlob $blob

This example gets credentials from the user and uses the credentials to connect to a replication service.


Get-EmcReplicaCopySnapshot

Get-EmcReplicaCopySnapshots

Gets the list of snapshots for the specified replica copy.

Syntax

  • Get-EmcReplicaCopySnapshots -Copy <ReplicaCopy> [-LatestImage] [-Silent] [<CommonParameters>]

  • Get-EmcReplicaCopySnapshots -Copy <ReplicaCopy> [-Silent] -PointinTime <DateTime> -MaxRange <Int64> [-Name <String>] [-ImageType <ImageType>] [<CommonParameters>]

Parameters

-Copy <ReplicaCopy>

Attributes: Required, Position: Named

The replica copy for which snapshots should be retrieved

-LatestImage <SwitchParameter>

Attributes: Optional, Position: Named

If specified, the last snapshot created for production and transferred to the copy journal. This is the image at the top of the image list and the most current snapshot sent from production.

-Silent <SwitchParameter>

Attributes: Optional, Position: Named

Turns off all informational and verbose messages. However, it still displays errors.

-PointinTime <DateTime>

Attributes: Required, Position: Named

If specified, the cmdlet searches for an image that was created at the specified date and time.

-MaxRange <Int64>

Attributes: Required, Position: Named

If specified, the cmdlet searches for an image that was created the specified number of microseconds before and after the specified Point in Time.

-Name <String>

Attributes: Optional, Position: Named

If specified, the cmdlet searches for an image with the specified bookmark name.

-ImageType <ImageType>

Attributes: Optional, Position: Named

If specified, the cmdlet searches for the specified image type. The options include: All, AllBookmarks, SystemBookmarks, and UserBookmarks.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *38*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role LocalCopy

$snapshots = Get-EmcReplicaCopySnapshots -Copy $copy[1]

Gets the list of snapshots for a replica copy.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *38*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role LocalCopy

$snapshots = Get-EmcReplicaCopySnapshots -Copy $copy[1] -LatestImage

Gets the latest snapshot for a replica copy.

-------------- Example 3 --------------

C:\PS>$service = Get-EmcReplicationService -ID *38*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role LocalCopy

$snapshots = Get-EmcReplicaCopySnapshots -Copy $copy[1] -PointinTime (get-date) -MaxRange 1000000

Gets the list of snapshots for a replica copy with the specified filter of current date and maximum range of 1 second.

-------------- Example 4 --------------

C:\PS>$service = Get-EmcReplicationService -ID *38*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role LocalCopy

$snapshots = Get-EmcReplicaCopySnapshots -Copy $copy[1] -PointinTime (get-date) -MaxRange 10 -Name *Test* -ImageType All

Gets the list of snapshots for a replica copy with the specified filter of current date with a maximum range of 10 microseconds, a name that contains test, and the image type of All.


Move-EmcProductionReplicaCopy

Performs a permanent failover to the specified replica copy, and then the copy becomes the new production copy.

Syntax

Move-EmcProductionReplicaCopy -Copy <ReplicaCopy> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Copy <ReplicaCopy>

Attributes: Required, Position: named

Specifies the replica copy that will become the new production copy.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

Move-EmcProductionReplicaCopy -Copy $copy

This example performs a failover to the remote copy.


New-EmcConsistencyGroup

Creates a new consistency group, which is a group of one or more replica sets.

Syntax

New-EmcConsistencyGroup -ReplicationServiceCluster <ReplicationServiceCluster> -Name <String> [-Silent] [<CommonParameters>]

Parameters

-ReplicationServiceCluster <ReplicationServiceCluster>

Attributes: Required, Position: named

Specifies the replication cluster from which to create the consistency group.

-Name <String>

Attributes: Required, Position: named

Specifies the name of the consistency group.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = New-EmcConsistencyGroup -ReplicationServiceCluster $cluster -Name "RP_PS_TEST"

This example creates a new consistency group.


New-EmcBookmark

Creates a RecoverPoint bookmark for the specified consistency group.

Syntax

New-EmcBookmark -ConsistencyGroup <ConsistencyGroup> -Name <String> -ConsolidationPolicy <ConsolidationPolicy> -ConsistencyType <ConsistencyType> [-Silent] [<CommonParameters>]

Parameters

-ConsistencyGroup <ConsistencyGroup>

Attributes: Required, Position: named

Specifies the consistency group for the bookmark.

-Name <String>

Attributes: Required, Position: named

Specifies the name of the bookmark.

-ConsolidationPolicy <ConsolidationPolicy>

Attributes: Required, Position: named

Specifies the consolidation policy for the bookmark. The available options are: AlwaysConsolidate, SurviveDaily, SurviveWeekly, SurviveMonthly, and NeverConsolidate.

-ConsistencyType <ConsistencyType>

Attributes: Required, Position: named

Specifies the consistency type for the bookmark, which can be ConsistencyUnknown or ApplicationConsistent.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID RP_PS_TEST

New-EmcBookmark -ConsistencyGroup $group -Name "RP_PS_TEST_BM" -ConsolidationPolicy AlwaysConsolidate -ConsistencyType ConsistencyUnknown

Creates a bookmark for the specified consistency group with the specified consolidation policy and consistency type.


New-EmcParallelBookmark

Creates a parallel bookmark for multiple consistency groups.

Syntax

New-EmcParallelBookmark -ConsistencyGroups <ConsistencyGroup> -Name <String> -ConsolidationPolicy <ConsolidationPolicy> -ConsistencyType <ConsistencyType> [-Silent] [<CommonParameters>]

Parameters

-ConsistencyGroups <ConsistencyGroup>

Attributes: Required, Position: named

Specifies the list of consistency groups for the parallel bookmark.

-Name <String>

Attributes: Required, Position: named

Specifies the name of the bookmark.

-ConsolidationPolicy <ConsolidationPolicy>

Attributes: Required, Position: named

Specifies the consolidation policy for the bookmark. The available types include: AlwaysConsolidate, SurviveDaily, SurviveWeekly, SurviveMonthly, and NeverConsolidate.

-ConsistencyType <ConsistencyType>

Attributes: Required, Position: named

Specifies the consistency type for the bookmark, which can be ConsistencyUnknown or ApplicationConsistent.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>New-EmcParallelBookmark -ConsistencyGroups < ConsistencyGroup > -Name < String > -ConsolidationPolicy < ConsolidationPolicy > -ConsistencyType < ConsistencyType > -Silent

Creates a parallel bookmark for the specified consistency groups.


New-EmcReplicaCopy

Creates a new replica copy for a consistency group.

Syntax

  • New-EmcReplicaCopy -ConsistencyGroup <ConsistencyGroup> -Name <String> [-ProductionCopy] -Site <ReplicationServiceSite> -JournalPool <LunStoragePool> -JournalSize <UInt64> [-Silent] [<CommonParameters>]

  • New-EmcReplicaCopy -ConsistencyGroup <ConsistencyGroup> -Name <String> [-ProductionCopy] -Site <ReplicationServiceSite> -JournalPool <LunStoragePool> -JournalSize <UInt64> [-Silent] -PoolsByReplicaSetName <Hashtable> [<CommonParameters>]

  • New-EmcReplicaCopy -ConsistencyGroup <ConsistencyGroup> -Name <String> [-ProductionCopy] -Site <ReplicationServiceSite> -JournalPool <LunStoragePool> -JournalSize <UInt64> [-Silent] -LunsByReplicaSetName <Hashtable> [<CommonParameters>]

Parameters

-ConsistencyGroup <ConsistencyGroup>

Attributes: Required, Position: named

Specifies the consistency group from which to create the replica copy.

-Name <String>

Attributes: Required, Position: named

Specifies the name for the replica copy.

-ProductionCopy <SwitchParameter>

Attributes: Optional, Position: named

If specified, this replica becomes the production copy.

-Site <ReplicationServiceSite>

Attributes: Required, Position: named

Specifies the replication site for the replica copy.

-JournalPool <LunStoragePool>

Attributes: Required, Position: named

Specifies the LUN storage pool that will be used to create the journal LUN for the copy.

-JournalSize <UInt64>

Attributes: Required, Position: named

Specifies the size of the journal LUN for the copy.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-PoolsByReplicaSetName <Hashtable>

Attributes: Required, Position: named

Specifies a hash table where each key is a replica set name and each value is a storage pool. ESI uses this table to create the LUN that protects the replica set for the new replica copy.

-LunsByReplicaSetName <Hashtable>

Attributes: Required, Position: named

Specifies a hash table where each key is a replica set name and each value is a LUN. ESI uses this table to protect the replica set for the new replica copy.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$site = Get-EmcReplicationServiceSite -ReplicationService $service -ID *Site4*

C:\PS>$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID RP_PS_TEST

C:\PS>$storageSystem = Get-EmcStorageSystem -ID *6439

C:\PS>$storagePool = Get-EmcStoragePool -StorageSystem $storageSystem -ID *RaidGroup*0*

C:\PS>$prodCopy = New-EmcReplicaCopy -ConsistencyGroup $group -Name "RP_PS_TEST_CP" -ProductionCopy -Site $site -JournalPool $storagePool -JournalSize 10240mb

This example creates a new replica copy.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$site = Get-EmcReplicationServiceSite -ReplicationService $service -ID *Site4*

C:\PS>$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID RP_PS_TEST

C:\PS>$storageSystem = Get-EmcStorageSystem -ID *6439

C:\PS>$storagePool = Get-EmcStoragePool -StorageSystem $storageSystem -ID *RaidGroup*0*

C:\PS>$storagePoolLoc = Get-EmcStoragePool -StorageSystem $storageSystem -ID *RaidGroup*2*

C:\PS>$storageSystemRem = Get-EmcStorageSystem -ID *6440

C:\PS>$storagePoolRem = Get-EmcStoragePool -StorageSystem $storageSystemRem[0] -ID *RaidGroup*0*

C:\PS>$hashTable = @{RP_PS_TEST_CL=$storagePoolLoc;RP_PS_TEST_CR=$storagePoolRem}

C:\PS>$prodCopy = New-EmcReplicaCopy -ConsistencyGroup $group -Name "RP_PS_TEST_CP" -ProductionCopy -Site $site -JournalPool $storagePool -JournalSize 10240mb -PoolsByReplicaSetName $hashTable

This example creates a replica copy using the PoolsByReplicaSetName parameter.


New-EmcReplicaLink

Creates a new replica link between two replica copies.

Syntax

  • New-EmcReplicaLink -SourceCopy <ReplicaCopy> -TargetCopy <ReplicaCopy> -Synchronous [-Silent] [<CommonParameters>]

  • New-EmcReplicaLink -SourceCopy <ReplicaCopy> -TargetCopy <ReplicaCopy> [-Silent] -Asynchronous [<CommonParameters>]

Parameters

-SourceCopy <ReplicaCopy>

Attributes: Required, Position: 1

Specifies the source replica copy of the link.

-TargetCopy <ReplicaCopy>

Attributes: Required, Position: 2

Specifies the target replica copy of the link.

-Synchronous <SwitchParameter>

Attributes: Required, Position: named

If specified, ESI performs synchronous replication.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-Asynchronous <SwitchParameter>

Attributes: Required, Position: named

If specified, ESI performs asynchronous replication.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$prodCopy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -ID RP_PS_TEST_CP

$locCopy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -ID RP_PS_TEST_CL

$link = New-EmcReplicaLink -SourceCopy $prodCopy -TargetCopy $locCopy -Synchronous

This example creates a new synchronous replica link.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$prodCopy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -ID RP_PS_TEST_CP

$remCopy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -ID RP_PS_TEST_CR

$link = New-EmcReplicaLink -SourceCopy $prodCopy -TargetCopy $remCopy -Asynchronous

This example creates a new asynchronous replica link.


New-EmcReplicaSet

Creates a new replica set for a consistency group.

Syntax

  • New-EmcReplicaSet -Name <String> -ConsistencyGroup <ConsistencyGroup> -ProductionLun <ConcreteLun> [-PoolsByReplicaCopyName <Hashtable>] [-Silent] [<CommonParameters>]

  • New-EmcReplicaSet -Name <String> -ConsistencyGroup <ConsistencyGroup> [-Silent] -LunsByReplicaCopyName <Hashtable> [<CommonParameters>]

Parameters

-Name <String>

Attributes: Required, Position: named

Specifies the name for the replica set.

-ConsistencyGroup <ConsistencyGroup>

Attributes: Required, Position: named

Specifies the consistency group from which to create the replica set.

-ProductionLun <ConcreteLun>

Attributes: Required, Position: named

Specifies the concrete LUN to protect in the replica set.

-PoolsByReplicaCopyName <Hashtable>

Attributes: Optional, Position: named

A hash table specifying the LUN storage pools to be used to create the replication replica LUN for each of the replica copies in the consistency group. Each key in the hash table is the name of a replica copy in the consistency group and each value is the LUN storage pool to be used when creating the LUN for that replica copy.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-LunsByReplicaCopyName <Hashtable>

Attributes: Required, Position: named

Specifies a hash table where each key in the hash table is the name of a replica copy in the consistency group, and each value is the LUN for that replica copy. The table specifies the LUN for each replica copy in the consistency group.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Examples

-------------- Example 1 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS>$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID RP_PS_TEST

C:\PS>$storageSystemLoc = Get-EmcStorageSystem -ID *6439

C:\PS>$storagePoolLoc = Get-EmcStoragePool -StorageSystem $storageSystemLoc -ID *RaidGroup*0*

C:\PS>$prodLun = Get-EmcLun -Pool $storagePoolLoc -ID *RP_PS_TEST_ProdLun*

C:\PS>$storageSystemRem = Get-EmcStorageSystem -ID *6440

C:\PS>$storagePoolRem = Get-EmcStoragePool -StorageSystem $storageSystemRem[0] -ID *RaidGroup*0*

C:\PS>$hashTable = @{RP_PS_TEST_CL=$storagePoolLoc;RP_PS_TEST_CR=$storagePoolRem}

C:\PS>$set = New-EmcReplicaSet -ConsistencyGroup $group -ProductionLun $prodLun -Name "RP_PS_TEST_S1" -PoolsByReplicaCopyName $hashTable

This example creates a new replica set using the PoolsByReplicaCopyName parameter.

-------------- Example 2 --------------

C:\PS>$service = Get-EmcReplicationService -ID *60*

C:\PS> $cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

C:\PS>$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID RP_PS_TEST

C:\PS>$storageSystemLoc = Get-EmcStorageSystem -ID *6439

C:\PS> $storagePoolLoc = Get-EmcStoragePool -StorageSystem $storageSystemLoc -ID *RaidGroup*0*

C:\PS>$prodLun = Get-EmcLun -Pool $storagePoolLoc -ID *RP_PS_TEST_ProdLun*

C:\PS>$storageSystemRem = Get-EmcStorageSystem -ID *6440

C:\PS>$storagePoolRem = Get-EmcStoragePool -StorageSystem $storageSystemRem[0] -ID *RaidGroup*0*

C:\PS>$reproLun=Get-EmcLun –pool $storagePoolRem –ID *RP_CopyLun*

C:\PS>$hashTableForLuns = @{RP_PS_TEST_CL=$prodLun;RP_PS_TEST_CR=$reproLun}

C:\PS> $set = New-EmcReplicaSet -ConsistencyGroup $group -ProductionLun $prodLun -Name "RP_PS_TEST_S1" -LunsByReplicaCopyName $hashTableForLuns

This example creates a new replica set using the LunsByReplicaCopyName parameter.


Remove-EmcConsistencyGroup

Deletes a consistency group and removes all associated resources for that consistency group.

Syntax

Remove-EmcConsistencyGroup [-ConsistencyGroup] <ConsistencyGroup> [-DestroyReplicaLuns] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-ConsistencyGroup <ConsistencyGroup>

Attributes: Required, Position: 1

Specifies the consistency group to delete.

-DestroyReplicaLuns <SwitchParameter>

Attributes: Optional, Position: named

Specifies whether or not to destroy the replica (non-production) LUNs in the consistency group.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$group = Get-EmcConsistencyGroup -ReplicationServiceCluster $cluster -ID RP_PS_TEST

Remove-EmcConsistencyGroup -ConsistencyGroup $group -DestroyReplicaLuns

This example destroys a consistency group.


Remove-EmcReplicaCopy

Deletes a replica copy from a consistency group and removes and masks LUNs for that replica copy.

Syntax

Remove-EmcReplicaCopy [-Copy] <ReplicaCopy> [-DestroyReplicaLuns] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Copy <ReplicaCopy>

Attributes: Required, Position: 1

Specifies the replica copy to delete.

-DestroyReplicaLuns <SwitchParameter>

Attributes: Optional, Position: named

Specifies whether to destroy the replica (non-production) LUNs in the replica copy.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

Remove-EmcReplicaCopy -Copy $copy -DestroyReplicaLuns

This example destroys a replica copy.


Remove-EmcReplicaSet

Deletes a replica set from a consistency group and removes and masks LUNs for that replica set.

Syntax

Remove-EmcReplicaSet [-ReplicaSet] <ReplicaSet> [-DestroyReplicaLuns] [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-ReplicaSet <ReplicaSet>

Attributes: Required, Position: 1

Specifies the replica set to delete.

-DestroyReplicaLuns <SwitchParameter>

Attributes: Optional, Position: named

Specifies whether or not to destroy the replica (non-production) LUNs in the replica set.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

$set = Get-EmcReplicaSet -ReplicationService $service -ID RP_PS_TEST_S1

Remove-EmcReplicaSet -ReplicaSet $set -DestroyReplicaLuns

This example destroys a replica set.


Set-EmcRecoverProductionCopy

Recovers the production copy by using the specified replica copy. This recovers the production to correct file or logical corruption by rolling the production back to a previous point-in-time

Syntax

Set-EmcRecoverProductionCopy -Copy <ReplicaCopy> [-Force] [-Silent] [-WhatIf] [-Confirm] [<CommonParameters>]

Parameters

-Copy <ReplicaCopy>

Attributes: Required, Position: named

Specifies the replica copy to be used for production recovery.

-Force <SwitchParameter>

Attributes: Optional, Position: named

Allows the cmdlet to continue without asking for user confirmation.

-Silent <SwitchParameter>

Attributes: Optional, Position: named

Turns off all the informational and verbose messages. However, it still displays errors.

-WhatIf <SwitchParameter>

Attributes: Optional, Position: named

Shows what would happen if you ran the cmdlet without actually running it.

-Confirm <SwitchParameter>

Attributes: Optional, Position: named

Prompts you for confirmation before executing the command.

<CommonParameters>

This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, and OutVariable. Type get-help about_commonparameters for more details.

Example

C:\PS>$service = Get-EmcReplicationService -ID *60*

$cluster = Get-EmcReplicationServiceCluster -ReplicationService $service

$copy = Get-EmcReplicaCopy -ReplicationServiceCluster $cluster -Role RemoteCopy -ID RP_PS_TEST_CR

$snapshots = Get-EmcReplicaCopySnapshots -Copy $copy[0]

$copy = Enable-EmcReplicaCopyImageAccess -Copy $copy[0] -ImageAccessScenario RecoverProduction -Snapshot -$snapshot[1]

Set-EmcRecoverProductionCopy -Copy $copy

Recovers the production copy by using the specified replica copy.


Troubleshooting EMC storage systems

Troubleshooting EMC systems and hypervisors

This section describes known problems and limitations for troubleshooting storage systems and hypervisors.

Symptom

Prevention, resolution, or workaround

ESI will not provision LUNs in oversubscribed storage pools.

The ESI GUI does not support oversubscribed storage pools. However, you can use ESI PowerShell Toolkit to provision LUNs in oversubscribed storage pools.

When a valid description is typed in the Storage Pool Description field, sometimes the description is not displayed in the column on the Storage Pool tab.

This is a known problem. The description display is for more information and is not critical for system operations.

  • ESI fails to connect to Windows clusters or failover clusters.

  • ESI cannot create, delete, or disconnect a cluster disk.

  • Healthy clusters are an ESI requirement. Confirm that the clusters are healthy.

  • Cluster resource dependencies are not removed before you delete or disconnect a cluster disk. Before deleting or disconnecting a cluster disk, remove disk resource dependencies.

Ping system timeout fails.

Set the timeout value according to your network status in ESI.

You are unable to connect to a Windows server.

  • Check that firewall rules are enabled on both controller and controllee hosts.

  • Check that remote PowerShell is enabled on both controller and controllee hosts.

  • Check that DNS is configured correctly.

Rescan fails to find a LUN.

  • Check that the FC Zoning is configured correctly.

  • Check that the iSCSI initiator is logged in to the target port.

  • Check that the multipath software is configured correctly.

  • Storage-related data does not display in the host view, cluster view, or SharePoint view.

  • The Storage pools in the create disk wizard do not load and the wizard is blank.

  • ESI shows storage related information for a disk or shared folder only when the corresponding storage systems are registered. Verify that the corresponding storage systems are registered with ESI (under Storage Systems). If not, register these storage systems.

  • The storage system may be taking longer than the default time-out value of 60 seconds. Set a higher time-out value (in seconds) in the following Registry key:

Key: HKLM\SOFTWARE\EMC\WSI\Config

DWORD Value Name: DefaultOperationTimeout

One of the following error messages occur:

  • "Unable to get host system with given parameters."

  • "EmcVdsProxyService is not available. The operation 'RemoveHostSystem' is unsuccessful."

This might occur when trying to connect ESI to a Windows host by using ESI PowerShell cmdlets that are running within a remote PowerShell session. ESI does not support running the cmdlets within a remote PowerShell session on the ESI controller host.

  • When a storage system is added to ESI, it is not listed in PowerShell.

  • When a storage system is added in PowerShell, it is not listed in ESI.

Log out of the other application and then reopen it to refresh the list.

PowerShell scripts from earlier versions of ESI that use the Connect-EmcSystem PowerShell cmdlet fail with the "Parameter ConnectionName is needed to create the Host System Object" error.

For ConnectEmcSystem, use ConnectionName instead of HostSystemName for the Creation parameter.

  • The Set-EmcLunAccess PowerShell cmdlet fails.

  • An unmasking operation fails.

Before unmasking a LUN or using the cmdlet, ESI requires that you register all iSCSI and FC HBAs or host initiators used to unmask LUNs on the storage system.

“Retrieval of host disks failed: Operation RefreshDisks failed on VDS proxy...” error occurs.

When the VDS load operation uses the target host FQDN, this name resolution error occurs. To resolve this error, you must configure the Windows host file on the ESI controller host system with both the short (NETBIOS) and long (FQDN) host names.

For XtremIO systems, errors occur when using the following cmdlets:

  • Get-EmcStorageRegisteredHost

  • Get-EmcStorageRegisteredInitiator

  • New-EmcStorageRegisteredHost

  • New-EmcStorageRegisteredInitiator

  • Remove-EmcStorageRegisteredHost

  • Remove-EmcStorageRegisteredInitiator

Because XtremIO systems do not require the registration of hosts, ESI does not support using the ESI PowerShell cmdlets related to registering hosts for XtremIO.

In ESI, right-clicking a tree node does not display all the menu options.

This is the default behavior of the Microsoft Management Console Framework. Select an item, and then right-click to display the menu options.

When creating a disk, ESI fails or creates the incorrect volume size.

If you create a host disk and ESI fails or creates the incorrect volume size, you might need to increase the disk size.

If the file system type is FAT32, provisioning a storage volume fails.

  • FAT32 file system type for volumes is no longer supported in this release.

When you specify both the -ID and -ConcreteLun parameters together with the Get-EmcLun ESI PowerShell cmdlet, an AmbiguousParameterSet exception error occurs.

The -ConcreteLun switch parameter specifies the Concrete LUN type as an optional parameter, through which only Concrete LUNs can be filtered out. Do not use this parameter with the -ID parameter. This parameter supports only block storage systems.

When you create a virtual hard disk or passthrough SCSI disk for a virtual machine, no IDE controllers are listed.

ESI does not support IDE-based disks. Use hypervisors to create IDE-based disks.

For hypervisors, cannot create new SCSI controllers for virtual machines.

ESI does not support creating new SCSI controllers for creating disks for virtual machines. Use the hypervisor to create new SCSI controllers. Then use ESI to create and attach the disks for virtual machines with these existing SCSI controllers.

For hypervisors, the Connect to Host action leads to the following error message: "Can't retrieve IP from MAC address:…" or the "host name is empty."

This error can occur for a number of reasons. Confirm the following to avoid this error:

  • The virtual machine is a part of a reachable domain.

  • The supported Windows operating system is installed on that virtual machine.

  • The IP of that virtual machine is configured correctly.

  • The ESI-mandatory firewall settings are configured correctly if you want to manage the virtual machine in ESI.

For VMware, you cannot expand RDM disks that are attached with virtual compatibility mode.

For VMware systems, ESI does not support RDM disks that are created with virtual compatibility mode. Use ESI to provision disks without the virtual compatibility mode setting.

For a VMware ESX host that is connected with ESI to a virtual machine, when expanding a file-based disk on the virtual machine, the operation fails with an "Access to resource settings on the host is restricted to the server that is managing it" error message.

This is a VMware restriction for expanding file-based disks, which requires the operation to only succeed when only the vCenter host is connected and the ESX host is disconnected from ESI. Try removing the ESX host and adding the vCenter hypervisor again in ESI. Then try the expand operation again.

For VNX systems, the local administrator account status appears as Offline.

This occurs when a VNX storage array is added with a global account without administrator rights or a local administrator account, and the status is shown as Offline. VNX systems require administrator accounts with a global scope.

For VNX systems, unable to connect a host disk.

If the VNX storage array does not have Access Logix enabled, the host disk connection fails. VNX block storage systems must have Access Logix enabled on a storage array before you connect a host disk on a Windows host.

For VNX systems, advanced snapshot LUNs can be viewed on the LUNs tab in the ESI GUI, but are not listed in ESI PowerShell.

You can view advanced snapshot LUNs in ESI GUI. Even though the snapshots exist, you cannot currently view the list with the Get-EmcSnapshotLuns cmdlet.

For VNXe and Hyper-V, when you use the New-EmcLun cmdlet to create a LUN for Hyper-V, a "LUN does not exist" error occurs.

This occurs in older versions of VNXe. To resolve this problem, update your VNXe to version 2.3.1.20364.

For VNXe, a snapshot cannot be promoted.

If the resource has no access to the snapshot, a snapshot cannot be promoted for a host. Set up host access to the snapshot, and then the snapshot can be promoted for that host.

When adding a VNXe, the "System cannot find the file specified" error appears when you click Test Connection.

VNXe Unisphere CLI is not available on the controller host where ESI is running. Download and install Unisphere CLI from the EMC Online Support website.

After installing VNXe Unisphere CLI on the controller host, retry adding the system.

When creating volumes for XtremIO, the Login Status is Unknown on the LUN Masking Settings page in the Create Disk wizard.

ESI cannot display the port addresses for all zoned storage system ports for XtremIO systems in the ESI GUI.


Troubleshooting the VMAX Adapter

Troubleshooting the ESI VMAX Adapter

This section describes known problems and limitations for troubleshooting the ESI VMAX Adapter.

Symptom

Prevention, resolution, or workaround

When creating disks with the Create Disk wizard for VMAX, "no appropriate storage system found" appears as the only option in the Storage System page.

ESI does not support provisioning disks for host systems (VMware, Windows, and so on) with only iSCSI initiators (HBAs) on VMAX storage systems.

“Symmetrix system with serial not found: 123400688” error occurs when you are adding VMAX systems.

  • When adding VMAX systems to ESI, if you did not include the initial zeroes at the beginning of the serial number, an error will occur.

  • Confirm that you include all of the required twelve digits, which might include a prefix of zeroes. For example: 000123400688.

Unable to apply a FAST VP policy to an existing storage group.

Try binding the existing LUN or storage pool in the policy storage tier with the Unisphere SYMCLI commands or SMC.

Fails to add a LUN to an existing meta, meta volume, or composite LUN.

  • Confirm that the LUN is bound.

  • Confirm that the specified meta volume is striped and the correct size is specified for the LUN.

The Expand-EmcLun cmdlet fails.

  • Check that the specified capacity is the exact number of bytes for LUN sizes.

  • For striped meta volumes, check that the specified capacity is the exact multiple for the stripe size.

  • Cannot create, view, or remove snapshot LUNs in ESI.

  • Or when using the following ESI PowerShell cmdlets, results are incomplete or incorrect:

  • Get-EmcSnapshotLun

  • New-EmcCandidateSnapshotLun

  • New-EmcSnapshotLun

  • Remove-EmcSnapshotLun

  • Restore-EmcSnapshotLun

These tasks and cmdlets are not available, because snapshot LUNs for VMAX systems are not supported in this release. However, future releases of ESI will support snapshot LUNs for VMAX.


Troubleshooting the SharePoint Adapter

Troubleshooting the ESI SharePoint Adapter

This section describes known problems and limitations for troubleshooting the ESI SharePoint Adapter.

Symptom

Prevention, resolution, or workaround

SharePoint provisioning fails when you create a web application or a SQL Server database in ESI.

  • Verify the SQL Server authentication method and try again. Integrated Security may be used instead of SQL Authentication, or vice versa.

  • Verify the username and password and try again.

  • The provisioning wizard lists all SQL instances that are installed on the server. Ensure that the correct SQL instance is selected and that the authentication mechanism matches.

SharePoint cannot connect to the named instance when the named and default instances are on the SQL server to which SharePoint connects remotely.

In a multi-server deployment where ESI and SharePoint Central Admin are on a computer that is distinct from the SQL server computer, ESI and SharePoint connect to SQL Server remotely. If the SQL Server computer has a named instance in addition to the default one, the connection to the named instance may fail. To validate the deployment scenario, ensure that SQL Management Studio can connect remotely to the target SQL Server instance.

The recommended setup is to have the remote SQL Server computer with either the default instance or the named instance, but not both. If the SQL Server computer must have both the default and named instances, then SharePoint access should be limited to the default instance.

ESI cannot open a farm.

  • Ensure that the SharePoint Foundation 2010 SP1 or SharePoint Server 2010 SP1 API is installed on the ESI host computer.

  • Verify the SQL Server or configuration database name are spelled correctly and try again.

  • If the ESI Server cannot join the farm domain controller because of an authentication failure, verify the domain settings and try again.

  • Verify that the network connection to the farm is available and functioning and try again.

  • Verify the SQL Server authentication method that is used and try again. Integrated Security may be used instead of SQL Authentication, or vice versa.

  • Verify that the correct SQL instance is used. If the farm is remote, the full SQL Server and instance name is required in the same format used by SQL Server.


Troubleshooting the Exchange Adapter

Troubleshooting the ESI Exchange Adapter

This section describes known problems and limitations for troubleshooting the Exchange Adapter.

Symptom

Prevention, resolution, or workaround

During discovery of Exchange DAGs, mailbox servers, or mailbox databases, the "assignment statements are not allowed in a restricted language mode or data section" error appears.

On the Exchange mailbox server that connects to ESI, you might need to set an application setting for Windows PowerShell.

  1. On the Exchange mailbox server, open the Internet Information Services (IIS) Manager for Windows PowerShell and in the Application Settings, and set the PSLanguageMode to FullLanguage.

  2. After changing the IIS setting, restart IIS to apply the change. To restart IIS on the server, click Start > Run, type IISReset, and click OK.

Cannot locate the EDB file disk ID or log folder disk ID.

Confirm that ESI can discover the storage LUNs by adding the mailbox server as a host system in ESI and enumerating host volumes with mount points as EDB file and log folders.

If the storage LUN information is not discovered, then the storage system may need to be reconnected or the connection refreshed in ESI.


Troubleshooting SQL Server Adapter

This section describes known problems and limitations for troubleshooting the ESI SQL Server Adapter.

Symptom

Prevention, resolution, or workaround

ESI sets the virtual machine state as Unknown and displays the following connection message: "Failed to connect to one or more SQL Servers."

This connection message occurs if ESI scans a server and the firewall is blocking the ESI connection or you are not authenticated to access the SQL Server instance. If you select to add the unknown instances, the servers with no detected SQL Server instances are listed as Unknown in ESI.

When you add a SQL Server database to an availability group, the following error occurs:

"Cannot drop the database <database ID>, because it does not exist or you do not have permission."

  • Confirm that the ESI host is connected with the correct permissions.

  • Or you might have specified a local path for the Shared Network Location field. Shared Network Location must be a Universal Naming Convention (UNC) path.

When you modify auto-generated T-SQL for bulk-create databases, ESI does not display a successful completion message.

ESI might not display any messages when you modify auto-generated T-SQL in ESI. This is a known issue that does not require a workaround.


Troubleshooting the RecoverPoint Adapter

Troubleshooting the ESI RecoverPoint Adapter

This section describes known problems and limitations for troubleshooting the ESI RecoverPoint Adapter.

Symptom

Prevention, resolution, or workaround

When enabling image access to a replica copy, "the specified replica copy has no valid snapshot, which is required to enable access to the copy" error appears.

Check that the replica copy is enabled, and that the link state is in an active state.

After failing over to a remote replica copy, when enabling the replica copy that used to be the local copy, the "at least one of the enabled replica copies doesn't have a defined link to the production copy" error appears.

Manually create a link from the new production copy to the copy that used to be the local copy. You can do this with the New-EmcReplicaLink PowerShell cmdlet.

When using VMAX with the Exchange Integration, after adding a mailbox database copy on the remote site and adding subsequent copies, the "device is involved in a RecoverPoint Rcopy session and cannot be modified" or "a specified device is involved in a Remote Copy session and cannot be modified" errors might appear.

The copies are in a RecoverPoint session, so the SMI-S provider prevents all write operations. To avoid these errors, do one of the following:

  • Use the ESI GUI or PowerShell Toolkit to manually disable the replica copy, add the copies on the remote site, and then enable the replica copy afterwards. For other subsequent copies, repeat these steps.

  • Alternatively, only add subsequent copies on the local site and maintain only one remote copy on the remote site.


Troubleshooting the ESI Service and ESI SCOM Management Packs

This section describes known problems and limitations for troubleshooting the ESI Service and ESI SCOM Management Packs.

Symptom

Prevention, resolution, or workaround

When upgrading to the latest version of the ESI SCOM Management Packs, reimporting the management packs in SCOM fails.

When upgrading, SCOM requires that you delete the existing ESI version 2.1 SCOM Management Packs from SCOM before you can install and import the latest version of the SCOM Management Packs. Installing the ESI SCOM Management Packs provides instructions.

After upgrading ESI and importing the latest version of the ESI SCOM Management Packs, your override settings for the ESI SCOM management packs no longer exist in SCOM.

The EMC.SI.Customization.xml management pack file contains your SCOM overrides and customizations. When importing the management packs into SCOM, you might have overridden this file and lost your settings.

You can reimport the latest backup copy of this file to get your customizations back.

Notice: This file is installed with version number 1.0.0.0. You can increment the version number when you make changes.

How to Import a Management Pack in Operations Manager 2007 and How to Import a Management Pack in Operations Manager 2012 on Microsoft TechNet provides instructions for importing the management packs.

After upgrading ESI, "EMC.WinApps.Service.DirectoryServicesSystemDb.*" errors occur in your ESI Service event log.

If you are using Active Directory (AD) or AD LDS, you might not have unpublished all systems from the ESI Service before upgrading. Try cleaning up the AD container used for the ESI Service, restart the service, and then republish the systems to the ESI Service.

SCOM degrades the health state of the snapshot pool for reserved LUN pools of VNX or CLARiiON block systems, regardless of the true health state of the reserved LUN pool in Unisphere, which causes a warning error and generates an alert.

Unisphere does not provide an operational status for reserved LUN pools, so SCOM defaults to "unknown" for the health state of the snapshot pool. This unknown state in SCOM degrades the health of the system, which generates an incorrect warning error and alert in SCOM.

You can disable the health monitor for the snapshot pools in SCOM to avoid this incorrect warning error and alert. How to Enable or Disable a Rule or Monitor on Microsoft TechNet provides instructions.

  • Some or all system components are not discovered or monitored by SCOM.

  • Event 104 appears in the SCOM agent event log, which includes basic connection information and an HTTPS link to EMC SI Service that cannot be completed.

  • EMC SI Service Discovery in SCOM cannot connect to the ESI Service, or the connection time is unacceptable.

  • Workflow processes are timing out.

  • Confirm that the firewall settings are correct for both the SCOM agent and ESI Service.

  • Enable and use EMC SI Windows Service Monitoring to confirm that the ESI Service is running on the ESI host.

  • Open this link on the SCOM Agent machine: https://<ESI Service IP>:<https port>/esi/console/graph/Entities?class=StorageSystem, replacing <ESI Service IP> and <https port> with the applicable values. Then confirm that the load time displayed at the bottom of the page is less than one second. Repeat this step a few times for consistent results.

  • Confirm that the SCOM agent connects successfully with the ESI Service. The connection information and link are provided in Event 104. Use credentials specified in the Setting up the EMC SI Monitoring Profiles for the SCOM agent. Open the HTTP link provided in the Event 104 description and confirm that the event completes in less than two minutes. If the connection fails, investigate the cause and update EMC SI discovery overrides accordingly. Changing the discovery interval overrides provides more details for changing the overrides.

  • List of physical or logical components displayed in the views is not current.

  • New system changes are not being discovered in SCOM.

If the components do not appear after the set interval refresh time has passed, try toggling the Enabled override properties setting for the EMC SI Service Discovery in SCOM:

  1. Open the EMC SI Service Discovery Overrides Properties window.

  2. Clear the checkbox for the Enabled override setting and click Apply to apply the change.

  3. Before closing the window, select the Enabled checkbox again.

This override change triggers the discovery process. After toggling the override setting, check in the Operations Manager event log on the SCOM agent for two sequences: Event 1201 followed by Event 1210. If these occurred, then the discoveries should be current.

The Subscribed Capacity Presentation view in SCOM does not display the system serial numbers.

To work around this SCOM limitation, you can create a group for each system and a favorite view for the group:

  1. In Operations Manager, go to Authoring > Groups > Create a new Group, enter a name, and select EMC Storage Integrator Customizations management pack to save changes.

  2. Select Dynamic Members > Create/Edit rules, and select EMC SI Storage System > Add.

  3. Select Serial Number Equals <serial number> and Create.

  4. To create a view for the group, select My Workspace > Favorite Views > New > Performance View > type a name for the view> select collected by specify rules > choose Storage Pool Available Capacity Performance Collection and Create.

The pools of only the specified systems will be displayed.

  • Updates for the component health status take more than 40 minutes to update the SCOM views.

  • Long delays exist between changes in health of components and the changes being updated in SCOM views.

  • Confirm that the related SCOM agent is running without performance problems. If errors occur, troubleshoot those as described in the previous resolution.

  • Reduce the ESI Service System Refresh Interval, which is set to 30 minutes by default. Changing the system refresh interval has more details.

  • Reduce the Interval override for monitors that experience latency, which by default is set to six minutes.

  • Changing discovery interval overrides has more details.

One or more systems do not appear in the SCOM view and are not discovered by SCOM.

  • Confirm that the related SCOM Agent successfully connects to the ESI Service.

  • Confirm that the system is registered with the ESI Service.

  • Confirm that the System Filter file exists on the related SCOM agent and has the correct list of ESI Service Registered System Friendly Names.

  • SCOM agent is experiencing performance problems due to a large number of monitored component instances.

  • List of discovered components is not complete. Health state of components is not current and other suggestions do not work.

  • Event 6022 from the Health Service Script does not appear in Operations Manager event log on the SCOM agent machine for more than 15 minutes.

  • Performance counters related to the CPU or memory usage are typically hitting the maximum limits.

  • Event 21411 from the Health Service modules appears and includes the "process will be dropped because it has been waiting in the queue for more than 10 minutes" message.

  • Event 1101 from the Health Service appears multiple times in the Operations Manager Event log on the SCOM agent computer.

  1. Increase the local data queue on the SCOM agent machine by updating the Registry key:

  1. Replace <MG> with the SCOM management group name and size, which can be between the default 15360 (15 MB) and 102400 (100 MB):

HKEY_LOCAL_MACHINE\SYSTEM\Current ControlSet\Services\HealthService\Parameters\ Management Groups\<MG>\MaximumQueueSizeKb

  2. Restart the HealthService.

Try the Flush Health Service and Cache task. To do this:

  1. In Operations Manager, go to Monitoring > Operations Manager > Agent-Details > Agent Health State and, in Agent State view, click the SCOM agent machine.

  2. In the Health Service Tasks section of the Actions pane, run the Flush Health Service and Cache task.

Adding resources to share the monitoring can improve data and I/O performance for large storage environments. Consider adding more SCOM agents or more ESI Services to share the monitoring of multiple systems with heavy traffic. With more than one SCOM agent to monitor one or more ESI Services, you can assign fewer systems to each SCOM agent or each ESI Service. Use the System Filter file to assign systems to different SCOM agents.

Sample event logs can also provide assistance with diagnosing issues.

  • SCOM agent changes to a gray state or the discovery is not complete within an acceptable time.

  • Too many LUN masking views are being discovered.

  • SCOM does not discover all of the storage groups.

  • The system has more storage groups than SCOM discovers.

The discovery override for the EMC SI Storage Group limits the number of discovered instances in SCOM. Confirm that the override has the correct limit.

The maximum limit for this override is 5000. To improve performance, change the discovery override to a smaller number.

  • The ESI Service or the SCOM agents have connection problems.

  • Time-out error message Event 104 or Event 21402 occurs.

Check the Operations Manager event log for any events and also try to connect to ESI Service from a web browser on the SCOM agent computer. Changing HTTP connection defaults has more details.

The Sample event logs include an Event 21402 log example.

Proxy Monitoring is not available (grayed out) in Operations Console and Event 623 occurs in Operations Manager.

If the Proxy Monitoring agent is monitoring systems with a large number of components, distributing the monitoring of systems to more proxy agents may solve the problem. Or you can make the registry change as described in One or more management servers and their managed devices are dimmed in the Operations Manager Console of Operations Manager at http://support.microsoft.com/kb/975057.

SCOM does not discover a VPLEX system.

  • Confirm the SCOM Management Pack is set up with the correct ESI Service host and SSL port 54501.

  • Confirm the ESI Service is running.

  • Confirm the user is in an administrator group (if UAC is enabled, web browser must be launched with Run As Administrator).

  • Check event logs for ESI Service errors.

  • Check that the remote connection to ESI Service uses one of the following:

  • http://<host>:54500/esi/console

  • https://<host>:54501/esi/console

  • Confirm that the firewall settings are correct for both the SCOM agent and ESI Service.

  • Check SSL Certificate on ESI Service host is set up correctly: Get-ChildItem cert:\LocalMachine\My

  • Confirm the latest service packs and cumulative updates are deployed on the SCOM agents and clients.

  • Confirm the SCOM server and agent systems meet the minimum system requirements.

Event 21114 occurs in the Operations Manager event log.

Confirm that HKLM\System\CurrentControlSet\Services\HealthService\Parameters => Persistence Version Store Maximum has been changed to 5120 (decimal).

VPLEX system does not appear in SCOM for the SCOM monitoring agent.

Check event log for event 104 and confirm the ESI Service connection information is set up correctly in SCOM.

VPLEX discovery times out.

  • The SCOM agent might be monitoring too many systems. Check event log for events: 6024, 2114, 21402.

  • Consider using the system filter file to assign systems to specific SCOM agents.

Sample event logs

The key information is highlighted as bold text in the following event log examples. The events generated from the monitoring agent Operation Manager event log and alerts are also added to the Monitoring Delays, Errors and Timeouts view in the Diagnostics folder.

The following is an example of an event log with connection problems. In this example, Event 21402 occurred because of a disk drive component problem. By locating the problem component class, you can then decide which component monitor to troubleshoot and maybe change that specific time-out interval override while resolving the problem:

Log Name: Operations Manager

Source: Health Service Modules

Date: 9/19/2012 1:24:59 PM

Event ID: 21402

Task Category: None

Level: Warning

Keywords: Classic

User: N/A

Computer: PATHENDGSCOM.PATHENDG.emc.com

Description:

Forced to terminate the following process started at 1:24:43 PM because it ran past the configured time-out 600 seconds.

Command executed: "C:\Windows\system32\cscript.exe" /nologo "GetEntityStatus.js" 10.5.222.40 7001 c85793d1108ee9f4c30a970941593d7c966a2748 DiskDrive none none True True false 0

Working Directory: C:\Program Files\System Center Operations Manager 2007\Health Service State\Monitoring Host Temporary Files 1\126109\

One or more workflows were affected by this.

Workflow name: many

Instance name: many

Instance ID: many

Management group: JerryAir

The following is an example of an event log that has overloaded resources:

Event 21411

Level Warning

Source Health Service Modules

The process will be dropped because it has been waiting in the queue for more than 10 minutes.

Command executed: "%windir%\system32\cscript.exe" /nologo "DiscoverLunStorageServiceNode.js" {934DBB77-5CDA-4EF8-E2D5-37DE605B11A9} {A86B6475-C74D-7AF0-1B69-AEA88050B9EF} ZBSCOM2007.ZBEMC.dev 10.5.222.40 7001 3f08b7000dc65c9f29417af195d75cac12f5ea3e 6bec6ca7f35635f45d6d5f54c6e4d7996f3e37b8 none none True False 0

Working Directory:

One or more workflows were affected by this.

Workflow name: EMC.ESI.LunStorageServiceNodeDiscoveryRule

Instance name: Bus 1 Enclosure 1

Instance ID: {A86B6475-C74D-7AF0-1B69-AEA88050B9EF}

Management group: ZBDEV


Logs

ESI logs

ESI log details are as follows:

  • ESI Controller Default log location: C:\Users\administrator.ESIAD\AppData\Local\EMC\ESI\Logs

  • Default log level: Verbose (Valid log levels: Verbose, Information, Warning, Error, Critical )

  • Log level settings: C:\Program Files\EMC\EMC Storage Integrator\ EMC.WinApps.GUI.Mmc.dll.config

  • To change the log level, edit the initializeData parameter as shown in the Log level setting.

Log level setting


EMC Sales and Customer Service contacts

EMC support, product, and licensing information can be obtained as follows:

  • Product information: For documentation, release notes, and software updates, or for information about EMC products, licensing, and service, go to EMC Online Support (registration required).

  • Technical support: Go to EMC Customer Service on the EMC Online Support website. To open a service request through EMC Online Support, you must have a valid support agreement. Contact your EMC sales representative for details about obtaining a valid support agreement or to answer any questions about your account.

Related links |
Troubleshooting EMC storage systems | ESI overview
Troubleshooting the VMAX Adapter | Home window
Troubleshooting the SharePoint Adapter | ESI Logs
Troubleshooting the Exchange Integration | Troubleshooting Active Directory
Troubleshooting the RecoverPoint Adapter |
Troubleshooting the ESI Service and ESI SCOM Management Packs |


Troubleshooting Active Directory

Troubleshooting Active Directory Services

This section describes known problems, limitations, or suggestions for troubleshooting the use of Microsoft Active Directory Domain Services (AD DS) and Active Directory Lightweight Directory Services (AD LDS) with ESI supported applications.

Symptom

Prevention, resolution, or workaround

The following error occurs when you add systems to ESI Applications that use AD LDS:

"ERROR: EMC.WinApps.Fx.Common.Directory.EsiDirectoryException: Protocol = 'Ldap', Result = 'NotExist'. NoSuchAttribute 00000057: LdapErr: DSID-0C090D11, comment: Error in attribute conversion operation, data 0, v23f0 -System.DirectoryServices.Protocols.DirectoryOperationException: The requested attribute does not exist."

Confirm that you configured the AD LDS instance schema with msDS-App-Configuration and msDS-Settings. If not, extend the AD LDS instance to get these, and retry the operation.

The following error occurs when you add systems to ESI Applications that use AD DS:

"ERROR: EMC.WinApps.Fx.Common.Directory.EsiDirectoryException: Protocol = 'Ldap', Result = 'NotExist'. NoSuchObject 0000208D: NameErr: DSID-03100213, problem 2001 (NO_OBJECT), data 0, best match of: 'DC=EMC,DC=Storage,DC=Integrator,DC=COM'

---> System.DirectoryServices.Protocols.DirectoryOperationException: The object does not exist."

  • For ESI, MMC, and ESI PowerShell Toolkit, confirm the container for the user exists.

  • For ESI Service, confirm a container exists for each ESI Service machine name.

  • Confirm that ESI has read and write permissions for the container and it is accessible to ESI.

Setting up Directory Services integration provides details.